Console consult

Discussion in 'Bukkit News' started by Dinnerbone, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    KillerBunnys122

  2. Offline

    Tfs Halo

    my seems to work just u have to wait when moving it because it flashes kind of slow and it should come with the recommended build :/
     
  3. Offline

    Pieman

    I'd like to see the Delete key delete text in the proper direction. It seems to delete characters to the left (like Backspace) instead of to the right like Delete usually does. Other than that, the new console looks great! :)
     
  4. Offline

    Huns

    Complaining is where you just say you don't like something without being constructive. What I've done here is provide constructive criticism, which is good because constructive criticism is useful. That's why this thread is here, and why "consult" is in the name.
     
  5. Offline

    Takato

    now the recommended is 493 and I still have the same issues with it doing absolutely nothing.

    my cmd window simply shows me this

    http://i54.tinypic.com/2i6ki6f.png

    Can anyone at least try to help me ? For a recommended build + supposed new console, I get no improvement =/

    I even tried disabling ALL my plugins and it does the same thing, so plugins =/= the issue.

    I run W7 64bit

    EDIT : I found other stuff out.

    if I put min/max ram to 1 gig, I can run the older servers fine, but now I can't put 3gig because the cmd window instantly disappears.

    For the latest recommended build, both amount of ram does't work. this is dumb >_>

    EDIT 2 : So what am I supposed to write on my bat file ?
    I run W7 64 bit, but it appears I'm not using 64 bit java to run minecraft or where it's installed screws up stuff.
     
  6. Offline

    FloydATC

    Dunno if this is a known problem, but I got this with 493. Has anyone else seen it? It happened as I tried to use norwegian characters (æøå) and the console no longer accepts input. Everything else seems to work fine though:
    Code:
    22:16:42 [SEVERE] null
    java.io.IOException: invalid UTF-8 first byte: -8
            at jline.UnixTerminal$ReplayPrefixOneCharInputStream.setInputUTF8(UnixTerminal.java:403)
            at jline.UnixTerminal$ReplayPrefixOneCharInputStream.setInput(UnixTerminal.java:384)
            at jline.UnixTerminal.readVirtualKey(UnixTerminal.java:172)
            at jline.ConsoleReader.readVirtualKey(ConsoleReader.java:1453)
            at jline.ConsoleReader.readBinding(ConsoleReader.java:654)
            at jline.ConsoleReader.readLine(ConsoleReader.java:494)
            at net.minecraft.server.ThreadCommandReader.run(ThreadCommandReader.java:25)
    Platform: CentOS 5
     
  7. Offline

    Frizkie

    Is there any way to get... well I'm not sure what to call them - the $, &, and § color coding. When users talk, I still get lines like these:

    Code:
    20:53:09 [INFO] §f[§aOwner§f] Frizkie: §ftest
    
     
  8. Offline

    Plague

    Oh yes please! (and I think they are formatting characters)
     
  9. Offline

    DorthLous


    You are more than likely running your server with the x86 java (the path in the .bat should reflect that). Install the x64 java, if you haven't already, and change your path (it's the same exact path, but in the Program Files rather than the Program Files (x86) if you've left it to the defaults)
     
  10. Offline

    Golux

    I'm on a mac and I just set up a server following the wiki instructions but the console is just in terminal. What should I do to get the nice one?
     
  11. Offline

    NathanWolf

    Holy crap, awesome! So glad you convinced me to get off my butt and make NetherGate's commands all work from the server console...
     
  12. Offline

    Huns

    How many players do you have online simultaneously? 3 gigs is a ton of memory unless you have hordes of people online at the same time. Have you tried using 32-bit Java?

    If you're not sure whether you're running 32- or 64-bit Java, type "java -version" in a DOS box. If it's 64-bit, it will tell you explicitly. If it's 32-bit, it won't say anything about that.

    Also, I'm pretty sure the new console features rely on ANSI escape sequences. That's recognized by all Linux terminals, but DOS boxes under Windows are not ANSI compliant so you won't get any benefit.
     
  13. Offline

    Zace66

    Well I have the latest CraftBukkit build installed - its running rather nicely on my Mac thanks.
    The only 'console' I see is my terminal window that have been the same since day 1 when i first tried the bare bones MC server. It tells me I have my plugins loaded, etc, but nah - its nothing new,
    So, having read all this thread, simply put - how do I get to see this nice new console please? is it in game or a gui outside?
    Thanks.
     
  14. Offline

    Ed the Dev

    These are very welcome features. You rock!

    - Ed
     
  15. Offline

    itorrent

    Same problem here :/ cant get this new Console to work :(

    EDIT:
    well the "desgin" isn't any different....
     
  16. Offline

    Takato

    Alright, so I recently formatted my comp due to... java issues >_>
    and ATM, newer builds work, but I don't see anything different from previous versions.

    I checked the version and it's 32 bit, but I have both installed.

    I use

    "java -Xms1024M -Xmx1024M -jar craftbukkit-0.0.1-SNAPSHOT.jar"

    for my bat file, I have no choice since 32 bit ONLY allows 1 gig.

    so how would I now allow my 64 bit to work ?

    I know you link to the c:/programfiles/stuff stuff but it seems to crap out on me.
    Is the path variable different for 64/32 bit ?
     
  17. Offline

    DorthLous

    Yes, only the 32 bit is installed in the Path. If you want the x64, you'll have to use the full path, something like "c:\Program Files\Java\jre6\bin\java.exe" -Xm...
     
  18. Offline

    Takato

    So far so good, but now I get a new error.

    "Error occured during initialization of VM
    java/lang/NoClassDefFoundError: java/lang/Object"

    If I could fix this then Ill be gold D:
     
  19. Offline

    byuni

    For whatever reason, running this through new console does not work through a cygwin prompt. I can type in commands but they are ignored and passed through to the shell when the server stops.

    The new console works great if I run it through cmd, but I want to use cygwin for screen.

    (edit: should note that I am running a cygwin prompt through SSH and putty)
    [MERGETIME="1300051357"][/MERGETIME]
    Never mind, figured it out. Details here: http://softwaremavens.blogspot.com/2009/10/cgwin-interpretersjline-carriage-return.html

    TLDR: add -Djline.terminal=jline.UnixTerminal to the jvm arguments. Tada! Working console in cygwin. Pretty colors too.
     
  20. Offline

    Takato

    Ok so I thought my build issue was gone, but apparently I was using build 440 all along...

    I finally decided to go all out and it's build 444 and onwards that don't work.
    What did they change in build 444 that could cause my cmd window to only display my bat file text and do nothing else ?

    "Much better console interaction. History, no more losing the command, colours, inline editing, etc. Shorter log output to console (but not to file)."

    So yeah, still the same issue... and once Minecraft updates to 1.4+ I'm going to get screwed over by the lack of possible Bukkit updates.
     
  21. Offline

    DorthLous

    Takato, here's my launcher's code on win 7 x64:
    Code:
    @echo off
    "%ProgramFiles%\Java\jre6\bin\java.exe" -Xincgc -Xmx4G -XX:UseSSE=3 -jar craftbukkit.jar nogui
    pause
    Hope this'll help.
     
  22. Offline

    Takato

    Ill give this a shot and see how it goes, thanks ;)

    EDIT : Says it's unable to access jarfile *insert name of craftbukkit snapshot*

    I'm sad :(

    EDIT 2 : Tried it with the old version first to make sure that it worked, but then I tried it with the latest build ( 556 )

    and I get this error again

    "Error occured during initialization of VM
    java/lang/NoClassDefFoundError: java/lang/Object"

    again, that's the issue I need to fix, I feel weird for probably being the only one with this issue with the latest builds :(

    EDIT 3 : Making progress LOL, I can now run minecraft with java 64bit :)
    but now it does nothing again :( shows my line in my run.bat file and then just does nothing after that D:
     
  23. Offline

    Uzza

    Having made my own, mod independent server wrapper, I agree with what a lot of people have been saying. Make this terminal off by default, and add a single command enable it.


    I basically agree with everything that Huns have said. Make things mimic vanilla as far as possible, and separate the new stuff.

    Being a software developer, the worst thing for me to encounter is when something diverts from set standards and breaks stuff.
    If I encounter that, I have to think about why it breaks the standard, and how to get around it so things work again.
    For example, the .NET Framework is, just that, a framework that everyone works from. It is available to every programming language that conforms to the CLI standard.
    If Microsoft were to make a breaking change in the .NET framework, all hell would break loose in the .NET development world.

    It is like a class called Person implements the interface IHaveAName, but then throws an exception because Person apparently does not have a name.

    The Minecraft standard is what the vanilla server does. Everything beyond that should be implemented separately, without disturbing the common denominator that is the vanilla server.

    So, make the default command line output the same as the vanilla server, and any changes to it's functionality shall be an option.
     
  24. Offline

    Plague

    +1 that'S the unix way to do it.
     
  25. Offline

    meyers

    heyo guys,

    i have a quick question. How can i enable the new console. i have the latest recommended build.

    My server is on a Linux machine. I start it with the normal commands like the normal minecraft server. do i have to change the start line?
     
  26. Offline

    Uzza

    Also I forgot, stop with the localization of the console output, or ad it as an option too.
    It makes the parsing of the output completely impossible, or at least extremely hard.
     
  27. Offline

    Plague

    That's java adhereing to standard locale settings...
     
  28. Offline

    meyers

    how can i get this new console? I didnt find it in this thread!
     
  29. Offline

    Uzza

    I'm talking about the "[Info]", "[Warning]" etc parts of the output. Before we updated to the bukkit version with the updated terminal, it was still in English.
    However, after updating bukkit it became localized. I can only take it that the bukkit team made it be so.

    It's another thing that should be an option.
     
  30. Offline

    Plague

    But it IS, just start it LC_LANG=C java. This is the standard ways for over 40 years now...
     
Thread Status:
Not open for further replies.

Share This Page