Connection resets

Discussion in 'Bukkit Help' started by Juntu, Mar 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I have browsed the forum and found people with similiar issues but no solution at all.

    From serverlog:
    SEVERE] Connection reset by peer: socket write error
    2011-03-16 16:20:14 [SEVERE]     at Method)
    2011-03-16 16:20:14 [SEVERE]     at Source)
    2011-03-16 16:20:14 [SEVERE]     at Source)
    2011-03-16 16:20:14 [SEVERE]     at Source)
    2011-03-16 16:20:14 [SEVERE]     at net.minecraft.server.Packet.a(SourceFile:148)
    2011-03-16 16:20:14 [SEVERE]     at net.minecraft.server.NetworkManager.e(SourceFile:130)
    2011-03-16 16:20:14 [SEVERE]     at net.minecraft.server.NetworkManager.d(SourceFile:9)
    2011-03-16 16:20:14 [SEVERE]     at
    2011-03-16 16:20:14 [SEVERE] Connection reset
    2011-03-16 16:20:14 [SEVERE]     at Source)
    2011-03-16 16:20:14 [SEVERE]     at Source)
    2011-03-16 16:20:14 [SEVERE]     at Source)
    2011-03-16 16:20:14 [SEVERE]     at net.minecraft.server.Packet.b(SourceFile:113)
    2011-03-16 16:20:14 [SEVERE]     at net.minecraft.server.NetworkManager.f(SourceFile:155)
    2011-03-16 16:20:14 [SEVERE]     at net.minecraft.server.NetworkManager.c(SourceFile:9)
    2011-03-16 16:20:14 [SEVERE]     at
    2011-03-16 16:20:14 [INFO] Juntu lost connection: disconnect.genericReason
    2011-03-16 16:20:50 [INFO] Saving players
    2011-03-16 16:25:50 [INFO] Saving players
    2011-03-16 16:30:50 [INFO] Saving players
    2011-03-16 16:35:50 [INFO] Saving players
    2011-03-16 16:40:50 [INFO] Saving players
    2011-03-16 16:45:50 [INFO] Saving players
    2011-03-16 16:50:50 [INFO] Saving players
    2011-03-16 16:55:50 [INFO] Saving players
    2011-03-16 17:00:50 [INFO] Saving players
    2011-03-16 17:05:50 [INFO] Saving players
    2011-03-16 17:05:50 [SEVERE] The handle is invalid
    2011-03-16 17:05:50 [SEVERE]     at Method)
    2011-03-16 17:05:50 [SEVERE]     at net.minecraft.server.RegionFile.a(SourceFile:342)
    2011-03-16 17:05:50 [SEVERE]     at net.minecraft.server.RegionFile.a(SourceFile:279)
    2011-03-16 17:05:50 [SEVERE]     at net.minecraft.server.ChunkBuffer.close(SourceFile:259)
    2011-03-16 17:05:50 [SEVERE]     at Source)
    2011-03-16 17:05:50 [SEVERE]     at Source)
    2011-03-16 17:05:50 [SEVERE]     at net.minecraft.server.ChunkRegionLoader.a(SourceFile:59)
    2011-03-16 17:05:50 [SEVERE]     at net.minecraft.server.ChunkProviderServer.b(
    2011-03-16 17:05:50 [SEVERE]     at net.minecraft.server.ChunkProviderServer.a(
    2011-03-16 17:05:50 [SEVERE]     at net.minecraft.server.World.a(
    2011-03-16 17:05:50 [SEVERE]     at net.m
    Running on Windows XP Profesional SP3 X86
    100mbit up & down, no ROUTER and no Firewall!

    When this happens i have to replug the network cable for some reason which i honestly dont know why.
    ISP? - None that you will know of, since its swedish but posting it anyway

    Gastubudstaden AB
    Java version: Java(TM) 6 Update 24
    .Net framework 2.0
    Microsoft visual c++ 2008 installed, no clue if this is related but still mentioning it incase.

    The connection reset is on my side, since all players will get disconnected and unable to join, is this caused by the server or is it caused by the ISP?

    I tried with no plugins but no luck at all.
    I got the latest recommended build which is #531, im testing the latest build for now to see if it still occurs.
    And sometimes my connection gets wrong ip adress as a result of this, note: this does not happen when im not hosting.

    While hosting i run it stable for 20-40minutes then it happens, nothing special going on and it still happens..

    Oh yeah, im trying vanilla Minecraft server right after i try build #556 .
    Thanks in advance,
  2. Offline


    This could be many problems. 1st could be Bukkit is still getting fixed so some people will have problems.
    2nd could be, something like a firewall, e.g. mcfee and so on. 3rd could be your internet your self it mite be messed up or some thing. 4th could be the server your on it mite be getting hit a lot.
  3. Offline


    1. Might be.
    2. Firewall = nope if you read the text
    3. Perhaps but im still looking for any other reason in before i contact the ISP itself
    4. Server getting hit? its a 3 player server, which isnt public, and i did a fresh server installation and that didnt help

    And the newest build #556 didn't make it.
    What i've noticed is when this error/bug/w/e occurs , i replug the network cable and when my buddy tried to join he made it reset again and which lead to another replugging.

    I'm gonna try vanilla now.

    Oh and i played around in my NOD32 antivirus excluding the serverfolder etc. to see if it affects and the javaw aswell from the filtration thingy.
  4. Offline


    Have you had any luck disabling your antivirus?
    2011-03-16 17:05:50 [SEVERE] The handle is invalid
    This looks to me like there is something interrupting your Java I/O, which may very well be AV related.

    If you can, you could also try a different NIC just to see if that would work better.
  5. Offline


    Infact just disabling it didnt do it, but i'll give it a shot removing it from autostart and then switch to a more compatible antivirus.
    Strange, never had issues with nod before.
  6. Offline


    Note: I didn't say it was definitely NOD related, but its a good thing to try.
  7. Offline


    Exactly, nope it didnt help.
    Nothing has helped me so far, i've reinstalled everything i had from previous.
    What's remaining is: Hosting on a diffrent ISP, check if error still occurs or reformat PC (virus?)
  8. Offline


    Your ISP shouldn't cause that problem.

    Double check your folder permissions for your directory where you have your craftbukkit. Make sure the user you are running it as has full access to those folders.
  9. Offline


    I ran Hmod aswell and had the same issues so i dont really know what to do.
  10. Offline


    Is that machine hosted by your ISP, or is it your own server?
  11. Offline


    Oh, im hosting the server on my computer.

    2,20ghz core 2duo
    2gb RAM
    7500RPM 250 gb harddrive

    Not to slow either
  12. Offline


    Try starting fresh on that machine - create a brand new directory - make sure folder permissions are correct (aka, your username has full control of that folder).

    Download the latest recommended build - rename it to craftbukkit.jar and place it in that new folder.
    Now, create a new batch file (name it run.bat) with simply this:
    @echo off
    java -Xms1G -Xmx1G -jar craftbukkit.jar nogui
    Now you should have two files in that directory - the craftbukkit.jar and the batch file. Double click the batch file. Does the output look better?
  13. Offline


    It didn't help sorry, same error occurs.. looks like something is incompatible with hosting minecraft server somehow.
    Another one with the same issue

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  14. Offline


    I confirm I am having this issue. I am also getting very slow response time, even in the console (only with the Craftbukkit jar), as well as the "[WARNING] Can't keep up! Did the system time change, or is the server overloaded?" error few minutes or so, which is way more than normal, especially since there's no one on the server at the time. (It even shows one right after the server is done starting)

    The slow response is also client-side, regardless of computer or network (everyone on my server is having problems).

    On login (which takes about 1/2 minute by itself), it takes 1/2 a minute to load the first chunk beneath you. Then, it takes minutes to load the rest of the chunks. I played around for 5 minutes, and not even a third of my render distance was filled (far).

    Commands take minutes to actually run, as well.

    I am seeing major packet loss, and my friend is also having the same issue as me, although running minecraft through a proxy from my server (ssh) to his server fixes the lag for me.

    Running CB #556. Any help would be appreciated. I've also had this problem since #543.
  15. Offline


    I must sadly add myself to the list of people hit with this issue. Build 543. Didn't had this until I switched to bukkit a while back.
  16. Offline


    Error was solved when installing the OS over again, at least for me, i switched to ubuntu which made it work flawless.
Thread Status:
Not open for further replies.

Share This Page