Solved "Connection Lost: End of Stream" Detailed.

Discussion in 'Bukkit Help' started by XxEmeraldxX, Apr 8, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I made this account because I've searched all over and nothing has helped. The problem is, Minecraft multiplayer on LAN. At first I could connect to my server and my sister's server while my sister couldn't login to either server but on her computer my server would at least be green, hers is red and says "Can't reach server".
    Now, I can still get on my server but I can't get on hers. Her server now says "Can't reach server" It's only been a few minutes in between. She still can't get on to either of the servers. On her minecraft, it looks the same with her server red and mine being green.

    I've opened the port 25565(my server) and 25569(sister's server).
    I've uninstalled java and reinstalled on both computers.
    I've deleted hosts files.
    I've checked the ipv4 for both computers.
    I've taken down firewalls and antivirus on both computers.
    I've uninstalled and reinstalled servers and minecraft.
    Both have online-mode=false.
    I've pinged her computer and everything is dandy.
    I've restarted the router.
    Everything Minecraft is updated on my end and on her far as I know.
    I've given my server more RAM.

    She can't login with "localhost" or her IPv4.
    She can't login to ANY of the IPs I've given her to login to my server but "192.168.x.x" is the one that says "Connection Lost End of Stream".
    I CAN login to my server with "localhost" and my IPv4 .
    I could login to her server with her IPv4 before but now it says "Failed to Connect to Server: Connection refused: connect".

    Something else you should know. I'm a Windows 7 laptop with wireless internet and my sister is on a Windows Vista desktop with a wireless adapter. My mother's computer is the one with the router. We're all definitely in the same Network.
    Safe to say, the problem is with my sister's Window Vista Computer. I'm just wanting to know what's up with her computer that won't let her log in to her own server.
    I've been going at this for days so if I could PLEASE get some help, I would be EXTREMELY grateful.

    EDIT: I see where the problem is but I don't know how to fix it.
    I looked at her "netstat" in the Command Prompt and it doesn't even MENTION anything about the minecraft port. So I guess the question is, how can I get her computer to listen to the ports I opened in the Network?

    EDIT: Nevermind.. the port is definitely opened and stuff. She just can't connect to her server. Ruling Networking, out for good. Also ruling out, restarts, reinstalls(of everything), updates, and firewalls.

    EDIT: PROGRESS! Her server is green on both hers and mine! Which means I can login to it. I just had to add the port number at the end like this "192.168.x.x:25569". She still can't login to my server or her own though....even with "localhost". She's having communication issues with her minecraft server. I've been going at this for a week now..

    EDIT: My username has 13characters and my sisters has 18characters. I seen a video that mentioned that long usernames usually cause this kind of problem...will try.

    SOLVED!!! FINALLY SOLVED!!! Her name was past 14characters!!!!! Later, we're gonna make houses!
  2. Offline


    Bumping the post.
    Any help would be great~
  3. Offline


    did you tried less ram???
Thread Status:
Not open for further replies.

Share This Page