[COMPLETED] Custom NPC Skins. By: Crash

Discussion in 'Archived: Plugin Requests' started by 25CentStudios, Aug 16, 2011.

  1. Offline


    no problem :)
  2. Offline


    They say stuff about a "Clear Cache" Button? I cant find it.
  3. Offline


    are you using the spoutcraft launcher or did you manually install the spoutcraft files in your minecraft.jar? im pretty sure the clear cache button will be in the launchers options page or something (im not 100% sure on that because i manually installed the files in my jar the old fashioned way and havnt tried the launcher).
  4. Offline


    I did it manually and it isnt in the options.
  5. Offline


    just grab the launcher and go to the options menu and 'clear cache'.
  6. Offline


    I did but now Spoutcraft crashes.
  7. Offline


  8. Offline


    no luck yet? im out of ideas man :( sounds like a spout issue though. did the spout guys have any ideas?
  9. Offline


  10. Offline


  11. Where can i get this?
  12. Offline


    Hey, so i got these plugins "Spout", "SpoutPlugin", "SpoutPluginAPI", "Citizens" and "NPCSkin" and it still wont work :'(...

    The Config file for the NPCSkin is:

    url: http://www.minecraftskins.info/warriorprincess.png
    url: http://www.minecraftskins.info/warriorprincess.png

    and i have a npc called "Weapons 'R' Us and his UID is : 0

    plz help me figure it out.. why cant i see the skin?!
    plZ REPLY

    also do i need SpoutCraft. all thos mods i said went into the plugins folder.. is tht right?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  13. Offline


    You do need Spoutcraft. Also you only need SpoutPlugin, Citizens, and NPCSkin. SpoutPluginAPI is included in SpoutPlugin and Spout is a server not a plugin.
  14. Offline


    I got the problem that skin disappear for my client when i go too far from an NPC and then come back to it.
    It has probably something to do with chunks unloading.
    However logging out and back in does solve that (till the next time i run out of range anyway).

    I'm not sure if it is an "issue" with Citizens, Spout or NPCskin but maybe it is possible to refresh skins close to players?
  15. Offline


    Any change this plugin is wokring with the latest 1.1 versions of everything? I've tried a few of the download links in the thread, but I keep getting this error:

    08:14:19 [INFO] [NPCSkin] Loading NPCSkin v0.3.
    08:14:19 [SEVERE] Error occurred while enabling NPCSkin v0.3 (Is it up to date?): net/citizensnpcs/SettingsManager
    java.lang.NoClassDefFoundError: net/citizensnpcs/SettingsManager
        at com.Crash.NPCSkin.NPCSkin.onEnable(NPCSkin.java:82)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:231)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:1057)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:379)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:191)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:174)
        at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:356)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:343)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:175)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:407)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
    Caused by: java.lang.ClassNotFoundException: net.citizensnpcs.SettingsManager
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        ... 11 more
  16. Offline


    Hey crash great work as i see, can you plz upload the plugin to another website like mediafire as i cannot access this file
  17. Offline


    Is this still in development or can you please upload again. The download link does not work. Oh and GREAT work!
  18. The download link doesn't work anymore. :'(

Share This Page