Command Blocks's TP Not working?

Discussion in 'Bukkit Help' started by Mackdonalds, Nov 14, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Mackdonalds

    Im trying to make my command block tp to a pair of cords, and it seems not to use, I have command blocks turned on.

    Pluggins in use:
    Chestshop
    CoreProtect
    DeathControl
    DisguiseCraft
    Essentials
    EssentialsChat
    Permissions
    GroupManager
    EssentialsSpawn
    Freeze
    BukkitCompat r20A
    NoCheatPlus
    PreciousStones
    SimpleHelpTickets
    SpamGuard
    Vault
    Worldedit
    Commandspy
    iConomy
    iZone

    'tppos @p 700 63 91' is exactly what i put into the commandblock
     
  2. Offline

    Mr. Minecraft

    Do you get any messages in the chat?
     
  3. Offline

    Mackdonalds

    No i did not, although i know command blocks work because i can do '/clear @p' and it works
     
  4. Offline

    Mackdonalds

    Bump for still no answer on why it doesn't work.
     
  5. Offline

    Mr. Minecraft

    I have a few theories, but for all I know none of them are correct.

    1st. The person using the command block does not have permission to use the block

    2nd. The command block may be overrided by another plugin. Try removing plugins until it works

    3rd. Its a bug in bukkit that needs to be fixed. Seeing as the all of the 1.4's are either beta or dev builds, this may be the case.
     
  6. Offline

    Joshuame13

    This is happening to me, too. I don't have any plugins except world edit and essentials, which should not interfere. If I copy the world to a vanilla server, the command block TPs properly, but if I run the world file with Bukkit, the block does not work. It has to be Bukkit because it is the same world file, so it is the exact same setup, only Vanilla works, but Bukkit does nothing.
     
  7. Offline

    Necrodoom

  8. Offline

    Joshuame13

    Honestly, I don't remember. It was something to the extent of tp @a[x=-271,y=85,z=-321,r=6 -271 86] -321, but I'm not quite sure. I know I typed the command correctly, because it worked when I switched to vanilla.
     
  9. Offline

    XDMAN00

    you have to go some steps
    1)Turn command blocks on in sever.properties
    2)Run server
    3)Do /gamerule
    4)Do /gamerule commandBlockOudtput true
    5)do /gamerule commandBlockOutput
    6)Test the command blocks

    Pm me if you need more help!
     
  10. Offline

    Bodenseehost

    Just for the protocol...
    I run my own little Homeserver using
    - craftbukkit
    - worldedit
    - multiverse2-core + -portal

    There it works fine, and the commandblock uses the tp-command flawlessly.

    The server of a friend uses
    - craftbukkit
    - essentials
    -multiverse2-core + -portal
    aaaand: commandblocks can't use tp, and it seems the xp-command doesn't work either. So I guess it's essentials and will try it. I didn't check the versions of craftbukkit yet... the two used versions will differ slightly, too.
     
  11. Offline

    04dowie

    @Bodenseehost

    What version off bukkit are you using that the tp command works with?
     
  12. Offline

    Bodenseehost

    1.4.2 as you can see it in my signature...


    With that, /tp works... I'll have to check the version of my friend's server, where you need /tppos etc...

    EDIT: I just switched to cb 1.4.5 Build 2492 and the tp-command seems to be the same. So I'm pretty sure the essentials-Plugin overrides the normal tp with all those tpa/tppos....-commands. That's it.

    Well I didn't miss essentials on my homeserver yet... good for my command-blocks ;)
     
  13. Offline

    Necrodoom

    Joshuame13 thats because you are using a format that essentials doesnt use. use the /tppos command and check command reference for how to type the command.

    Bodenseehost use /tppos instead of /tp for bukkit coords teleportation
     
  14. Offline

    Bodenseehost

    necrodoom Hmmm... no
    My problem is the tp-command allready used in downloaded adventure-maps, not in ones I build myself ;)
    Furthermore I'd say it would be better to develop adventuremaps based on the original /tp-command, not on the tppos that only essentials-users would be able to use. No offline-/localclient-Player can use these commands!
     
  15. Offline

    Necrodoom

    ah, then, disable /tp in essentials plugin.yml to allow bukkit /tp to work
     
    SebZos and Yonoobs12 like this.
  16. Offline

    Bodenseehost

    Oh - yes... thats the way if you need essentials running. Ill tell my friend :)
     
  17. Offline

    VDEStudios

    That Helped a ton, thanks super much.
     
  18. Offline

    Necrodoom

    this is fixed as of 2.9.6 and bukkit /tp now works fine with essentials.
     
  19. Offline

    VDEStudios

    No mine still doesn't work with tp, I have to use the tppos still, but I don't care about a few extra letters.
     
  20. Offline

    Necrodoom

    what EXACTLY are you typing in command block?
     
  21. Offline

    German121314

    Oh.. I have such problem. When i do /tp .. .. .. it works, but command block doesnt do anything. And the same problem with commands: /clear @p; /kill @p; /killmobs @p.

    Maybe ill solve this problem with yours help.
    Write me back, if you know how to repare it.
    My e-mail/// german.zobov@gmail.com ///

    OH!!! THANK YOU GUYS!!!

    I just cleared the plugins and it works!!!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 29, 2016
Thread Status:
Not open for further replies.

Share This Page