Solved Command Blocks not working even with enable-command-block=true

Discussion in 'Bukkit Help' started by wolfo9999, Apr 17, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I never used command blocks on this server before, so I have no clue which plugin is causing this. I have set 'enable-command-block' to 'true' in, I have tested almost every command there is, and none seem to do anything, not even output to the console. I also have the 'commandBlockOutput' gamerule set to 'true'. Any ideas on which plugin it could be?

    Here is a list of my plugins:
    WorldEdit, iConomy, AutoKick, CommandBook, MultiMOTD, Vault, ProtocolLib, PermissionsEx, Modifyworld, MyCommand, WorldGuard, warptastic, ChatManager, DisguiseCraft, HeavySpleef, TagAPI, VanishNoPacket, NameTags
  2. Offline


    Command blocks run different types of commands , for command usage check out the minecraft wiki
  3. Offline


    OOoohhh. I didn't know that. Well now I do :D. And it seems that the command block can only run vanilla commands, and as most of them are overridden with my plugin setup, I tried all non-vanilla commands. So I changed my configs to not override the command I wanted to use.

    Thanks! [Solved]
  4. Offline


    you can run non-vanilla commands with commandblocks. the problem is some plugins may deny the usage of commandblocks.
  5. Offline


    Glad I could help
  6. Offline


    I'm sorry to post in a dead thread like this, but I've spent 3 days searching the forums trying to find this kind of question. I figured I could use non-vanilla commands through command blocks, but I can't figure out how to do it. Specifically, I'm trying to use the WorldEdit command /butcher. Any help will be appreciated. Again, I hope it wasn't wrong to back post so far, but I didn't want to create a new thread when the same question had already been asked.
Thread Status:
Not open for further replies.

Share This Page