CombatTweaks

Discussion in 'Plugin Requests' started by madtomic, Nov 6, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    madtomic

    Suggested Name: CombatTweaks

    What I need: A plugin that only allows hand, bow and swords be used for combat. Any other blocks/actions used against entities is blocked and does no damage or 1 heart damage. LOL

    Support Crit: If the "max damage" for swords is 10 and someone does a critical hit with a 10-damage sword, they'll still do 15 damage by the +50% extra damage from the critical hit

    config.yml

    Combat:
    bow: 3
    hand: 1

    Swords:
    wood: 2
    stone: 3
    gold: 0
    iron: 4
    diamond: 5

    Thanks,
    madtomic
     
  2. Offline

    Vinc0682

    Started working on this plugin, entitys are already unable to get damage.
     
  3. Offline

    madtomic

    Sounds promising! I can't wait!
     
  4. Offline

    Gonmarte

    @madtomic You are a java developer and you cant do this plugin? just saying that because you have 9 plugins....
     
  5. Offline

    timtower Moderator Moderator

    You also saw that most of them are as Tester?
     
  6. Offline

    Gonmarte

  7. Offline

    timtower Moderator Moderator

    @Gonmarte You click on the link "My Plugins"
     
    Gonmarte likes this.
  8. Offline

    Gonmarte

    timtower likes this.
  9. Offline

    madtomic

    Firestar311, Gonmarte and timtower like this.
  10. Offline

    Vinc0682

    Hi, just a small status update,
    i'm actually having problems with dedecting weather a hit is
    a critical or not, config and changing damage aren't a bit deal.

    Vinc0682

    FINISHED!
    I uploaded the plugin to bukkit.org and have to wait for approval :(
    I'll send the link ASAP (or just keep looking for a plugin called "CombatTweaks")
     
    Last edited by a moderator: Nov 9, 2015
  11. Offline

    madtomic

    @Vinc0682

    Great! Can you Dropbox it in the meantime here?
     
  12. Offline

    Vinc0682

    Last edited: Nov 12, 2015
  13. Offline

    madtomic

    Last edited by a moderator: Nov 10, 2015
  14. Offline

    Vinc0682

    Last edited: Nov 12, 2015
  15. Offline

    madtomic

    Thanks for the update but the new link still the NTApi load up error.
     
  16. Offline

    madtomic

  17. Offline

    TheSimpZone

    Without doing/testing this myself I'd imagine you open up the .jar using 7zip or winrar etc. and then edit the plugin.yml. After depend remove the bit that says NTApi. Save the file and reload the server, and it should work.
     
  18. Offline

    madtomic

  19. Offline

    madtomic

Thread Status:
Not open for further replies.

Share This Page