Discussion in 'Plugin Development' started by blackvoid, Apr 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I got a problem when coding my plugin after i updated the bukkit git.
    So i updated bukkit git to the latest version and after that i started to get
    Description    Resource    Path    Location    Type
    The type com.avaje.ebean.EbeanServer cannot be resolved. It is indirectly referenced from required .class files    /DynamicEffectAdminForMinecraft/src/com/dynamiceffect/bukkit    line 1    Java Problem
    In all my projects on the first line. How do i solve this?
  2. Offline


    It happened to me too when I tried to use Bukkit #497, which was the latest build at the time. Googled a lot, and found this post. You can get around the problem by using build #495, which is the latest recommended build as I'm writing this. Due to the problems the team had with Jenkins, the link is down... Until they bring it back up - or release another Bukkit RB - I uploaded my copy on Dropbox, you can get it here. =)
  3. Offline


    I've had the same problem, and I just added the latest version of Ebean as libary just as bukkit or the permissons...
    That will fix the problem
  4. Offline


    It does fix it, but since I'm not sure just adding dependencies is the way to go. If you need Ebean to compile your plugin using Bukkit 497 (for example, I think that one gives the error), will you need it to run the plugin afterwards? I'm not sure, but I think you will. I'd have to test, though, and I don't have my copy of Bukkit 497 anymore since I used RB 495 instead.
  5. Offline


    No, you wont need it to run the plugin.
  6. Offline


    You can add craftbukkit as a external jar to fix this problem.
  7. Offline


    Uh. That's cool, then! I learned something today. Thanks! =)
  8. Offline


    Thank you that solved it for me.
Thread Status:
Not open for further replies.

Share This Page