Chunk load problems with Vanilla 1.8.1 and Bukkit 1145+

Discussion in 'Bukkit Discussion' started by FiZi, Sep 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    This chunk loading issue has me stumped. I've got users complaining the server either lags to the point where it's unplayable or after connecting nothing loads around them.

    We did a large amount of testing tonight and found the problem occured with Vanilla Minecraft 1.8.1, Bukkit 1145 with no mods, Bukkit 1145 with mods (TimeFold, SimpleChestLock, WorldBorder, PermissionsBukkit, mcMMO). I've even tried newer builds of Bukkit but always downgraded back to 1145 because it did work at one point in time. The problem occurs with brand new worlds or our existing world. Oddly the problem started after this weekend (Sept 18th, 2011).

    My server is a Core 2 Duo 2.2Ghz, 8GB of RAM and a 100mbit down/5mbit up internet connection (Shaw Cable, Canada). We're using Java 1.6.0_26 64-bit and I've tried 1.6.0_27 with no help there running CentOS 5.7 64-bit. During testing we also tried using my Windows 7 64-bit desktop (Quad core, 4GB RAM) to run a server. No dice.

    Stranger still. During the day 6:00am - 4:00pm PST everything appears to be working fine. After that everything seems to go down hill. I know Canadian ISPs throttle P2P traffic during prime-time so I'm starting to think Minecraft traffic might be triggering their throttling and causing the problem. I've got a friend who literally lives across town with the same ISP and can't play on my server as well as other users from across Canada and the USA.

    Three questions:
    1. Based on what I've written does anyone have any suggestions for me?
    2. Is anyone else experiencing a similar problem?
    3. Anyone else on the forums using Shaw Cable in British Columbia, Canada and having/NOT having this problem?

    I'm stumped.
  2. Offline


    I get lag issues, but mainly from users (and me) flying around on the server - bumping the mem usage to over 4GB from the standard ~700MB. I've just chalked that up to the dev build/plugin/client mods not all working together seeing as there isn't an RB yet.

    Yes, I know, flying around is bound to increase resource usage... but this is more of. Restart server, log in, 300MB usage. Fly around, just fine, hit a random area that is loading slow, client freezes, server mem usage starts to climb until it maxes out, or I force quit the client. - something i never had any issue with running 1.7.3 (with 5+ users flying around on a 700MB+ map)

    are you having any memory usage issues? Or just "lag" in users loading chunks? I do know that an ISP up there just got in trouble for throttling gaming traffic - could very well be yours will be next, and in a couple weeks be in good shape.
  3. Offline


    We used WorldBorder to limit the world to a square with a diameter of 4000. We also used the fill command to generate the entire world. Our entire world is 300mb and no one can fly. My users are literally just logging into their bases from the afternoon or morning when everything was working fine to end up in laggy, mising chunk failure.

    Friend of mine from the East Coast connected in at 4:00am PST and reported zero problems with the server.

    It's looking more and more like ISP throttling OR some kind of clock related bug in the server. The former is more likely.

    As far as I'm aware we are not having any memory usage issues. I just implemented garbage collection as part of troubleshooting this problem as well. I've given the Minecraft server 3GB of RAM (-Xms3072M -Xmx3072M) to play with and I don't think it ever uses it all.

    The ISP that got in trouble was Rogers which is an ISP back east and they were miss-classifying World of Warcraft traffic. It's entirely possible my ISP (Shaw) is doing the same thing with Minecraft.

    Tonight if the problem occurs again I'm going to get one of my users to VPN into my network and then try Minecraft. The theory is the VPN traffic won't be throttled because it's encrypted and can't be identified.
  4. Offline


  5. Offline


    wassilij likes this.
  6. Offline


    1179 is a bad build ... try 1178 or 1179+ when its out.
  7. Offline


    I tried a few of the most recent builds and none of them worked, even with BananaChunk. I erased the world files and let Bukkit craft a new one from scratch without a specific seed and now upon joining the game stalls at the 'downloading terrain' loading message and eventually gets the 'internal exception: read timed out' message.
  8. Offline


    Sorry I meant 1178.

    One thing I've noticed is on a fresh world bang the first 2-5 min are always terribly laggy while the spawn area generates. If it doesn't clear up after that then I'd say there is a problem.

    Just a quick update. So far with Bukkit 1178 my users haven't reported any problems tonight.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  9. Offline


    Recommend Bukkit Build 1185 is out ;) Update CraftBukkit, but dont delete BananaChunk
  10. Offline


    Heh yeah I saw. Just in time for Notch to release 1.8.2 :)

    I'm going to update shortly.
  11. Offline


    Thing is, I didn't even make it that far. On a fresh world, I would hang on the downloading terrain screen, but no terrain would download and I'd eventually get kicked back out. Gonna try the new RB here in a bit and see if that helps.
  12. Offline


    I have been having the same problem with my server. I got the bananachunk thing too. its like soon as you log on the server you get the few chunks in the area but nothing else loads you cant even talk in chat. although you can move around freely and break things. After a minute or so it crashes out and you remain logged on even tho your not there until the server gets restarted. any attempt to walk out into an unloaded area and you fall off the earth.

    we have mcmyadmin and the latest bukkit build the #1185 one. so i have no idea what is going on.
  13. Offline


    same problem here but i havent tried bannachunk, no matter what I do it still loads so slow.

    -EDIT Tried it without any plugins installed also and it still loads terribly slow, bukkit RB 1185 btw,

    I am using McMyAdmin also.... hmm I wonder if its that

    Without McMyAdmin running the chunk loads are faster, much faster. but still slower than 1.7.3

    Okay I found a solution, In McMyAdmin go to your McMyAdmin config file and change the java from client to server, Client doesnt give enough bandwidth for the chunks but server gives more than enough AND it runs faster with less memory if I have tested right :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  14. Offline


    there is a spec chunk when i log in while standing in it it will lag my client. using 1185. tried no plugins. I even worldedit the chunk and remove all blocks from it. same issue.
Thread Status:
Not open for further replies.

Share This Page