Inactive [CHAT/MECH] DimensionDoor v2.1.1 Multiworld management made easy [1.3.1-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by grandwazir, Jun 28, 2011.

  1. Offline


    is it true that you not save the items when you go in e creative world? then wen i go back is my inventory clear....
  2. Offline


    About those :
    - generate-structures=true/false
    - level-type=DEFAULT/FLAT
    - spawn-npcs=true/false

    Will you update your plugin to be able to create/modify a world with these settings ?
    Or does bukkit don't let you do that because no one has posted something in ? =p
  3. Offline


    I don't know how but some of my users have found a way to bring items back from the creative world.
  4. Offline


    you should add a portal system
  5. Offline



    /dd create <new_world>
    /dd teleport <new_world>

    And you place your portals.

    I love DimensionDoor + Stargate. =)
  6. Offline


    Hey, I've created a world with /dd create temp s:8700829340959843130

    ... And it took that seed instead ! -947059995 ...

    I think the seed bug is still not properly fixed. =p

    Edit : Oddly, with "1234" it works (seed "1234" is used), but with 8700829340959843130, it use the seed "-947059995".
  7. Offline


    Hello, I sorry but I found a problem when removing worlds from a list. I have some worlds that have spaces in it:
    Red Stone Inventions
    Red Stone Inventions_nether
    Red Stone Inventions_the_end

    I tried removing them but It won't let me. I tried to delete the world files but the server crashes then recreates the worlds. How can I remove it?
  8. Offline


  9. It's not something a lot of plugins deal with. Basically Bukkit should handle the persistence thing on its own. It's a blurb in your bukkit.yml, the database section. It just needs to be sane so DD can create a database and use it. By default Bukkit will use SQLite databases for each mod.
  10. Offline


    hey again i'm sure i'm doing something wrong i hope some of u can help me out.
    first of all this is what my bukkit.yml points after.
    username: Minecraft
    isolation: SERIALIZABLE
    driver: org.mysql.JDBC
    password: somepassword
    url: jdbc:mysql://localhost:3306/Minecraft
    also here is the bug lines i get when running the server
    2012-02-16 11:48:34 [INFO] This server is running CraftBukkit version git-Bukkit-1.1-R3-b1846jnks (MC: 1.1) (Implementing API version 1.1-R3)
    2012-02-16 11:48:34 [SEVERE] not found
    2012-02-16 11:48:34 [SEVERE] Could not load 'plugins/DimensionDoor.jar' in folder 'plugins':
    javax.persistence.PersistenceException: Problem loading Database Driver [org.mysql.JDBC]: org.mysql.JDBC
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.initialise(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.<init>(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourceManager.getDataSource(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourceGlobalManager.getDataSource(
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.getDataSourceFromConfig(
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.setDataSource(
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.createServer(
        at com.avaje.ebeaninternal.server.core.DefaultServerFactory.createServer(
        at com.avaje.ebean.EbeanServerFactory.create(
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.<init>(
        at net.minecraft.server.ServerConfigurationManager.<init>(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException: org.mysql.JDBC
        at Method)
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(
        at com.avaje.ebeaninternal.api.ClassLoadContext.forName(
        at com.avaje.ebeaninternal.api.ClassUtil.forName(
        at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.initialise(
        ... 18 more
    so i think i'm doing something wrong with the url: jdbc:mysql://localhost:3306/Minecraft
    is that the right way or do i have to write it somewhat diffrent ?
  11. Your configuration indicates a MySQL server running on your system on port 3306 with a database named Minecraft (if I'm not mistaken, I'm not familiar with the syntax when using MySQL), and a MySQL login name of Minecraft and <somepassword>. If you don't have a MySQL server, I'd recommend changing it over to SQLite which is standalone and doesn't require you to install anything else. For that, you'll want to update the following lines to match:
    driver: org.sqlite.JDBC
    url: jdbc:sqlite:{DIR}{NAME}.db
    And I'll assume that the user name and password aren't hard coded and are taken from this file in creating the databases. But if it doesn't work we'll figure it then.
  12. Offline


    still not working for me.....

    username: bukkit
    isolation: SERIALIZABLE
    driver: org.sqlite.JDBC
    password: someweirdpassword
    url: jdbc:sqlite://localhost/Minecraft.db

    should that not work or?....?
  13. Unless you mistyped, you didn't update your URL to the one I listed completely. Copy what I put verbatim.
  14. Offline


    Is this plugin no longer being updated then? :(

    Grandwazir, you still haven't published a build with the bugfix that will let people use creative and survival worlds without letting people bring things back and forth.
  15. Offline


    You should add a feature where it puts the world name before your name. This is useful, as i have got to maps and we have people in different permissions in the different worlds so using this would make it easy to tell which world they have those perms on.
    For example:
    [main][Owner]Canio22: test
    and after hopping worlds [world][Owner]Canio22:test
  16. I would think this is something a chat plugin would handle over a world management plugin.
  17. Offline


    I haven't seen any chat plugin that does this.
  18. Offline


    Hmm... update needed. =p

    15:21:47 [GRAVE] Error occurred while enabling DimensionDoor v2.0.1 (Is it up to date?)
    java.lang.NoClassDefFoundError: org/bukkit/event/world/WorldListener
            at java.lang.ClassLoader.defineClass1(Native Method)
            at java.lang.ClassLoader.defineClassCond(Unknown Source)
            at java.lang.ClassLoader.defineClass(Unknown Source)
            at Source)
            at Source)
            at$000(Unknown Source)
            at$ Source)
            at Method)
            at Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at name.richardson.james.bukkit.dimensiondoor.DimensionDoor.registerListeners(
            at name.richardson.james.bukkit.dimensiondoor.DimensionDoor.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.t(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException:
            at$ Source)
            at Method)
            at Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 27 more
    Using git-Bukkit-1.1-R4-30-ge00a561-b1963jnks.
  19. Offline


    ehh well my console is getting errors and when i write /dd list or anything all that comes up is the commands
  20. Offline


    Please update your plugin.
  21. Offline


    Update please? Pretty please?
  22. Offline


    Need Update for 1.2.3 :(
  23. Offline


    Really sorry everyone. I had updated this plugin ready for the recommended build (in fact it was the first one I did) but I did not change the download address. The updated version has been available since 2nd of February from my personal repository. Good news is it works perfectly with the new version.

    I did fix a couple of bugs related to that. If it still happens with he latest version post a bug on GitHub. I see things quicker there.
    At the moment either delete the sqlite database for DimensionDoor or drop the database in MySQL.


    Please post details about that seed bug to github so I can look into it.
    HereInPlainSight likes this.
  24. Offline


    Very nice! works well!

    Just a suggestion tho, it needs a CONSOLE command that TPs a player to a specific world :D
  25. server proberties PVP can be OFF if i want to make new world with pvp true?
  26. Offline



    i love the plugin but have recently been coming up with this error:

    [INFO] DataSourcePool [DimensionDoor] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    [INFO] SubClassFactory parent ClassLoader []

    I am running Craftbukkit 1.2.3-R0.2 and DimensionDoor v2.0.1

    if you could reply it would be appreciated.

  27. Offline


    is there any way to have different inventories between 2 different worlds?
  28. there is a plugin called MultiInv which handles that and you can even choose to store exp per world so that each world has it's own exp.

    can you add support for the flat world type please. it would be very useful for creative worlds

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016

Share This Page