CB 2190 Startup Error: java.lang.NoClassDefFoundError

Discussion in 'Bukkit Help' started by quickclay, May 18, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, I get the following error immediately after startup after upgrading to the new RB 2190. Any ideas?

    182 recipes
    27 achievements
    java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.
    at org.fusesource.jansi.internal.WindowsSupport.getConsoleMode(WindowsSu
    at jline.WindowsTerminal.getConsoleMode(WindowsTerminal.java:176)
    at jline.WindowsTerminal.init(WindowsTerminal.java:80)
    at jline.TerminalFactory.create(TerminalFactory.java:93)
    at jline.TerminalFactory.get(TerminalFactory.java:151)
    at jline.console.ConsoleReader.<init>(ConsoleReader.java:140)
    at jline.console.ConsoleReader.<init>(ConsoleReader.java:126)
    at net.minecraft.server.MinecraftServer.<init>(MinecraftServer.java:94)
    at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:615)
    at org.bukkit.craftbukkit.Main.main(Main.java:140)
    Press any key to continue . . .
  2. Offline



    i got the same error and searched on google for this. All i found is that you have to install the Microsoft Visual C++ 2008 SP1 Redistributable Package (x86). But on my Windows Server 2008 R2 (x64) it won't run :( I also tried to install the 2010 version (x64)... Anyone out there who got a solution for this?
  3. Offline


    Ok.. I added --nojline to my startup scripts and it seems to have stopped the spewing of errors. It seems to have disabled colors completely at the console. lol. Maybe I will try another terminal emulation. Probably ANSI. Also seems that minecraft.net is DOWN.. augh
  4. Offline


    I found something else:

    if i start the R1.0, the file "jline_git-Bukkit-1_2_5-R1_0-b2149jnks.dll" will be created in the %Temp%-folder, but if i want to start the R2.0, the created file is named "jansi-64-git-Bukkit-1.2.5-R1.3-13-g7ab0391-b2190jnks.dll".

    Now i wonder why it says "R1.3" and not "R2.0". Maybe the file is outdated?

    i just tried to start the server on my desktop and it worked fine, the file in the %Temp%-folder is named equal...
  5. Offline


    I have the same problem. I installed the C++ redistributable package like julianhendricks said, but it didn't help. I am also using server 2008 R2 x64, and it still works fine on my desktop.
  6. Offline


    I am using server 2008 R2 as well. This is a bummer.
  7. Offline


    I think i'll just stay on build 1.3 for now.
  8. Offline


    Quote from the official release-information on bukkit.org

    Answer from "feildmaster" (and as "diskman2011" already said).

    The line in my startup script now looks like this:
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xms64M -Xmx1536M -jar craftbukkit.jar --nojline
    I added this and now it works fine (first time i failed while placing "--nojline" :D). I hope this also helps you :)
  9. Offline


    Great thanks for the help. I wasn't getting -nojoline to work (bad placement).
  10. Offline


    Hi julianhendricks thank you sooooo much :D
  11. Offline


    Jestes ZAjebisty
  12. Offline


  13. Offline


Thread Status:
Not open for further replies.

Share This Page