Can't load plugin

Discussion in 'Plugin Development' started by Znerox, Aug 9, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Znerox

    I'm just learning how to program plugins (with Adamki11's tutorial). I've made my first plugin, but when i try to use it i just get this message in console when MCMA starts:

    [SEVERE] Could not load 'plugins\TestPlugin.jar' in folder 'plugins': name '<TestPlugin>' contains invalid characters.
    org.bukkit.plugin.InvalidDescriptionException: name '<TestPlugin>' contains invalid characters.

    I've looked through the code and i can't find anything wrong with it. Can somebody help me out? :)
     
  2. Offline

    Taco

    I think it's saying that < and > aren't valid characters to be used in a plugin name. Try changing that and report back if the problem persists.
     
  3. Offline

    Znerox

    But i didn't include < > in the name. I just called it "TestPlugin".
     
  4. Offline

    Zarius

    Can you post your plugin.yml file?
     
  5. Offline

    Znerox

    plugin.yml
    Code:
    name: <TestPlugin>
    main: <me.znerox.testplugin>.<TestPlugin>
    version: <0.1>
    I cleaned it up and it's working as it should now. I guess i went through the tutorial on autopilot and didn't notice :rolleyes:. But thanks for helping me see the problem.
     
  6. Remove the <> from everything :O The code should be this:
    Code:
    name: TestPlugin
    main: me.znerox.testplugin.TestPlugin
    version: 0.1
     
Thread Status:
Not open for further replies.

Share This Page