Solved Can't keep up!

Discussion in 'Bukkit Help' started by Fabrikantje, May 1, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hello guys!

    I'm having (another) problem with my server.

    This time he always says "Can't keep up! Yada yada yada."

    It occured after I've installed bPermissions and bChatManager.

    Any ideas?

    Show Spoiler

  2. Offline


    Can't keep up is mostly related to low upload speeds
    do you have high or low upload speed?
  3. Offline



    Edit: High I guess?
  4. Offline


    Oh i already know what is causing the problem

    my friend also wanted to host a server and he also had Belgacom and trust me it won't work
    belgacom has very low upload speed even if you have 3mb/s
    my speed is even slower and i don't get that error
    and im on wifi (3rd floor) my modem is at main floor
    when my pc is at main floor i reach connection download : 75 mb/s upload 5-10 mb/s
  5. Offline


    Uh, can't keep up doesn't have anything to do with upload speed. It's to do with the hardware of your server not being fast enough. I've seen it when using a slow HDD, with a slow CPU or not enough RAM allocated.
    Fabrikantje likes this.
  6. Offline


    Deleted bPermissions and bChatManager and works like a charm again.

    Too many plug-ins I guess?

    Edit: Or not.. Still the same error.

    Got Intel i3 CPU & 8gb of RAM.
    Maybe has my PC been up too long?
  7. Offline


    Post your CraftBukkit version, startup script/batch file, and your plugin list.
  8. Offline


    if you just dont care about error and want to cant keep up message disappear
    go to your bukkit folder there open bukkit.yml

    and next to something like
    warn when overload change true to false
  9. Offline


    throw an i7 in there :p (or an i5) its the CPU, though it shouldnt matter. Do you experience lag in the game? Also, there seems to be a problem with the craftbukkit server where it uses way more CPU power than it should. Lets see what happens
  10. Offline


    CraftBukkit Version:
    [INFO] This server is running CraftBukkit version git-Bukkit-1.2.5-R1.0-b2149jnks (MC: 1.2.5) (Implementing API version 1.2.5-R1.0)
    Startup Batch:
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xmn4G -Xmx5G -Xms5G -XX:MaxPermSize=6G -jar Minecraft_RKit.jar hidden:hidden
    Plug-in List:
  11. Offline


    There's a setting to disable it in bukkit.yml
  12. Offline


    I know, but it still worries me.
  13. Offline


    All it means is that you didn't have 20tps (due to something calculating something) at that moment in time.
    20tps isn't acheived on any major server - even herocraft (the multiverse) I think at full capacity with their i7 5ghz monster only gets about 16tps
  14. Offline


    The problem is your playing Minecraft on the same computer your trying to host on.
  15. Offline


    It didn't happen before.
    Also, it isn't happening now.

    It's.. random I guess?
  16. Offline


    Server has the common cold? happens. don't know though.
  17. Offline


    There are some other things which can cause the servers TPS to drop triggering the warning, but I’m not seeing them in your case. Your server had just started, you’re not running very many plugins and at the time of the screenshot, it was just you on the server. Everything to me seems to point at something else taking up a lot of processor time. If it happens again, look at your task manager and see what other processes are doing in terms of CPU.
  18. Offline


    As others have asked, does this actually translate into in game lag for you?

    Is some other process running when this happens? Even something as simple as you copying some files around at the time could be the cause. I used to see it whenever my backup plugin started but that's been resolved with an SSD

    Some things that may be contributing since this is probably CPU or disk and your CPU is fairly weak.

    Try excluding the entire bukkit folder (and all subfolders) from any antivirus software you have running, since the world files are always changing this could be putting load on your CPU and disk

    Try removing dynmap, it can be a bit of a hog if you're already struggling for performance

    It looks like your startup command line is telling java to start with more memory (5G) than it should run with normally (4G). That shouldn't hurt anything but it might be worth removing the -Xmn option. Some people have also reported adding -server to that command line helps
    Fabrikantje likes this.
  19. Offline


    No lag for me, I've not yet tested it with friends on the server.

    Applied -server & deleted -Xmn, will test tomorrow if anything changes.

    Thanks for now.
  20. Offline


    Applied -server & deleted -Xmn.

    Much more stable right now, no more overloads.

    Thank you!
  21. Offline


    Does it really works!? Gonna test it out soon! This problem is freaking me out!
Thread Status:
Not open for further replies.

Share This Page