Can't get rid of bugged Player Entity...

Discussion in 'Bukkit Help' started by djrazr, Apr 9, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    djrazr

    I have this problem on connecing of several accounts (restart doesn't solve):
    Plugins are:
    I don't know how this happend and which plugin caused that, but not everyone has this problem - only a few... Things i tried so far:
    Is there a way to restore the world?, i mean right not its just me and some clients which are not able to connect... Is there no way (maybe a plugin) to remove those "dead" entities as worldedit has the /remove for items and exp?
     
  2. Offline

    djrazr

    Well.. okay, i stopped, deletet all Users in the Worldfolder and the Problem stopped to occur... Till now /; Half of my users are bugged again.. Can nobody help me with this? Is there no nearly identical problem which already occured like this here?, Thanks -dj
     
  3. Offline

    dadaemon

    Two things. Are you running in offline mode?

    Second, have you updated all your plugins?
     
  4. Offline

    Avarice

    Hmm, I'm having the same issue. The only thing that we appear to have in common is VanishNoPacket, which I recently updated. Going to try to downgrade and fix it. Also, only seems to be happening to my moderators, which have the vanish permissions.

    Edit: Whelp, it's not VanishNoPacket. :\

    All plugins:


    Added just before issue:
    CombatTag
    HomeSpawnPlus
    PVP_PROPER
    pvparena
    RideThaDragon

    Have tried chunkster, removing each plugin one at a time to isolate the issue, but it seems to correct itself eventually. Truly a headache.
     
  5. Offline

    djrazr

    Well... thought about that and assumed that only the world managment plugins could be an issue / so i disabled Multiverse and fixed that problem without needing to delete user files... I know researched that problem further and found out that if Multiverse is installed /Latest Dev Build #527) The the spawn of an user is impossible if he logged out in another world... So easy :D..
     
  6. Offline

    djrazr

    Try again to remove multiverse.. and totaly restart Bukkit..
     
  7. Offline

    Avarice

    Removed multiverse (sort of out of necessity, since I tried first to update it to a recommended build unsure of whether or not I had been using a dev build) and it refused to initialize, put the backup back in and it still errored out.

    We still had the bugged player entity issue with one person afterward, but I'm not sure if that was still just because the file truly was damaged in some way, or if multiverse was not the issue.

    The thing that got me was that multiverse was working fine before the pvp update, and we were not having this issue.
     
  8. Offline

    Avarice

    It's definitely not Multiverse. It hasn't been on the server, and players who are disconnected in the Nether will get the internal server error. It is thought that xAuth may be the culprit, but an update of that didn't help anything.
     
  9. Offline

    djrazr

    xAuth v2.0.5 andVanishNoPacket v3.6.2 (Is outdated now.. i know..) are runnin fine on my machine.. It behaves the same on my machine, no update, nothin.. it just started to occur... What you can do, and will probably fix that for a unique player is removin him from all Usermanagement Plugins which has a record of him / so essentials if you have, and Minecraft itself in the Players directory of all worlds... Just turn ya machine off, remove him completly and if he then enters with blank inventar / he should spawn at your spawn without any issues..

    It is Multiverse over here.. dk what your problem is if you say its not..
     
  10. Offline

    Avarice

    Multiverse had it's own set of problems, but it's not causing my particular one since we haven't even had it on the server in days. I think it may have something to do with a bug that is vanilla that is spawning players on TOP of the nether when they first log in, and that something is trying to correct it (Bukkit?) and failing.
     
  11. Offline

    Frisky

    Offline mode does not cause this error...
     
  12. Offline

    djrazr

    Just ignore it if'ts dumb :D
    Well, i have it again now, with mv turned off :S ...
     
  13. Offline

    Avarice

    Recreated my server, fresh configs, all plugins are the most recent versions, do not have this issue anymore.
     
  14. Offline

    rhino033

    Same thing happening here, I log-out in another world and get the same exact problem
     
  15. Offline

    gaculu

    It's xAuth's issue. Try using:
    Code:
    /xauth location remove global
     
  16. Offline

    Avarice

    We actually hadn't been using the xauth location set feature until the new revision of the server. The issue reoccurred with one player, however it seemed to be after he had set up a falsebook toggleable area in the Nether. We removed the area and the issue went away.
     
  17. Offline

    theLAZYway01

    I Have tried almost everything except takin plugins out like 1 or 2 and for only a couple people on mine (me and a friend) it says internal server error and i am getting PISSED what should i do plz help ip is 69.116.206.40
     
Thread Status:
Not open for further replies.

Share This Page