Can't get port to forward.

Discussion in 'Bukkit Help' started by Thanitos, Jun 17, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Thanitos

    Hello, so with both this server and the regular minecraft server I cannot get my port to be forward(ed?).

    I am running windows 7
    My router is a NetGear WNDR3300
    I also have an Verizon DSL modem.

    My desktop connects to my router VIA an USB wifi adapter, NETGEAR WNDA 3100 V2


    EDIT- I didnt realize the pictures would be so small so...
    Netgear router.
    IPv4 is 10.0.0.2

    default Gateway is 10.0.0.1

    Verizon modem-
    Ip is 192.168.1.30
    this also has my REAL ip address I think its called my external?

    The server ip is left blank
    My netgear port is set to the ip of 10.0.0.2 and 25565
    [​IMG]


    [​IMG]


    [​IMG]


    [​IMG]
     
  2. Offline

    ronald8940

    Try using this.

    http://www.simpleportforwarding.com

    This is what I used to forward my port. Just install it and run it and on the right window there are steps to follow. Just follow them and at the end it should ask you to test the port if it is open on both TCP and UDP. Good Luck !

    -------Edit----------
    Are you getting an error?
     
  3. Offline

    Thanitos

    I tried this but it still failed to open the port.
     
  4. Offline

    ronald8940

    Are you getting an error? What makes you think your port is not forwarded?
     
  5. Offline

    TheMadMan697

    This is setup correct as far as I can see however 192.168.1.30 is not your external address. Get it from here http://www.whatismyip.com/
     
    Thanitos likes this.
  6. Offline

    Thanitos

    I know that isnt, thank you. I didn't get an error I just went to the port checking websites and it tells me the port is closed
     
  7. Offline

    sverre26

    Try to mark the plase where you can mark the port then press aply
     
  8. Offline

    jacklin213

    Thanitos the reason y it says the ports are closed on the websites is because all those websites ping the port and expect it to ping back but its not ment to thats y it says the port is close.Use this http://www.ipfingerprints.com/portscan.php go to advance and select "Don't ping" then type in your internal ipaddress which you used to port forward (use the one which starts with 192.168.****) then enter for the start port :25565 and then end port:25565.
    if you port forward correctly it should say this:
    Host is up.

    PORT STATE SERVICE

    25565/tcp filtered minecraft
     
    Thanitos likes this.
  9. Offline

    Thanitos


    Ah that worked perfectly thank you so as Themadman said, it is set up correctly and as you said, its just the websites not being designed for what I needed. So if I want someone to play I give them my real Ip for instance......

    Xxx.xxx.xxxx:25565

    ?
     
  10. Offline

    jacklin213

    you go to www.whatsmyip.org/ that is your exturnal ip. with that ip u give it to other people
    you use ur portforwarded ip to start the sever (thats your internal ip address)(remeber to put it in your sever.properties file) and you use your inturnal ip to join ur sever if that doesnt work then use ur exturnal one

    you dont need to give them the ":25565" because thats the port by default
     
  11. Offline

    Thanitos

    Ok, so I gave them my ip and my port is forwarded but they still get cannot connect to server.

    My windows firewall port isnt set up and when it tells me to click add port under allow a program through the firewall but I cannot find 'Add port"

    Sorry......
     
  12. Offline

    ePic4Lyfe

  13. Offline

    Thanitos

    I added the exception to windows for both inbound and out bound to allow Minecraft at port 25565

    I shut off avast and still nothing

    I changed my port from 25565 to 56408 because 56408 is established on 10.0.0.2 while 25565 is not. At the moment I have no way to test if this worked though, my friend went to sleep.

    [​IMG]
     
  14. Offline

    jacklin213

    Thanitos oh boy u shouldnt have done that
     
  15. Offline

    Thanitos

    Whats that?
     
  16. Offline

    jacklin213

    that ^
     
  17. Offline

    Thanitos

    Is it the port I selected? I don't understand really....

    It isn't like I cant switch it back I'm just still getting an issue with others connecting but I saw another forum that said in netgear routers you can select it to NOT scan incoming ports and to enable a DMZ to a certain address so I made the DMZ my ipv4 address but like I said no way to test it yet.
     
  18. Offline

    jacklin213

    kk feed back after u test it
     
  19. Offline

    Thanitos

    Alright, so still the same issues as before..........
    What I am about to try......

    I'm going to factory reset my router, re do all the ports I need and get rid of any firewalls I have....

    What I noticed......

    My verizon modem which is my external IP shows my router as having the IP of 192.168.1.30

    To access verizons modem I have to type 192.168.1.1

    To access my router I have to type 10.0.0.1 but if I unhook the modem I can use 192.168.1.1...

    My router gives out ips in the form of 10.0.0.X

    In my router settings I cannot forward info to any ip outside of the 10.0.0.X range so I cannot set it to 192.168.1.30 for instance....

    Is it possible that, since my MODEM ip is being shown as my external IP that my computers external IP isnt the same? I dont know if this really makes sense I don't mess with this much but it just makes sense to me.

    Maybe the router not letting me forward to my modems external IP is the issue?
     
  20. Offline

    Sketaful

    To port forward you need to open the correct ports in your router.
    To bypass the router completely you can set your computer as DMZ which means it acts as if no router stands in its way.

    The problem you're facing isn't only the router thought. Since your modem also is reachable through an ip-adress it seem to have an built in router aswell. This means you have two routers you need to bypass.

    Check your modem if it's possible to configure DMZ in that as well. If not, open all ports on it. There is hardly any sequrity issue with opening all ports on the modem since you still have the router after that.
     
  21. Offline

    Thanitos



    I will try this tomorrow, my Modem DOES have a Firewall I just cannot access it, not sure what my modem password is, I think its the billing number so I will have to call to be sure. So set my pc up as the DMZ and port forwarding on my router wont matter?
     
  22. Offline

    Sketaful

    It probably doesn't help until you've configured the modem. :(
     
  23. Offline

    jacklin213

    y do u want to use both?? all u need to do is to portforward your NON-NETGEAR router to the port :25565
    the go to google and search up whats my ip. give them that one. REMEBER to put ur internal ip into ur serverproperties file . if they cant connect tell them to type in this "(your external ip):25565"
    what firewall are you using??
     
  24. Offline

    Sketaful

    He did say "my Modem DOES have a Firewall I just cannot access it" so it would be fare to believe he actually can't configure it yet. If that modem is connected to a router then the router will stop the connection when he finaly have configured the modem to let the connection through, right?

    Why he have a router connected between the modem and the computer on the other hand... Well, perhaps he need it for something. :p
     
  25. Offline

    Thanitos


    I have windows Firewall and Avast, the firewall I referred to just a second ago was the one on my DSL modem which I don't know the password for so once I get that Ill open that port as well.

    My router is hooked up to the modem down in the family room to our main pc, my pc is across the house and a wifi adapter seemed like a logical item to have. Plus three laptops, 3 ipods, 2 cellphones, I think you get my drift lol..

    Ok.........so another update.

    Here is what Im seeing... My modem has an external ip that shows up on all my computers when i check in on an ip testing site.....

    My router connects to my modem through the ip 192.168.1.30

    In my Modem I can port forward to any ip in my LAN so what ip do i use? My minecraft host is on 10.0.0.2 so my modem should forward any incoming connections on 25565 to 10.0.0.2? Or should it forward it to 192.168.1.30 (my router) which then ports it to 10.0.0.2 making a DMZ in my router to 10.0.0.2 and or port forwarding to 10.0.0.2 as well.

    I can also only choose in or out for the port, should I set a rule for both types?

    with my external IP I should still give that out to the person I want to play with even though that links Directly to my modem and not my pc? because if my modem gets a 'call' from a pc to 25565 it will send it to my router 192.168.1.30 which will see another forward to 10.0.0.2?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 26, 2016
  26. Offline

    ImminentFate

    I have the exact same router as you, so I know that you have done the steps right.
    I wrote this tutorial on how to port forward. Ironically, a week after writing it, I found I could not port forward myself :p. I discovered the problem was with the windows firewall. Disable it, and everything would work, enable it, and the stupid thing would not work.
    To solve the issue, Simply open up Control Panel, and follow these steps:
    1. Click System and Security.
    2. Under Windows Firewall, select Allow a program through the firewall
    3. In the top right, select Change settings.
    4. Scroll down until you see "Java (TM) Platform SE Binary"
    5. Select the checkbox next to it, and then also select the checkbox allowing it to connect to Home/work networks.
    6. If you see many ones, select them all for now. But come back later and work out which ones you don't need
    7. Try running the server, and head to http://canyouseeme.org and type in the port.
    If it won't work, try using this tool I made, and enter in your portforward details. It will automatically set up the port for you. You will still need to configure your firewall, unfortunately, but I'm working on that.

    At the end of all this, make sure to go back into your firewall and work out exactly which java process is your server. That way, any that were disabled before can go back to being disabled
     
    HK83 likes this.
  27. Offline

    Thanitos

    Does an Hamachi server requier all this BS? I really cannot figure out what to do. I'm not an expert in this field so I give up. My router was forwarded my modem was forwarded it just doesn't want to load up for some reason.

    ...........After bitching like.......a bitch...............I fixed it........With magic?????

    I really appreciate all the help I received here from everyone that posted. You all lead me to my end goal and it is well appreciated. So here is what I have .....

    Starting from my mode.

    Ports ranging from 25560-25565 are forwarded to 192.168.1.30

    192.168.1.30 is my Netgear ROUTER

    From 192.168.1.30 port 25565 is forwarded to 10.0.0.3, My computers LAN ip

    With the port checker tools you all listed i know get OPEN!!!!!!!

    Again, thanks to everyone that replied I greatly appreciate the help. This can now be locked as we have solved it!
     
  28. Offline

    jacklin213

    Thanitos np now mark it as solved lol >.>
     
    HK83 likes this.
Thread Status:
Not open for further replies.

Share This Page