Problem/Bug Bukkit won't launch on Amazon EC2 Linux

Discussion in 'Bukkit Help' started by nicholasjw, Aug 11, 2018.

  1. Offline

    nicholasjw

    This is the error message I keep receiving whenever I try and launch the server.

    Exception in thread "main" java.lang.UnsupportedClassVersionError: org/bukkit/craftbukkit/Main : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14 2)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:323)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)

    Then it brings me back to the terminal where I can re-launch, and it does the same thing. I checked, and I have Java 8 installed. Any ideas?

    Problem fixed!

    Just do
    sudo update-alternatives --config java

    And select the java verison you want.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Aug 12, 2018

Share This Page