Bukkit not working, secret update from notch?

Discussion in 'Bukkit Help' started by SpyDaniel, Jan 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    SpyDaniel

    Bukkit stopped working a while ago, maybe 2-3 hours ago from now. I can not connect to my server while running the bukkit dev build. Has Notch released a sneaky update to the client just in spite of bukkit?
     
  2. Offline

    Archelaus

    It works fine for me. Tested 10 seconds ago.
     
  3. Offline

    SpyDaniel

    Which build?
     
  4. Offline

    Euphoriant

    I have a similar problem. One minute I was testing a plugin, I restart my server, and then I cant log into my server. Im not certain if it is a hidden little notch-update or what.

    [edit] Oh yeah, I'm using the latest build (66 I think). Windows 7 x64. I can run minecraft_server.jar and connect to the server, but when I run a server through Bukkit I cannot.

    Yeah, I'll bump this because it seems like a strange occurrence.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jan 9, 2016
  5. Offline

    8e8

    Have you tried running cbukkit w/o plugins? I had no problem with build 66.
     
  6. Offline

    l5p4ngl312

    Yup. Notch decided to run a seeccreeet sunday update called "FukaBukkit", the goal of which being to break Bukkit, after he already agreed to help Bukkit with their licensing...
     
  7. Offline

    Euphoriant

    That's pretty much what I was thinking ... except I figured the update would be called FukkitBukkit.

    Actually, yes I've tried running without plugins. To no avail.
     
  8. Offline

    liquidthex

    So...Troll thread?
     
  9. Offline

    SpyDaniel

    Tested Bikkit on my local machine, works fine. Try it on my server provider and it won't start up. I say wont, but I did actually get it to once, then it stopped again after I rebooted.

    I'm guessing it has nothing to do with notch updating, but some thing to do with the java process hanging and not responding, but keeping the port/ip open so that when the server is ran again it can't, as the ip/port are in use already, so closes.

    My server is hosted on a linux machine.
    Local test is ran on windows.
     
  10. Offline

    TnT Retired Staff

    I've restarted my craftbukkit server (java process) many times and haven't seen this issue. What build are you running? What OS/OS Version? What java version?
     
  11. Offline

    Ante0

    I'm having troubles with 66-69 builds. It doesn't save chunks correctly (it actually removed chunks that were already saved).
    Had to use #65 which works fine :)

    So maybe it's the build that gives you troubles?
     
  12. Offline

    SpyDaniel

    Seems the problem was with my server host. The .jar was not closing when I restarted the server, so it was hanging onto the IP and port, stopping another server being ran. It has been resolved now.
     
Thread Status:
Not open for further replies.

Share This Page