[BUG] Map generator in #1467 (1.0)

Discussion in 'Bukkit Discussion' started by umarth, Nov 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I try create a map in #1467, and see extranges lines in ocean biomes, try other seeds, and the lines appear in all it. Create a map in single player with the same seed (Es un mapa genial) and this lines gone:

    Bukkit server:

    Singleplayer map:

  2. Offline


    As the team have not recommended this build, there is no support for it. Bugs are likely to exist.

    Craftbukkit for 1.0 is still in development, so stay tuned.
  3. Offline


    Excellent bug report.
    Tadas159 likes this.
  4. Offline


    Oh, I was reporting, I was not complaining XD
  5. Offline


    I didn't say you were?
    Oh well.
  6. Offline


    Good bug report. We should see more threads like this, as opposed to all the "when will" threads :)
    Thanks for testing!
  7. Offline


    Well if nobody reports them then it's unlikely they'll get fixed? I'd have barely noticed this one, as it's quite subtle if you're not flying but just walking around.
  8. Offline


    you definitely were implying, as his post didn't contain anything that could even be considered complaining about the bug being present. he was simply stating a bug that might have not been known.
  9. Offline


    I wish the forum had a dislike button. I could use one for RROD's posts right now.
  10. Offline


    I also found a bug with the map generator.. I punched or even collected dirt but it transformed into sand..
  11. Offline


    Bugs should be submitted here: http://goo.gl/WDT05

    @Vhab Let's try to keep a positive attitude. If you don't like his posts, that's your opinion. However, you should only elaborate on it if it's on topic and you're not blatantly trolling.
  12. Offline


    Why not link the "bugs" button to this page, as leaky is off?
  13. Offline


  14. Offline


    Link this button (pic) to "http://goo.gl/WDT05" as its original link is down.

  15. Offline


    I clicking this before to post... don't work then an don't work now xD... And my english sucks xD
  16. Offline


    This is pretty bad... I hope they see this, because it's pretty difficult to notice just walking around the map.
  17. Offline


    This could be related to the fact that the biome code hasn't yet been updated to 1.0. It still contains only the biomes from 1.8 plus a few earlier ones which are no longer used.
  18. Offline


    To my knowledge this is false. Craftbukkit is at Minecraft 1.0, but the modification for bukkit probably brokered the generation code.
  19. Offline


    I can't do that and this isn't a permanent bug system. Just a temporary one because leaky is down.
  20. Offline


    Has somebody already tested if this only happens with CraftBukkit or also with the vanilla Minecraft server? Just to make sure it really is a CraftBukkit problem.
  21. Offline


    Oh crap... I noticed this too and thought it was normal! :(
  22. Offline


    Anyone think these two may be the same issue? Just a guess, but the problem in umarth's pictures is that sand is rendering with cutoffs as dirt. Maybe it's still actually sand, but it's dirt that's being displayed in-game?
  23. Offline


    I had a very interesting bug. Some chunks in my current world got overwritten. Jut my luck, one of them had to be my house :( Instead of a mountanous terrain it replaced it with a snow biome 30 blocks or so higher. Was really odd. Some of the wood I had got moved up too, but some of the materials didn't. :O
  24. Offline


    I have experienced a similar bug in a vanilla 1.0 SMP server. I was in the nether and found a nether fortress and was walking along one of the netherbrick viaduct things to find a gap in the viaduct, I tried placing some netherrack to bridge the gap only for it to turn into netherbrick when I tried placing it! I also have walls of netherrack that would turn into netherbrick if it tried to mine it. I disconnected from the server and all the pseudo-netherrack was netherbrick when I rejoined. So I wonder if this is some kind of client side desync.
  25. Offline


    Does the bug exist in the latest build (1485)?
  26. Offline


  27. Offline


    OK I can confirm that this is a display bug only (kinda)

    Apparently the server is sometimes sending chunks to the client before the block populators finished running. This is how Notch implements multi-threading I guess.




    Also, a simple rejoin will send you the chunks again and everything looks the way it should:


    So terrain generation isn't broken after all :)

    Btw: Another thing I noticed here: Right after joining the server (server was up for maybe 15 seconds) the client was not responding for about half a minute. :/
    On the rejoin this didn't happen, everything was fine.
  28. Offline


    I chek it, it's true
Thread Status:
Not open for further replies.

Share This Page