Barley any mobs...

Discussion in 'Bukkit Help' started by javoris767, Mar 21, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    javoris767

    I just started a new map and I haven't seen a legit mob walking around for a few irl days.

    Code:
    # This is the main configuration file for Bukkit.
    # As you can see, there's actually not that much to configure without any plugins.
    # For a reference for any variable inside this file, check out the bukkit wiki at
    # http://wiki.bukkit.org/Bukkit.yml
    settings:
      allow-end: true
      warn-on-overload: false
      permissions-file: permissions.yml
      update-folder: update
      ping-packet-limit: 100
      use-exact-login-location: true
      plugin-profiling: true
      connection-throttle: 4000
      query-plugins: true
      deprecated-verbose: default
      shutdown-message: Server closed o-o
      restart-script-location: start.bat
      timeout-time: 300
      restart-on-crash: true
      filter-unsafe-ips: true
      whitelist-message: Server whitelisted for fixes!
      log-commands: true
      command-complete: true
      spam-exclusions:
      - /skill
    spawn-limits:
      monsters: 10
      animals: 15
      water-animals: 5
      ambient: 10
    chunk-gc:
      period-in-ticks: 600
      load-threshold: 0
    ticks-per:
      animal-spawns: 50
      monster-spawns: 50
      autosave: 600
    auto-updater:
      enabled: true
      on-broken:
      - warn-console
      - warn-ops
      on-update:
      - warn-console
      - warn-ops
      preferred-channel: rb
      host: dl.bukkit.org
      suggest-channels: true
    database:
      username: xxxxxx
      isolation: SERIALIZABLE
      driver: com.mysql.jdbc.Driver
      password: xxxxxxxx
      url: jdbc:mysql://xxxxxx/xxxxx
    aliases:
      icanhasbukkit:
      - version
      savestop:
      - save-all
      - save-all
      - save-all
      - stop
      perms:
      - permissions
    
    The spawns thing and tick confuses me. Do I have them wrong?
     
  2. Offline

    Iroh Retired Staff

    That could be your problem, not an expert, but it looks like you have limited the number of monsters in the world to 10. If I am wrong correct me more knowledgeable people xD
     
  3. Offline

    zipfe

    You changed both the limit and the tick rate for when monsters spawn, no wonder you don't see any.

    spawn-limits: monsters is 70 default, and the ticks-per monster-spawns is 1 default. Every tick, 20 times per second, the server will check if it needs to spawn a monster somewhere. Your setting means that your server does this 50 times less than default. Btw, animals-spawns should be 400, no need to change that to 50.

    Just start a new, blank craftbukkit server in a temp directory, let it generate a default bukkit.yml and use this.

    And make sure you didn't change view-distance in server.properties, a value below 10 affects mob spawn rate as well.
     
Thread Status:
Not open for further replies.

Share This Page