AutoBroadcast & Broadcast

Discussion in 'Plugin Requests' started by Aphyio, Oct 14, 2020.

  1. Offline

    Aphyio

    Plugin category: Broadcast, Auto

    Minecraft version: 1.16.3 and Higher

    Suggested name: Auto Broadcast & Broadcast

    What I want: You can edit in your plugin folder where you can have up to 4 broadcasts and make it that you can use color codes &. Also, set the options for the timer and the name too. Forex:

    I want to edit the broadcast prefix from [BROADCAST] to this:

    &7------&e✮ &4&lAmong Us &b&lAlerts &e✮&7------

    Ideas for commands: /ab start {broadcast start auto}
    /ab end {broadcast end auto}
    /ab {send a broadcast in all world in the server, make sure to have color codes too}

    Ideas for permissions: Op can only access to the commands.

    When I'd like it by: Take your time, and I wish you good luck :}

    I know you might say, oh this there, or that or that.. but I can't seem to find a good plugin that is up to date..
     
  2. @Aphyio Could you elaborate on commands? How do you define if it is an automated broadcast or an immediate one? How do you define the time in between automated broadcasts?
     
  3. Offline

    Lv_

    There are tons of plugins I could recommend to you, but since I'm a newbie at Java and I wanted a project idea I decided to make this for you, everything is configurable in the config.yml. To view to commands you can do "/ab"
    I wasn't sure what exactly you wanted for "/ab end" and "/ab send" so let me know if I did it wrong and I can fix it.
    I also added "/ab start" and also "/ab reload" for convenience.

    Anyways you can download it here: https://www.spigotmc.org/resources/lv_s-autobroadcast.84819/
     
  4. Offline

    Aphyio

    Well, Lv_ There were bugs..
    Code:
    [10:21:01] [Server thread/ERROR]: Could not load 'plugins/AutoBroadcast.jar' in folder 'plugins'
    16 org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
    17 at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:162) ~[minecraft_server.jar:git-Paper-231]
    18 at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:148) ~[minecraft_server.jar:git-Paper-231]
    19 at org.bukkit.craftbukkit.v1_16_R2.CraftServer.loadPlugins(CraftServer.java:389) ~[minecraft_server.jar:git-Paper-231]
    20 at net.minecraft.server.v1_16_R2.DedicatedServer.init(DedicatedServer.java:204) ~[minecraft_server.jar:git-Paper-231]
    21 at net.minecraft.server.v1_16_R2.MinecraftServer.w(MinecraftServer.java:939) ~[minecraft_server.jar:git-Paper-231]
    22 at net.minecraft.server.v1_16_R2.MinecraftServer.lambda$a$0(MinecraftServer.java:177) ~[minecraft_server.jar:git-Paper-231]
    23 at java.lang.Thread.run(Thread.java:748) [?:1.8.0_252]
    24 Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
    25 ... 7 more
    Do you know how to fix it?

    Also, when i said, /ab start.. the auto broadcast starts

    and when /ab send, means send a broadcast from an operator. Which you can use color codes.

    Also the AutoBroadcast, I renamed.
     
    Last edited by a moderator: Oct 15, 2020
  5. Offline

    timtower Moderator Moderator

    @Aphyio Well, you changed the file, there is no plugin.yml in it anymore.
    Don't change something that isn't yours. Then you get stuff like this.
     
  6. Offline

    Newdel

    Looks like @Lv_ forgot to export the plugin.yml into the jar
     
  7. Offline

    timtower Moderator Moderator

    Nope, it is there.
     
  8. Offline

    Aphyio

    Code:
    [08:31:03] [Server thread/ERROR]: Could not load 'plugins/AutoBroadcast-1-0-0.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/lv/autobroadcast/Main has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:141) ~[minecraft_server.jar:git-Paper-231]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:397) ~[minecraft_server.jar:git-Paper-231]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:305) ~[minecraft_server.jar:git-Paper-231]
    at org.bukkit.craftbukkit.v1_16_R2.CraftServer.loadPlugins(CraftServer.java:389) ~[minecraft_server.jar:git-Paper-231]
    at net.minecraft.server.v1_16_R2.DedicatedServer.init(DedicatedServer.java:204) ~[minecraft_server.jar:git-Paper-231]
    at net.minecraft.server.v1_16_R2.MinecraftServer.w(MinecraftServer.java:939) ~[minecraft_server.jar:git-Paper-231]
    at net.minecraft.server.v1_16_R2.MinecraftServer.lambda$a$0(MinecraftServer.java:177) ~[minecraft_server.jar:git-Paper-231]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_252]
    Caused by: java.lang.UnsupportedClassVersionError: me/lv/autobroadcast/Main has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_252]
    at java.lang.ClassLoader.defineClass(ClassLoader.java:756) ~[?:1.8.0_252]
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_252]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:167) ~[minecraft_server.jar:git-Paper-231]
    at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:216) ~[minecraft_server.jar:git-Paper-231]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:111) ~[minecraft_server.jar:git-Paper-231]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:100) ~[minecraft_server.jar:git-Paper-231]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_252]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_252]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_252]
    at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_252]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:68) ~[minecraft_server.jar:git-Paper-231]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:137) ~[minecraft_server.jar:git-Paper-231]
    ... 7 more
    Ok, I took your suggestion and didn't do anything. This is the untouched and it didn't work. Any Idea?
     
  9. @Lv_ used Java 11 for the plugin, while your server runs Java 8.
     
  10. Offline

    Aphyio

    oof, can Liv make the plugin Java 8?
     
  11. Offline

    Lv_

    @Aphyio I was busy yesterday and didn't see this post until now, lol sorry like I said, I'm still a newbie.
    I have updated the resource on spigot, it should work now.
     
  12. Offline

    Aphyio

    [​IMG]
    Uh, can you help me
    @Lv_

    [​IMG]
     
  13. Offline

    timtower Moderator Moderator

    @Aphyio You posted 2 broken images.
     
  14. Offline

    Aphyio

  15. Offline

    Newdel

  16. It is probably a string literal. It would be better for @Lv_ to use a string list in the config.
     
  17. Offline

    Newdel

    The whole BroadcastTask class is ... weird...It should be refactored
     

Share This Page