Solved Authentication servers down?

Discussion in 'Bukkit Help' started by AleXG66, Jul 27, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    I'm running windows 7 professional X64
    my version of java is 1.7.0_60
    I am not running any wrappers and I'm using the recommended 1.6.4 build (I believe 1.6.4
    The most important string is "2014-07-26 22:28:28 [INFO] Disconnecting alexgibbs [/]: Failed to verify username, session authentication server unavailable!" but the rest of the log will be here -->>
    The logs have the most recent activity on my server and the first time that the error occurred. Before that, the server had worked fine being put under normal stress for a server. Use by up to 3 people (mostly 2) switching game modes, chatting, and more. The problem started the instant that I downloaded the latest stable 1.7.9 version (the one that came out 1.7.9-R0.2) and attempted to run the server, it started fine with the exception that the new UUID's caused a player error, after that, I tried to join the server, then I got the error: "Failed to verify username, session authentication server unavailable!" When I opened the 1.6.4 server again, I received the same message. I removed all the plugins to try it again, and I've restarted the server multiple times.
    Since then, I have searched on bukkit's forums and online as well as the troubleshooting. I also completely re downloaded the server and tried it again. Nothing has seemed to work, so I figured maybe you guys could help.

    Thanks for your time and help

  2. Offline


    Hello @AleXG66!
    I Guess that the problem is Minecraft. If Minecraft is down, you will get this error/message. Otherwise its Bukkit..
  3. Offline


    AleXG66 I think it could be your internet connection or something wrong with your server. As I see here, authentication servers are up and running.
  4. Offline


    I ran both the 1.6.4 and the 1.7.9 servers with the same results, I know that its bukkit as I ran a vanilla minecraft server and didn't get this error. I have double and triple checked even with other people that the Authentication servers run by Mojang are indeed up and that is not the problem. I assume that the issue came from when I ran the 1.7.9 server with the change to using the UUID system somehow changed how people connect? However, of course I'm not sure whats the problem, thus the reason why I'm asking for help.

  5. Offline


    I think you're using a non-legit (cracked) version of Minecraft. Bukkit forums do not support cracked servers/Minecraft clients.
  6. Offline


    I have the full version of minecraft and have had it since before the beta days. You could technically say that because I did get minecraft early enough were I never had to pay for it, but since then, I've bought two more profiles that I did pay for. So unless Mojang is blocking my account because I signed up for minecraft before I had to pay then maybe. But I also tested joining the server on my second computer which had my GF's account on it which she bought much more recently and it showed the same error.

    Also, this got my thinking about Modding the .minecraft folder, for clarification, I thought that might have been the case since both of us had been modding our minecraft for a while. I backed up my .minecraft folder then completly deleted and re downloaded it.

  7. Offline


    AleXG66 Try both my plugin, IsMinecraftDown, and this online checker. After veiwing both of them, tell me what they both say. If both shows its down, then its an error with Mojang, if the plugin says its down and the website shows its up, then its an error with the server.

    For the plugin, all you need to do is put it on the server, start the server, and do /ismcdown and it will tell you whats currently online and offline.
  8. Offline

    AleXG66 : yellow ~ check auth : green : green : green : green : green : green
    The rest ->>
    I'm guessing this means that my server is having trouble connecting due to the changes with the update and the UUID's. But other than that I have no clue. Thank you for your help! hopefully you know what this means and can help me.
    oh, and all the services are online according to Mojang's website and the one that you gave me.

  9. Offline


    Seeing you are hosting this at home, mind trying this site on the computer that's running the server and tell me what it says. The server is saying its unable to verify your session when you connect, so I wanted to see if you are able to connect directly to the Session Server. If you aren't, then something is blocking the connection to the service.
  10. Offline


    I tried opening the page with both the server running and without, they happened to be the same.

    {"Status":"OK","Runtime-Mode":"productionMode","Application-Author":"Mojang Web Force","Application-Description":"Mojang Session Server.","Specification-Version":"2.5.1","Application-Name":"yggdrasil.session.restlet.server","Implementation-Version":"2.5.1_build189","Application-Owner":"Mojang"}

    Thanks for you time and help

  11. Offline


    While just screwing around on my own time while the servers were down this morning, and I figured out that for some reason, my Kaspersky is causing the issue for some reason... I honestly don't have a clue how. But when I disable Kaspersky or its closed (which for some reason, I have to do while starting my server too) then I and anyone else can get on. However; I'm still having the same problem with the server when Kaspersky is up.
    Thanks Gamecube762 for all the help! please pm or anything to me if you do end up finding a permanent solution.
  12. Offline


    AleXG66 I'm not to sure how Kaspersky does their protection, it is possible that its blocking Java from pinging the session service. The plugin might not be affected by it since it connects to which pings the other services.

    See if you can run the .bat file as an administrator.
  13. Offline


    That would make sense. Let me tell you all what is going on on the computer when I try and run the server with my Kaspersky protection on.

    When I open the server with the run.bat file and Kaspersky on, it gives me this message: "Java(TM) Platform SE binary from group Trusted is trying to create an embedded key or parameter in protected registry key included in group Operating system PID: 11788" This balloon-like popup occurs either four or five times with the same information. After even clicking allow now through all of them, and even checking the Save rules change box, I get this message in the console. *Note: this is after everything had been loaded and the line "Done" (that signifies that the server is loaded and on)*
    [INFO] [Metrics] Connection refused: connect
    [WARNING] Could not get information about this CraftBukkit version; perhaps you are running a custom one?: ConnectException
    [WARNING] Could not get latest artifact information: ConnectException
    After this, I can try and get on the server, which results in this *Note: I did double check all minecraft, java, windows, and Bukkit versions and updates before any attempts*
    -- Client:
    Disconnected by Server
    Failed to verify username, session authentication server unavailable!
    -- Console:
    [INFO] Disconnection alexgibbs [/**LOCAL COMPUTER IP**:54976]: Failed to verify username, session authentication server unavailable!
    First, the ports that I opened in my Internet's firewall is different, but I'm not sure if that makes a difference.
    The connection error happens regardless if my Kaspersky is on or not. However; if I turn on Kaspersky to turn on the server, it opens just fine (with exception to one thing which I will ask about later *not and issue, just question*). After the server is on, if I have Kaspersky still on, I can't connect to the server and it gives me the same client and console error as above, however, when I have Kasperky off, my client joins just fine. This also works with other computers on my home network, but I have yet had the opportunity to attempt a non-local connect. However; with kaspersky off, the server has been working.
    The other question I had with the server starting is that seconds after the server starts regularly, and I'm noticing that its also doing it when I've started the server with kaspersky, is that seconds after startup and every ten minuets on the second after that point I get the "[Metrics] Connection refused: connect" Message. I'm sure its nothing, but you know more about it than I do, so I wanted to make sure its not an issue.

    I just realized that you had a second part to your post, I apologize for not noticing sooner. When I did open the server as a Admin, I got this message: *note: this is with kaspersky on*
    Error: Unable to access jarfiles craftbukkit.jar
    After that, I press any button and it closes. I did check and the .jar file is in the folder and it still has no problem running without Kaspersky on.

    Also, I'm a little new to forums, but since the command lines were only a few lines long, I didn't use the Pastbin links, but in your opinion, should I have and I'll make sure to next time.

    Thank you so much for your help, I apologize for the long time between posts, and how long this post was, It was a bit of information to put together and I've been quite busy over the past few days.

    Once again, Thanks for all the time and help!!

  14. Offline


    AleXG66 It seems Kaspersky is disallowing the connections. I haven't heard of this happening before, but then again, Minecraft just started using the new UUID system for keeping track of players.

    Metrics is a system that a lot of plugins use, its mostly for the developers to see how popular their plugin is. Metrics not connecting isn't much of a problem, but other services not connecting kind of is.

    Here are three steps for you to try, if a step doesn't work, try the next one.
    1. Uninstall Java and re-install it from here.
    2. Add Java to Kaspersky's exclude list. (program files/java/jre7/bin/java.exe)
    3. Try a different AntiVirus, personally I use MicrosoftSecurityEssentials and MalwareBytes. (both are free)
    You are doing fine on the Pastebin links, using it makes it easier to read the post, but only having a line or two in Pastebin is kind of a waste.
    AleXG66 likes this.
  15. Offline


    I did re-install java and it started working fine again. Do you know what could have caused it so I can prevent it from happening again?
    Also, this fixed the Metrics thing as well.

    Thank you for the tip! On the topic of new to the forums. Since this post had been answered, is there a way that I can tag your post as the answer, or is that something that a mod has to do?

    Thank you so much for your time and help, It seems like a lot of trouble to go through with such a simple solution, but I appreciate all the time you put into it!

  16. Offline


    AleXG66 Only things I could think of is a possible security error in java being fixed, or something malicious had added itself to your Java install.

    You can mark this thread as Solved by looking above the first post, thread tools, edit thread, and set it to Solved. There is no way to tag a post as an answer, this forum does have a feature to like posts, but asking for likes is against the rules.
Thread Status:
Not open for further replies.

Share This Page