Attributes not working on my server.

Discussion in 'Bukkit Help' started by Thomassaurus, Feb 11, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    Thomassaurus

    I've been trying to make custom items with attributes on my server but it's not working.
    I've been using /give commands on a single player world to get attributes. But when using the same commands on my server, I get the item - but no attributes...

    These are the plugins I have, are any of them disabling attributes?
    MultiWorld, WorldEdit WorldGuard, skript. Essentials.
    I even have unsafe enchants set to 'true' on essentials.
    I also tried the SimpleAttributes plugin but it wasn't working.

    Edit:
    I also should point out that the commands I'm trying to use are via command-block since they don't fit in the normal chat box.
     
  2. Offline

    Necrodoom

    What are you trying to do exactly? If you are trying to use /give vanilla syntax, get essentials prerelease builds.
     
  3. Offline

    Thomassaurus

    I'm trying to use the default minecraft /give commands for attributes. The same commands work fine in single player.

    Also what do you mean by get essentials prerelease builds.? I have the core essentials plugin.
     
  4. Offline

    TnT Retired Staff

    The minecraft give command is only available in the latest development builds of CraftBukkit.

    You can try using /minecraft:give if you are using the development builds.
     
  5. Offline

    Thomassaurus

    So is CraftBukkit the problem possibly since it seems to be changing how the give command works? I'm using craftbukkit 2991 DEV (1.7.2)
     
  6. Offline

    TnT Retired Staff

    No, by that build the meta data was supported in the CraftBukkit version of the give command. A plugin may be over riding that command though, so its best to test your server without plugins to determine where the problem resides.
     
Thread Status:
Not open for further replies.

Share This Page