Are 1.0 maps safe to update to 1.1?

Discussion in 'Bukkit Discussion' started by GROMkill, Jan 16, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I couldn't find a thread that explicitly had this question answered, so I made one.

    Regardless of plugins (I know that some may work, some may not), is my map safe to update to 1.1?

    I've read that existing, pre-generated swamp biomes' transitions will be smoothened. I've also read that the existing pine biomes will have snow. Will all of the pine biomes on my map have snow? What about the rest of the biomes? Around 1.6 or so, I updated my map and every single biome got thrown around. I had lakes ice over, deserts start snowing, and snowy places melt and turn into desert-y areas.

    Will only the swamp changes and pine->snowy pine changes occur?
  2. Offline


    It's safe, and those changes do infact occur.
  3. Offline


    Are there any more changes other than those? Will I find anything like the 1.6 (or whatever it was) update where the rest of my biomes got screwed?
  4. Offline


    Nope, the 1.1 generator is completely 1.0 compatible. Only thing changing are swamp biome transitions and snow in pine forests ( biomes that were actually snowy but because of a bug weren't ).
  5. Offline


    Screenie.png Just make sure you backup first. I tried a dev build today and it corrupted everything. Thankfully I had recent backups. Not sure if you can see in the pic but it seems like it tried to regenerate old terrain (Namely, my house -_-).
  6. Offline


    Same for me, but no recent backup :( I had to manually copy buildings, regen chunk and paste buildings with WE.
    World gen seems to be a little bit different.
  7. Offline


    This happens if you use a dev CB build with an outdated Spout version thats NOT ready for that CB build (the newest Spout versions are). So make sure to have them both, or else - all Stone gone.
  8. Offline


    Always disable spout until you have fully tested it with the CB build you are planning on using, it tends to break on every update and causes horrible problems in my experience.

    I'm running CB 1774 with Spout dev build 688 and haven't had any trouble so far
  9. Offline


    That is the combination that works e.g.
    Using Spout 681 and CB 1774 causes the Stones go missing issue for many.
  10. Offline


    I can confirm this - my castle's moat suddenly got a lot deeper :) But this why you should always:
    • Test new releases on a dev machine first
    • Keep regular backups of your live worlds
    Then this sort of thing is a minor hiccup, and not a disaster.
  11. Offline


    I wasn't running Spout when this happened to me. >>
  12. Offline


    What craftbukkit were you using when this happened?
  13. Offline


    I can't be sure, it's possible I just didn't notice it, but it was either #1772 or #1774. I noticed it on #1774.
  14. Offline


  15. Offline


    Holy crap, I had this happen too. I think I had Spout 644 installed when I first rebooted. Luckily, I had backups from the previous hour. Oy.

    Did anyone have this re-occur after removing/updating Spout? I'm on cb1774 btw.
  16. Offline


    I had the same thing. After I removed Spout and used a back-up, all the stone were there again :)
  17. Offline


    So what is the latest, most stable version of Bukkit? 1774?
Thread Status:
Not open for further replies.

Share This Page