Application Port Mapper - The Easy Way To Forward Ports

Discussion in 'Bukkit Tools' started by ImminentFate, Jun 20, 2012.


Did you find this tool helpful?

  1. Yes

  2. No

Thread Status:
Not open for further replies.
  1. Offline


    you know your server is portforwarded when it shows up in the table in the program. Like so:

    Then, to connect to your own server (if it's on the same computer as the server) you go into minecraft, and type into the multiplayer server section "" or "localhost:25565"
    Other people will have to use your external ip to connect.
  2. Offline


    And now I'm having a problem where I did all of the stuff above but no one can get into my server using my external IP. Im not sure if UPnP is enabled but if it isn't I don't know how to check. Thank you for reading my n00b like comments
  3. Offline


    if you've port forwarded, and you can see your server name in the port map tool, then the port has been forwarded correctly and upnp is enabled.
    Your friends will need both your external ip and the port to connect; for example, if your external ip is 123.424.241.632 and the port you chose for minecraft was 28493, then your friends would connect by entering
    123.424.241.632:28493 into the server address in their clients.
    Note that your external ip will change regularly (unless you've bought a static ip) so keep this in mind; you will have to check to make sure your external ip hasn't changed whenever you want others to connect.
  4. Offline


    getting an error message :/
    System.NullReferenceException: object reference not set to an instance of an object
    Archarin likes this.
  5. Offline


    alright so it says specified details are invalid, everything is enabled, still has probs.
  6. Offline


  7. Offline


    I'm getting....

    System.NullReferenceException: Object reference not set to an instance of an object.
    at Portmapper.Form1.list_fill()

    Imminent, any help?
    Archarin likes this.
  8. Offline


    brok249 megasaad44 mc432
    I'm seeing errors here that I've never encountered before. I have a feeling it might be either because you don't have permission (you're not running the program as an admin, try right clicking and pressing "Run as Administrator")
    or that your router either does not support UPnP or the feature is turned off. Open up your router config in your web browser (look it up, some routers are different) and find the UPnP switch, and enable it.
    Or possible, windows firewall is blocking the program from opening the required ports.
  9. Offline


    ImminentFate I ran it as an admin and my router has upnp enabled. i triple checked. Now the admin thing did make a difference, i put the info in then it gave an error, BUT! it showed that 25565 is open in the list and named minecraft server, HOWEVER! begs to differ... and so does my server :/ Solutions? I'm pretty sure it's that error... As for the firewall thing, it's kinda plausible i guess, i'm using AVG and yes it comes with it's own firewall, but i looked into it. Now i added port mapper to my firewall. I ran it as an admin, and then i got a different error: and the tables are all empty... I tried then to fill the details for 25565 it gave me: Followed by: Then it's just an empty table again...
    This is what happened to me... I gave you as much details as i can, solutions? :/
  10. Offline


    I'm either really bad at programming or .NET 4 got a painful update...
    this error here:
    is one I've had before on my own computer, and for some reason nothing would work. Then I did a clean install of windows and voila, it worked for some reason.. don't reinstall btw, there must be an easier way.
    As for the other errors, partially bad coding on my part, because it means it's trying to show all the open ports, except there aren't any that are open (hence the error). What I would suggest now is disable AVG firewall, disable windows firewall, see if it works. If it does work, then there's a conflict there somewhere, and I'll work you through that when you reply.
  11. Offline


    ImminentFate Disabled both, Newp... Any other solutions?
  12. Offline


    [​IMG]I get this when I start the application and when I try to add a port. It also says "The specified details are invalid" when I try to add a port.
  13. Offline


    What do i do
  14. Offline


    StevenMG craftxbox
    You guys don't have access to a UPnP router, or it's settings have been disabled. This is common at work, or on university/college internet, as they practically isolate your computer completely from the network for safety.
    (it can happen at home as well, if your network is set up to either have UPnP disabled, or isolate all devices)
    Basically you get the error because it's trying to fill the table with details of active UPnP devices, but the router isn't letting it have the info.
  15. Offline


    ok now i have UPNP enabled the the "The Specifyed Details are not valid" thing still pops up
  16. Offline


    craftxbox This time it means your computer won't let UPnP work. Sadly, I have never found one solution that works every time (besides a complete reinstallation of Windows) but you can try adding an exception for the portmapper in your windows firewall (or, disabling it).

    I apologise for the error message being misinformative, it was bad error handling on my part (I chucked the entire code for checking if a port exists, reading the existing UPnP ports, and writing a new entry all into one try/catch clause of the code - basically everything that goes wrong will give you that error (Am going to make it better, I promise).
  17. Offline


    i get this error
  18. Offline


    It's erroring because either your router does not support UPnP, or UPnP is turned off (the second one is more likely, unless your router is 5+ years old)
    It could also be because your firewall is blocking the program, so check that as well.

    The error message should really tell you that instead of giving you this error, but I guess I'm really bad at coding error catching :p. I might have to fix that.
  19. Offline


    The program Worked earlier but it started doing this yestarday it worked every windows but then this happens
  20. Offline


    That's interesting. Can't say it's happened before.
    Have you installed any other programs recently? Or changed firewall settings? Perhaps restarted your router?
    I honestly have no idea what could be causing it sorry. If it was working before, then all I can say is that something's changed since then and now.

    And by the way, I'm assuming you're using this at home/apartment, and not at a college or university. The latter places will most likely not work because of the way they set up their networks.
  21. Offline


    i didn't change anything exept from HOMEGROUP

    Now the program works WTF?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 18, 2016
  22. Offline


    Theironlefty I guess take advantage of it working haha.
    By the way, Homegroup may open up the firewall a bit more, allowing it to work I guess.
  23. Offline


    Um, it only says "thee specified details are not valid"if i type 25565 in the port, anything else works? wtf?
  24. Offline


    bad error management on my part - it means that either your router doesn't support UPnP, or that UPnP is turned off in your router, in which case you'll have to log into the router settings and turn it on.
    If could also be your firewall blocking the program.
  25. Offline


    When I click add port it doesn't show on the list I refreshed but it still doesn't show.
    Here's what I put

    Attached Files:

  26. Offline


    I got it it opens up with this error: System.NullReferenceException: Object reference not set to an instance of an object. at PortMapper.Form1.list_fill() Also when I try to create a port it says Specified details are not valid and then the error I said earlier shows up. Please help
  27. Offline


    It means that either your router or your firewall is not set up to allow UPnP. You'll have to go into your firewall and add an exception for the port mapper, and if that doesn't work you'll have to try to enable UPnP from your router.
    Bear in mind that some routers won't work at all due to the fact that they use a difficult (but more secure) method of routing information from the internet to your computer and vice versa. If you try both methods and it still doesn't work, you may have one of these such routers. (They use Symmetric NAT if you're interested, and that's what causes problems with P2P game servers sometimes)
  28. Offline


  29. Offline


    I tried to use this today. I have two routers in my office. One is a cisco and another is an AnyGate. Cisco details are picked up directly. But when I switch to the AnyGate network your app frozes and does nothing .... Please help ... I am attaching screenshot of the error too

    Attached Files:

  30. Offline


    Does this work for dual routers? I have 2 routers, which give 1 signal. To access them, there are separate IP addresses. I was confused how to port forward, so im looking for a software that would do it for me. Would it?
Thread Status:
Not open for further replies.

Share This Page