Application Port Mapper - The Easy Way To Forward Ports

Discussion in 'Bukkit Tools' started by ImminentFate, Jun 20, 2012.


Did you find this tool helpful?

  1. Yes

  2. No

Thread Status:
Not open for further replies.
  1. Offline


    funny how some things happen isn't it? My best guess is that either:
    a) Your windows firewall magically started blocking the program after the house move (maybe it recognised your internet connection as a "new connection" instead of registering it as the same old one.)
    b) It was just a coincidental change that you perhaps installed some new software, or changed some settings around the same time that you moved house.

    I encountered a similar sort of issue (minus the house swap) where I tested the program on a Tuesday to see that it was working fine after someone said there was an issue with it - and it worked fine.
    The next day, I tried again, and the thing wouldn't work for some reason.
    I realised later that on Tuesday night, I set my router to upgrade its firmware, which turned UPnP off. Perhaps your router has done a similar thing? Try going into your router's settings and looking for UPnP and making sure it's turned on.

    Hopefully that helps

    Sorry for the very (very) long delay in replying, the notifications haven't updated me on the goings on here :confused:
    If you go into your firewall settings, and choose "Allow a program through the firewall" it should give you the option to browse for a program. Click that, and browse to the application to select it, and then hit save (you may need to have admin rights, and a restart may be required afterwards)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 18, 2016
  2. Offline


    Yeah you're a little late. :p Thanks though! I'm using a hosted server now so no more portfowarding!
  3. Offline


    Neat idea taking advantage of the protocol. Didn't know routers could be controlled this way.

    Did you ever succeed on creating a UPnP app for mac/cross platform? I've always considered UPnP a dark magic shrouded in secrecy that 'just works' on home networks :oops: . Would be interesting to see a Java implementation.

    Edit: more ideas, it could even be part of a plugin where plugins that used TCP ports such as mine could "Register" port forwarding permission, to save diving into router interfaces each time a person installed a network based plugin. Hmm
  4. Offline


    No, but port map works!
  5. Does this really set the router settings or just use a trick like uTorrent?
  6. Offline


    A magician never reveals his secrets! ;)
    Kidding, all it is is a hook into the Windows NATUPNP Library that allows ports to be forwarded using UPnP - a function that allows forwarding ports (amongst other things) as required. So yes, basically it's the same wizardry that uTorrent uses.
    KovacsA likes this.
  7. Offline


    How do I remove this from my computer? o.o
  8. Offline


    Just delete the application it self
  9. Offline


    New GUI.
    What do you guys think? Yes or no?
    (If you're thinking I simply screenshotted this on Windows 8, I didn't. It was all built on 7, so it will look exactly the same no matter what computer you run it on)
    obscurehero and Eats_Rainbows like this.
  10. Offline


    The specified details are not valid.
  11. Offline


    This error tends to occur when you either haven't put the details in correctly, or if you don't have UPnP enabled on either your computer or your router. In your case, it's the UPnP issue.
    If you have any sort of modern router, UPnP is enabled by default - so it's probably your computer. Just have a look around for information on enabling UPnP on your pc. might even be worthwhile checking your router too.
    (it's not hard at all - a matter of finding the right place and either ticking a checkbox or changing something to "enabled")
  12. Offline


    wooww! This is helpful for allot of people! This is not helpful for me! But helpful for my Friend! Thankyo!
  13. Offline


    hey umm, can anyone help me? i double click the icon but it doesnt do anything ._. double click *poof* nothing...
  14. Offline


    Do u have the required dependencies installed, .net framework and redistributable 2008+
  15. Offline


    jacklin213 pretty sure i do. Anyway to check just in case?

    OSX version?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Aug 23, 2018
  16. Offline


    osx ones already exist, run a google search for "osx port mapper"
    there are several, try one of them, should suit your needs just fine
  17. Offline


    ImminentFate The program does not open ._. i double click it and nothing happens, solution?
  18. Offline


    Hello! I'm having a bit of a problem. I download this wonderful-looking application and try to run it in my Downloads folder, on my Windows 7 64-bit laptop. I have both Microsoft .NET 4 framework and extended installed, as well as multiple versions of Microsoft C++ 2008 Redistributable that are required for Steam games. I attempt to open it and it instantly gives me the "Portmapper has stopped working" window. Any help?
  19. Offline


    If I remeber hawkfalcon has made one
  20. Offline


    yep, a failure on my part, i think. just realised it works in debug mode, not as a standalone... must've botched the bundled dependencies. I'll have a look into it. In the meanwhile, I've put the old one back up
  21. Offline


    Could you make this for mac, please?
  22. Offline


    ImminentFate likes this.
  23. Offline


    Still having the same issue, I don't want to clog up the thread though. Any progress?
  24. Offline


    My apologies.
    I'm currently having a very (very) busy time, and when i said I'd post the old version, I thought I did. I just checked, and it turns out that due to my bad backup habits, I overwrote the old one with the new one (derp).
    Therefore, I shall have to fix the issue in this version - if I can isolate the cause, it shouldn't take too long to fix, but it will have to be done this Saturday, as I cannot spare any time earlier than then.
  25. Offline


    I have the same backup issues, so I understand. Thanks for putting up with me. :3
  26. Offline


    Problem signature:
    Problem Event Name: CLR20r3
    Problem Signature 01: portmapper.exe
    Problem Signature 02:
    Problem Signature 03: 51ebdde8
    Problem Signature 04: Microsoft.VisualBasic
    Problem Signature 05:
    Problem Signature 06: 4ba2183b
    Problem Signature 07: 78
    Problem Signature 08: 2b5
    Problem Signature 09: 34SSPS20BDJ3NJ0WMIT5KAMZHVGLFZCC
    OS Version: 6.1.7600.
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
    Read our privacy statement online:
    If the online privacy statement is not available, please read our privacy statement offline:

    this is what it keep's doing and it is makeing me mad what do i do to fix this problem!!!!!!!!!!!!!!!!!!!!!!!!!
  27. Offline


  28. Offline


    When I downloaded the file it says, "This file may be harmful to your computer. This type of file isn't commonly downloaded and isn't signed by it's author." So I deleted it but I really want to set up a server. Has this download caused a virus on anyone's computer?
  29. Offline


    As the creator of the program, I'm probably not the verification you're looking for, however I can, with full honesty, say it's not a virus.
    The reason this message comes up on some systems is because I don't use the publish feature in Visual Studio - what this means, essentially, is that I'm distributing the file before it's been compiled through Microsoft's Click-to-Run system, and as a result, it has no code signing. Some antivirus programs pick this up as a potential threat and warn against it. However, I can say that this has no viruses/malware/spyware in it.
  30. Offline


    Okay thank you for answering but now I have nother question. How do I know if my server is portforwarded and how would I connect to it?
Thread Status:
Not open for further replies.

Share This Page