Solved Annoying NoClassDefFoundError..

Discussion in 'Plugin Development' started by kreashenz, Mar 18, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I get an error now, ( just happened, after many days of it working ) of the NoClassDefFoundError. I haven't changed my code at all, only deleted the previous plugins folder, and exported a new one, and its doing this.. Full stack trace ( of command )
    [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'a' in plugin MinecraftRP v0.2
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.v1_5_R1.CraftServer.dispatchCommand(
    at net.minecraft.server.v1_5_R1.PlayerConnection.handleCommand(
    at net.minecraft.server.v1_5_R1.PlayerConnection.a(
    at net.minecraft.server.v1_5_R1.Packet3Chat.handle(
    at net.minecraft.server.v1_5_R1.NetworkManager.b(
    at net.minecraft.server.v1_5_R1.PlayerConnection.d(
    at net.minecraft.server.v1_5_R1.ServerConnection.b(SourceFile:35)
    at net.minecraft.server.v1_5_R1.DedicatedServerConnection.b(SourceFile:30)
    at net.minecraft.server.v1_5_R1.MinecraftServer.r(
    at net.minecraft.server.v1_5_R1.DedicatedServer.r(
    at net.minecraft.server.v1_5_R1.MinecraftServer.q(
    Caused by: java.lang.NoClassDefFoundError: Could not initialize class me.kreashenz.minecraftrp.Utilities.Functions
    at me.kreashenz.minecraftrp.Commands.AdminChat.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    ... 15 more
    It's caused by the Functions class, not the AdminChat class, so I won't post that.
    Functions class:
    1. package me.kreashenz.minecraftrp.Utilities;
    3. import;
    5. import org.bukkit.configuration.file.FileConfiguration;
    6. import org.bukkit.configuration.file.YamlConfiguration;
    8. import me.kreashenz.minecraftrp.Utilities.ChatFormat.ColourUtils;
    10. public class Functions {
    12. private static File file = new File( "plugins/MinecraftRP/config.yml" );
    13. private static FileConfiguration config = YamlConfiguration.loadConfiguration(file);
    14. public static String prefix = ColourUtils.format(config.getString("messages.prefix"));
    15. public static String noPerm = ColourUtils.format(config.getString("messages.noPermission"));
    16. public static String NEA = ColourUtils.format(config.getString("messages.notEnoughArgs"));
    17. public static boolean isInt(String sInt)
    18. {
    19. try
    20. {
    21. Integer.parseInt(sInt);
    22. }
    23. {
    24. return false;
    25. }
    26. return true;
    27. }
    29. public static boolean isDouble(String string) {
    30. try{
    31. Double.parseDouble(string);
    32. return false;
    33. }
    34. return true;
    35. }
    37. public static String getPrefix(){
    38. return prefix;
    39. }
    41. public static String noPerm(){
    42. return noPerm;
    43. }
    45. public static String NEA(){
    46. return NEA;
    47. }
    48. }
  2. Offline


    kreashenz I believe the issue you're having is due to the class not exporting when you create the .jar. I would double check to make sure that class is being exported properly when you create the jar.
  3. Offline


    NoClassDefFoundError simply means that a needed class is in neither the native library nor the running jar. There is no problem with the code.

    For future reference, if it ends with "Error" instead of "Exception", the problem likely isn't the code, but the package/jar itself. Another example is UnsupportedClassVersionError (or something like that). Like NoClassDefFoundError, there is no problem with the code what-so-ever. In this case, the problem is the user has a version of java that is older than the program theyre trying to run.
  4. Offline


    psychic94 The user being me? How can you tell if the problem is that? How do I change this, I got no idea.. Lol..
  5. Offline


    I may take a wild guess and say that you:
    1) Registered your commands in the onEnable then forgot to put them into the yaml

    What's at line 34? What method are you calling?
  6. kreashenz
    Is "UnsupportedClassVersionError" your current error ? No, he told you what your current error means, read more carefuly :)

    Open your jar with an archive program and see if the class is actually there.
    Ne0nx3r0 likes this.
  7. Offline


    beastman3226 The is not a command, it holds the functions that I can use throughout my plugin.. Here's the, and I set the alias via plugin.yml to /a ..
    1. package me.kreashenz.minecraftrp.Commands;
    3. import me.kreashenz.minecraftrp.MCRP;
    4. import me.kreashenz.minecraftrp.Utilities.ChatFormat.ColourUtils;
    5. import me.kreashenz.minecraftrp.Utilities.Functions;
    7. import org.bukkit.Bukkit;
    8. import org.bukkit.command.Command;
    9. import org.bukkit.command.CommandExecutor;
    10. import org.bukkit.command.CommandSender;
    11. import org.bukkit.entity.Player;
    13. public class AdminChat implements CommandExecutor {
    15. public MCRP plugin;
    16. public AdminChat(MCRP plugin){
    17. this.plugin = plugin;
    18. }
    19. public boolean onCommand(CommandSender sender, Command cmd, String label, String[] args) {
    20. if(cmd.getName().equalsIgnoreCase("adminchat")){
    21. if(sender instanceof Player){
    22. if(sender.hasPermission("mrcp.adminchat")){
    23. String chatMsg = "";
    24. for (int i = 0; i < args.length; i++) {
    25. chatMsg = chatMsg + args + ' ';
    26. }
    27. for(Player t : Bukkit.getOnlinePlayers()){
    28. if (t.hasPermission("mcrp.adminchat")){
    29. String player = sender.getName().replace("%player%", sender.getName());
    30. t.sendMessage(Functions.getPrefix() + player + " §b" + ColourUtils.format(chatMsg));
    31. }
    32. }
    33. }
    34. } else sender.sendMessage(Functions.noPerm());
    35. } else sender.sendMessage(Functions.noPerm());
    36. return true;
    37. }
    38. }

    Digi It is there, I exported and everything..[​IMG]
  8. Offline


    Off-topic but damnn you must love using statics. lol
  9. Offline


    kreashenz Bottom line: if it says the class wasn't found, that means it was there are compile time, but missing at run time.

    Your troubleshooting should focus on verifying that what's in your IDE/source matches what's in your compiled jar on your server. This includes your bukkit.jar/other plugin references.
  10. Offline


    That's a nuance of statics I wasn't aware of.
  11. Offline


    I knew it wasn't a command and I have a similar object in nearly all of my projects. What I'm asking is what are you calling.
  12. Offline


    OK, solved it self.. I have no idea why the hell it was doing this, after MANY reloads/restarts..
  13. Most likely because of 'reload', if you have a class that is not loaded then you re-export the jar and reload, next time you're attempting to use it will trigger that error.

    You could fix this easily by loading all of your classes in the main class by calling a method from that class, an empty method.
  14. Offline


    Love Some Help! Thx -iGamer

    ---- Minecraft Crash Report ----
    // Uh... Did I do that?

    Time: 4/11/14 8:56 PM
    Description: Exception in server tick loop

    java.lang.NoClassDefFoundError: net/minecraft/client/Minecraft
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
    at java.lang.Class.getDeclaredMethods(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.gatherAnnotations(
    at cpw.mods.fml.common.FMLModContainer.constructMod(
    at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at cpw.mods.fml.common.LoadController.sendEventToModContainer(
    at cpw.mods.fml.common.LoadController.propogateStateMessage(
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(
    at cpw.mods.fml.common.Loader.loadMods(
    at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(
    at cpw.mods.fml.common.FMLCommonHandler.onServerStart(
    at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(
    Caused by: java.lang.ClassNotFoundException: net.minecraft.client.Minecraft
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 31 more
    Caused by: java.lang.RuntimeException: Attempted to load class atv for invalid side SERVER
    at cpw.mods.fml.common.asm.transformers.SideTransformer.transform(
    at net.minecraft.launchwrapper.LaunchClassLoader.runTransformers(
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(
    ... 33 more

    A detailed walkthrough of the error, its code path and all known details is as follows:

    -- System Details --
    Minecraft Version: 1.6.4
    Operating System: Windows 8 (amd64) version 6.2
    Java Version: 1.7.0_51, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 1444549832 bytes (1377 MB) / 1916796928 bytes (1828 MB) up to 4772069376 bytes (4551 MB)
    JVM Flags: 2 total; -Xms1048M -Xmx5120M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: FML and Forge are installed
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    CraftBukkit Information:
    Failed to handle CraftCrashReport:
    at org.bukkit.Bukkit.getName(
    at net.minecraft.crash.CrashReportCategory.func_71500_a(
    at net.minecraft.crash.CrashReport.func_71504_g(
    at net.minecraft.crash.CrashReport.<init>(

    FML: MCP v8.11 FML v6.4.49.965 Minecraft Forge 152 mods loaded, 152 mods active
    mcp{8.09} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed
    FML{} [Forge Mod Loader] (Server.jar) Unloaded->Constructed
    Forge{} [Minecraft Forge] (Server.jar) Unloaded->Constructed
    CodeChickenCore{} [CodeChicken Core] (minecraft.jar) Unloaded->Constructed
    denLib{3.2.6} [denLib] (minecraft.jar) Unloaded->Constructed
    OpenModsCore{0.4} [OpenModsCore] (minecraft.jar) Unloaded->Constructed
    PowerCrystalsCore{1.1.8} [PowerCrystals Core] (PowerCrystalsCore-1.1.8-9.jar) Unloaded->Constructed
    TConstruct-Preloader{0.0.1} [Tinkers Corestruct] (minecraft.jar) Unloaded->Constructed
    BuildCraft|Core{4.2.2} [BuildCraft] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed
    UniversalElectricity{3.1.0} [Universal Electricity] (0_Universal-Electricity- Unloaded->Constructed
    CalclaviaCore{1.1.1} [Calclavia] (0_Calclavia Core- Unloaded->Constructed
    DC1{} [DukeCore] (0_DukeCore-v2.4.0.12.jar) Unloaded->Constructed
    KeithyUtils{1.2} [Keithy Utils] (0_KeithyUtils-1.6.4-1.2.16.jar) Unloaded->Constructed
    KerberosLib{1.0.5} [Kerberos's MOD Library] ( Unloaded->Constructed
    AS1{} [Arcane Scrolls] ([1.6.4] ArcaneScrolls v2.4.5.21.jar) Unloaded->Constructed
    SC0_SpaceCore{0.6.2} [SpaceCore] ([1.6.4] SpaceCore 0.6.2.jar) Unloaded->Constructed
    BuildCraft|Factory{4.2.2} [BC Factory] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed
    BuildCraft|Transport{4.2.2} [BC Transport] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed
    BuildCraft|Silicon{4.2.2} [BC Silicon] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed
    APUnofficial{2.6.0} [Additional Pipes] (AdditionalPipes2.6.0-BC4.2.1.jar) Unloaded->Constructed
    Agriculture{1.0.0} [Agriculture] (Agriculture-1.6.4-1.2.13WWM5.jar) Unloaded->Constructed
    arsmagica2{1.1.2b} [Ars Magica 2] ( Unloaded->Constructed
    Aquaculture{1.2.4} [Aquaculture] ( Unloaded->Constructed
    Artifacts{0.12.3} [Artifacts] ( Unloaded->Constructed
    Autoutils{1.0.1} [Autoutils] (autoutils-1.6.4-1.0.1.jar) Unloaded->Constructed
    BuildCraft|Builders{4.2.2} [BC Builders] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed
    BuildCraft|Energy{4.2.2} [BC Energy] (buildcraft-A-1.6.4-4.2.2.jar) Unloaded->Constructed
    BCTools{1.4-a-15} [Buildcraft Tools] (bcTools-v1.4-a-15.jar) Unloaded->Constructed
    bdlib{} [BD Lib] (bdlib-mc164- Unloaded->Constructed
    BiblioCraft{1.5.5} [BiblioCraft] (BiblioCraft[v1.5.5].zip) Unloaded->Constructed
    Natura{2.1.14} [Natura] (Natura_mc1.6.X_2.1.14.jar) Unloaded->Constructed
    BiomesOPlenty{1.2.1} [Biomes O' Plenty] (BiomesOPlenty-universal-1.6.4- Unloaded->Constructed
    BiblioWoodsBoP{1.3} [BiblioWoods Biomes O'Plenty Edition] (BiblioWoods[BiomesOPlenty][v1.3].zip) Unloaded->Constructed
    Forestry{} [Forestry for Minecraft] (forestry-A- Unloaded->Constructed
    BiblioWoodsForestry{1.3} [BiblioWoods Forestry Edition] (BiblioWoods[Forestry][v1.3].zip) Unloaded->Constructed
    BiblioWoodsNatura{1.1} [BiblioWoods Natura Edition] (BiblioWoods[Natura][v1.1].zip) Unloaded->Constructed
    SC0_BiomeWand{1.1.5} [Biome Wand] ( Unloaded->Constructed
    AWWayofTime{v0.7.2} [Blood Magic: Alchemical Wizardry] ( Unloaded->Constructed
    Thaumcraft{4.0.5b} [Thaumcraft] ( Unloaded->Constructed
    Railcraft{} [Railcraft] (Railcraft_1.6.4- Unloaded->Constructed
    buildcraftAddon{1.6.4_v0.3.3} [BuildCraftAddon] ( Unloaded->Constructed
    CarpentersBlocks{2.0.4} [Carpenter's Blocks] (Carpenter's_Blocks-v2.0.4-MC Unloaded->Constructed
    CoFHCore{} [CoFH Core] (CoFHCore- Unloaded->Constructed
    CoFHLoot{} [CoFH Loot] (CoFHCore- Unloaded->Constructed
    CoFHMasquerade{} [CoFH Masquerade] (CoFHCore- Unloaded->Constructed
    CoFHSocial{} [CoFH Social] (CoFHCore- Unloaded->Constructed
    CoFHWorld{} [CoFH World] (CoFHCore- Unloaded->Constructed
    ComputerCraft{1.58} [ComputerCraft] ( Unloaded->Constructed
    CCTurtle{1.58} [ComputerCraft Turtles] ( Unloaded->Constructed
    coralmod{1.6.4r2} [CoralReef Mod] ( Unloaded->Constructed
    CowboyHat{1.0} [Cowboy Hat] ( Unloaded->Constructed
    emashercore{} [Emasher Resource] ( Unloaded->Constructed
    emasherdefense{} [Defense] ( Unloaded->Constructed
    DenPipes-Forestry{1.1.8} [DenPipes-Forestry] (DenPipes-Forestry-1.6.4-1.1.8.jar) Unloaded->Constructed
    DenPipes-Emerald{1.1.6} [DenPipes-Emerald] (DenPipes-Emerald-1.6.4-1.1.6.jar) Unloaded->Constructed
    xreliquary{1.1.2} [Xeno's Reliquary] (Reliquary-1.1.2b.jar) Unloaded->Constructed
    DenPipes{2.1.18} [DenPipes] (DenPipes-1.6.4-2.1.18.jar) Unloaded->Constructed
    numina{0.1.2-55} [Numina] (Numina-1.6.2-0.1.2-55.jar) Unloaded->Constructed
    powersuits{0.10.0-91} [MachineMuse's Modular Powersuits] (ModularPowersuits-1.6.4-0.10.0-91.jar) Unloaded->Constructed
    NetherOres{1.6.2R2.2.1} [Nether Ores] (NetherOres-2.2.1-14.jar) Unloaded->Constructed
    ForgeMultipart{} [Forge Multipart] (ForgeMultipart-universal-1.6.4- Unloaded->Constructed
    ThermalExpansion{} [Thermal Expansion] (ThermalExpansion- Unloaded->Constructed
    DragonAPI{release} [DragonAPI] (DragonAPI 1.6 Unloaded->Constructed
    DynamicLights{1.2.8} [Dynamic Lights] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    DynamicLights_onFire{1.0.3} [Dynamic Lights on burning] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    DynamicLights_creepers{1.0.3} [Dynamic Lights on Creepers] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    DynamicLights_dropItems{1.0.5} [Dynamic Lights on ItemEntities] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    DynamicLights_entityClasses{1.0.0} [Dynamic Lights on specified Entities] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    DynamicLights_mobEquipment{1.0.3} [Dynamic Lights on Mob Equipment] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    DynamicLights_flameArrows{1.0.0} [Dynamic Lights on Flame enchanted Arrows] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    DynamicLights_otherPlayers{1.0.5} [Dynamic Lights Other Player Light] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    DynamicLights_thePlayer{1.0.9} [Dynamic Lights Player Light] (DynamicLights_1.6.4-1.2.8.jar) Unloaded
    easycrafting{1.1.6} [Easy Crafting] ( Unloaded
    eng_toolbox{} [Engineer's Toolbox] ( Unloaded
    EnviroMine{1.1.3} [EnviroMine] ( Unloaded
    Metallurgy3Core{3.2.3} [Metallurgy 3 Core] (Metallurgy-1.6.4-3.3.2-WWM5.jar) Unloaded
    Metallurgy3Base{3.2.3} [Metallurgy 3 Base] (Metallurgy-1.6.4-3.3.2-WWM5.jar) Unloaded
    TConstruct{1.6.X_1.5.3dev} [Tinkers' Construct] (TConstruct_mc1.6.4_1.5.3.jar) Unloaded
    ExtraTiC{0.7.6} [ExtraTiC] (ExtraTiC-1.6.4-0.7.6.jar) Unloaded
    ExtraUtilities{1.0.3a} [Extra Utilities] ( Unloaded
    FinndusFillies{1.0.0} [Finndus Fillies] (FinndusFillies-1.6.2-universal- Unloaded
    gascraft{} [GasCraft] ( Unloaded
    GateCopy{3.1.4} [GateCopy] (GateCopy-1.6.4-3.1.4.jar) Unloaded
    gendustry{} [GenDustry] (gendustry-mc164- Unloaded
    GregsLighting{1.9.1} [Greg's Lighting] (GregsLighting-1.9.1-mc1.6.4.jar) Unloaded
    GunCus{1.6.4 BETA v2} [Gun Customization] ( Unloaded
    GunCusExplosives{1.6.2 BETA v1.1} [Gun Customization Explosives] ( Unloaded
    GunCusOfficialGuns{1.6.2 BETA v4} [Gun Customization Official Guns] ( Unloaded
    Hats{2.1.4} [Hats] ( Unloaded
    HatStand{2.1.0} [HatStand] ( Unloaded
    pamrandomplants{1.0} [Pam's RandomPlants] (Pam' Unloaded
    HungerOverhaul{1.6.X-2l} [Hunger Overhaul] ( Unloaded
    iChunUtil{2.4.0} [iChunUtil] ( Unloaded
    ImmibisCore{57.1.94} [Immibis Core] (immibis-core-57.1.94.jar) Unloaded
    ImmibisPeripherals{57.0.2} [Immibis's Peripherals] (immibis-peripherals-57.0.2.jar) Unloaded
    InfiniTubes{57.0.5} [InfiniTubes] (infinitubes-57.0.5.jar) Unloaded
    inventorytweaks{1.56} [Inventory Tweaks] (InventoryTweaks-MC1.6.2-1.56-b77.jar) Unloaded
    IronChest{} [Iron Chest] ( Unloaded
    JABBA{1.1.1a} [JABBA] ( Unloaded
    jammyfurniture{4.5} [Jammy Furniture Mod] ( Unloaded
    SGCraft{0.1.0build82} [Delta-SGCraft-Reloaded] (LanteaCraft-0.1.0-forge9.11.1.933-snapshot-82.jar) Unloaded
    LavaMonsters{2.2} [Lava Monsters] ( Unloaded
    LightBridgesAndDoors{0.1.7} [kris91268's Light Bridges and Doors] ( Unloaded
    magicalcrops{3.1.6} [Magical Crops] ( Unloaded
    ThaumicTinkerer{2.1-74} [Thaumic Tinkerer] (ThaumicTinkerer-2.1-74.jar) Unloaded
    MagicBees{2.1.11} [Magic Bees] (magicbees-2.1.11.jar) Unloaded
    MapWriter{2.0} [MapWriter] ( Unloaded
    Stucuk_MCICraft{1.0.4} [MCICraft] (mcicraft_core-1.0.4_MC-1.6.4_WIP_16_02_2014.jar) Unloaded
    Stucuk_MCICraft_Machines{1.0.4} [MCICraft Machines] (mcicraft_machines-1.0.4_MC-1.6.4_WIP_16_02_2014.jar) Unloaded
    Stucuk_MCICraft_Redstone{1.0.4} [MCICraft Redstone] (mcicraft_redstone-1.0.4_MC-1.6.4_WIP_16_02_2014.jar) Unloaded
    Mekanism{6.0.2} [Mekanism] (Mekanism- Unloaded
    Metallurgy3Machines{3.2.3} [Metallurgy 3 Machines] (Metallurgy-1.6.4-3.3.2-WWM5.jar) Unloaded
    Metallurgy3Vanilla{3.2.3} [Metallurgy 3 Vanilla] (Metallurgy-1.6.4-3.3.2-WWM5.jar) Unloaded
    minegicka{1.4.3} [Minegicka 2] ( Unloaded
    MiscPeripherals{3.3} [MiscPeripherals] ( Unloaded
    MobProperties{0.0} [Mob Properties] ( Unloaded
    MFFS{3.6.2} [Modular Force Field System] (Modular-Force-Field-System- Unloaded
    nohero_morehealth{4.5} [More Health Forge] ( Unloaded
    OpenMods{0.4} [OpenMods] (OpenModsLib-0.4b.jar) Unloaded
    OpenPeripheralCore{0.3.1} [OpenPeripheralCore] (OpenPeripheralCore-0.3.1.jar) Unloaded
    OpenPeripheral{0.1.1} [OpenPeripheralAddons] (OpenPeripheralAddons-0.1.1.jar) Unloaded
    OpenBlocks{1.2.5} [OpenBlocks] (OpenBlocks-1.2.5.jar) Unloaded
    SimpleRecipes{1.9} [Pam's Simple Recipes] (Pam' Unloaded
    ParticleBox{1.6.4_0} [ParticleBox] ( Unloaded
    particlephysics{0.1.1} [Particle Physics] (ParticlePhysics-1.1.jar) Unloaded
    PluginsforForestry{3.2.30} [PluginsforForestry] (PluginsforForestry-1.6.4-3.2.30.jar) Unloaded
    PneumaticCraft{1.0.6} [PneumaticCraft] ( Unloaded
    rcdusts{0.0.6d} [Rock Crusher Metal Dusts Add-On] ( Unloaded
    RedIO{1.1} [RedIO] ( Unloaded
    Redstone Arsenal{} [Redstone Arsenal] (RedstoneArsenal- Unloaded
    RedStoneHandGuns{1.6.4 v2} [RedStoneGuns] ( Unloaded
    RopesPlus{1.5.3} [Ropes+] ( Unloaded
    RotaryCraft{Gamma} [RotaryCraft] (RotaryCraft 1.6 Unloaded
    secretroomsmod{4.6.2} [The SecretRoomsMod] (SecretRoomsMod-universal-1.6.4- Unloaded
    Shatter{2.0.2} [Shatter] ( Unloaded
    StargateTech2{0.6.5-Alpha} [StargateTech 2] (StargateTech2-Alpha-0-6-5-MC164-Forge965.jar) Unloaded
    Sync{2.1.1} [Sync] ( Unloaded
    TMechworks{19.d4b8fa0} [Tinkers' Mechworks] (TMechworks_mc1.6.4_0.1.4.2.jar) Unloaded
    Translocator{} [Translocator] (Translocator- Unloaded
    Tubestuff{57.1.3} [Tubestuff] (tubestuff-57.1.3.jar) Unloaded
    TwilightForest{1.20.3} [The Twilight Forest] (twilightforest-1.20.3.jar) Unloaded
    UndergroundBiomes{0.4.3} [Underground Biomes] ( Unloaded
    Vending{1.1.1} [Vending] (vending-1.6.4-1.1.1.jar) Unloaded
    witchery{0.14.0} [Witchery] ( Unloaded
    WR-CBE|Core{} [WR-CBE Core] (WR-CBE- Unloaded
    WR-CBE|Addons{} [WR-CBE Addons] (WR-CBE- Unloaded
    WR-CBE|Logic{} [WR-CBE Logic] (WR-CBE- Unloaded
    xact{0.4.3} [XACT Mod] (XACT-v0.4.3.jar) Unloaded
    Chisel{1.5.0} [Chisel] (zchisel-1.6.4-1.5.0fix-WWM5.jar) Unloaded
    McMultipart{} [Minecraft Multipart Plugin] (ForgeMultipart-universal-1.6.4- Unloaded
    ThaumcraftMobAspects{1.6.X-1d} [Thaumcraft Mob Aspects] ( Unloaded
    ForgeMicroblock{} [Forge Microblocks] (ForgeMultipart-universal-1.6.4- Unloaded
    Profiler Position: N/A (disabled)
    Is Modded: Definitely; Server brand changed to 'mcpc,craftbukkit,fml,forge'
    Type: Dedicated Server (map_server.txt)
Thread Status:
Not open for further replies.

Share This Page