[ADMN/SEC/WEB] HawkEye [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by oliverw92, Aug 15, 2011.

  1. Offline


    sethgandy, phimt, matan7890 and 7 others like this.
  2. Offline


    So you actually want me to put on the wiki 'go to google. type "how to set up mysql database"'...

    It is very common for that to be the case

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  3. Offline


    I had to switch hosting companies because of this.
  4. Offline


  5. Offline


    Worked perfectly to start with...

    Then all over sudden some of the admins/mods can use the tool - and some can't ?
    Etc: whenever I try to click a block to see the logs, nothing happens. - When I use /he I can see and use all commands.
    Also worked just fine a few hours ago, I'll be browsing through the logs to see if I can find anything odd...

    Also - can you show me how to rollback a player, let's say for today.
    In LogBlock the command was /lb rollback player freakdk since 22.08.2011
    I've got a bit of trouble trying to figure out how to :)
  6. Offline


    I dont mind writing a page on the wiki for "How to set up MySQL for hawkeye" for people like SilencShadoW
  7. Offline


    could you add logging of workbenches ?
  8. Offline


    well, i didnt know that i HAD to set up a database. i dont even know wtf a database is, i thought it did everything i needed automatically, i dont know shit about this, so its useful to help tell people what they need to do.

    oh, and as something else, can u add logging of people inventories at set intervals to a text document or something, that way when something causes them to loose their inventories i can give it back to them without them bullshitting me about what they had
  9. Offline


    Working fine, thanks. I couldn't connect to external mysql database (not localhost) so I had to mess with linux :p
  10. Offline


    Commands/tool randomly stopped working.. :/
  11. Offline


    HawkEye was working well for a few days, then it started doing this:
    2011-08-22 18:37:34 [INFO] [HawkEye] Starting HawkEye initiation process...
    2011-08-22 18:37:34 [INFO] [HawkEye] Using Permissions for user permissions
    2011-08-22 18:37:34 [INFO] [HawkEye] Performing update check...
    2011-08-22 18:37:35 [WARNING] [HawkEye] New version of HawkEye available: 1.0.4
    2011-08-22 18:37:35 [WARNING] [HawkEye] Compatible with your current version of CraftBukkit
    2011-08-22 18:37:35 [SEVERE] [HawkEye] Error whilst attempting to get connection: java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: NO)
    2011-08-22 18:37:35 [SEVERE] [HawkEye] Error initiating HawkEye database connection, disabling plugin
    2011-08-22 18:37:35 [INFO] [HawkEye] Version 1.0.3 disabled!
    H haven't change any settings, and I have tried updating to 1.0.4, it still won't work.
  12. Well I redownloaded, issue remains Oo
  13. i finally made it(host was not localhost, it was cubehost.hu and the port was 3306)
    How can install webinterface to a webpage? i uploaded the zip (and with unzipped for sure) to webserver root but nothing changed
    View attachment 6118 View attachment 6119
  14. Offline


  15. Offline


    save as...
  16. Offline


    so I've completely gone over my whole network setup. all privileges are set, all ip addresses are binded. i can access the MySQL server from the localhost, i can access it from the minecraft server computer on my household network, mcmmo is currently writing to tables, and i can even access it remotely in every way. (with a strong 26 character password of course XD) and i'm running a forum off this mysql server.
    version 1.04 didnt fix it, although i really hoped it would, but i happened to notice sometimes the config resets to default :S

    *edit* after testing that, its been everytime. explains my problem, a reset config everytime i enable the plugin.

    and of course,the error

    2011-08-22 20:52:51 [INFO] [HawkEye] Starting HawkEye initiation process...
    2011-08-22 20:52:51 [INFO] [HawkEye] Using Permissions for user permissions
    2011-08-22 20:52:51 [INFO] [HawkEye] Performing update check...
    2011-08-22 20:52:52 [INFO] [HawkEye] No updates available for HawkEye
    2011-08-22 20:52:54 [SEVERE] [HawkEye] Error whilst attempting to get connection: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    2011-08-22 20:52:54 [SEVERE] [HawkEye] Error initiating HawkEye database connection, disabling plugin
    2011-08-22 20:52:54 [INFO] [HawkEye] Version 1.0.4 disabled!
  17. Offline


    Deleted the post and reply, but note to self: Don't integrate winrar with every file type :p Not sure why I did it in the first place. Didn't realize I was actually extracting the jar heh. Never mind on the download thing.
  18. Offline


    Yet again...........

    22:26:21 [SEVERE] [HawkEye] Error whilst attempting to get connection: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

    The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    22:26:21 [SEVERE] [HawkEye] Error initiating HawkEye database connection, disabling plugin
    22:26:21 [INFO] [HawkEye] Version 1.0.2 disabled!

    Config ( I assume you only need the SQL part )

    hawkeye-table: datalog
    port: 3306
    player-table: dl_players
    username: root
    world-table: dl_worlds
    max-connections: 10
    password: ''
    database: minecraft
    version: 1.0.2
  19. Offline


    If your username was really root without a password, that's a major security risk. I assume you haven't set up your MySQL server correctly.
  20. Offline


    Probably not.. Should I change that? :3
  21. Offline


    Woah CRAZY ram user unlike logblock,
    20 mins of running server with this= 700,000K ram usage
    20 mins OR WAAAAY more with logblock= 250,000K ram usage
    I thought this had better management than logblock (as written in original post)!

    EDIT: Also this HARDLY logs worldedit...
  22. Offline


    Seems like you need to update your HawkEye.
    My Server normally uses 800-1000 mb ram, with v1.0.3 it had a bug which (for me) caused a memory leak, I decided to restart everything when it reached 2,2 GB ram when I set it to a 2 GB limit.
  23. Offline


    @angus22397 This never said it logs worldedit. It will log the commands but not the actions. This supports world edit because you can use WorldEdit selections to select regions to roll back
  24. Offline


    Does a /reload or server reboot fix the issue of them not being able to use it?

    To do that you can do /he rollback p:freakdk t:2011-08-22

    I already have a page that tells you what to do generally: https://github.com/oliverw92/HawkEye/wiki/MySQL-and-web-server
    I was thinking about making a video for setting it up on windows.

    Interesting idea. Do you mean log what people craft?

    Ok well I'll work on that part of the wiki.

    I won't be adding that type of logging. That would be the job of another plugin.

    They won't randomly stop - something will trigger it.

    Look at the error - Access denied for user 'root'@'localhost' (using password: NO). Your password or username is wrong.

    It is definitely gone in the current download :\

    I see you have fixed it now?

    Hm. I'm going to have to try and replicate this setup to see what the issue is.

    Could you try turning lava and water flow logging off. That might make a difference.
    And no-where does it claim to log worldedit changes - it uses worldedit for rolling back selections.
  25. No more debug issues with latest JAR now.

    Also do not see any change in RAM use after enabling this, did not have issues with Datalog either. I do have flow logging disabled, that seems far far from worth it :p
  26. Ifixed it it works now, just permissioex plugin crashed the server now:) I can fix it thx for your help
  27. Offline


  28. Offline


    Yes I understand that, I simply needed to know that so I can fix the problem :)

    Does it happen if you do this:
    • reload server
    • enable hawk tool
    • use it
    • log out
    • log back in
    If you do that is the tool working when you log back in?
  29. Offline


    Super noob here. How do I set up MySQL on a server? I downloaded it from the site, and have the nice little preference pane on my mac. But when I type the NEW_STRONG_PASSWORD in terminal, it says could not find command mysqladmin. I know I did something wrong. I just downloaded Apache and im trying to figure it out

    EDIT: It seems i dont need apache. SO what do I do?
  30. Offline


    Yes I did mean what they put in the workbench :)
    Or what comes out might be even better
  31. Offline


    Ooh! It seems i have gotten closer:

    08:24:12 [SEVERE] [HawkEye] Error whilst attempting to get connection: java.sql.SQLException: null, message from server: "Host '**IP**' is not allowed to connect to this MySQL server"
    08:24:12 [SEVERE] [HawkEye] Error initiating HawkEye database connection, disabling plugin
    08:24:12 [INFO] [HawkEye] Version 1.0.2 disabled!

Share This Page