[ADMN/SEC] VanishNoPacket 3.14.2 - Invisibility made easy! [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by mbaxter, Aug 16, 2011.

  1. Offline

    dyrmaster

    i mean edit, but can you help me maybe in a file you can send me?
     
  2. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    Read your permissions plugin documentation and grant yourself the nodes you want.
     
  3. Offline

    Icee2199

    ok so i have the permission node: "--vanish.effect.toggle.explode" and "--vanish.effect.toggle.lightning" and even then when i do /v lightning comes down and lights everything on fire....
     
  4. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    It's "effects" ;)

    Op doesn't get toggle permission, or even have the effects enabled. You must have granted those nodes separately. Maybe the * node? If it's something you don't want to edit, negate the nodes (vanish.effects.explode/lightning/smoke presumably) you don't want.

    Op doesn't get * in any perms plugin I'm aware of, what plugin are you using?

    Also, to quote my previous post: If it's something you don't want to edit, negate the nodes (vanish.effects.explode/lightning/smoke presumably) you don't want.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 14, 2016
  5. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

  6. Offline

    alltra09

    With my top staff rank i give them the *.* permission node in permissionsex so they get all the permissions but now i can not get rid of this explosion and lightning effects, so why is there not a part in the config for this cause i am going to have to switch to a different plugin.
     
  7. Offline

    afistofirony

    Code:
    groups:
      GroupName:
        options:
          prefix: &8[&4GroupName&8]&f
          suffix: &c
        permissions:
        - -vanish.effects.explode
        - -vanish.effects.lightning
        - -vanish.effects.smoke
        - *

    Problem solved.

    I have no clue why people freak out over not having all permissions.
     
  8. Offline

    alltra09

    Thanks but no thanks i have already done that it still does the explosion and lightning
     
  9. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    Paste YOUR permissions file and name what plugin its for
     
  10. Offline

    alltra09

    Head-Admin:
    default: false
    inheritance:
    - Admin
    build: true
    permissions:
    - '*'
    prefix: '&6Head-Admin &6'
    suffix: '&f'

    Plugin: PermissionsEX
     
  11. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    So where's the negation?
     
    afistofirony likes this.
  12. Offline

    alltra09

    What?
     
  13. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

  14. Offline

    alltra09

    I have already, as i said i have used this permissions plugin for around 10 months now and i know to use - in front of permission nodes to stop people from being able to use it like LWC but it does not work with your plugin. I put
    - -vanish.effects.explode and yet when i join then do /v it still does it.
     
  15. Offline

    afistofirony

    permissions:
    - '*'

    @alltra09 You didn't put it...

    If it's an inheritance, then it won't work. PEX reads the permissions of a group before it reads the inheritance.

    OKAY. Fourth try.

    Try this:


    - -vanish.*
    - vanish.standard
    - *
     
  16. Offline

    alltra09

    Still does the explosion and lightning
     
    supervolk likes this.
  17. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    Ask in PEX help thread.
     
  18. Offline

    alltra09

    Ok but in the next update is there any chance of it being added to the config to turn it off?
     
  19. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    No. The permissions work fine.
     
  20. Offline

    supervolk

    The plugin is great, but im an OP, i has '*' permission on my server and i has 88 plugins (and my own, so it's 89), so i can't give ALL permissions to myself from ALL plugins! It will take a week! So that must be set in config in next version.
     
    alltra09 likes this.
  21. Offline

    Phoenix901

    I'm currently useing PermissinsEx or PEX with VainishNoPacket and i'm a admin aswell.
    If you set this in your permissions.yml file it should work. Works for me atleast.


    Code:
        - -vanish.nointeract
        - -vanish.nochat
        - -vanish.silentjoin
        - -vanish.silentquit
        - -vanish.effects.smoke
        - -vanish.effects.explode
        - -vanish.effects.lightning
        - -vanish.joinwithoutannounce
        - -vanish.joinvanished
        - '*'
    Hope it helped you out.
     
    supervolk likes this.
  22. Offline

    supervolk

    Yeah it helped me, but it must, (must and again MUST!) to be in config.
    Thank you!
    PS: I'm using PEX too
     
  23. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    Why does it need to be in the config? The above linked permissions setup works fine.
     
  24. Offline

    supervolk

    mbaxter, I think that there is no way to configure it, but if there is no permission plugin installed (i have, but if somebody doesn't)?
     
  25. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    If you don't have a permissions plugin, then everything is disabled by default (even if you have op, you only get the ability to /vanish, pretty much). And you can add it using permissions.yml which is a bukkit feature.
     
  26. Offline

    supervolk

    mbaxter, yes i can, but it's more easier to configure it using config-file
     
  27. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    No, same number of lines to edit.
     
  28. Offline

    supervolk

    mbaxter, but it is easier, only 'true' or 'false'
     
  29. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    Same thing as a permissions file, you say?
     
  30. Offline

    supervolk

    No, i must set all that permission nodes to permission file, it's harder than set true/false in config file
     

Share This Page