[ADMN] ModTRS v2.1 - Moderator Ticket Request System [1240]

Discussion in 'Inactive/Unsupported Plugins' started by Yetanotherx, Apr 4, 2011.

  1. Offline


  2. Offline


    will there be an update? checking requests from the console doesnt work
  3. Offline


  4. Offline


    For some reason I can't get my modtrs making a table in mysql.
    This is what I filled in bukkit.yml (everything is slightly altered so it are not my real info)
      username: 9999
      isolation: SERIALIZABLE
      driver: org.sqlite.JDBC
      password: 99999999
      url: jdbc:mysql://mysqleu1.fragnet.net:9999/8888_clientdb.db
    According to fragnet I do not need to change the driver and is this the url setup.

    Also when I try to use the commands in minecraft it does not regocnize the commands.
    I hope i will get a answer soon because I really like this plugin. Igot it solved I was close to it though. This is what I did for those who got the same problem.
      username: '9999'
      isolation: SERIALIZABLE
      driver: com.mysql.jdbc.Driver
      password: '999999999'
      url: jdbc:mysql://mysqleu1.fragnet.net:9999/8888_clientdb
  5. Offline


    There's your issue.
  6. Offline


    Having a problem i have given the permissions to moderators and they work fine but users who are op or have the '*' permission node in groupmanager just gets you do not have access to the command
    PLEASE HELP!!!! :(
    turtles9788 likes this.
  7. Offline


    This happens to me too. could someone please help us?
    thedjtrollin likes this.
  8. Offline


    This plugin is essential for a large server, couldn't do without it, wish modreq-ban worked though :(
  9. Offline


  10. Offline


    Please Update, we need this Plugin!
  11. Offline


    Is their anyway that you could make it so that people can only make a request every 15 to 20 mins? or allow my server, Unlimited Craft, to change it so that this happens? reason being is we dont want trolls to make a million requests and clog the mods inbox. Thanks.
  12. Offline


    Please fix permissions, people with the permissions:

    - modtrs.command.modreq
    - modtrs.command.modlist
    - modtrs.command.check.self

    Cannot use them. Only by having the permissions '*' will you be able to operate this plugin. Could this get fixed please?

    Just ban the trolls from making the requests.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  13. Offline


    Users with the proper permission nodes (Essentials+GM, dev 2.8.35) are getting a permission error (when it used to work just fine). Bukkit version 1783
  14. Offline


    I'm going to assume that we don't have a remedy for the OP's not having the ability to use MODTRS?
  15. Offline


    I don't have the time, nor experience to maintain this plugin. But I compiled ModTRS from the GitHub source to work with newer builds of CraftBukkit. I have confirmed this to work with the version I am currently using on my server (CB #1772).
    The things I have done is recompile the plugin from the source code, using newer versions of CB as libraries, meaning it uses console commandsender correctly. Not in moonspeak: It works from the console.
    Permissions 2 code has been stripped out from this version and it uses SuperPerms instead, which means that it will work with SuperPerms-only Permission Handlers, such as bPermissions 2.x (excluding 2.7.7+) and PermissionsBukkit.
    And lastly, fixed the getPlayer(username).isOnline(); check to return false, instead of null if the player is offline (fixes NPE).

    Do not ask Yetanotherx for support if you decide to use this version.



    MatrixJ21 likes this.
  16. Offline


    Hey Im An Owner on my server all admins and mod have access to the ModTRS
    But i Don't shouldn't i Have access to all Commands on my server since I'm an Owner
  17. Offline


    Yes becuase of this error I see.
    2011-12-13 03:53:23 [SEVERE]    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:180)
  18. Offline


    I don't know why, but the ModTRS on my server doesn't work at all... i have it installed and it worked a week ago but for some reason it doesn't work now.... How do i fix it? Because there's not error on the console when it loads up.
  19. Offline


    Post your startup log, that normally helps.
  20. Offline


    I would love to see this ModTRS system updated. My OP really liked this plugin. I made 'taking care of player request' so much easier. :)
  21. Offline


  22. Offline


    I added a workaround for this.

    Remember that you need SuperPerms for this version and not to give the permission node modtrs.command.reset to anyone except those you wish to be able to reset the database on-the-fly (/modreset).

    As per usual, a visual representation of the change.

    See the link above. Like normally, do not ask Yetanotherx for support if this version does not work for you. I personally use this on a server with 100+ users daily. So I wouldn't fear anything. :)

    Update. I decided to add a held notification upon login cause I tend to forget about it.
    Remember to delete messages.yml to have it regenerate.

    kahlilnc likes this.
  23. Offline


    Excellent plugin, works perfect with 1.1 R3, just switched from okmodtickets since modtrs is easier to use.
  24. Offline


    I'm using ProjectInfinity's JAR and I just can't get it to work. I'm using groupmanager, and I've given myself the modtrs.* permissions node, I've verified that. However when ingame I do /modtrs the only extra command it gives me is /modreset , it doesn't give me any of the other modtrs commands. This is on a server full of plugins, on a clean server with just essentials, groupmanager and modtrs I can get it working fine by giving myself the modtrs.* node. Very confusing!
  25. Offline


    Just so you know since this is outdated, bReport has the same functionality.
  26. Offline


    You are some kind of god, thank you!
  27. Offline


    Lol. Like my post if I helped guyag
  28. Offline


    Try specifying every single permission node. I use this daily on my own server, so I know there's no problems with it.
    kahlilnc likes this.
  29. Offline


    I do not know what's going on, but other players can not write / modreq text (my translation may not be 100% accurate because I'm from Polish):p
  30. Offline


    Have you given them the permission node modtrs.command.modreq?

Share This Page