Inactive [ADMN] MCTelnet v1.2.7 - Remote Console Access using Telnet [1185]

Discussion in 'Inactive/Unsupported Plugins' started by bekvon, Feb 21, 2011.

  1. Offline


    MCTelnet - A telnet server plugin for bukkit.
    Current Version: v1.2.7

    First off, this is not a wrapper, its a simple plugin. Plop it into your plugins folder, tweak the config file and your good to go.

    • Ability to access the server console from telnet.
    • Requires username + password on connect.
    • Port can be specified in config.yml
    • Additional users with different permissions can be set up.
    • Passwords can be encrypted in the config file (md5).
    • Contains a "sudo" command that will elevate you to the root user.
    Sample Config File:
    #Setup information
    encryptPasswords: true
    telnetPort: 8765
    allowAuthlessLocalhost: false
    #Root login information
    rootUser: console
    rootPass: abcd
    rootEncrypted: false
    #Other users
            log: true
            password: abcd
            commands: list, plugman, help
            passEncrypted: false
    Instructions by ScorchRaserik:
    • Possibly implementing usernames to log on with. Done
    • Possible Integration into Permissions. Not really possible right now.
    • Make config file write default values if missing. Done
    • Code cleanup
    • Make passwords hidden as you type (almost done).Done
    • Optional idle-timeout.
    • Sudo command (similar to linux). Done
    • Encrypt passwords in the config. Done
    Change Log:
    v1.2.7 - 9/23/2011
    - Fix chat color codes being printed on console.

    Change log (open)

    v1.2.6 - 8/16/2011
    - Fixed to work with CB 1060.

    v1.2.4 - 4/11/2011
    - Allowed periods to be used.

    v1.2.2 - 3/19/2011
    - Added ability to specify a listen address.
    - Rebuilt with latest CB (556)

    v1.2.1 - 2/28/2011
    - Rebuilt against latest recommended craftbukkit build (440 as of now).
    - Changed to static download link.

    v1.2 - 2/24/2011
    - Added sudo command.
    - Passwords will now be setup to be encrypted in the config file.
    - Passwords are now hidden as you type.
    - Other minor improvements.

    v1.1 - 2/22/2011
    - Added usernames, can now specify users and what commands they can use.
    - Cleaner config file with more information.
    - Missing config file is regenerated.
    - Many aesthetic improvements.

    v1.0 - 2/21/2011
    - Initial Release.

    File: MCTelnet
    Configuration File: config.yml
    Recommended Telnet Client: PuTTY

    Source: GitHub
    kittenchunks, umnumnum, sbeex and 7 others like this.
  2. Offline


    Ah, ok good, glad you got it to work :) The encrypt passwords feature is kinda confusing for some people. To get you password properly encrypted, you first enter you password in the config as plain text, then set passEncryped to false (since its not encrypted yet). Then set encryptPasswords to true, and the next time MCTelnet runs it will encrypt the password, save the encrypted password in the config, and automatically change passEncrypted to true.
  3. Offline


    I am getting the Invalid Username or Password Error.
    This is the config file:
    rootUser: David
    telnetPort: 45137
    listenAddress: 50.22.**.***
    rootPass: "encrypted password here"
    rootEncrypted: true
    encryptPasswords: false
    I am on BroHoster, with a random port. I have tried the default 8765, and a couple other random ones. Nothing seems to work.
  4. Offline


    If your password is already encrypted, you need to set encryptPasswords: true

    Stop your sever. Set your config like this, then restart:

    rootUser: David
    telnetPort: 45137
    listenAddress: 50.22.**.***
    rootPass: "Non-encrypted password without quotes"
    rootEncrypted: false
    encryptPasswords: true

    Obviously, make sure you enter your IP in the config.
    connect with putty to your IP AND port.
  5. Offline


    Would it be possible to fix in/output in Mac OS X's Terminal? As you can see here, it's a mess.

    ^? = backspace
    ^M = enter

    And it doesn't seem to like the / character. Or the color S thing.
  6. Offline


    Don't use a plus sign in the version tag. If you really need to use more versions, use [X-Y] or [X,Y].
  7. Offline


    I'm running C.B. build 720 (latest at time of writing) and there are no errors from MCTelnet, but it doesn't issue certain commands even if it says it does.

    21:08:19 [INFO] [MCTelnet] - Client connected: /
    21:08:20 [INFO] [MCTelnet] console issued command: help
    21:08:20 [INFO] [MCTelnet] Closing connection: /
    But nothing happens. I realize build 720 is not a recommended build, but I thought you'd like to know anyway.

    "stop", on the other hand, works fine.

    One more thing; do you think it would be possible for you to introduce a 'require-auth' option that could disable the need for user/password authentication?

    I have a dedicated server that no-one but me has access to and MCTelnet is bound to anyway, so it wouldn't make a difference in the grand scheme of security concerns.

    Try updating your CB build first - latest is 720.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  8. Offline


    Can you restart/stop then start a few mins later from this? Or does the server need to be running in order to enable the plugin?
  9. Offline

    City Builder

    It's not a wrapper so if the server is not running, the plugin is not running.
  10. Offline


    Hmm, that odd. I unfortunately do not own a Mac, so it would be really hard for me to test any changes I made specifically for Mac. I could maybe implement some kind of config option that will cause the program to manually enter linebreaks at the end of each line, but im worried that those too might get converter to ^M . :(
    Ok, I'll stay away from the "+" then :) Really hoping that a recommended CB comes out soon though so I can just use it for supported version.
    Hmm, maybe its just the output text that is broken, but the actual commands are making it to the server fine. I'll prolly end up waiting until I can support a recommended CB build before I play with it too much though.
  11. Offline


    733 was just promoted to a recommended build a few hours ago or so.

    Also, the output I quoted was directly from the console on the server, not read from MCTelnet. In CB #709 the output would come both over the telnet connection but also be logged in server.log, which is no longer the case as of (what i tested) 720.
  12. Offline

    City Builder

    I'm wondering if there is a way that I can change mctelnet so that when I don't type a / it acts like typing say instead?

    Basically I'd rather not type say all the time when I want to say something to my members, is this somehow possible using Putty and MCTelnet?

  13. Offline


    The commands nolonger output to the console, they are still logged as being issued but they dont actually print their output to the console. They only print their output back to the person who issued the command. This was done so that multiple admins could issue commands without spamming each other too much from each others commands. :) All the commands still get issued fine though.
    Hmm, replacing a / with say wouldn't be too hard i guess, but this seems like this should be done by another plugin rather then MCTelnet itself... but i suppose I could get do it, will take me a while to get to it though.
  14. Offline


    I have a problem. Just before the 1.5 update normal player messages stopped showing in the MCTelnet. Only private messages showed. Now I do not know if it is MCTelnet or Herochat that is causing this or both.

    Any ideas? I can't monitor chat through console anymore.
  15. Offline


    I keep trying to log in through PuTTY, but it won't let me type in a password? I can type in the username, I press enter, and no matter what character I press, it won't put anything down. When I finally press enter, it just tells me invalid password or username. How do I type in the password?
  16. Offline

    City Builder

    Passwords don't show up in the putty console. But they are being recorded to validate them with your server
    Nuk3d likes this.
  17. Offline


    As the developer posted:
    • Make passwords hidden as you type (almost done).Done
    Which means that you won't see the password as you type, but it will receive it. Just type it, press enter and WIN.
    Nuk3d likes this.
  18. Offline


    Hmm, I noticed a "colours" section in the Putty Reconfiguration>Window and my dad says that you can use colours in Telnet if the client supports it. It also looks like the colours listed there are very similar to the ones Minecraft uses. It would be super cool if this could be implemented; mostly so that this stops happening:​
  19. Offline


    I would appreciate the use of
    '<','>', and ':' symbols plox!
  20. Offline


    Is it possible that you could allow useage of colon etc? PermissionsPlus does now require colons (god knows why), and that essentially breaks the usefulness of this plugin as it gets filtered. More special characters please!
  21. Offline


    Add that line to your config file somewhere.
    ProjectInfinity likes this.
  22. Offline


    Thanks a lot! That worked.
  23. Offline


    This is GREAT! Now I can rescue my server if my graphic environment locks up! (happens often enough)
  24. Offline


    I managed to lock myself out of my VNC connection at least twice -- and had to lug a KVM set downstairs -- while setting up Cygwin so I could SSH in and loopback to telnet... from my phone!
  25. Offline


    Guys can anyone please tell me if
    Is it HeroChat that's doing this or MCTelnet? I need to monitor chat sometimes through MCTelnet and now it's broken :/
  26. Offline


    Use PermissionsPlus and the commands will work from Telnet. It's what I do in the panel I am making and it works great.
  27. Offline


    looks crappy


    seems this and similar commands broke the output
  28. Offline


    That Regex is prepending all my commands with a space. Wat.
  29. Offline


    Will the no-chat-output-to-console bug be fixed? That's pretty important to the plugin (in my opinion)- I mostly use it to send messages to players, but I can't see any responses in the telnet client.
  30. Offline


    Its probably HeroChat, but I'm not 100% sure. MCTelnet locks onto the "Minecraft" logger, and pretty much any text that hits the console goes through the "Minecraft" logger and so it should catch anything that the console outputs.
    I cannot replicate this bug on my side, its probably caused by one of your other plugins. See my reply above as well.
  31. Offline


    Would it be possible so that if someone was using the remote console and use the /say command in Minecraft it would say "RC:message here"?

Share This Page