Inactive [ADMN/GEN/TP/INFO]motd 1.2 - Greeting, Teleport Request, Time Vote, IP, WhoList [2126] superPerms

Discussion in 'Inactive/Unsupported Plugins' started by zweizeichen, Mar 13, 2011.

  1. Offline


    Latest Version: v1.2 (Bukkit 1.2.4)
    Please use BukkitDev for bug reporting and support!


    motd is a lightweight MOTD and basic command plugin for your minecraft server.
    There are lots of 'basic commands' plugins around here, but most of them have lots of features you will never need - or they do not allow you to deactivate them easily. They often cause lag and make configuring your server a pain in the *** because there is no documentation.

    With motd I made a simple, yet powerful plugin for creating advanced, custom colored and formatted MOTDs, who lists and rules. If you do not have the time to always be around on your server, rtp and vtime can help you. Even if you decide to install permissions on your server, motd is ready for that change.

    Here's a small overview of what you can do with motd:

    Customizable MOTD (text and color)
    You can enable/disable each command by editing a config file

    • who
    • rtp [playername / yes]
    • vtime [dawn / day / evening / night]
    • ip
    • motd
    • rules
    The plugin provides several features for your minecraft server. The first one you will notice, is whenever a player joins the game he will be greeted and shown other online players.

    To bring up the online players list again type:

    To bring up the MOTD again type:

    To bring up the rules type:



    The plugin is generally designed for servers where an admin is not online all the time. Therefore I have implemented the following two commands:

    vtime is a time vote system. Everyone can start a vote to change the time. You can vote for dawn, day, evening and night. To vote for a time change just use the argument yes. If not at least half of the online players voted yes within 60 seconds, the vote expires.

    rtp creates a teleport request to another player. The other player has to type in /rtp yes to teleport the player. There can only be one request to one player at a time.


    ip shows the ip of the player using the command.

    Please read the manual for further information on using and configuring motd.

    Permissions Nodes

    • motd.ip.use
    • motd.who.use
    • motd.rtp.yes
    • motd.rtp.request
    • motd.vtime.use
    • motd.rules.use
    • motd.motd.use
    • motd.edit
    • motd.reload
    • note that motd.rtp.request includes motd.rtp.yes

    Version 1.1.1
    • FIXED: /vtime now displays the correct name of the world
    • FIXED: some Permissions related stuff in /motd
    Version 1.1
    • REWROTE: Entire command, permission and config handling
    • ADDED: Permission's prefixes to <who>
    • ADDED: Modular command system
    • ADDED: Internal task management for vtime
    • IMPROVED: Multiworld support in vtime
    • FIXED: Some problems with names in /rtp and /vtime
    • CHANGED: Node motd.rtp.use is now split into
      • motd.rtp.yes
      • motd.rtp.request
      • Important: request includes yes
    • Some minor changes I cannot remember (spelling...)
    Older Changelogs (open)

    Version 1.0

    • ADDED: Permissions support
      • Nodes
        • motd.ip.use
        • motd.who.use
        • motd.rtp.use
        • motd.vtime.use
        • motd.rules.use
        • motd.motd.use
        • motd.edit
        • motd.reload
    • ADDED: /rules command
    • ADDED: changeable /who text
    • ADDED: /motd reload command
    • ADDED: /motd edit %property% %value% command
    • ADDED: config now migrates itself from 0.5.3 to 1.0
    • ADDED: build 733 compatibility
    • MOVED: Motd/motd.yml to motd/motd.yml
    • CHANGED: some minor changes in the config. They should be self-explaining
    • Please read the manual first if you have questions
    Version 0.5.3

    • The plugin is compatible with 609 / 1.4 now
    • CHANGED: /who command and <who> now displays the calling player too, for consistency with <numplayers>
    • ADDED: <ae>, <ue> and <oe> for the umlaute ä, ü and ö
    • MOVED: The config is now located in plugins/Motd
    • CHANGED: Default motd to match the change in <who>
    Version 0.5.2

    • ADDED: <numplayers> and <maxplayers> placeholders in MOTD
    • CHANGED: placeholders are now written in <brackets> for better readability
        • '%red' changes to '<red>' for example
    • CHANGED: %p is <playername> now
    • CHANGED: %w is <who> now
    • UPDATED: config to version 2
    Version 0.5.1

    • ADDED: /motd command to bring up the motd again
    • ADDED: some kind of config file version management
    Version 0.5

    • FIXED: Handling of offline players in /rtp
    • UPDATED: Internal teleport function for future versions of craftbukkit
    • ADDED: Use %n for a new line in the MOTD
    • IMPROVED: Internal color handling
    Version 0.1b

    • ADDED: colors for the MOTD are now available. Please see the manual for further instructions on using them.
    Version 0.1a

    • FIXED: /who no longer shows "nobody!" as other player
    • ADDED: motd.yml (will be created at first launch)
    • ADDED: Changeable MOTD (use %p for playername and %w for the player online list)
    • ADDED: use true or false in the motd.yml to enable or disable the different commands
    Version 0.1

    • release

    Planned Features
    • different MOTDs for different groups
    • multiple MOTDs
    • broadcast messages
    • more placeholders
    • pm command
    • localization
    Have fun and good luck,

    EarlyLegend and Pinkpixels like this.
  2. Offline


    Hi I am having an issue with getting a error whenever I run it. Here is the error:
    [spoiler = Error]
    >14:15:32 [SEVERE] Error occurred while enabling motd v1.1 (Is it up to date?): while parsing a block mapping; expected <block end>, but found Scalar

    while parsing a block mapping

    in "<reader>", line 2, column 1:

    motd: '<red>Hello <playername> a ...

    expected <block end>, but found Scalar

    in "<reader>", line 6, column 7:

    who: '<green><red>Online Players:<n><r ...

    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(

    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(

    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(

    at org.yaml.snakeyaml.composer.Composer.composeNode(

    at org.yaml.snakeyaml.composer.Composer.composeDocument(

    at org.yaml.snakeyaml.composer.Composer.getSingleNode(

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(

    at org.yaml.snakeyaml.Yaml.load(

    at org.bukkit.util.config.Configuration.load(

    at org.zweizeichen.Motd.modules.Config.initConfig(

    at org.zweizeichen.Motd.Motd.onEnable(



    at org.bukkit.plugin.SimplePluginManager.enablePlugin(

    at org.bukkit.craftbukkit.CraftServer.loadPlugin(

    at org.bukkit.craftbukkit.CraftServer.enablePlugins(

    at net.minecraft.server.MinecraftServer.e(

    at net.minecraft.server.MinecraftServer.a(

    at net.minecraft.server.MinecraftServer.init(


    Do you know what could be wrong? My craftbukkit version is 945 and I am attaching my config file. Please help because I really love this plugin and I would like it to work! (Config file is in yml format it is just that this wouldent let my upload a yml)

    Attached Files:

  3. Offline


    You forgot an apostrophe at the end of line 2:
    motd: ' ...Type /who for info on who is on the server.'<---
  4. Offline


    Oh man, I can't believe I did not see that! Oh well, thanks for your timely response, now I can finally use this awesome plugin! Keep on coding!
  5. Offline


  6. Offline


    First of all - thank you for posting your log.
    Does this error occur every time anyone uses /rtp? Do you have any plugins which are changing player's names installed?
  7. Offline


    Hey, I'm liking the whole concept of the plugin, but it seems that whenever I try any of the commands a help menu for it pops up instead. Running Build 1060, using the default configuration file (version 3) that enables permissions and disables vtime, ip and rtp. Rules, who and motd are enabled. I've added the permissions for the enabled ones to the default group as well. I can't find anyone with a similar problem in this thread :/

    Uh... nevermind, it was something stupid on my part, disregard that last message. Sorry about that :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  8. Offline


    1st question: no, about 1 time a week
    2nd question: no.
  9. Offline


    Okay I'll have another look at the code, but since the error only occurs once a week, it should not be a big problem if I can't find a solution.
  10. Offline


    Would there be anyway that you can add another message for commands? For example, just as you have /rules setup to display a set of rules, could you have /command or /cmdlist? Or better yet, can make it so that it can be customized so that you can create any message that will display for only you with a command string?

    The chat doesn't allow for too much text on the screen and there is no scroll bar, and to have it on a looped announcement is too much spam. So I figure if you have separate string of commands, you can display them at anytime without spamming other players.
  11. Offline


    Yeah many asked for a plugin like that. The problem is, that with bukkit it's kind of difficult to program. I'll put that functionality into another plugin.
  12. Offline


    YEEEEEESSSSS sorry for the spam but finally a motd system that supports bukkit perms
    thanks so much :D
  13. Offline


    You should add support for the nordic letters.. like : åäö and more :)
    Except for that, this plugin is great.
  14. Offline


    å is the only one which is not implemented. If you want to use äöü, use <ae>, <oe>,<ue> in your config string.
  15. Offline


    Can you add the ability for someone (permissions or OP) to use /ip <player>?
    That would ultimately make me use this plugin
  16. Offline


    I do not know if that would be okay, since that could provoke abusive use of this function (data protection).
  17. Offline


    Any chance of getting Bukkit Permissions support? and/or a list of the permissions nodes for it?
    zweizeichen likes this.
  18. Offline


    That's one of my main goals for the next release but that could take a while since I really do not have much time for coding at the moment.
  19. Offline


    Very nice plugin, i just have one input!

    If only 2 people are online and one are afk (alot of people are afk in grinders), /vtime is useless as, for some reason, 1 vote of 2 is not counted as "minimum half of the votes" as the manual states is the need for the vote to be accepted.

    So either make so that the vote-% can be set in the config file or make it work the same way when 2 players are online as when you are alone. First solution is best imo.
  20. Offline


    Thank you so much for incorporating a /rtp command - been looking for a simple, lightweight /rtp for absolutely ages...!!

    +1 [meat] for you!!
  21. Offline


  22. Offline


    Can you add a new Permissionnote? motd.vtime.yes? I'd like to give VIP the votingstart right and the member the viteright.
  23. Can I make pages of rules , and so how ?
  24. Offline


    No, you can not make pages of rules.
  25. Offline


  26. Offline


    does this plugin still work with 1.0.1?
  27. Offline


    Works on 1.0.1-R1. Is there any way you could add a command that requests to have a player teleported to you? I've been using this plugin for a while and have gotten that request on a multiple occasions.
  28. Offline


    Hi - I have installed 1.1.1 on the latest Bukkit, and got the plugin working - the motd and rules display correctly, and I have motd.* permissions. When I try to change the motd or the rules via a command rather than editing confi.yml, it just lists the syntax for the command and never applies the changes. I am trying the following command:
    /motd edit motd <red>Hello
    /motd edit rules <yellow> Example Rule
    Here is my config file:
    # MOTD related stuff. See manual for further instructions on editing the config.
    motd: '<white>Please follow the rules!'
    motd_enabled: true
    # Who - It is formatted just like the MOTD.
    who: '<green>Online (<numplayers>/<maxplayers>): <who>'
    who_alone: '<green>You are the only one on the server.'
    who_enabled: true
    # Rules - They are formatted just like the MOTD.
    rules: 'Rules for <green>My Server<n><n><aqua>1. Do not grief!<n><aqua>2. Do not grief!<n><aqua>3. Do not grief!'
    rules_enabled: true
    # Commands
    motd_command_enabled: true
    rtp_enabled: true
    vtime_enabled: true
    who_enabled: true
    ip_enabled: true
    # Third party plugins
    permissions_enabled: true
    # Do not change please
    config_version: 3
  29. Offline


    Have you tried changing a true/false value?
  30. Offline


    Yup, the only thing that I can change that makes any difference is the permissions_enabled line. Set to True I get this:
    12:37 AM [INFO] motd: Permissions system not detected - you have to edit the config manually!
    12:37 AM [INFO] motd version 1.1.1 is enabled!
    Set to false, just the 2nd line appears.
    Here is my Pail output showing my permissions plugins:
    12:39 AM [INFO] [Pail] Pail 0.7.5 Enabled
    12:39 AM [INFO] CraftBukkitUpToDate version 2.7.2 is enabled!
    12:39 AM [INFO] motd version 1.1.1 is enabled!
    12:39 AM [INFO] PailPlus v0.2 beta enabled
    12:39 AM [INFO] WorldEdit 5.0 enabled.
    12:39 AM [INFO] CButD: CraftBukkit is up to Date
    12:39 AM [INFO] CommandBook 1.7 enabled.
    12:39 AM [INFO] CommandBook: 1 Warps(s) loaded
    12:39 AM [INFO] CommandBook: 0 Homes(s) loaded
    12:39 AM [INFO] CommandBook: Maximum wrapper compatibility is enabled. Some features have been disabled to be compatible with poorly written server wrappers.
    12:39 AM [INFO] CommandBook: Time locked to '13:00 (1:00 pm)' for world 'World One'
    12:39 AM [INFO] CommandBook: 0 banned name(s) loaded.
    12:39 AM [INFO] CommandBook: 1 kit(s) loaded.
    12:39 AM [INFO] PermissionsBukkit v1.2 is now enabled
    12:39 AM [INFO] Reload complete.
    12:39 AM [INFO] The automatic update-Check only work every 6 hours, the last check was 5 minutes ago.
  31. Offline


    Try this version of motd

    Attached Files:

Share This Page