Inactive [ADMN/GEN/TP/INFO]motd 1.2 - Greeting, Teleport Request, Time Vote, IP, WhoList [2126] superPerms

Discussion in 'Inactive/Unsupported Plugins' started by zweizeichen, Mar 13, 2011.

  1. Offline


    Latest Version: v1.2 (Bukkit 1.2.4)
    Please use BukkitDev for bug reporting and support!


    motd is a lightweight MOTD and basic command plugin for your minecraft server.
    There are lots of 'basic commands' plugins around here, but most of them have lots of features you will never need - or they do not allow you to deactivate them easily. They often cause lag and make configuring your server a pain in the *** because there is no documentation.

    With motd I made a simple, yet powerful plugin for creating advanced, custom colored and formatted MOTDs, who lists and rules. If you do not have the time to always be around on your server, rtp and vtime can help you. Even if you decide to install permissions on your server, motd is ready for that change.

    Here's a small overview of what you can do with motd:

    Customizable MOTD (text and color)
    You can enable/disable each command by editing a config file

    • who
    • rtp [playername / yes]
    • vtime [dawn / day / evening / night]
    • ip
    • motd
    • rules
    The plugin provides several features for your minecraft server. The first one you will notice, is whenever a player joins the game he will be greeted and shown other online players.

    To bring up the online players list again type:

    To bring up the MOTD again type:

    To bring up the rules type:



    The plugin is generally designed for servers where an admin is not online all the time. Therefore I have implemented the following two commands:

    vtime is a time vote system. Everyone can start a vote to change the time. You can vote for dawn, day, evening and night. To vote for a time change just use the argument yes. If not at least half of the online players voted yes within 60 seconds, the vote expires.

    rtp creates a teleport request to another player. The other player has to type in /rtp yes to teleport the player. There can only be one request to one player at a time.


    ip shows the ip of the player using the command.

    Please read the manual for further information on using and configuring motd.

    Permissions Nodes

    • motd.ip.use
    • motd.who.use
    • motd.rtp.yes
    • motd.rtp.request
    • motd.vtime.use
    • motd.rules.use
    • motd.motd.use
    • motd.edit
    • motd.reload
    • note that motd.rtp.request includes motd.rtp.yes

    Version 1.1.1
    • FIXED: /vtime now displays the correct name of the world
    • FIXED: some Permissions related stuff in /motd
    Version 1.1
    • REWROTE: Entire command, permission and config handling
    • ADDED: Permission's prefixes to <who>
    • ADDED: Modular command system
    • ADDED: Internal task management for vtime
    • IMPROVED: Multiworld support in vtime
    • FIXED: Some problems with names in /rtp and /vtime
    • CHANGED: Node motd.rtp.use is now split into
      • motd.rtp.yes
      • motd.rtp.request
      • Important: request includes yes
    • Some minor changes I cannot remember (spelling...)
    Older Changelogs (open)

    Version 1.0

    • ADDED: Permissions support
      • Nodes
        • motd.ip.use
        • motd.who.use
        • motd.rtp.use
        • motd.vtime.use
        • motd.rules.use
        • motd.motd.use
        • motd.edit
        • motd.reload
    • ADDED: /rules command
    • ADDED: changeable /who text
    • ADDED: /motd reload command
    • ADDED: /motd edit %property% %value% command
    • ADDED: config now migrates itself from 0.5.3 to 1.0
    • ADDED: build 733 compatibility
    • MOVED: Motd/motd.yml to motd/motd.yml
    • CHANGED: some minor changes in the config. They should be self-explaining
    • Please read the manual first if you have questions
    Version 0.5.3

    • The plugin is compatible with 609 / 1.4 now
    • CHANGED: /who command and <who> now displays the calling player too, for consistency with <numplayers>
    • ADDED: <ae>, <ue> and <oe> for the umlaute ä, ü and ö
    • MOVED: The config is now located in plugins/Motd
    • CHANGED: Default motd to match the change in <who>
    Version 0.5.2

    • ADDED: <numplayers> and <maxplayers> placeholders in MOTD
    • CHANGED: placeholders are now written in <brackets> for better readability
        • '%red' changes to '<red>' for example
    • CHANGED: %p is <playername> now
    • CHANGED: %w is <who> now
    • UPDATED: config to version 2
    Version 0.5.1

    • ADDED: /motd command to bring up the motd again
    • ADDED: some kind of config file version management
    Version 0.5

    • FIXED: Handling of offline players in /rtp
    • UPDATED: Internal teleport function for future versions of craftbukkit
    • ADDED: Use %n for a new line in the MOTD
    • IMPROVED: Internal color handling
    Version 0.1b

    • ADDED: colors for the MOTD are now available. Please see the manual for further instructions on using them.
    Version 0.1a

    • FIXED: /who no longer shows "nobody!" as other player
    • ADDED: motd.yml (will be created at first launch)
    • ADDED: Changeable MOTD (use %p for playername and %w for the player online list)
    • ADDED: use true or false in the motd.yml to enable or disable the different commands
    Version 0.1

    • release

    Planned Features
    • different MOTDs for different groups
    • multiple MOTDs
    • broadcast messages
    • more placeholders
    • pm command
    • localization
    Have fun and good luck,

    EarlyLegend and Pinkpixels like this.
  2. Offline


  3. Offline


    Your link is dead D:
  4. Offline


    The mirror still works. I'm going to get a new webserver soon... stay tuned!
  5. Offline


  6. Offline


    I would like to add that feature but permissions' API is... not very well documented at the moment.
    So this could take a while.
  7. Offline


    The /rtp bugs in my server Permissions are on false i dont use permissions but sometimes when i /rtp a friend it says
    " An internal error occured while attempting to perform this command." help please..
  8. Offline


    Same problem here, /rtp fails since the new craftbukkit builds supporting 1.6.x :/
  9. Offline


    Could you please post your serverlog?
    Whenever an 'internal server error' occurs, bukkit writes a more detailed description of the error to the log. Try to find the corresponding message and post it here.
  10. Offline


    Here is my log. Me (ahweb) attempting to teleport via /rtp to Gronaze.
    The error appears when he does /rtp yes.

    09:10:57 [INFO] Ahweb [/] logged in with entity id 5560 at (-484.69451961757176, 70.0, 856.4431865534796)
    09:10:57 [INFO] SimpleSave: Current save interval is 10 minute(s)
    09:10:57 [INFO] SimpleSave: Current backup interval is 60 minute(s)
    09:11:01 [INFO] SimpleSave: Deleting old backups
    09:11:01 [INFO] [SimpleSave] Ending world backup
    09:12:42 [INFO] Gronaze [/] logged in with entity id 6559 at (-50.96577567816554, 67.0, 499.3735462881317)
    09:13:08 [INFO] [xAuth] Player 'Gronaze' has authenticated
    09:13:20 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'rtp' in plugin motd v1.0
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.NetServerHandler.handleCommand(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet3Chat.a(
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
            at org.zweizeichen.Motd.Motd.requestTeleport(
            at org.zweizeichen.Motd.Motd.onCommand(
            at org.bukkit.command.PluginCommand.execute(
            ... 12 more
  11. Offline


    That's strange... The plugin does not seem to be able to find one of the players.
    Which build of bukkit are you using? I tried it myself with 818 and everything worked perfectly.
    Does every teleport request fail?
  12. Offline


    Thanks for the answer !

    Yes, every player on my server tried it (we used it a lot before) and it always fails :/
    I use build 819 but since there are only 3 lines different from 818, I don't think that's the problem...
  13. Offline


    I am not able to reproduce the error.
    I even tried it with #847, but no 'success', which leads to the assumption that another plugin might cause those problems. Could everyone who is experiencing any similar problems post a list of the plugins they are using? Maybe we can track down the issue that way.
  14. Offline


    Hey mate, can you give me the permission nodes for these two commands.

    /rtp (name)


    /rtp yes

    they'll be motd.rtp.use.(something?)

    I need the seperate permission nodes, so i can give the /rtp command to specific players, while having /rtp yes for all players.

    The node you currently have pretty much only lets me either 'activate /rtp for all players', or 'disactivate it for all players'.

  15. Offline


    Thank you for your suggestion! I will implement that feature in the next version.
  16. Offline


    Can you add permissions group support for motd please?
    eg because im admin my messages appear like [Admin] username messgae
    i use ichat for this
    can you integrate this into motd and who?
  17. Offline


    This feature is will be included together with the color-fix for permissions.

    Luckily I had some time for coding today - motd 1.1_BETA is ready for testing!
    This update is mainly permissions-related.
    Changes include:
    • ADDED: Permission's group / player prefixes / colors to <who>
    • CHANGED: Node motd.rtp.use is now split into
      • motd.rtp.yes
      • motd.rtp.request
      • Important: request includes yes
    • Some minor changes I cannot remember (spelling...)
    Get it here

    Have fun and good luck,

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  18. Offline


    how would i show the groups?

    doesnt matter
    thanks for the update.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  19. Offline


    Well here are the plugins installed on my server :
    • craftscripts
    • SimpleSave
    • WorldEdit
    • dynmap
    • MCStats2
    • dynmap.jar
    • SphereWorld
    • xAuth
    • Essentials
    • motd
    • Essentials.jar
    • Stargate
    • HeroicDeath
    • PlgSetspawn
    If you need me to test some things, please tell me ;)
  20. Offline


    We have a problem
    To make my name not appear like Adminuser
    i put a space in my prefix so it appears like Admin user
    only problem is that because i now have iChat installed the chat looks like [Admin ] user message
    i tried changing the colour of the group but it just doent load permissions
    Any help / thoughts?

  21. Offline


    @Aweb: Thank you for posting your plugins this could help a lot!
    @JW97: Thank you for trying out the beta - I will simply add a space between the prefix/suffix and the playername...

    Good news Aweb! I found the error. It's Essentials messing around with the OP's playernames resulting in letting motd crash and messing up every color-formatting.

    The solution is quite simple:
    # A color code between 0-9 or a-f. Set to 'none' to disable.
    ops-name-color: 'none'
    btw: Essentials also breaks many other plugins... Maybe you can find an alternative solution for your server.

    I also made motd 1.1_BETA2 fixing JW97's bug - it should put a space into the string automatically if you have a prefix.

    Have fun and good luck,

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 12, 2016
  22. Offline


    Thanks a lot ! I'm gonna try this at once ;)
    Again, thanks for the quick and good communication ;)
  23. There is a conflit with EasyRules. With motd config to rules_enabled: false it says i dont have perm to use /rules. but /rules is what easyRules command is.. Thoughts?
  24. Offline


    This version of motd_BETA2 does not have the /rules command registered in the plugin.yml. That should solve you issue.
  25. Perfect Thanks!!
  26. Offline


    Thanks a TON! :D
  27. Offline


    The problem with /rtp was indeed fixed. Thanks a lot !
  28. Offline


    For some reason my builders cant do /rtp even though i think i have added the permission nodes.
  29. Offline


    After updating to 860, I can't get the MOTD to work anymore - it just says internal error. However, everything else works.

    Suggestions anyone?
  30. Offline


    Which version of MOTD is running on your server?
    If you use the 1.1_BETA2, the nodes are:

    If you use an older version, then there is only one node:

    Post your log please, so we can solve this problem.
  31. Offline


    Anyway you can support iconomy with this? You don't have too. Just would like to charge people for casting a vote for time or for a tp.

Share This Page