[ADMN/GEN]AdminCmd 7.3.5-time, give, tp, repair,kill, warp,weather,afk,OpenInv [1.5.1]

Discussion in 'Archived: Plugin Releases' started by Dark_Balor, Apr 1, 2011.

  1. Offline


    AdminCmd - Fork of PlgEssentials:
    [​IMG] Website : www.admincmd.com
    [​IMG] Wiki : http://wiki.admincmd.com
    [​IMG] BugTracker : http://bug.admincmd.com
    [​IMG] Downloads : HERE
    [​IMG] GitHub : http://github.com/Belphemur/AdminCmd

    AdminCMD is a powerful plug-in that brings you commands that can give you total management over your server. Featuring the most widely used commands in Bukkit server management such as: inventory management, banishment of bad players, limitation to teleporting, setting spawn and home way points, and much, much more! Blockface approved and rated as one of the best plug-in by server owners.
    Unleash the power of Bukkit!

    For the blog : www.admincmd.com
  2. Offline


    Where do i check it? I don't remember the version

    Nvm, ty i fixed it

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  3. Look for the following line in your Serverconsole:
    16:55:38 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-980-
    g4ed23b1-b1060jnks (MC: 1.7.3)

    The number at the end (b1060jnks) is what you are looking for.

    Oh, ok ....
  4. In the dev version the old homes are not work
  5. Offline


  6. can you please upload the new dev version ?
  7. Offline


    17:23:58 [SEVERE] [AdminCmd] The command bal_timeday throw an Exception please r
    eport the log to this thread : http://forums.bukkit.org/threads/admincmd.10770
    17:23:58 [SEVERE] java.util.ConcurrentModificationException
    17:23:58 [SEVERE]       at java.util.ArrayList$Itr.checkForComodification(Unknow
    n Source)
    17:23:58 [SEVERE]       at java.util.ArrayList$Itr.next(Unknown Source)
    17:23:58 [SEVERE]       at org.bukkit.craftbukkit.CraftWorld.getPlayers(CraftWor
    17:23:58 [SEVERE]       at org.bukkit.craftbukkit.CraftWorld.setFullTime(CraftWo
    17:23:58 [SEVERE]       at org.bukkit.craftbukkit.CraftWorld.setTime(CraftWorld.
    17:23:58 [SEVERE]       at be.Balor.Tools.Utils.setTime(Utils.java:302)
    17:23:58 [SEVERE]       at be.Balor.Tools.Utils.timeSet(Utils.java:312)
    17:23:58 [SEVERE]       at be.Balor.Manager.Commands.Time.Day.execute(Day.java:4
    17:23:58 [SEVERE]       at be.Balor.Manager.ACCommandContainer.execute(ACCommand
    17:23:58 [SEVERE]       at be.Balor.Manager.CommandManager$ExecutorThread.run(Co
    Craftbukkit: 1060
  8. Offline


    I've gotten this and a couple others like it.

    @Dark_Balor: Is there a way in Admincmd (or perhaps you could add this) where you could add a permission node which prevents a certain group from having anything in their inventory or holding anything? i.e. admincmd.player.noinventory.
  9. Offline


    @Ritsbits && @nemesis91 : This exception should be corrected in last dev version that I just uploaded.

    @nemesis91 : You mean some kind of no_pickup activated by default for the player having the node ? avoid him to pick any item on the map and then to have anything else that what he have in his inventory (or what you give him with /i command)
    Ritsbits likes this.
  10. Offline


    A little suggest, use permissions for to set the homes limit per group (admincmd.tp.home.setlimit.X, X=a number). And if is it possible, display who is online with /list...
  11. Offline


    1) Already the case, didn't you read the second post ? in the first post I put a link with : More Explanations about the Configuration File, HomeLimit, Color, Permissions, Changelog, Folders and Files HERE
    You have 3 way to set it depending of with Permission Plugin you are using.

    2) You have /plist and /who, later you'll can set your own alias but /list is already used for a server command (in the dev version).
  12. Offline


    Oh, sorry...
    Ok, I'll simply to disable /list in bukkit.yml and make an alias with a plugin (like rTrigger).
    Edit :
    Sometimes, I'm really stupid... In bukkit.yml, aliases, "list: [plist]". :oops:
  13. Offline


    @Dark_Balor: Precisely. Don't allow him to have anything. Can't pickup stuff from the ground, can't be given anything via /i either.
  14. Offline


    Hmmm would it be possible to integrate a /help command???
  15. Offline


    /help command is right now on testing phase :)
    You can try the dev version if you want it.
  16. Offline


    =D thanks!

    What would the permission be to /help ??

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  17. Offline


  18. Offline


    I know this is a simple fix, and i'm clearly over looking something.

    Anyone else have this error?

  19. Offline


    it tells you right there, you don't have permission, if you don't have permissions, (bukkit permissions, or other) installed, you have to be an op.
  20. Offline


    do you realize you spelled Gliding as Glinding
  21. Offline


    Both Download links are currently broken.
  22. Offline


    I was curious if there is anyone else having problems where if people teleport /home they occasionally die, is it a known bug or should i use a plugin like exactspawn to fix it?
  23. Before I used to get the 'You don't have the permission blahblah (perm node)' when I tried an AdminCmd I had no permission for, now it just repeats the syntax for it back at me instead of saying I dont have permission, any idea what I've broken?
  24. Offline


    @marvinej : Corrected in dev version ... my finger slipped when I typed that configuration parameter --''
    @Asaky : I'll change later from bukkit to another hoster.
    @Silicon : What do you mean by die ? are you tp "in the ground" ?
    @ghowden : Did you change something in the config file ? did you installed a Permissions plugin ?
  25. Only MOTD and log private messages, I'm using PEX
  26. Offline


    @ghowden : For the MOTD, you must change it in the locale file not in the config. The config is only for true/false.

    Log private messages ? you are using the dev version ? if yes, download the last ^^
  27. Yeah tried with the normal, then downloaded the dev to see if it worked there, gonna delete all of it and redownload it without changing anything see if it works

    Without changing anything from the stock download it does the same, for example typing /mob Creeper 3 gives the syntax back instead of saying no permission and for people with permission it just works as it should :s

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  28. Offline


    delete the folder locales. Check in the config if you haven't set noMessage to true.
  29. noMessage is set to false and the locales folder just regenerated, still the same
  30. Offline


    Is there anything in the server.log ?
    can I see the config file ?

    edit : Did you restart the server after updating AdminCmd, sometime (like going into a major version) it's better to restart than reload.
  31. Nothing in the log, I deleted AdminCmd.jar and the AdminCmd folder then stopped the server, downloaded the .jar again and then started the server up
    DefaultVulcanPower: 4.0
    mutedPlayerCantPm: false
    maxHomeByUser: 0
    autoAfk: true
    locale: en_US
    forceOfficialBukkitPerm: false
    disabledCommands: []
    firstConnectionToSpawnPoint: false
    resetPowerWhenTpAnotherWorld: true
    glideWhenFallingInFlyMode: true
        newYvelocity: -0.5
        YvelocityCheckToGlide: -0.2
        multiplicator: 0.1
    maxRangeForTpAtSee: 400
    autoKickAfkPlayer: false
    - reload
    MessageOfTheDay: false
    verboseLog: true
    DefaultFlyPower: 1.75
    DefaultFireBallPower: 1.0
    afkKickInMinutes: 3
    noMessage: false
    invisibleRangeInBlock: 320
    tpRequestTimeOutInMinutes: 5
    ColoredSign: true
    fakeQuitWhenInvisible: true
    afkTimeInSecond: 60
    statutCheckInSec: 20

Share This Page