Inactive [ADMN/FUN] SpawnMob - Advanced mob spawning.[1.2.5 and up]

Discussion in 'Inactive/Unsupported Plugins' started by jordanneil23, Feb 25, 2011.

  1. Offline

    jordanneil23

    [​IMG]
    MOVED TO BUKKIT DEV!
    ------------------------------------------------------------------------------------------------------
    THIS IS NO LONGER WATCHED, IT WILL BE RARE TO GET A REPLY FROM ME ON THIS POST GO TO THE BUKKIT DEV PAGE TO GET HELP
    ------------------------------------------------------------------------------------------------------
    This is a continuation of SpawnMob which was originally made/developed by xmlns.​
    ------------------------------------------------------------------------------------------------------
    Downloads
    Zip

    -​
    [​IMG]
    -​
    ------------------------------------------------------------------------------------------------------
    Twitter/Donations
    -
    [​IMG]
    -
    Follow SpawnMob on twitter for details on when updates will be released.
    -
    I'm not asking for a donation but if you like the plugin and feel generous click the donate button :)
    [​IMG]
    ------------------------------------------------------------------------------------------------------
    Commands and Features

    On the Wiki
    ------------------------------------------------------------------------------------------------------


    Mob List
    On the Wiki
    ------------------------------------------------------------------------------------------------------

    Mob Kits
    On the Wiki
    ------------------------------------------------------------------------------------------------------
    Permissions
    On the Wiki
    ------------------------------------------------------------------------------------------------------
    Known Bug(s)
    On the Wiki
     
  2. Offline

    TheChrisHill

    for some reason when i spawn a mob, it'll flash, and then go away. I'm using the newest craftbukkit
     
  3. Offline

    darkcammo

    you probably have monsters turned off in your server config bro


    Glad to see you have a new home :) yeah that whole post within a post thing was a tad confusing. It'll be nice to just bookmark this thread.
     
  4. Hi, I believe it still doesn't work with Permissions 2.1, however I cannot verify this as the download link for it is down... I am using a mirror someone put up, so I'm not sure, but I think it is 2.1.
     
  5. Offline

    jordanneil23

    Give me the download link to that and I will rebuild the plugin with it for you :)
     
  6. Hi, it appears Nijikokun updated her links. I downloaded that, then downloaded your 1.5.8 version, however it is still saying I cannot spawn this type of mob. I am an OP, as well as having all permissions ( '*' ).
    I'm looking at your links... I have downloaded the jar only file, however it looks like your zip file is still at 1.5.7... did you update the links?
     
    Bengu likes this.
  7. Offline

    maxw3ll

    i have the same problem as thechrishill, when i spawn a monster they dissapear. but when i spawn an animal like a cow or chicken they dont dissapear.. using build 440
     
  8. Offline

    jordanneil23

    Looks like have messed up somewhere. Fixing now.
     
  9. Ah, I see that I am wrong, I'll edit my post anyways... and thanks again for picking up this project, I don't believe there is any other plugin that does this, at least of right now.
    Update: Hi, sorry to bother you again, but it is still not working, I've tried downloading the jar only and the zip, still saying I cannot spawn this type of mob... [​IMG]
     
  10. Offline

    jordanneil23

    Its is not able to work with Permissions 2.1 as I built it on Permissions 2.2 that is developed by @TheYeti I will have to re-build it on Permissions 2.1 for it to work with that and Permissions 2.2 is now 2.4. This sounds a bit confusing doesn't it? :confused:

    ALSO in the future this will only support TheYeti's Permissions :)

    Actually can you please just download TheYeti's Permissions and tell me if it works pretty, pretty please :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 10, 2016
  11. ... I really don't want to go to TheYeti's Permissions, and I believe Nijikokun is keeping the Permissions plugin updated, despite the fact she one time she was "taking off the coat" (I believe she's off break now). Also, I have other plugins, and they are working fine with Permissions 2.1
    Or, you could have it look at the ops.txt file if one does not have TheYeti's permissions installed, as I don't need specific permissions.
     
  12. Offline

    TheYeti

    I just checked it myself and it is working perfectly fine with me having a permissions node of *. Lets me spawn slimes and other mobs like mad.

    And PC Tech Guy, Niji is not keeping Permissions updated. From IRC:

    Code:
    [11:30] <@Nijikokun> I don't do permissions anymore
    [11:30] <@Nijikokun> TheYeti now does that
    [11:30] <@Nijikokun> :P
     
  13. Offline

    jordanneil23

    As long as Yeti's permissions still works with Niji's I will build this on Niji's permissions so people won't get mad...
     
  14. Ok...? I thought iConomy 3.0 has recently came out, though... I don't know if I'm wrong about that... but OK, I'll take your word for it... However, having ops able to use if the server does not have Permissions can help those who are less educated...
    Ok, I downloaded Permissions 2.4, since I was using 2.1 I only swapped the jar file. Still not working, everything else is, however
     
  15. Offline

    jordanneil23

    Redownload this now...
    As it works perfectly for me! ;)
     
  16. Offline

    cuzzaa

    This is fantastic! Can you spawn Giants?
     
  17. Ok, I do not know if you are using the development version or the recommended version of Craftbukkit, as it is still saying I cannot spawn this type of mob... [​IMG] I tried with Permissions 2.1 and 2.4, still no success...
     
  18. Offline

    TheYeti

    Ahhhh, that would be for jordanneil23 then. As that isn't a problem with Permissions and this plugin. It's a message from this plugin itself saying that you are trying to spawn something wrong.
     
  19. Well, as for me trying to spawn something wrong, I don't think so, I've tried Zombie, chicken, pig, cow, etc. but it says I can't spawn this type of mob. It will, however, when I try to spawn something like this: aklmvo, it will say invalid mob type. So I know I'm not doing it wrong, and it is a Permissions issue, however that doesn't mean that the Permissions plugin itself is wrong (all other plugins are working with both permissions), it could be how the plugin is built... It's just very frustrating.
     
  20. Offline

    Cerberus12

    Someone help me? I run it with bukkit server launch and says a bunch of things about java
     
  21. Offline

    gazius

    Does this fix the problem with the invincible pigs?
     
  22. No, this is because the client is simulating the pigs as well. Until Notch puts out an update that will prevent the client from spawning pigs on its own when in multiplayer, this will not solve the "invincible pigs."
    How do you think we could help you if you do not post any information? And if it is about Java in general, this is the wrong thread. Also, you should see this before posting again: http://forums.bukkit.org/threads/request-saying-its-broke-doesnt-help-solve-the-issue.839/

    jordanneil23, it's only working with Permissions 2.0 for me.
     
  23. Offline

    Cerberus12

  24. Looks like a bug with the Nether plugin interacting with Permissions 2.1. Post your problem there, and then the correct developer can investigate it. The developer probably has not added support for 2.1 yet.
    Oh, and Jordanneil23, I've been playing around with the plugins, and after remembering to test your plugin, it worked with 2.4. Must be a conflict with another plugin...
     
  25. Offline

    Cerberus12

    So i should take away the nether plugin? Im not sure cause im a noob at all of this D: i need a tutorial one day
    --- merged: Feb 27, 2011 6:17 PM ---
    I foudn the problem http://pastebin.com/7nQQPVHm, its because mobspawner is outdated i think but i dont know which version of bukkit i can use to make it compatable anyone willing to help?
     
  26. Offline

    jordanneil23

    I am now CORRECTLY adding support for Permissions 2.1, sorry for any troubles my stupidity has caused. :oops:
    --- merged: Feb 27, 2011 6:49 PM ---
    Also this is NOT compatible with the CraftBukkit version that took away PLAYER_COMMAND, it is built on CraftBukkit 450 (I forgot to change the post title)

    @Cerberus12 you will need to downgrade to CB 450 or lower for this to work, sorry.
     
  27. Offline

    Cerberus12

    Ah thank you very much if you can show me how to downgrade it would be most appreciated
     
  28. Offline

    jordanneil23

  29. Offline

    Cerberus12

  30. Offline

    jordanneil23

    You're welcome.

    PS. I did not fully make this plugin (Original Post), I am just continuing it and I have added allot of features to it like /spawnmob kill <all-animals-monsters> :)
     

Share This Page