[ADMN/FUN/MISC] MakeUse v1.1 - Make somebody use a command! [1240]

Discussion in 'Inactive/Unsupported Plugins' started by main(), Aug 18, 2011.

  1. MakeUse - Make somebody use a command!

    Version: v1.1

    At my server, we wanted a way to force somebody to read the rules. Well, by making him use /rules you don't really force him to actually read it, but I think it would help. Use it if you want. (This is not yet tested on the newest Bukkit-Build, but I think it should work. Would be nice if you could tell me if it does.)

    /makeuse <the user who should use the command> <the command (without the /)>

    When you run MakeUse the first time, it creates a config.yml with two lines: "onjoin" and "onnewuser". You can write commands that everybody should execute on join/on his first join (new user) there. The "onjoin"-Commands are NOT executed on a player's first join.
    If you just want to use the /makeuse-Command without this features: Just leave these lines at the defaults. MakeUse will recognize that and won't even register the events ==> It doesn't make the server slower!

    This plugin uses Permissions (It should work without it, then Ops get access to everything and non-ops to nothing).
    The permission-nodes depend on the command you want to make the player use. So I can give someone access to "/makeuse ... rules" but not to "/makeuse ... kill" by just allowing "makeuse.rules". (btw. I just discovered that it's actually impossible to make someone use /kill... why?)

    • Make somebody use a command!
    Download MakeUse
    Source Code

    (Note to the downloads at github: The "MakeUse.jar" is always the newest version while e.g. "MakeUse v1.0.jar" is and will always be version 1.0.)

    Version 1.1
    • Added the requested "onjoin"- and "onnewuser"-Feature
    • Now fixed!
    Version 1.0
    • Releasing my awesome plugin
    Tallcraft likes this.
  2. Offline


    this will really help! thanks!
  3. Offline


    Could you add the function that would make the server automatically have a user use a command on logging on? For example, it would make them use /spawn as the spawning system sucks when new people join.

    Also maybe an option for my last request that lets you change a config file line like "isNewUser = true/false" so that it only forces new users to use the command?
  4. Offline


  5. I'm currently not at home, but I think I'll make a "onnewuser"-line and a "onjoin"-line in a config file where you can write those commands. (I'm still about 1 Week away)
  6. MakeUse v1.1 is released. It has the requested feature.
  7. Offline

    Daniel Few

    Really like this plugin. Haven't seen one yet that does the same things and I love the idea of First Join and Log In options.
    Thanks for this,
  8. Offline


    It tells me that bukkit is sad and doesnt want me to use the command.
  9. More details?
    What exactly are you trying to do? What's the exact error message? etc.
  10. Offline


    Honest to death, this is what it says to both the client and the server.
  11. You know that you can't use /makeuse without any arguments?
  12. Offline


    To make a point, I can do /makeuse boyerz warp TsuiHome, /makeuse sunomeow kill lora, and /makeuse ZSlayer101 suicide, but it won't work. Otherwise, I wouldn't have spent 30 seconds replying.
  13. This is really strange...
    I've never experienced such a thing in my tests.
    So you have the permissions "makeuse.warp", "makeuse.kill" and "makeuse.suicide"?
    And what Permissions-plugin(s) do you use?

    EDIT: I just noticed that you were trying to use /makeuse from the server console. This is not yet possible. (coming soon!)
  14. Offline


    Nah, you have it all wrong. This is done in-client. I will edit this post when I am on Minecraft next. (I just woke up and I have to attend college. Check back in... oh, 8~10 hours from when I post this? Sorry...)

    P.S.: It's weird... "leaky." It's probably because of 1.8.1. I'd check that one while you're waiting for the evidence. Sorry to keep you waiting.
  15. Offline


    When I try /make use I get the Bukkit sad message too. I am op and I added myself permission makeuse.*.

    Even when I try makeuse from console do I get this:

    The idea of the plugin is awesome! It would just be nice if it would work. :s


  16. I finally managed to reproduce that bug and I'm now trying to fix it. Something must have changed with the newest RB.
  17. Offline


    A new RB came out. I'm gonna test it out and I will definitely post if that may have fixed the issue. Check back in around an hour.


  18. Thanks, but you've misunderstood me: I didn't want to say that it was the RB's fault, I think they've changed something and MakeUse needs to be changed for it to work.
  19. Fixed.
    It's still version 1.1 because the original 1.1 never worked.
  20. Offline


    I can get the console issue a command after a player triggers something, the only problem is that I would need the console to "make the player use the command". Let's say I want the player to get teleported somewhere after a quest,
    I would set the end quest command to : /warp <place>
    Problem is, when the console issues that command, it doesnt know who to warp because /warp is supposed to be used by a player in-game. Also, I can make the player issue the command without plugins after the quest but regular builders don't have permission to /warp. What I'm trying to say is that, your plugin looks great but could you make the /makeuse command bypass permissions? Maybe a flag that says, no matter what command I make him do, he will have temporary (or something like that) permission to use it. Then, I could just give myself and the admins the /makeuse command. ty I hope you understand!
  21. Hm, that sounds a bit difficult, but if Player.addAttachment() does what I think it does, this might be easily solved. Would only work if you use SuperPerms, however.
  22. Offline


    I'm happy you've answered, I do use superperms so if you could keep me up to date on this I would greatly appreciate it :) thank you for reading my previous post cause it's enormous lol.
    also, to be clear about my goal... I need to make players issue commands as if they had all permissions. So, let's say they dont have the /rules perm, and I want them to see the rules when they enter or something, I would like the capability of forcing a player to do so reguardless of their current rank or permission nodes. obviously in this case I couldnt just issue the command from the console because the console doesnt know who needs to see the rules. In other words, it's a self-oriented command, SOC. ( I kinda like my new term ^^)

  23. Offline

    Taylor Bindon

    perfect for when my mods are out of line :p
  24. Offline


    Awesome Plugin! Please add timers :)! What i mean by this is in the config file, you could set a delay, like 2 minutes and the command to use at that delay. I would use this to automatically save data on my server. I have a plugin called citizens, and it lets you create NPCs. To save your npcs you have to use the command /citizens save. This is annoying for me to remember. If you also added permissions support for this, for example if only the group admin used this /citizens save timer, I would use this plugin on every server :D
  25. Offline


    This is an essential plugin on my server. Thanks for creating it!
    I hope you'll keep this updated, especially now that CB 1.1-R5 is supposedly going to change a lot and require many plugins to be updated.
  26. *sigh* I think I should update it, shouldn't I?
    M1KE_N_IK3, Djumen and Oscarius like this.
  27. Offline


    Would be awesome, especially since it breaks with the 1.2 builds:

    2012-03-02 11:44:45 [SEVERE] Error occurred while enabling MakeUse v1.1 (Is it up to date?)
    java.lang.NoClassDefFoundError: org/bukkit/event/player/PlayerListener
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:791)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
        at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:234)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:37)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
        at me.main__.MakeUse.MakeUse.onEnable(MakeUse.java:95)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:215)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:336)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:363)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:250)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:232)
        at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:369)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:356)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:187)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:420)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:490)
    Caused by: java.lang.ClassNotFoundException: org.bukkit.event.player.PlayerListener
        at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
        ... 26 more
  28. Offline


    Please update! This would help our server so much.
  29. Offline


    Please update this useful plugin! :)

Share This Page