Inactive [ADMN/DEV] PermissionsEx (PEX) v1.19.5 - Tomorrow is Today! [1.4.6-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by t3hk0d3, May 21, 2011.

  1. Offline

    t3hk0d3

    [​IMG]
    Version: 1.19.5

    PLEASE USE BUKKIT-DEV FORUM FOR DISCUSSION/HELP
    http://dev.bukkit.org/server-mods/permissionsex/
    THANKS IN ADVANCE.

    PermissionsEx (PEX) is a new permissions plugin, based on Permissions ideas and supports all of its features. But PEX is more! It offers different backends, powerful ingame management, fine grained restrictions for world modification.

    [​IMG]

    Current features
    1. Bukkit Permissions (SuperPerms) compatible.
    2. Several backend support. Currently bundled backends is File (YAML) and SQL (MySQL, SQLite). Also it's possible to add your own.
    3. YAML backend, with new, fully rethinked, config schema. Now all user, groups and their permissions are stored in one file - permission.yml. BTW file name is adjustable too.
    4. SQL backend, most delicious. Currently MySQL and SQLite supported, but other DB (like Postgre) are possible too. PEX deploys the DB scheme (tables and initial data) automatically. This means, that you only need to provide data on how to connect to the db, everything else PEX will handle by itself.
    5. Flexible architecture and API - you can change a lot programmatically.
    6. Compatibility layer with TheYeti's Permissions (2.7.4) (as a separate part of the plugin). In most cases plugins, which use Permissions, will alsowork with PEX also.
    7. Rich chat/console command interface. You can do almost everything ingame. Command list below.
    8. Modifyworld - Embedded restrictions mechanism (we call it "modifyworld"), which provides the possibility to control players abilities, such as destroying/placing blocks, riding carts/boats or even getting spotted by mobs and much more. Disabled by default.
    9. Multigroup inheritance. User, as well as Group, can be member of several groups. And inherit their permissions, options and prefix/suffix.
    10. Permissions based upon Regular Expressions. This mean you can use regular expressions. Example: modifyworld.blocks.(destroy|place).(3|12) - this permission allow place or destroy only sand (12) or dirt (3) blocks. There is still limitation on dot usage in your regexps - dots are escaped by default.
    11. Multiworld permissions. Just don't specify world and permission would work in any world.
    12. Multiworld inheritance. You can inherit different groups in different worlds.
    13. Easy migration from Permissions 2.x. Converter for both YAML and SQL are embedded into PermissionsCompat. Just use simple instruction.
    14. Perfomance friendly. Low-level caching helps alot when you have 100+ online users :)
    15. Promotional/Demotional system. You can assign ranks to groups and promote/demote users to higher/lower ranked group.
    16. World-inheritance - permissions/option of one world can be inherited by another world.
    17. Timed Permissions - you can give user permission only for some amount of time.
    18. Chat Manager - small chat plugin, bundled with PEX. With prefixes/suffiex and colors. Check wiki for more details.


    Documentation
    Wiki

    Basic setup tutorial (Thanks to lycano)

    Nice tutorial made by Bennetman


    Download
    Stable version

    Development version (mostly stable) - always lastest dev build.

    Sources
    https://github.com/PEXPlugins

    Builds
    http://webbukkit.org:8080/

    Maven Repository
    http://repo.tehkode.ru/browse/ru.tehkode

    IRC
    Join us on #permissionsex, irc.esper.net. Feel free to ask any related questions.

    Tools !NEW!
    Pex Auto-Setup Tool - MySQL and FlatFile !


    Changelog
    Show Changelog (open)
    v1.19.5
    Proper intervals for timed commands (both group/permissions management), without pesky seconds calculations (like /pex user t3hk0d3 timed add cool.permission 10days)
    Bugfixes.
    1.4.6 compatibility.


    v1.19.4
    Built for Bukkit 1.4.2-R0.1
    Added inventory permissions (modifyworld.items.put/take.<item>.of.<chest>)
    Added item hold permission (modifyworld.items.hold.<item>)
    Sdded monster egg spawn permission (modifyworld.spawn.<creature>)
    Few other minor fixes
    v.1.19.3
    Modifyworld improvements (configurable messages, now independent from PEX)
    /pex help command
    Minor improvements and bugfixes
    v.1.19.2
    New modifyworld permissions
    Some bugfixes
    v.1.19.1
    Bugfix release
    v1.19
    Bukkit R6 compatible.
    Several bugfixes!
    Permissions now case-insensetive.
    v1.18
    Users logging and cleanup feature.
    Non-inheriting nodes feature.
    Several Bugfixes.
    PermissionsCompat is finally remove from default bundle.
    v1.17
    User/group specific management permissions (permissions.manage.group.Admin)
    Fixed some superperms compatibility issues
    Fixed several bugs
    v1.16
    SuperPerms compatbility bridge were rewritten - no lags anymore and now with debug output (now you can view superperms checks).
    Numerous of bugs were fixed (Thanks you guys for reporting them)
    Modifyworld were improved (modifyworld.item.use)
    v1.15
    Compatiblity for 1317+
    Fixed perfomance issues with SuperPerms (if you still experience they try to disable "raw-permissions" in config.yml)
    Fixed issue with prefix inheritance
    v1.14
    Improved Options mechanism.
    Auto saving new users feature, disabled by default.
    SuperPerms bridge improved - more permissions supported by wildcards.
    File backend dumping now fully functional. SQL dumping is still bogus (do not dump world-specific inheritance and prefixes), will be fixed soon.
    Many bugfixes and minor improvements.
    v1.13
    Superperms (BukkitPerms) support
    Multiworld inheritance and prefixes/suffixes
    Groups weighting
    ChatManager, chat plugin which bundled with PEX.
    Modifyworld now separate plugin, but still bundled with PEX.
    API changed slightly, CustomEvents (PermissionsEntityEvent, PermissionsSystemEvent) introduced.
    Many lesser improvements and tons of bugfixes.
    v1.12
    API get slightly improved
    Ranking ladders.
    User/group name case-insensetivity.
    World-inheritance.
    Timed permissions.
    Modifyworld rules are get improved.
    Tons of minor improvements and bugfixes.
    v1.11
    Many bugfixes and improvements.
    MySQL connection stability improved - reconnection mechanism.
    v1.10
    Promotional/Demotional system.
    Perfomance improvement, with new low-level caching system (thx Joy)
    Modifyworld improved.
    Many lesser improvements and bugfixes.
    v1.06
    New p2compat backend, for easy migration from Permissions 2.x to PEX.
    v1.05
    Users/Groups dumping (pex dump <backend> <file>).
    New commands pex promote/demote. Actually this is just aliases for "pex user group set/remove"
    Few bugfixes.
    v1.04
    Players now can be informed about changes (has been added to group, changed permission/option). Disabled by default - set "permissions.informplayers.changes" to "true"
    Config node "permissions.verbose", which responsible for player informing about modifyworld restrictions has been renamed to "permissions.infromplayers.modifyworld".
    Autocomplete has been improved.
    New command "pex config <node> [value]". This command help to manipulate configuration file (config.yml) from console/chat interface.
    Many bugfixes.
    v1.03
    Autocomplete for users (taken from registred users and online users) and groups names.
    New command for user removing (pex user <user> delete)
    Fixed several nasty bugs. Thanks for bugreports!
    v1.02
    Compatibility layer loading order issue fixed. Now most of plugins should work.
    Tested with new CB 803 build.
    v1.01
    Regular expression permissions support.
    Newer permissions now added above (bugfix).
    Several bugfixes.
    v1.00
    Initial public release.
     
    BRampersad, grid21, MrRazull and 71 others like this.
  2. Yes, seriously. I wouldn't suggest it if I wasn't serious (or at least have a winking smiley after it :))

    Why? I take it that strikes you as bad in some way?
     
  3. Offline

    Takel

    Are you using the PermissionsCompat bridge? (it's the permissions.jar file in the PEX zip)
    WorldEdit doesn't support SuperPerms based permission interfaces so you'll need to have the compatibility layer to get it to realise that PEX is there.
     
  4. Offline

    kyle772

    Question: Does this have the same format as bukkitpermissions? I was using bukkitpermissions until I found out that worldedit permissions nodes don't work with it. Would I be able to just copy/paste the bukkit permissions over to PEX?

    EDIT: it would be nice if I could get a quick reply I am in the middle of setting up a server atm
     
  5. No. The format PEX uses is closer to what the pluging Permissions 2/3 uses.

    Umm, do do realize that it's a weekend now and there isn't any dedicated support group for this plugin, right? :)
     
  6. Offline

    lipe123

    Thats for the old and dead permissions 3, did you read the wiki about multiworld permissions? By default all permissions you set up is global. If you dont want that you need to specify the world after the nodes, i'd suggest making your first world the one with all the permissions and then set - -'*' on your second world. So basically no one will have any permission there for a quick and dirty fix.
     
  7. Offline

    Vixolus

  8. Offline

    RogerWilco

    Hi, I've also posted this in the IRC channel, but apparently everyone is in bed, even though there are 40+ users logged in:

    Is there anyone who can help me with converting from permissions 3?
    I've tried following the guide "Migrate-from-Permissions" in the wiki
    putting groups.yml and users.yml in a single world.yml
    It now has created a permissions.yml, with the users and groups from my old permissions
    but I get lots of errors
    I think it's in the wrong format
    Code:
    06:51:32 [SEVERE] null; mapping values are not allowed here initializing PermissionsEx v1.14 (Is it up to date?)
    mapping values are not allowed here
     in "<reader>", line 106, column 14:
                group:
                     ^
    
    I think the advice on the wiki to move users.yml and groups.yml into one world.yml and then run the suggested commands might not be sufficient to migrate from Permissions 3.
    I think there are some syntax differences in the yml, but I'm stuck.

    I did follow the steps in the wiki.

    I would really like to use my old Permissions 3 config, instead of having to use the in game command to recreate everything.

    My permissions.yml looks somewhat like this (simplified):

    Code:
    users:
        User1:
            group:
            - Default
        User2:
            group:
            - Member
        User3:
            group:
            - Admin
        User4:
            group:
            - Default
            - Member
    
    groups:
        Default:
            permissions:
            - essentials.motd
            - essentials.rules
            options:
                prefix: ''
                build: 'true'
                suffix: ''
        Member:
            permissions:
            - lwc.protect
            - essentials.afk
            - essentials.helpop
            - essentials.msg
            - essentials.r
            - essentials.list
            - nSpleef.member.creategame
            - nSpleef.member.join
            - nSpleef.member.leave
            - nSpleef.member.list
            - nSpleef.member.deletegame
            inheritance:
            - Default
            options:
                prefix: ''
                build: 'true'
                suffix: ''
        Moderator:
            permissions:
            - lwc.mod
            - essentials.*
            - nSpleef.admin.*
            inheritance:
            - Member
            options:
                prefix: ''
                build: 'true'
                suffix: ''
        Admin:
            permissions:
            - '*'
            options:
                prefix: ''
                build: 'true'
                suffix: ''
    Is there anyone who knows where to find the syntax for either Permissions 2.7's world.yml, or PermissionsEx's permissions.yml?

    I currently can't use the ingame commands, I only get exceptions.
     
  9. I would suggest dropping your permissions entries into the online YAML parser at https://yaml-online-parser.appspot.com/ and use that to help figure out your formatting issue.

    I'm suggesting this method for the following reasons:
    1. You didn't post your actual permissions config
    2. The simplified one you posted passes validation, so there is no way for anyone to make any helpful suggestions.
    I'm not trying to be a jerk, really I'm not, this is the only way I can think of right now that might help you with the limited amount of info you provided.
     
  10. Offline

    slimpyman

    is there a way to pull every permission node from the plugins into a txt file? or do i have to fetch all the permission nodes myself from all these wiki and dev pages

    is it possible to have a feature where we can toggle with /globalchat or /localchat and that will be the default chat? it seems most people are not a fan of the ! for global.... i love this chat plugin cause of the minimalistic feel

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 9, 2018
  11. Offline

    NicoHood

    Hi,
    I just have the plugin LWC and your 4 fromn the package. But if is start the Server I have this error so the Plugin dont work.
    I use the stable version. Maybe I can try the def version...


    2011-09-24 09:15:48 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1067-g6301507-b1185jnks (MC: 1.8.1)
    2011-09-24 09:15:48 [INFO] [PermissionsEx] sql backend registered!
    2011-09-24 09:15:48 [INFO] [PermissionsEx] file backend registered!
    2011-09-24 09:15:48 [INFO] [PermissionsEx] PermissionEx plugin initialized.
    2011-09-24 09:15:48 [INFO] [PermissionsEx] p2compat backend registered!
    2011-09-24 09:15:48 [INFO] [PermissionsCompat] Compatibility Layer Initalized!
    2011-09-24 09:15:49 [INFO] LWC: Loading shared objects
    2011-09-24 09:15:49 [INFO] LWC: Protection cache: 0/10000
    2011-09-24 09:15:49 [INFO] LWC: Native library: plugins/LWC/lib/native/Linux/amd64/libsqlitejdbc.so
    2011-09-24 09:15:49 [INFO] [PermissionsEx] Initializing file backend
    2011-09-24 09:15:49 [SEVERE] while scanning for the next token; found character '\t' that cannot start any token initializing PermissionsEx v1.14 (Is it up to date?)
    while scanning for the next token
    found character '\t' that cannot start any token
    in "", line 6, column 1:

    ^

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:360)
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
    at org.yaml.snakeyaml.parser.ParserImpl$ParseIndentlessSequenceEntry.produce(ParserImpl.java:536)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.java:203)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:158)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at ru.tehkode.permissions.config.Configuration.load(Configuration.java:65)
    at ru.tehkode.permissions.backends.FileBackend.initialize(FileBackend.java:104)
    at ru.tehkode.permissions.PermissionManager.setBackend(PermissionManager.java:420)
    at ru.tehkode.permissions.PermissionManager.initBackend(PermissionManager.java:471)
    at ru.tehkode.permissions.PermissionManager.(PermissionManager.java:53)
    at ru.tehkode.permissions.bukkit.PermissionsEx.onLoad(PermissionsEx.java:73)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:141)
    at org.bukkit.craftbukkit.CraftServer.(CraftServer.java:103)
    at net.minecraft.server.ServerConfigurationManager.(ServerConfigurationManager.java:52)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:136)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-09-24 09:15:49 [WARNING] [PermissionsCompat] PermissionsEx plugin not found. Some plugins may not work.
     
  12. Offline

    gsand

    You have a yaml error. Only you can fix it.
     
  13. Offline

    NicoHood

    Ok, I found it.

    Now I followed the instruktion from the Wiki, but I still have no permission. I am in group admin, with * permissons, i am op but i have no permissions do set a new group without the command line. ingame i cant set this.

    I dont know what dto do...
     
  14. Offline

    xenogray

    Help please ^^"
     
  15. Offline

    cind3r69


    I wrote an inteligent response, but unfortunately it was meant for someone else. my bad. Another, try the commands in the console. you should be able to use the pex commands from there.
     
  16. Offline

    NicoHood

    I found a bug:
    After i typed in the console:
    pex user YourPlayerName group set Admins

    i was in the group "Admins." but the "." you must remove. So that was the problem.

    also the "*" doesnt work:
    - '*.'

    I dont know how to set all permissions for me. Which are the permissions for pex?
    - pex.* doesnt work...
    /help command from bukkit also doesnt work

    It is a bit bugy...
     
  17. Offline

    Jahmaican

    It's the most stupid compatibility problem I've ever heard of, but simply adding permissions.jar to my plugins solved the problem... thanks a lot!
     
  18. Offline

    Jäsef

    use - '*' not with a dot ;)
     
  19. Offline

    Pixiio

     
  20. Offline

    nerenther

    Hi
    I have a small problem: only ops can place or destroy blocks, and I can't see why. Can anyone help?
    My permissions file looks like this:
    Code:
    groups:
        default:
            default: true
            permissions:
            options:
                rank: '1000'
        God:
            permissions:
            - '*'
            options:
                rank: '0'
            prefix: '&0(&4is God&0)&7'
        Peasant:
            permissions:
            - dc.who
            - dc.help
            - dc.do
            - dc.join.self
            - dc.sethome.self
            - dc.home.self
            - dc.spawn.self
            options:
                rank: '900'
        OP:
            options:
                rank: '800'
    users:
        nerenther:
            group:
            - God
        trygve_e:
            group:
            - Peasant
        larzan:
            group:
            -  OP
        snostorm2002:
            group:
            - Peasant
    
    
     
  21. Offline

    briankdk

    What strikes me is that it makes no scence to read i from bottom and up..... it would make more cense if i was from top to bottom.
     
  22. Offline

    FreeZed2

    Its possible to set peoples can use one time commands or have time limit?
    And if yes then how ?
     
  23. Offline

    briankdk


    It seems other also thinks its weird

    "Please read this if you are using PermissionsEx
    PermissionsEx loads nodes in a very screwed up manner. You need to put any wildcards AFTER their negations. So if you want to allow access to all networks except 'Bah' you would do it as such:

    Code:
    - -stargate.network.Bah - stargate.network.*
    This is a PermissionsEx issue, and there is nothing I can do to make it easier to use negations."

    Taken from:

    http://forums.bukkit.org/threads/tp-stargate-v0-6-9-the-bukkit-port-a-portal-plugin-1185.3927/
     
  24. Offline

    kyle772

    Sadface D; Do you know how I could get worldedit to work with bukkitpermissions?

    Sorry I saw a bunch of the same people replying and I figured you were the support group ;P
     
  25. Offline

    Donny

    What do each of these settings in the config do?
    matched permissions? raw permissions? disable-unmatched?

    superperms:
    disable-unmatched: false
    enable: true
    matched-permissions: true
    raw-permissions: true
    debug: false
    allowOps: true
    debug: false
    createUserRecords: false
     
  26. Offline

    SuBByDew

    I have a new server and i am using MySQL, i have essentials for all the commands but i am having trouble getting it to work with essentials. does PEX actually support essentials properly?
     
  27. Offline

    Vaupell

    I have switched to this from the old perm 3.x
    but im having problems it seems the server is Ignoring PermissionEX
    setting i have set default group build to false..

    but default can still build / mine.. :(
    groups:
    Default:
    default: true
    info:
    prefix: '&8'
    suffix: ''
    build: false

    I want to enforce that default cannot build
     
  28. Offline

    Zaonhort

    I love Chat Manager. But to me it would be nice to add two new variables. 1. Group name like %group and 2. %displayname for plugins that can change your name in game, like /nick in essentials or towny.
     
  29. Offline

    briankdk

    read the answers i got a few days ago (i had the same problem)

    Here:

    ***********************************************************


     
    Vaupell likes this.
  30. Offline

    jullianluna

    I was running around #1145 then saw that craftbukkit finally had a recommended build so put that in. After upgrading to #1185 I now get the following error when starting my server. After starting it still seems to operate ok, but I don't like having a startup error.

    [SEVERE] Error occurred while enabling PermissionsEx v1.14 (Is it up to date?): org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
    java.lang.NoSuchMethodError: org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
    at ru.tehkode.permissions.bukkit.BukkitPermissions.collectPermissions(BukkitPermissions.java:107)
    at ru.tehkode.permissions.bukkit.BukkitPermissions.<init>(BukkitPermissions.java:75)
    at ru.tehkode.permissions.bukkit.PermissionsEx.onEnable(PermissionsEx.java:103)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:920)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:173)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:156)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
     
  31. Offline

    briankdk

    d

    Download stable version again....that worked for me yesterday
     

Share This Page