Inactive [ADMN/DEV] PermissionsEx (PEX) v1.19.5 - Tomorrow is Today! [1.4.6-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by t3hk0d3, May 21, 2011.

  1. Offline

    t3hk0d3

    [​IMG]
    Version: 1.19.5

    PLEASE USE BUKKIT-DEV FORUM FOR DISCUSSION/HELP
    http://dev.bukkit.org/server-mods/permissionsex/
    THANKS IN ADVANCE.

    PermissionsEx (PEX) is a new permissions plugin, based on Permissions ideas and supports all of its features. But PEX is more! It offers different backends, powerful ingame management, fine grained restrictions for world modification.

    [​IMG]

    Current features
    1. Bukkit Permissions (SuperPerms) compatible.
    2. Several backend support. Currently bundled backends is File (YAML) and SQL (MySQL, SQLite). Also it's possible to add your own.
    3. YAML backend, with new, fully rethinked, config schema. Now all user, groups and their permissions are stored in one file - permission.yml. BTW file name is adjustable too.
    4. SQL backend, most delicious. Currently MySQL and SQLite supported, but other DB (like Postgre) are possible too. PEX deploys the DB scheme (tables and initial data) automatically. This means, that you only need to provide data on how to connect to the db, everything else PEX will handle by itself.
    5. Flexible architecture and API - you can change a lot programmatically.
    6. Compatibility layer with TheYeti's Permissions (2.7.4) (as a separate part of the plugin). In most cases plugins, which use Permissions, will alsowork with PEX also.
    7. Rich chat/console command interface. You can do almost everything ingame. Command list below.
    8. Modifyworld - Embedded restrictions mechanism (we call it "modifyworld"), which provides the possibility to control players abilities, such as destroying/placing blocks, riding carts/boats or even getting spotted by mobs and much more. Disabled by default.
    9. Multigroup inheritance. User, as well as Group, can be member of several groups. And inherit their permissions, options and prefix/suffix.
    10. Permissions based upon Regular Expressions. This mean you can use regular expressions. Example: modifyworld.blocks.(destroy|place).(3|12) - this permission allow place or destroy only sand (12) or dirt (3) blocks. There is still limitation on dot usage in your regexps - dots are escaped by default.
    11. Multiworld permissions. Just don't specify world and permission would work in any world.
    12. Multiworld inheritance. You can inherit different groups in different worlds.
    13. Easy migration from Permissions 2.x. Converter for both YAML and SQL are embedded into PermissionsCompat. Just use simple instruction.
    14. Perfomance friendly. Low-level caching helps alot when you have 100+ online users :)
    15. Promotional/Demotional system. You can assign ranks to groups and promote/demote users to higher/lower ranked group.
    16. World-inheritance - permissions/option of one world can be inherited by another world.
    17. Timed Permissions - you can give user permission only for some amount of time.
    18. Chat Manager - small chat plugin, bundled with PEX. With prefixes/suffiex and colors. Check wiki for more details.


    Documentation
    Wiki

    Basic setup tutorial (Thanks to lycano)

    Nice tutorial made by Bennetman


    Download
    Stable version

    Development version (mostly stable) - always lastest dev build.

    Sources
    https://github.com/PEXPlugins

    Builds
    http://webbukkit.org:8080/

    Maven Repository
    http://repo.tehkode.ru/browse/ru.tehkode

    IRC
    Join us on #permissionsex, irc.esper.net. Feel free to ask any related questions.

    Tools !NEW!
    Pex Auto-Setup Tool - MySQL and FlatFile !


    Changelog
    Show Changelog (open)
    v1.19.5
    Proper intervals for timed commands (both group/permissions management), without pesky seconds calculations (like /pex user t3hk0d3 timed add cool.permission 10days)
    Bugfixes.
    1.4.6 compatibility.


    v1.19.4
    Built for Bukkit 1.4.2-R0.1
    Added inventory permissions (modifyworld.items.put/take.<item>.of.<chest>)
    Added item hold permission (modifyworld.items.hold.<item>)
    Sdded monster egg spawn permission (modifyworld.spawn.<creature>)
    Few other minor fixes
    v.1.19.3
    Modifyworld improvements (configurable messages, now independent from PEX)
    /pex help command
    Minor improvements and bugfixes
    v.1.19.2
    New modifyworld permissions
    Some bugfixes
    v.1.19.1
    Bugfix release
    v1.19
    Bukkit R6 compatible.
    Several bugfixes!
    Permissions now case-insensetive.
    v1.18
    Users logging and cleanup feature.
    Non-inheriting nodes feature.
    Several Bugfixes.
    PermissionsCompat is finally remove from default bundle.
    v1.17
    User/group specific management permissions (permissions.manage.group.Admin)
    Fixed some superperms compatibility issues
    Fixed several bugs
    v1.16
    SuperPerms compatbility bridge were rewritten - no lags anymore and now with debug output (now you can view superperms checks).
    Numerous of bugs were fixed (Thanks you guys for reporting them)
    Modifyworld were improved (modifyworld.item.use)
    v1.15
    Compatiblity for 1317+
    Fixed perfomance issues with SuperPerms (if you still experience they try to disable "raw-permissions" in config.yml)
    Fixed issue with prefix inheritance
    v1.14
    Improved Options mechanism.
    Auto saving new users feature, disabled by default.
    SuperPerms bridge improved - more permissions supported by wildcards.
    File backend dumping now fully functional. SQL dumping is still bogus (do not dump world-specific inheritance and prefixes), will be fixed soon.
    Many bugfixes and minor improvements.
    v1.13
    Superperms (BukkitPerms) support
    Multiworld inheritance and prefixes/suffixes
    Groups weighting
    ChatManager, chat plugin which bundled with PEX.
    Modifyworld now separate plugin, but still bundled with PEX.
    API changed slightly, CustomEvents (PermissionsEntityEvent, PermissionsSystemEvent) introduced.
    Many lesser improvements and tons of bugfixes.
    v1.12
    API get slightly improved
    Ranking ladders.
    User/group name case-insensetivity.
    World-inheritance.
    Timed permissions.
    Modifyworld rules are get improved.
    Tons of minor improvements and bugfixes.
    v1.11
    Many bugfixes and improvements.
    MySQL connection stability improved - reconnection mechanism.
    v1.10
    Promotional/Demotional system.
    Perfomance improvement, with new low-level caching system (thx Joy)
    Modifyworld improved.
    Many lesser improvements and bugfixes.
    v1.06
    New p2compat backend, for easy migration from Permissions 2.x to PEX.
    v1.05
    Users/Groups dumping (pex dump <backend> <file>).
    New commands pex promote/demote. Actually this is just aliases for "pex user group set/remove"
    Few bugfixes.
    v1.04
    Players now can be informed about changes (has been added to group, changed permission/option). Disabled by default - set "permissions.informplayers.changes" to "true"
    Config node "permissions.verbose", which responsible for player informing about modifyworld restrictions has been renamed to "permissions.infromplayers.modifyworld".
    Autocomplete has been improved.
    New command "pex config <node> [value]". This command help to manipulate configuration file (config.yml) from console/chat interface.
    Many bugfixes.
    v1.03
    Autocomplete for users (taken from registred users and online users) and groups names.
    New command for user removing (pex user <user> delete)
    Fixed several nasty bugs. Thanks for bugreports!
    v1.02
    Compatibility layer loading order issue fixed. Now most of plugins should work.
    Tested with new CB 803 build.
    v1.01
    Regular expression permissions support.
    Newer permissions now added above (bugfix).
    Several bugfixes.
    v1.00
    Initial public release.
     
    BRampersad, grid21, MrRazull and 71 others like this.
  2. Offline

    Silarn

    One last thing to add to my bug report for 1.13. (At the very least, I consider this a bug and it ties in with groups not being handled on a per-world basis.) If I have groups set as defaults to worlds, these defaults work when no groups have been assigned. However, as soon as I assign a player to a group, they are no longer considered to be part of the default group on the other world. This leads to them having no permissions at all when in that world unless they are added back into the default group.
     
  3. Offline

    chroma

    looking for some mysql help.
    am i right in assuming that to use a command to multiple worlds i just need to set the world column like:
    Code:
    id        name               type          permission                     world                   value
    1         playername    0                essentials.whatever     world1, world2
    
    Also what do the type and value fields denote?

    Thanks for any help.

    also never EVER type /pex world world1 inherit world1 for reasons that should be obvious when your not exhausted...
     
  4. Offline

    Arton

    modifyworld.blocks.place.*
    modifyworld.blocks.destroy.*
    modifyworld.blocks.place.*modifyworld.blocks.interact.*

    The permissions nodes dosen't work for me :p if i add them they still not allowed to build and place
     
  5. Offline

    YellowFellow

    How can i make a group have just a prefix without a suffix
    is this the right format?
    Code:
    /pex group Owner prefix "&0[&4Owner&0]&e "
    EDIT: Never mind:) it wasnt working yesturday. it was like [Owner]username[Owner]
     
  6. Offline

    SBD09

    world edit doesn't seem to work with permissions ex can anyone help?
    i used the * but it doesn't work
     
  7. Offline

    MineMaster

    Too bad Permissions was discontinued, but this one follows up nicely. Good job devs. :)
     
  8. Offline

    drt

    - worldedit.* (for all world edit commands)
    - '*' (for all commands)
    - read (for education)
    - drt (for president)

    i know you guys are working on a rewrite. im excited bout that.
    can you please trow us a quick fix for listing added groups at the top of the users group list?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 9, 2018
  9. Offline

    SBD09

    Still don't work
     
  10. Offline

    drt

    i use worldedit with pex. ur more likely to be helped if you post a link to ur permissions on pastebin.com so someone can check where u have an error. Add a note in your post with the version numbers of pex, worldedit and craftbukkit too :)
     
  11. Offline

    Nijikokun

    http://permicon.nexua.org (Old Permissions to this easily)

    (Will not fix, or attempt to fix your permissions, only valid yaml will process. No it will not convert anything other than Permissions 1, 2, 3 yaml.)
     
  12. Offline

    Slyvr

    What chat plugins work with pex?
     
  13. Offline

    wolfz18

    whats the permision for give?
     
  14. Offline

    TowelieDOH

    Thank you for the plugin, i just switched from Permissions 2.x, works great :D
     
  15. Offline

    JOPHESTUS

    I use IChat, but i'm pretty sure EssentialsChat works as well

    If you have Essentials it's
    Code:
     - essentials.give 
    if your not using Essentials I thinks it's just
    Code:
     - give 
    (But i'm not sure with this one)

    -JOPH

    Just give an individual user the permission nodes like so:
    Code:
    users:
    jophestus:
    group:
    - Admins
    permissions:
    - 'give yourself the PEX user rank nodes here'
    
    That way you can set yourself as the default group and have all the default perms but still be able to rank yourself in-game

    -JOPH

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 9, 2018
  16. Offline

    Plet53

    Hey t3hk03d, I'm having a bit of a problem with PermissionsEX. Every time I run the server, this happens:
    Show Spoiler

    What exactly am I doing wrong? And what <block end> is supposed to be where those characters are?
    (Also the server is currently running in offline mode in order to allow some of my friend's friends to play, current plugins are AutoClear, Colors, ColorSign, Commandbook, HeroicDeath, HitCounter, Jail, LWC, MineBackup, MyHome, NoMovedTooQuicklyKick, PermissionsEX, RocketBoots, Spout, Tombstone, VanishNoPacket. War, WorldEdit, WorldGuard, all in latest non-dev builds)

    Thanks in advance,
    Plet53
     
  17. hmmm... but my understanding of this is that the Admin commands (much like give, time etc) would still be available as they are inherited through the group... I am obviously missing a trick here :-S.
    Is there a pex permission node for granting promotion rights to higher levels?
    Also quick question, is there a difference between adding permissions in ' ', " " quotes and no quotes as the wiki uses all of them :)
     
  18. Offline

    JOPHESTUS

    Just make it so you have in your user permissions, the pex promote/demote nodes ( i currently do not know the nodes ) so you can be a member or default or whatever group and have the perms of that group + the pex promote/demote

    -JOPH
    P.s i may not have fully understood your question so this may be no help.
     
  19. Offline

    sennethtsz

    erm...actually i have problems setting permission for flying.
    im using spoutcraft and i installed the plugin spoutflight.i am able to fly but when others joined they cant fly. i have already set their positions to admin with maximum permissions but they are still unable to fly. is there any permission i need to set to enable them to fly?

    i know that i need to add commands like spoutflight.nofalldmg: true in the permissions but where exactly do i add them? and how?
     
  20. Offline

    JOPHESTUS

    Why not just use zombes mod, I can offer no help with this btw i am a noob with spout
     
  21. Offline

    sennethtsz

    cause some of my plugins are only compatible with spout...hmm
    thanks anw!
     
  22. Offline

    tinez

    How do you "deny" a permissions, like ^permissions.xxx in permissions bukkit?
     
  23. Offline

    JOPHESTUS

    Wouldnt you post that in the permissions bukkit topic, anyways im pretty sure you just dont give that group ( or any groups it inherits) that permission node


    -JOPH
     
  24. No the answer was exactly what I was hoping for, but its the nodes that I need and they don't seem to be documented either in the OP or the wiki.
    Do you have any ideas on my other question? (Regarding assigning nodes with and without "")?
    Thanks for the help JOPH
     
  25. Offline

    wolfz18

    whats the all permisions command for owner ?
     
  26. Offline

    JOPHESTUS

    Ill get back to you about that tommorow

    Code:
     - '*' 
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 9, 2018
  27. Offline

    SBD09

    So world edit doesn't seem to work with permissions ex can anyone help?
    i used the '*' but it doesn't work.

    my permissions - http://pastebin.com/5srAXVqL
    i am using cb 1060
    wit permissions EX 1.13
    can anyone help?
     
  28. Offline

    Oscarius

    Any idea what might be causing double join messages when paired with DispNameChanger?
    [​IMG]
    Disabling either plugins will solve the problem, but I need the functionality of both.
    This occurs with Pex 1.12, 1.13 and 1.14 together with DispNameChanger 3.0 and CB#1060.
    PEX's Chat Manager is disabled.

    Thanks in advance.
     
  29. Offline

    Arno00

    Anyone know how to add an info field like Permission, but with the SQL backend of PEX ?

    Like that :
    Code:
    groups:
      foo:
        default: true
        info:
           warp:
             limit:
              private: 1
               public: 0
               global: 0
    I tried to add the option warp.limit.private with value 1, but it doesn't work :/
    pex group VIPStar set warp.limit.private 1
     
  30. Offline

    Slyvr

    A couple questions...
    How do you do negative permissions to disallow certain things that might be inherited.
    How do you add prefixes?
     
    theonewithgingahair likes this.
  31. Offline

    angelina

    Can someone please look at my code and see what I am doing wrong? I've searched everywhere I can think of for an answer so please forgive me if it is obvious.

    For now, the goal is 2 separate worlds. One is for Noobs and one is for advanced players. I want the advanced players to be able to build in both worlds. I want the Noobs to be able to enter both worlds but only build in the Noob world. I've managed to put the permissions together so it works like this. The issue I am having is that some of my commands are not working and I can't figure out why because it seems random.

    I cannot place the blocks for the items listed when I am logged into the server as a Noob in the Noob world. I get the message, "sorry you don't have enough permissions". There are other errors when I try to do other things but I think if someone can help me to nail down what it is I have done wrong, maybe I can figure out the rest.

    Some of the items I cannot place are:
    wood
    lapis lazuli ore
    lapis lazuli block
    bed
    sticky piston
    cobweb
    tall grass
    dead shrubs
    piston
    block moved by piston
    dandelion
    rose
    block of gold
    block of iron
    double slabs
    slabs
    brick block
    moss stone
    wooden stairs

    There are about 20 others that I can't place either but the rest of them are working fine.

    I realize I could use the "*" to allow placement of all blocks but we do not want the placement of all blocks.

    The code is here: http://pastebin.com/APkTwreq

    Thank you in advance! This is driving me bonkers!

    EDIT: I did not know you could disallow items. I have tried allowing all items using the "*" and then inputting the disallow command "- -modifyworld.blocks.destroy.<itemname|itemid> and that is not working for me either. It's not recognizing my command. :(
     

Share This Page