Inactive [ADMN/DEV] PermissionsEx (PEX) v1.19.5 - Tomorrow is Today! [1.4.6-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by t3hk0d3, May 21, 2011.

  1. Offline


    Version: 1.19.5


    PermissionsEx (PEX) is a new permissions plugin, based on Permissions ideas and supports all of its features. But PEX is more! It offers different backends, powerful ingame management, fine grained restrictions for world modification.


    Current features
    1. Bukkit Permissions (SuperPerms) compatible.
    2. Several backend support. Currently bundled backends is File (YAML) and SQL (MySQL, SQLite). Also it's possible to add your own.
    3. YAML backend, with new, fully rethinked, config schema. Now all user, groups and their permissions are stored in one file - permission.yml. BTW file name is adjustable too.
    4. SQL backend, most delicious. Currently MySQL and SQLite supported, but other DB (like Postgre) are possible too. PEX deploys the DB scheme (tables and initial data) automatically. This means, that you only need to provide data on how to connect to the db, everything else PEX will handle by itself.
    5. Flexible architecture and API - you can change a lot programmatically.
    6. Compatibility layer with TheYeti's Permissions (2.7.4) (as a separate part of the plugin). In most cases plugins, which use Permissions, will alsowork with PEX also.
    7. Rich chat/console command interface. You can do almost everything ingame. Command list below.
    8. Modifyworld - Embedded restrictions mechanism (we call it "modifyworld"), which provides the possibility to control players abilities, such as destroying/placing blocks, riding carts/boats or even getting spotted by mobs and much more. Disabled by default.
    9. Multigroup inheritance. User, as well as Group, can be member of several groups. And inherit their permissions, options and prefix/suffix.
    10. Permissions based upon Regular Expressions. This mean you can use regular expressions. Example: modifyworld.blocks.(destroy|place).(3|12) - this permission allow place or destroy only sand (12) or dirt (3) blocks. There is still limitation on dot usage in your regexps - dots are escaped by default.
    11. Multiworld permissions. Just don't specify world and permission would work in any world.
    12. Multiworld inheritance. You can inherit different groups in different worlds.
    13. Easy migration from Permissions 2.x. Converter for both YAML and SQL are embedded into PermissionsCompat. Just use simple instruction.
    14. Perfomance friendly. Low-level caching helps alot when you have 100+ online users :)
    15. Promotional/Demotional system. You can assign ranks to groups and promote/demote users to higher/lower ranked group.
    16. World-inheritance - permissions/option of one world can be inherited by another world.
    17. Timed Permissions - you can give user permission only for some amount of time.
    18. Chat Manager - small chat plugin, bundled with PEX. With prefixes/suffiex and colors. Check wiki for more details.


    Basic setup tutorial (Thanks to lycano)

    Nice tutorial made by Bennetman

    Stable version

    Development version (mostly stable) - always lastest dev build.



    Maven Repository

    Join us on #permissionsex, Feel free to ask any related questions.

    Tools !NEW!
    Pex Auto-Setup Tool - MySQL and FlatFile !

    Show Changelog (open)
    Proper intervals for timed commands (both group/permissions management), without pesky seconds calculations (like /pex user t3hk0d3 timed add cool.permission 10days)
    1.4.6 compatibility.

    Built for Bukkit 1.4.2-R0.1
    Added inventory permissions (modifyworld.items.put/take.<item>.of.<chest>)
    Added item hold permission (modifyworld.items.hold.<item>)
    Sdded monster egg spawn permission (modifyworld.spawn.<creature>)
    Few other minor fixes
    Modifyworld improvements (configurable messages, now independent from PEX)
    /pex help command
    Minor improvements and bugfixes
    New modifyworld permissions
    Some bugfixes
    Bugfix release
    Bukkit R6 compatible.
    Several bugfixes!
    Permissions now case-insensetive.
    Users logging and cleanup feature.
    Non-inheriting nodes feature.
    Several Bugfixes.
    PermissionsCompat is finally remove from default bundle.
    User/group specific management permissions (
    Fixed some superperms compatibility issues
    Fixed several bugs
    SuperPerms compatbility bridge were rewritten - no lags anymore and now with debug output (now you can view superperms checks).
    Numerous of bugs were fixed (Thanks you guys for reporting them)
    Modifyworld were improved (modifyworld.item.use)
    Compatiblity for 1317+
    Fixed perfomance issues with SuperPerms (if you still experience they try to disable "raw-permissions" in config.yml)
    Fixed issue with prefix inheritance
    Improved Options mechanism.
    Auto saving new users feature, disabled by default.
    SuperPerms bridge improved - more permissions supported by wildcards.
    File backend dumping now fully functional. SQL dumping is still bogus (do not dump world-specific inheritance and prefixes), will be fixed soon.
    Many bugfixes and minor improvements.
    Superperms (BukkitPerms) support
    Multiworld inheritance and prefixes/suffixes
    Groups weighting
    ChatManager, chat plugin which bundled with PEX.
    Modifyworld now separate plugin, but still bundled with PEX.
    API changed slightly, CustomEvents (PermissionsEntityEvent, PermissionsSystemEvent) introduced.
    Many lesser improvements and tons of bugfixes.
    API get slightly improved
    Ranking ladders.
    User/group name case-insensetivity.
    Timed permissions.
    Modifyworld rules are get improved.
    Tons of minor improvements and bugfixes.
    Many bugfixes and improvements.
    MySQL connection stability improved - reconnection mechanism.
    Promotional/Demotional system.
    Perfomance improvement, with new low-level caching system (thx Joy)
    Modifyworld improved.
    Many lesser improvements and bugfixes.
    New p2compat backend, for easy migration from Permissions 2.x to PEX.
    Users/Groups dumping (pex dump <backend> <file>).
    New commands pex promote/demote. Actually this is just aliases for "pex user group set/remove"
    Few bugfixes.
    Players now can be informed about changes (has been added to group, changed permission/option). Disabled by default - set "permissions.informplayers.changes" to "true"
    Config node "permissions.verbose", which responsible for player informing about modifyworld restrictions has been renamed to "permissions.infromplayers.modifyworld".
    Autocomplete has been improved.
    New command "pex config <node> [value]". This command help to manipulate configuration file (config.yml) from console/chat interface.
    Many bugfixes.
    Autocomplete for users (taken from registred users and online users) and groups names.
    New command for user removing (pex user <user> delete)
    Fixed several nasty bugs. Thanks for bugreports!
    Compatibility layer loading order issue fixed. Now most of plugins should work.
    Tested with new CB 803 build.
    Regular expression permissions support.
    Newer permissions now added above (bugfix).
    Several bugfixes.
    Initial public release.
    BRampersad, grid21, MrRazull and 71 others like this.
  2. Offline


    I've always been a PermissionsEX fan, but till today, when I used it on my server, it seems that new players are not automatically to the permissions.yml, further more you have to manually add it, to the group guest, default, or whichever you guys use.
    any help or tips on how to fix this?
  3. Offline


    I love this plugin, I use it for my server. Brilliant work!
  4. Offline


    ChatManager doesn't work yet?
  5. Offline


    i have permissionsex latest dev build on my server. and after the 1.4.6 uppdate no prefixes and rankes work enymore.
    i have tested to run the server with only pex but same thing.Plz help me i need this :( heres my permission:
  6. Offline


    This error-

    Vault loaded - using BOSEconomy

    Enabling EssentialsChat vPre2.9.6.7

    [INFO] Server permissions file permissions.yml is empty, ignoring it

    [INFO] Done (22.967s)! For help, type "help" or "?"

    [WARNING] [PermissionsEx] Unknown server implementation being used!

    [WARNING] [PermissionsEx] No Permissible injector found for your server implementation!
  7. Offline


    i need some help when i start the server this error is on the console how do i fix that please add me on skype and awnser or comment.
  8. Offline


  9. Offline


    When are you guys gonna fix permissions ex?! been waiting forever.
    skillman1428 likes this.
  10. Offline


    Love the plugin. :D
  11. Offline


    Please help I'm on 1.4.6 I have the latest PEX downloaded and everytime I'm on my server I can't do any commands none!!1 Please help
  12. Offline


    same here! damn our servers need this plugin so plz fix it!
  13. Fix what exactly? As far as I've been able to tell, it's working fine with the current bukkit builds (I've not checked 0.3 yet, but as it's a bug fix regarding enchantments, I can't see it breaking anything from 0.2)
  14. Offline


    I need lots of help. I am running this permissionsex on a 1.4.6 (r.02) build. When I run all o my permissions break. You have to be op to do anything. I'm running about 45 plugins. Please help. Skype is Austin Pacholek. I really want to start my server. I have been working on it for a long time, but am just stuck right now. Thanks
  15. Offline


    Nobody can use any commands.
    it spews out this every time someone tries any command.
    2012-12-25 16:08:09 [WARNING] [PermissionsEx] Unknown server implementation being used!
    2012-12-25 16:08:09 [WARNING] [PermissionsEx] No Permissible injector found for your server implementation!

    I know the permission nodes are right, and I know what nodes Ive assigned to what ranks. Ive been using this plugin for awhile and this is the only time Ive had a problem with it.

    Ive tried deleting the permissions ex folder and starting over and that didnt help either.
  16. You are using the wrong version of PEX.

    For bukkit 1.4.5 build 2488 and up, you need to use PEX 1.19.5 (current stable).
    For builds of bukkit earlier than that, you need to use PEX 1.19.4 and earlier

    Bukkit made some API changes around the time of the listed build that broke PEX (and other plugins).
  17. Offline


    I AM using the most recent version... And I am using the most recent 1.4.6 beta build.
    its NOT working.
  18. Well, that's strqange as I am using the 1.19.5 PEX and modifyworld available from the download link (NOT the dev version, the current stable) with the 1.4.6 beta build 2586 and the dev build 2489, and I do not have this problem.

    permissionsex.jar - 12.24.2012 3:03PM
    modifyworld.jar - 12.24.2012 3:06PM
    chatmanager.jar - 12.24.2012 3:06PM

    Those are the filedates I have on my copy.

    My test server is Windows 7 Ultimate with Java 7, and my production server is a hosted server (99% sure it runs linux and Java 6). I do not have this problem with either one. The only time I've seen that error is when an earlier version of PEX for minecraft 1.4.5 dev 0.2 and earlier (before the API changes) is loaded.
  19. Offline


    Well Im only using permissionsex.jar. I dont use either of the other 2.
    And ive tried downloading the most recent version 2 days ago, yesterday, and today. Nothing has changed.
    Im starting to give up hope with this plugin.

    And my server is ran off of my computer, I dont pay for a server.
  20. Can you put your server.log up somewhere like pastebin? I'd like to look at it and see if I can spot anything.
  21. Offline


    Well get this. I was gonna run the server, and put the permissionsex plugin back into the plugin folder and was gonna run the server and cut/copy the information of today to pastebin. But when I tried to do some commands with my MrTest account, it worked.

    I swear to you it wasnt working before. Maybe it was because I ran the server without permissionsex for a short period of time?
  22. No, that shouldn't make a difference.

    Odd, but hey, it's working now, that's what matters, right? :)
  23. Offline


    I am not new to PEX but something is ticking me off. Whenever i set my rank to something with a prefix the server lags a bit. Then i don't have a prefix. But my permissions for that rank work perfectly fine. The only error i found in my server log is...
    [Server] WARNING [PermissionsEx] No Permissible injector found for your server implementation!
    [Server] WARNING [PermissionsEx] Unknown server implementation being used!
  24. Offline


    I am having a bit of trouble. i recently just switched from groupmanager to this plugin but having the same issue. i deleted all the groupmanager plugins/files btw.
    my issue is when someone speaking in the server i want it to say
    [Member] -Username-
    so i set up groups and just like groupmanager the chat has
    [Default] [Member] -Username-
    How can i take off the group title out of chat? and only have the [Member]
    Thanks For Your Help
  25. Offline


    If something says default in the name like that. You must have the node under default that says... prefix: '[Default]'
    If so get rid of it.
  26. Offline


    Why are timed permissions STILL not working?

    Permissions are lost as soon as the user logs out. Anyone know any solution, workaround or alternative plugin for this?
  27. Offline


    "unknown server implementation" happened to me
    Any suggestions? because I tried the latest build and even the latest dev build (but i think that they were the same thing but they both gave the same result)
    Perms don't positive they are setup correctly and even the default players do not have permission to things
  28. Offline


    Same here
  29. Offline

    Tom Williams

    astidonius issued server command: /pex group admin add hyperconomy.admin
    23:50:20 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'pex' in plugin PermissionsEx v1.19.5
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.dispatchCommand(
    at net.minecraft.server.v1_4_6.PlayerConnection.handleCommand(
    at net.minecraft.server.v1_4_6.PlayerConnection.a(
    at net.minecraft.server.v1_4_6.Packet3Chat.handle(
    at net.minecraft.server.v1_4_6.NetworkManager.b(
    at net.minecraft.server.v1_4_6.PlayerConnection.d(
    at net.minecraft.server.v1_4_6.ServerConnection.b(SourceFile:39)
    at net.minecraft.server.v1_4_6.DedicatedServerConnection.b(SourceFile:30)
    at net.minecraft.server.v1_4_6.MinecraftServer.r(
    at net.minecraft.server.v1_4_6.DedicatedServer.r(
    at net.minecraft.server.v1_4_6.MinecraftServer.q(
    Caused by: java.lang.RuntimeException: java.lang.NullPointerException
    at ru.tehkode.permissions.commands.CommandsManager.execute(
    at ru.tehkode.permissions.bukkit.PermissionsEx.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    ... 15 more
    Caused by: java.lang.NullPointerException
    So I tried to dump to flat file from sql, and get Error:Null, anyone make any sense of this?
  30. Offline


    For some reason i cannot use any commands, and PEX seems to be the problem.
    Here is my config file, i think i set it up right but nothing is going straight!

    For some reson It will not assign me as an admin![​IMG]
  31. Offline


Share This Page