[ADMN/DEV] PermissionsBukkit v2.0 - Official Default Groups Plugin [1.5.2-R1.0]

Discussion in 'Archived: Plugin Releases' started by SpaceManiac, Jul 17, 2011.

  1. Offline


    PermissionsBukkit - the Official Default Groups Plugin
    Current Version: v2.0
    Find PermissionsBukkit on BukkitDev!

    If you are getting a specific error or cannot determine what is wrong with your permissions file, filing a ticket on BukkitDev will make me much more likely to respond to you; general questions are best to ask in this thread or on the forums on BukkitDev.

    It's been a long time coming, but with the accomplishment of build 1000 Bukkit has finally accomplished a built-in Permissions system (codenamed Superperms). For more info on how they work, and how to integrate them with your plugin, see the official Permissions FAQ. Keep in mind that you should rarely, if ever, have to hook this plugin directly; instead keep things in the realm of checking player.hasPermission("yourplugin.node"). The FAQ thread has more info on how to use Superperms with things like chat prefixes/suffixes.

    • Storage of users and groups in plugins/PermissionsBukkit/config.yml.
    • Both users and groups can be assigned individual permissions and parent groups to inherit permissions from.
    • Support for global and per-world permissions.
    • Reload configuration from file with out reloading the plugin.
    • Ability to check if a player has a specific permission node.
    • Ability to dump all permissions a player has and the plugins that set them.
    • Ability to print plugin, description, and default for a given permission node.
    • Ability to modify the permissions of groups and users and the groups of a user in-game.
    • Built-in antibuild via the "permissions.build" node (defaults to allowing anyone to build).
    • A minimalistic bridge from Permissions 3.0 to Superperms is available as a separate plugin, which does not depend on PermissionsBukkit.
    Command Usage:

    Show Spoiler
    PermissionsBukkit uses the command /permissions, with aliases /perms and /perm.

    /permissions reload - reload the configuration from disk.
    /permissions check <node> [player] - check if a player or the sender has a permission (any plugin).
    /permissions info <node> - prints information on a specific permission.
    /permissions dump [player] [page] - prints info about a player's (or the sender's) permissions.
    /permissions setrank <player> <group> - set a player to be in a group with per-group permissions.
    /permissions group - list group-related commands.
    /permissions group list - list all groups.
    /permissions group players <group> - list players in a group.
    /permissions group setperm <group> <[world:]node> [true|false] - set a permission on a group.
    /permissions group unsetperm <group> <[world:]node> - unset a permission on a group.
    /permissions player - list player-related commands.
    /permissions player groups <player> - list groups a player is in.
    /permissions player setgroup <player> <group,...> - set a player to be in only the given groups.
    /permissions player addgroup <player> <group> - add a player to a group.
    /permissions player removegroup <player> <group> - remove a player from a group.
    /permissions player setperm <player> <[world:]node> [true|false] - set a permission on a player.
    /permissions player unsetperm <player> <[world:]node> - unset a permission on a player.

    All commands have in-game help and are usable from the server console.

    Show Spoiler
    A permission node is a string like 'permissions.build', usually starting with the name of the plugin. Refer to a plugin's documentation for what permissions it cares about. Each node should be followed by true to grant that permission or false to revoke it, as in 'permissions.build: true'. Some plugins provide permission nodes that map to a group of permissions - for example, PermissionsBukkit has 'permissions.*', which automatically grants permissions for all PermissionsBukkit commands. You can also specify false for permissions of this type.

    Users inherit permissions from the groups they are a part of. If a user is not specified here, or does not have a 'groups' node, they will be in the group 'default'. Permissions for individual users may also be specified by using a 'permissions' node with a list of permission nodes, which will override their group permissions. World permissions may be assigned to users with a 'worlds:' entry.

    Groups can be assigned to players and all their permissions will also be assigned to those players. Groups can also inherit permissions from other groups. Like user permissions, groups may override the permissions of their parent group(s). Unlike users, groups do NOT automatically inherit from default. World permissions may be assigned to groups with a 'worlds:' entry.

    The cannot-build message is configurable. If it is left blank, no message will be displayed to the player if PermissionsBukkit prevents them from building, digging, or interacting with a block. Use '&' characters to signify color codes.

    An example configuration file might look like this:
                permissions.example: true
            - admin
                permissions.build: false
                permissions.*: true
            - user
                permissions.build: true
                    coolplugin.item: true
            - default
        build: '&cYou do not have permission to build here.'

    Show Spoiler
    PermissionsBukkit checks for the following permission nodes:
    • permissions.build - Allows a player to build. Defaults to true.
    • permissions.help - Allows viewing of usage for /permissions.
    • permissions.reload - Allows use of /permissions reload.
    • permissions.check - Allows use of /permissions reload.
    • permissions.info - Allows use of /permissions reload.
    • permissions.dump - Allows use of /permissions reload.
    • permissions.group.help - Allows viewing of usage for /permissions group.
    • permissions.group.list - Allows use of /permissions group list.
    • permissions.group.players - Allows use of /permissions group players.
    • permissions.group.setperm - Allows use of /permissions group setperm.
    • permissions.group.unsetperm - Allows use of /permissions group unsetperm.
    • permissions.player.help - Allows viewing of usage for /permissions player
    • permissions.player.groups - Allows use of /permissions player groups.
    • permissions.player.setgroup - Allows use of /permissions player setgroup.
    • permissions.player.addgroup - Allows use of /permissions player addgroup.
    • permissions.player.removegroup - Allows use of /permissions player removegroup.
    • permissions.player.setperm - Allows use of /permissions player addgroup.
    • permissions.player.unsetperm - Allows use of /permissions player removegroup.
    Also, the following parent nodes are provided for convenience:

    • permissions.* - Maps to permissions.help, .reload, .check, .info, .dump, and to permissions.group.* and permissions.player.*. Defaults to op.
    • permissions.group.* - Maps to permissions.group.help, .list, .players, .setperm, and .unsetperm.
    • permissions.player.* - Maps to permissions.player.help, .groups, .setgroup, .addgroup, .removegroup, .setperm, and .unsetperm.

    Frequently Asked Questions:
    1. Where are my * nodes? (open)
    Bukkit's Superperms has no built-in concept of a global '*' node that automatically gives all permissions, which is intentional - a player can instead be given all permissions by being given 'op' status (that is, listed in ops.txt). Additionally, individual plugins define a parent node (which could be 'pluginname.*' or 'pluginname.all' or anything else) which maps to whatever subpermissions in that plugin the author desires.

    An example is PermissionsBukkit, which provides three such permissions: 'permissions.group.*' for all /permissions group commands, 'permissions.player.*' for all /permissions player commands, and'permissions.*' for all /permissions commands (including permissions.group.* and permissions.player.*).

    If you are using SuperpermsBridge, you can do something similar to '*' nodes for plugins which use Permissions 2.7/3.1 - see the next FAQ for more information.
    2. How do I use SuperpermsBridge? (open)
    SuperpermsBridge is kind of like FakePermissions for GroupManager or PermissionsBridge for PermissionsEx. Once it's installed, it pretends to be the Permissions plugin and converts any plugins that use Permissions 2.7 or Permissions 3.1 to use Superperms instead.

    You can have PermissionsBukkit without SuperpermsBridge or SuperpermsBridge without PermissionsBukkit if you like, but both of these are limited in functionality. If you install SuperpermsBridge without PermissionsBukkit you will not be able to make use of PermissionsBukkit's groups feature or admin commands, and if you install PermissionsBukkit without SuperpermsBridge, plugins that have not updated to use Superperms directly will not function.

    For plugins that use Permissions 2.7/3.1, you can use the special node 'superpermbridge.*' to give the equivalent of what used to be the '*' node for plugins that do not use Superperms directly. If you don't want to give the * node, you can also use the node 'superpermbridge.pluginname' to do the equivalent of what used to be the 'pluginname.*' node. Once again, these only apply to plugins that SuperpermsBridge handles and not to plugins using Superperms directly.
    3. How do I use the root permissions.yml? (open)
    The file 'permissions.yml' in the root of your server can be used to set up custom parent permissions. Parent permissions are a single node that, when given to a player or group, automatically give all their children node. Here's a simple example:
            commandbook.motd: true
            commandbook.say: true
            commandbook.say.me: true
            commandbook.time: true
    Now, if you give a player the node 'server.basics', they automatically get all the nodes listed here. Children may also say 'false' instead of 'true', in which case giving the parent will remove the child instead of giving it.

    You can also specify a description if you like, which can be used by plugins to provide information on your node (such as PermissionsBukkit's /perm info command). If you want, you can also provide a default, which can be one of "true", "false", "op", or "notop". CraftBukkit will automatically assign everyone, no one (default), ops, or non-ops the children permissions based on the specified default. Without any plugin like PermissionsBukkit, you can use this defaults system as a limited way to assign people permissions. Here's a more complex example:
        description: Basic permissions for My Cool Server.
        default: true
            commandbook.motd: true
            commandbook.say: true
            commandbook.say.me: true
            commandbook.time: true
        description: Admin permissions for My Cool Server.
        default: op
            commandbook.broadcast: true
            commandbook.teleport: true
            commandbook.kick: true
            commandbook.ban: true
    You can also define permissions without children, but this is of limited usefulness in permissions.yml (though is important in plugin.yml; see question #6)
    4. How do I switch from (other Permissions plugin)? (open)
    Depends on the Permissions plugin! If you were using PEX's YAML backend, I have a converter done and available on the PermissionsBukkit Tools page. Also available on the tools page is an automatic converter for Essentials GroupManager users.yml and groups.yml files. Automatic converters for Permissions 2.7 and 3.x are on their way, but in the meantime you can still convert your configurations manually.
    5. Where are prefixes and suffixes (or option nodes)? (open)
    Bukkit Superperms has no built-in prefix/suffix settings or non-boolean permission nodes, so individual chat plugins will have to start supporting Superperms in order to make use of non-Permissions-plugin based prefixes and suffixes. Herochat, iChat, and Simple Suffix are all aware of the Superperms update, but in the meantime you can use mChat, which already supports Superperms.

    Once you install mChat and configure the mchat.prefix, mchat.suffix, and mchat.group names in its configuration file (see the example), use PermissionsBukkit to give players or groups the permissions "mchat.prefix.admin", replacing "admin" with whatever node you configured. For example, with an mchat configuration that looks similar to this:
    da-name-format: '+prefix+name&e'
    date-format: HH:mm:ss
    message-format: '+prefix+name&f: +message'
            admin: '&4DtK [SO] &7 '
            sadmin: '&9DtK [SA] &7 '
            jadmin: '&aDtK [JA] &7  '
            member: '&cDtK [M] &7 '
    You can assign players or groups the mchat.prefix.admin node to get the "SO" prefix, mchat.prefix.sadmin to get the "SA" prefix, and so on.
    6. (Coders) How do I set up my plugin.yml? (open)
    Take a look at this post in Dinnerbone's FAQ for an example. This is a lot like the setup of permissions.yml (see above), but you can also define non-parent permissions (just include description and default and leave out children).
    7. Is PermissionsBukkit outdated? (open)
    No! PermissionsBukkit 2.0 was last updated for 1.3.1-R2.0, is verified to work on 1.4.7-R1.0, and is unlikely to break on future releases.

    Current Version:

    PermissionsBukkit v2.0 (jar) (details)
    Old Versions:
    PermissionsBukkit v1.6 (jar) (details)



    Friday 7 September 2012 (2.0)
    • Fixed a case-sensitivity issue with setting per-world permissions that could cause some permissions to fail to apply.
    • Added /perm setrank <player> <group> subcommand (alias rank) with per-group permissions (permissions.setrank and permissions.setrank.<group>)
    • Added plugin metrics via http://mcstats.org/plugin/PermissionsBukkitMCStats (disableable in plugins/PluginMetrics/config.yml)
    Wednesday 29 February 2012 (1.6)
    • Fixed some massive issues that were caused due to having uploaded a buggy, in-development version instead of 1.5.
    • Note: If your configuration was messed up as a result of this issue, the new build should gradually correct it as needed.
    Saturday 25 February 2012 (1.5b)
    • Revamped to be compatible with R5.
    • Fixed issues with permissions not carrying properly on world change.
    • Many internal improvements for performance and stability.
    • SuperpermsBridge: in honor of R5 removing deprecated code, SuperpermsBridge is officially gone!
    Monday 18 July 2011 (1.1/1.2)
    • Fix BukkitContrib incompatibility issues.
    • Improved the output of the /perm check command.
    • Fixed issues when 'users:' is not specified in the config file.
    • Fixed the /permissions reload command.
    • SuperpermsBridge: improve wildcard handling; in addition to 'superpermbridge.*' and 'superpermbridge.pluginname', now supported are 'superpermbridge.plugin.*', 'superpermbridge.plugin.subnode.*', and so on.
    Monday 18 July 2011 (1.0/1.1)
    • SuperpermsBridge: adding the special 'superpermbridge.*' and 'superpermbridge.pluginname' nodes (see #2 in the FAQ for details).
    Sunday 17 July 2011 (1.0/1.0)

    • Initial release of PermissionsBukkit v1.0 and SuperpermsBridge v1.0.
    madmac, Gesundheit, tripleX and 23 others like this.
  2. Offline


    How do you know it's working?
    I think it work because the people in the default can't brick/get blocks
  3. Offline


    If you don't get any errors from PermissionsBukkit at startup then it is probably working.
    And if the default group user can't build it is definitely working.
    isaac_pops likes this.
  4. Offline


    will im having problems that it keeps on reseting and the permissions are back to normal and all the perms i made are gone so i need help wiht that plz reply

    plz help

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  5. Offline


    Really... making a 2nd post with 'plz help' 1 minute after the first post won't make you get a reply any faster.....

    Now about your problem, you made a mistake in your config.
    This plugin sometimes seems to reset the config when it is not correct. To avoid this, make backups of your config and try not to make any mistakes. :p
  6. Offline


    Thx for helping
  7. Offline


    Hey, I understood how to use permissions, and what i need is a tiny thing. I want to use 1 permission for ALL the users in the server except admins, but I dont know what to write instead of a name.. this is what i wrote:

    iConomy.plus: true

  8. Offline


    Thats not possible. You should work with groups instead of giving individual users permissions. Just give the 'iConomy.plus: true' permission to the group all of your users are in. And if you are using inheritance you might need to use the false node on the admin group.
  9. Offline


    what do the following permissions do?
    'permissions.example: true'
    'coolplugin.item: true'

    and if i want to add essentials and factions commands to the list do I write them like this? if i get them wrong please correct me.


  10. Offline


    Those are, rather obvious if you ask me, example permissions. They don't do anything at all, they are just there to show you how it works.

    essentials.give: true
    essentials.tpa: true
    essentials.tp: true
    essentials.home: true
    essentials.back: true
    essentials.sethome: true
    essentials.warp: true
    factions.*: true

    always specify true or false. Usually you don't need 'false' unless you use a * permission and want to deny 1 seperate permission. Or when you use inheritance and a higher group shouldn't have something a lower group has.
  11. Offline


    First of all thanks for the quick reply. Now, if i put the permission iConomy.plus: true for the group Default, do I need to set every user t o this group? like write


  12. Offline


    I have an issue.

    A really big issue.

    I had my perms pretty much set up. Then I used the command /permissions reload to reload the config without having to restart. I had done this, with success, at least 5 times that same night. The last time I tried it however, my entire perms got wiped out.

    Well, fuck.

    Now I have to redo them.

    But wait! It's not that simple! It never is!


    And I'm pissed.

    Here are my perms, exactly as they were before they got wiped.


  13. Offline


    No that is not needed, the default group is a special group that all users area automatically in.

    The only reason a config would be wiped is because there is a mistake in the file. This plugin is pretty strict so even a small mistake could make the plugin function incorrectly or, like in this case, wipe the config.
    So the lesson we learned from this.... make backups. :p

    Now I've checked your config and have made a few adjustments. First two things that probably aren't the cause.

    1. The user 'All' won't work, when a user joins the server he will automatically be put in the group named 'default' you can't just specify this by using 'ALL'.
    2. You are using inheritance for both bluemod and redmod... but not for the admin group. If you specify that the admin group inherits from the bluemod group you won't have to put admins in 2 groups like you did for jwalters93, _Sky_King_ and Willengard.
    3. You gave those same 3 users permissions that they already get from being in the admin group.

    Ok, now for a few mistakes that would be more likely to cause incorrect functioning or config wiping.
    4. 'foundboxx.notify' doesn't have a true or false after it at both bluemod and redmod groups.
    5. You seem to be using 4 spaces indention per 'level' but at the default group permission nodes you only indent 2 spaces... I know it is correct to use either 4 space indention's or 2 space indention's but don't recommend using both of them.
    6. You are missing the 'debug:' node at the bottom of the file.

    Here is the config with all the above things fixed:
            - admin
            - admin
            - admin
            - admin
            - admin
            - admin
            - admin
            - admin
            - admin
            - bluemod
            - bluemod
            - redmod
            - bluemod
            - default
                permissions.build: true
                essentials.help: true
                essentials.helpop: true
                essentials.ignore: true
                essentials.list: true
                essentials.mail: true
                essentials.mail.send: true
                essentials.motd: true
                essentials.near: true
                essentials.msg: true
                essentials.realname: true
                essentials.rules: true
                essentials.suicide: true
                essentials.sethome: true
                essentials.home: true
                essentials.spawn: true
                essentials.ping: true
                essentials.delhome: true
                essentials.tpaccept: true
                essentials.tpdeny: true
                essentials.getpos: true
                essentials.depth: true
                essentials.afk: true
                factions.kit.fullplayer: true
                signlift.*: true
                bookworm.*: true
                iConomy.holdings: true
                iConomy.holdings.others: true
                iConomy.payment: true
                iConomy.help: true
                iConomy.accounts.create: true
                iConomy.accounts.give: true
                iConomy.accounts.status: true
                bookworm.*: true
                ChestShop.shop.create: true
                ChestShop.shop.buy: true
                ChestShop.shop.sell: true
                mobarena.arenas.*: true
                mobarena.classes.*: true
                mobarena.use.join: true
                mobarena.use.leave: true
                mobarena.use.spectate: true
                mcmmo.skills.taming: true
                mcmmo.skills.mining: true
                mcmmo.skills.woodcutting: true
                mcmmo.skills.repair: true
                mcmmo.skills.unarmed: true
                mcmmo.skills.archery: true
                mcmmo.skills.herbalism: true
                mcmmo.skills.excavation: true
                mcmmo.skills.swords: true
                mcmmo.skills.axes: true
                mcmmo.skills.acrobatics: true
                mcmmo.skills.fishing: true
                mcmmo.ability.herbalism: true
                mcmmo.ability.excavation: true
                mcmmo.ability.unarmed: true
                mcmmo.ability.mining: true
                mcmmo.ability.axes: true
                mcmmo.ability.swords: true
                mcmmo.ability.woodcutting: true
                mcmmo.commands.ability: true
                mcmmo.commands.ptp: true
                mcmmo.commands.whois: true
                mcmmo.commands.party: true
                mcmmo.chat.adminchat: true
                mcmmo.chat.partychat: true
                foundboxx.ignore.*: true
                chesscraft.commands.create.game: true
                chesscraft.commands.invite: true
                chesscraft.commands.join: true
                chesscraft.commands.move: true
                chesscraft.commands.offer.draw: true
                chesscraft.commands.offer.swap: true
                chesscraft.commands.resign: true
                chesscraft.commands.archive: true
                chesscraft.commands.tp: true
                chesscraft.commands.win: true
                essentials.kick: true
                essentials.togglejail: true
                essentials.jails: true
                essentials.mute: true
                essentials.tpa: true
                essentials.tpahere: true
                essentials.back: true
                essentials.weather: true
                foundboxx.notify: true
            - default
                essentials.tp: true
                essentials.tp.others: true
                essentials.invsee: true
                simpleprefix.commands.*: true
                vanish.*: true
                mobdisguise.*: true
                foundboxx.notify: true
            - redmod
                permissions.*: true
                essentials.*: true
                essentials.sudo: false
                essentials.socialspy: false
                simpleprefix.commands.*: true
                vanish.*: true
                mobdisguise.*: true
                factions.*: true
                mobbounty.*: true
                mobarena.*: true
                mcmmo.*: true
                ChestShop.*: true
                worldedit.*: true
                worldguard.*: true
                foundboxx.*: true
                iConomy.*: true
                bookworm.*: true
                signlift.*: true
                vault.admin: true
                hawkeye.*: true
                anticaps.cancaps: true
                chesscraft.commands.create.board: true
                chesscraft.commands.delete.board: true
                chesscraft.commands.delete.game: true
                chesscraft.commands.redraw: true
                chesscraft.commands.getcfg: true
                chesscraft.commands.setcfg: true
                chesscraft.commands.save: true
                chesscraft.commands.reload: true
                chesscraft.commands.board.set: true
                chesscraft.commands.board.save: true
                chesscraft.commands.design : true
                chesscraft.commands.create.game: true
                chesscraft.commands.invite: true
                chesscraft.commands.join: true
                chesscraft.commands.move: true
                chesscraft.commands.offer.draw: true
                chesscraft.commands.offer.swap: true
                chesscraft.commands.resign: true
                chesscraft.commands.archive: true
                chesscraft.commands.tp: true
                chesscraft.commands.win : true
            - bluemod
        build: '&cYou do not have permission to build here.'
    debug: false
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  14. Offline


    But I still need to write


    for every user?

    Sorry for all the questions im new at this lol.
  15. Offline


    No, that's not needed. When a user joins the server, the plugin checks if the user is in the config. If the user is in the config he will be placed in the correct group. If the user is not in the config he will be placed in the 'default' group.
    So no, you don't have to place a user in the config. :p
  16. Offline


    Ohhhhhh! thats awsome! thank you so much for the quick replies man!
  17. Offline


    Glad i can help. :p
  18. Offline



    Thanks. A lot. I hope that'll do the trick.

    Woohoo! It's fixed! Thanks so much Snowy007!!

    Sooooo... the same thing happened. Sort of.

    I redid the perms with what you gave me Snowy, and it worked perfectly. I was doing some tweaking here and there, and I did /permissions reload a few times, and it worked fine. But I just reloaded the perms again, and my permissions.yml got erased. Again. Luckily, I have a copy of it on pastebin, so it's not too big of a deal, but what do you think made the yml erase itself? It seems like it might be a bug to me.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  19. Offline


    You probably made a small mistake in one of your last changes. As i already said, even the smallest mistakes can cause that to happen. And mistakes are easily made.
  20. Okay, I'm trying to set up this plugin and it's not working at all.

    in game, I'm using this command:
    /permissions group setperm admin <[world:jcommands.* [true]

    server responds with:
    Group admin now has jcommands.* = false.

    Why does it keep entering as false and not true?
    Can anyone help me with this problem?
  21. Offline


    /permissions group setperm admin world:jcommands.* true

    The < > signs and the brackets are just there to make it more clear for most people on how to use the command. You don't actually have to type in those signs when using the command.

  22. Yeah, I did it with and without the <> and it still wouldn't work. Kept setting it to true.
  23. Offline


    wait what.... You probably typed that wrong, it was supposed to set to true right. xD

    If the command doesn't work, you could also just change the config itself. Which i would recommend anyway since it gives you a better view of all the permissions the groups already have and its usually faster than typing that command every time. But you just have to make sure that you don't make any mistakes.
  24. Offline


    17:25:01 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'perm
    ' in plugin PermissionsBukkit v1.6
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:42)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:16
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:4
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:781)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:764)
            at net.minecraft.server.Packet3Chat.handle(Packet3Chat.java:34)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:229)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:113)
            at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:7
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:551)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:449)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.lang.NullPointerException
            at com.platymuus.bukkit.permissions.PermissionsCommand.createPlayerNode(
            at com.platymuus.bukkit.permissions.PermissionsCommand.playerCommand(Per
            at com.platymuus.bukkit.permissions.PermissionsCommand.onCommand(Permiss
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:40)
            ... 12 more
    help this error appeared when i tried adding some one to a group
  25. Offline


    You made a mistake somewhere in your config.
  26. Offline


    That...seems rediculously idiotic. Was the plugin made that way, or is it just a by-product of how the config works? Because, from personal experience, it's extremely aggravating to have your config wipe itself out if you make a mistake. A more resonable response would be to have a message pop up in game telling you you screwed up. :3
  27. Offline


    I think its a bug. :p
    A bug he is unlikely to fix anytime soon as he is only updating this plugin when it is absolutely necessary. And since it still works fine if you configure it correctly it is not 'absolutely necessary' xD
  28. Offline


    Thx snowy I fixed the problem :D
  29. Offline


    Glad you got it fixed on your own. That's the best way to learn how to keep a server running. For most people here, I have to search for the mistakes they made. :p
  30. Offline


    How do I add groups to the system
  31. Offline


    Hey, I'm trying to get my permissions working, but I'm having the following problem:
    When I open my config.yml, it says I'm member of the group admin, just how I want it. But when I go in-game and deop myself and try /help, /tp or /ping to try permissions it says
    "You don't have access to that command"

    When I type "/permissions player groups Pintrix" in the console,
    it says "Player pintrix is in the default group". (which should be "admin", not "default")
    And when I type "/permissions player setgroup Pintrix admin" in the console,
    it says "An internal error occurred while attempting to perform this command".
    Also, Permissions doesn't recognize the "default" group when I type something like:
    "/permissions group setperm default world:essentials.* true"
    (it says "No such group default")

    I have absolutely no idea why my config doesn't respond to what I type in-game, or why it completely clears itself whenever I type "/permissions reload" in the console.

    Still great plugin by the way (if I could get it to work)

    -- Pintrix

Share This Page