Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    the big problem is an overload of permissions, when someone gets a permission which he already has throgh a inheritance or an '*'. because of that a group who has '*' should inheritance anything and shouldnt has any other permissions, because it already has all.

    so remove all permissions from u as user and remove all permissions from the admin group so it has only '*'
    --- merged: Mar 7, 2011 5:01 PM ---
    yes i think. when they inheritance each other because '*' includes ''. and 'iConomyChestShop.*.*' them all.
    and btw: 'iConomyChestShop.*.*' is wrong it should be 'iConomyChestShop.*'
  3. Offline



    I rename world.yml to default.yml (contradictory to what's written in TheYeti's documentation)
    i move netherworld.yml to bukkitroot/netherworld (not mentioned anywhere in TheYeti's documentation)
    i move worldedit.yml to bukkitroot/worldedit (as above)

    And people wonder why everyone is having trouble with Permissions...

    I shall try this soon...
  4. Offline


    I did what you told me to do, but it dident work :(
  5. Offline


    hm, please copy the file again...
  6. Offline


  7. Offline


  8. Offline


    Still not working :(
  9. Offline


    i'm testing this solution and it doesn't work either.

    normally if i want to move or delete a file that's is in use by the server
    windows start nagging about the file cannot be transfered (it's locked).
    if i play around with my world2 copy, windows never nags. So this file
    isn't in use by the server. I know the file is without errors, (switching
    default world in the server properties to world 2 works as expected)

    my config:

    world1.yml is located at server\plugins\permissions\world1.yml

    i've tried:


    and none of them seems to work.

    the difference between world1.yml and world2.yml is that
    the user is assigned to different group. in world2.yml he
    has a 'lower' permission.

    i'll keep on testing, untill i got the [beep] thing working.
    Maybe someone here can point me in a right direction ?

    Greetzzz Saturnine
  10. Offline


    its okay now :)
  11. Offline


    Thanks for the update. Moving to 2.5.3 fixed the issues I was having here.
  12. Offline


    ok then i dont have any idea... :( ill pass it to TheYeti (placing block error)
  13. Offline


    Aww, my permissions won't work! :(

    There's no errors in when I run the server. And I can't see anything wrong with my config file. The config got the same name as my world.
  14. Offline


    anyone having issues with myhome and permissions?
  15. Offline



    Multiworld Permissions WORK now! Thanks Yeti!

    You must have a YML file called the same as your default world, in the folder */plugins/permissions/. (EG: If you default world was called "world", then you must have "world.yml".)
    One additional YML file per world in the same location. For example the world "nether" would need a "nether.yml".

    If the additional world has the same permissions as another world (EG 'nether' has the same permissions as 'world') then this is what it'll look like (using the said example).
            system: default
            copies: world
    If the additional world has different permissions, then the file needs filled out in much the same was as your default world file.


    Personally, i have three worlds. My main/default world is "world", i have a nether world called "netherworld" which has the same permissions as "world" so it's like single player in a way. and finally the third world called 'worldedit' which gives everyone access to WorldEdit plugin. This is, if you like, a free-build world.

    Here are my example YML files for the three worlds, located in */plugins/permissions/ :

            system: default
            default: true
                build: true
                - 'general.afk'
                - 'general.spawn'
                - 'general.player-info'
                - '*'
            system: default
            copies: world
            system: default
            default: true
                 build: true
                - 'worldedit.*'
                - 'general.*'
                - '*'
  16. Offline


    i think u mean that u alway get "no permissions to do..." ? the file seems to be ok, although u could remove the two last points of the mod group cause they are unnecessary, but this shoulnd solve anything... i dont know, maybe first try out only one goup with one permission to be sure that it basically works...
    --- merged: Mar 7, 2011 7:55 PM ---
    ok, but would did u do, im interested...
    --- merged: Mar 7, 2011 8:00 PM ---
    thank u, ill ask theyeti to make a link in the OP to this post.
    and where do u put the additional files? (edit it in ur post)

    make them OPs or use an additional plugin which supports these commands, permissions only support the permission system not the commands...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  17. Offline


    Ok so I was told to upload my whole server for the community. Permissions isnt working for admins. I started with admins to see if I could get them in there to start setting up(starting with myself) I was testing with a couple commands and eventually just started listing everything out of frustration(as you can see)

    Here is a link to the server files:
    (16MB file)

    Thoughts and help would be greatly aperciated.
  18. Offline


  19. Offline


    Yes, it does! Thanks for your response. :)
  20. Offline


    Hmm..yea. But I still can't find anything wrong. Maybe it's a bug. Well, I will wait and see.
  21. Offline


    what the hell did u do? download the default yml file, to see the structure, u must indent the permissions!
    --- merged: Mar 7, 2011 9:08 PM ---
    ok ill take a look but may take some time...
  22. Offline


    Is it supposed to be 4 spaces?
  23. Offline


    yes no tabs use 4 spaces for each tab. or use notepad++ and ge to preferences -> tab settings -> replace tab with spaces
  24. Offline


    this is beyond rediculous. i go from using heyo wich makes permisions literaly as easy as possible to this. ive been trying to figure this out since yesterday and i have made zero progress becuase the instructions leave way too much unexplained. why doesnt somyone who actualy has this plugin working just post their YML file so we can all just copy/paste and edit it to what we need? ive read through every page on this (30+) and im still in the same spot as where i started.

    what im trying to do is simple, i just switched to bukkit a few days ago (as theres no other option)
    and just want to add the starget mod. to do this it needs permissions. i got this plugin, put it in the pluginsfolder followed by the world.yml (as my world name is world) in the permissions folder in the plugins folder.

    the permissions i need are


    it shouldnt be this hard to go from using a groups.txt for permissions to this. this uterly fails in comparison.

    all i want is for somyone to post a yml configuration with those permissions set to default for anyone who joins my sever.
    or for somyone to post their yml configuration so that i can edit it to somthing i can use.
  25. Offline


    you missed some ' at the end of 3 permissions @admins.
  26. Offline


    Thats what I am getting whenever I destroy a block. Or place one, for that matter.
  27. Offline


    here u go:
    --- merged: Mar 7, 2011 9:15 PM ---
    i dont really know how to get this error, but please copy ur yml file to, ill have a look at it
  28. Offline


    How is the file now?

    I don't seem to be getting any more errors specific to Permissions, but it doesnt seem to be working with loginmessage. Here is the error:

    16:13:01 [SEVERE] Could not pass event PLAYER_JOIN to LoginMessage
    at com.nijiko.permissions.Control.getGroup(
    at com.tahkeh.loginmessage.LoginMessagePlayerListener.sendMultiMessage(L
    at com.tahkeh.loginmessage.LoginMessagePlayerListener.onPlayerJoin(Login
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at net.minecraft.server.ServerConfigurationManager.a(ServerConfiguration
    at net.minecraft.server.NetLoginHandler.b(
    at net.minecraft.server.NetLoginHandler.a(
    at net.minecraft.server.Packet1Login.a(SourceFile:46)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetLoginHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:87)
    at net.minecraft.server.MinecraftServer.h(
  29. Offline


    @prismweed Here is an example of the configuration file from my main servers main world: My individual world files mostly are just setup like so:

            system: default
            copies: Home
  30. Offline


    yes the file is ok, the is the error only there when permissions is enabled?
  31. Offline


    Yes, LoginMessage works perfectly without permissions.
Thread Status:
Not open for further replies.

Share This Page