Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    No, but the having no permission includes placing blocks, even though they have build permission.
  3. Offline


    Take a look at this. I'm not sure what to do.
    Permisions Error.JPG
  4. Offline


    Windows 98? Dayum. Also, I don't think I am getting the errors, but I can't figure out why they can't build.
  5. Offline


    No what? No you don't want to give them any permissions? No you aren't getting the errors anymore?
  6. Offline

    Don Redhorse

    looking forward to it, any idea when you are ready to release? After I got my temp server up, I will switch to the 3.0 build and let you know which bugs I find.
  7. Offline


    It's actually windows XP.....
  8. Offline


    Perhaps he is set up with something special in Essentials. I don't remember if Essentials chat is built in to Essentials or if there is a separate plugin for it. If it is build in, you can check the settings there. If not, you will still need a chat plugin to display prefixes and suffixes.
  9. Offline


    Hey there im absolutely new with permissions and / or bukkit...
    I tried to set up permissions and if i start the server, I can see that permissions is loaded. but no matter what I do in the 'world.yaml', as long as I'm not OP, I can't build or destroy anything...
    I've changed the name of the Admin in the default permissions '.yaml' to my name, so I'm in the group 'Admins' that has build:true, I've set the default group to be able to build... nothing works... (yes, I've restarted the server so changes could take effect.)
    Pleace help me. Tell me what to do to be able to build without being OP.
  10. Offline


    I didn't download the essentials chat plugin, i checked everything in essentials and found nothing about ctsoccer being a admin. But the main thing he's a ADMIN and can do every single command and he's listed as a member....(ctsoccer)
  11. Offline


    Ok thanks, I'll ask on the plugin page then.
  12. Offline


    No, I haven't gotten those errors for a while. They stopped before anything I tried to do. But this is different. The players should be able to build because they have that enabled on them
  13. Offline


    Sorry, I thought we were looking at his red name. Did you fix the permissions problems from above? Any new errors? If everything is working as expected, then check the ops.txt file to make sure he isn't in there.

    Ah, you just said they couldn't do anything and didn't have permissions and not that they couldn't build. I just tested your permissions file on my test server and it allows me to build and doesn't give me access to any commands so I don't think it is that so without specifics on who and what they can't do, I'll be at a loss to tell what the problem is. Could you post your server.log with someone trying to build?

    The file should be named world.yml and not world.yaml. Also, if you have extensions turned off, it should be just world.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  14. Offline


    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    #   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    #   If this file is for your default world (the one in then you must
    #   leave copies blank.
    #  Example: copies: Derp    -  This will clone the permissions of the world Derp
    # Make sure to rename this file to the name of the world that is in under
    # level-name.  So if it is level-name: world  then this should be world.yml and in the
    # plugins/Permissions directory (ie. plugins/Permissions/world.yml)
    # NOTE: Do not use tabs while editing this document.  Use only spaces.  A good way to avoid
    # doing this is to use Notepad++ and replace the tab with 4 spaces.
            system: default
    # AntiBuild is included with this.  To disable a group from being able to build then
    # set the build: flag to false (build: false).  If you want a group to be able to build
    # then set it to true.
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:" like so:
    #   Example:
    #       inheritance:
    #           - Default
    #   All permissions including the asterisks must be placed in single quotes.
    #   like so:
    #       - ''
    #   Otherwise errors will happen!
    #   Globalized Permission settings:
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #           - 'foo.*'
    #       This will allow you to use all general commands.
    #   Single Asterisk denotes all commands:
    #       - '*'
    #   If you give a group this permissions, do not have the group inherit any permissions
    #   from other groups.  Any users assigned to this group should NOT be given any additional
    #   permissions either.
    #   To exempt a node use the - prefix like so:
    #       - ''
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #   such as iChat or HeroChat in order for these to do anything.
            default: true
                prefix: ''
                suffix: ''
                build: false
                - ''
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
                - ''
                - ''
                - ''
                - 'towny.wild.destroy'
                - 'towny.wild.item_use'
                - 'fight.user'
                - 'warpz0r.warp'
                - 'warpz0r.set'
                - 'warpz0r.home'
                - 'warpz0r.sethome'
                - 'warpz0r.remove'
                - 'fishpeople.lavasafe'
                - 'fishpeople.infiniteair'
                - 'fishpeople.extendedair'
                - 'lwc.protect'
                - ''
            default: false
                prefix: ''
                suffix: ''
                build: true
                - ''
            default: false
                prefix: ''
                suffix: ''
                build: true
                - '*'
    This Is what I have, and everyone in my server is Admin, which I dont want- I just want to be the admin. Everyone else is placed in the group Builder but me, but are all treated as admins. My op notepad only has my ign in it. I deleted Group Manager, too. Help now.
  15. Offline


    Nothing wrong with that so I'm guessing that you are getting errors in your server.log. Take a look and please post them if they are there. If you don't want to, then check to make sure your file is named <world name>.yml and it is in the plugins\permissions directory. If you have extensions off, then the file will be named <world name>.

    Also, check to make sure you are running 2.7.3 and not 2.7.1 or 3.0.
  16. Offline


    I am Running 2.7.3, and I have the file named as my world name, in my permissions directory.
    Does PlgEssentials, Towny, or iConomy disrupt Permissions?
  17. Offline


    They shouldn't. Only plugin that I know of that does is GroupManager.
  18. Offline


    Ok thanks anyways!
  19. Offline


    Whenever I try to run my 766 Bukkit server, I get this giant wall of error: 16:08:03 [SEVERE] Could not load 'plugins/Permissions.jar' in folder 'plugins': java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass( at at at$100( at$ at Method) at at at at java.lang.ClassLoader.loadClass( at java.lang.ClassLoader.loadClass( at java.lang.ClassLoader.loadClassInternal( at java.lang.Class.forName0(Native Method) at java.lang.Class.forName( at at org.bukkit.plugin.SimplePluginManager.loadPlugin( at org.bukkit.plugin.SimplePluginManager.loadPlugins( at org.bukkit.craftbukkit.CraftServer.loadPlugins( at net.minecraft.server.MinecraftServer.e( at net.minecraft.server.MinecraftServer.a( at net.minecraft.server.MinecraftServer.init( at at Umm, something like that. Anyone know what the issue is? I am also running the slap plugin on my server.
  20. Offline


    Update to Java v1.6. Permissions requires it.
  21. Offline


    Thanks so much!
  22. Offline


    -- Could someone take a look at my permissions --

    They were working a few days ago, the Mayor and SIC section, now they don't have permission to use it.

    Also latest 64 bit of Java.

    Per 2.7.3
    WG Alpha 10
  23. Offline


    I'm not seeing anything wrong with it. What errors are you seeing?
  24. Offline


    That's the thing, there are none, all my user's including my test account.

    After I set the user's with and current
    "group: "

    We get the command "You do not have permission to use this command," It was fine a day ago, and /pr -reload all show's no internal error, no nothing in the nogui cmd.


    Edit: And I double checked the flags for WG.. :(
  25. Offline


  26. Offline


    I'll actually need specifics. For example, a couple days ago I was helping someone who kept telling me something didn't work and it all came down to that person not having the permissions to that command.

    One thing to try thought would be to add back the permissions tags to all the users. It really isn't optional.

    Every node after inheritance and permissions needs to be moved over 1 space.

    I've seen this now a few times in the last couple days. May I ask what plugin you use to modify your permissions? I'm now curious if the YAML editor has been updated recently and if we are going to see this a lot more.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  27. Offline


    Can anyone help me, i cant get rid of this error:


    while parsing a block collection
    in "<unicode string>", line 69, column 13:
    - ''
    expected <block end>, but found '<scalar>'
    in "<unicode string>", line 83, column 16:
    - ''

    **** Second Arrow is under bar

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  28. Offline


    I'm editing my permissions manually,throught notepad:D
    But wait, yesterday everything was fine!Maybe yaml was updated?
  29. Offline


    5 messages in under 5 minutes in 2 different threads. Now that is some spam. For the future, you can actually edit your post.

    As for what is broken, you are probably missing a closing ' on some line but we won't be able to tell if you don't post your permissions file in code blocks.
  30. Offline


    <All world guard related> <WG section has 0 help>
    Alright so, as you can see in the pastie i have set flags for world guard related stuff.
    few days ago my users could set there /region flag <name> pvp deny, and whatever world guard flags I gave them and allowed them.

    Now they can do /region info <region>, but not the flags, and they WERE working 99.9% for the longest time.

    The only thing I can recall was changing flags.* to specific flags only, at that time when I tested, it was 100% working, either or, the only reason I wanted to change it is so that user's can not change the mob-spawning flag, that's why I had to go through the process of setting each flag.

    Hope that helped.
  31. Offline


    Almost exactly looking error,i got this when i deleted quotes in prefix: field.
    WTF is going on?
Thread Status:
Not open for further replies.

Share This Page