Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    I don't see anything for a YAML to SQL conversion, lots of SQL to YAML though. Mind linking/PMing one in specific?

    The only thing holding up my server currently is how badly this SQL tables are set up for this. I can't mind hide nor hair of how to set it up.

    An alternative, is a screen shot of someone else's tables on a server using the SQL Permissions. Either one works.

    Or more easily, in what table to do I add the ability to Build. I should have almost all the other Permissions set up, but nobody can build.

    *edit* haha! I figured it out /permissions g:admin info set build b:true
  3. Offline


    I know that the 12 plugin problem has been brought up before, however I think that is it a real problem. My server also has this problem and as long as I have less than 13 plugins, permissions runs perfectly (3.1.4). However, any combination of 13 or more plugins completely breaks permsissions, throws countless errors into my log file, and makes everyone go to the default group. This leads me to believe that it is not the other plugins' fault, but actually a flaw in permissions.
  4. Offline


    Can you guys help me? I've had this problem before. I'm a Co-Owner and can't use any commands, but everyone else has a red name and can. Theres no errors on my server log. But this is my group config file. Im sure there's a screw up here hopefully...
            default: true
                prefix: '&7'
                suffix: ''
                build: false
                - ''
                - 'essentials.msg'
                - 'essentials.rules'
                - 'essentials.list'
            default: false
                prefix: '&1'
                suffix: ''
                build: true
                - Guest
                - 'essentials.depth'
                - 'essentials.getpos'
                - 'essentials.compass'
                - ''
                - 'essentials.home'
                - 'essentials.sethome'
                - 'essentials.warp'
                - 'essentials.warplist'
                - 'essentials.setwarp'
                - 'essentials.spawn'
                - 'essentials.mute'
                - 'essentials.item'
                - 'essentials.tpa'
                - 'essentials.tpaccept'
                - 'essentials.tpdeny'
                - 'essentials.clearinventory'
        Elite Builder:
            default: false
                prefix: '&a'
                suffix: ''
                build: true
                - Builder
                - 'essentials.nick'
                - 'essentials.give'
                - 'essentials.jump'
            default: false
                prefix: '&3'
                suffix: ''
                build: true
                - Elite Builder
                - 'essentials.ban'
                - 'essentials.tempban'
                - 'essentials.kick'
                - 'essentials.kickall'
                - 'essentials.unban'
                - 'essentials.togglejail'
                - 'essentials.jail.exempt'
                - 'essentials.setjail'
                - 'essentials.deljail'
                - 'essentials.jails'
                - 'essentials.invsee'
                - 'essentials.time'
                - 'worldedit'
                - 'worldedit.selection'
            default: false
                prefix: '&4'
                suffix: ''
                build: true
                - '*'
            default: false
                prefix: '&5'
                suffix: ''
                build: true
                - '*'
            default: false
                prefix: '&e'
                suffix: ''
                build: true
                - '*'
  5. Offline


    I'm having sort of this problem, and so I tried manually doing it with >pr <username> parents add <current-parent>. However when I did that, it added me to EVERY group, or so it seems. The result of this is that I can run most of the commands for the new group (/warp, /jump, even worldedit stuff and /pr -list worlds), but I can't build whatsoever, and any /pr commands I try that act on users, will fail, telling me I don't have permission. I can build in the nether and main worlds... this only seems to affect my world that was created with SphereWorld. I even tried disabling WorldGuard entirely... not really sure what could be causing it, at this point. Anyone else run into this before?

    Here are my configs, as well as some output from the server console while I was testing:
  6. Offline


    No one has ever said it was the other plugins fault just that removing some other plugins fixes things. The dev hasn't stopped looking for the cause of it nor has the devs of those plugins listed at the top stopped either. And it isn't some pick 12 plugins and it fails. Some people are running 90+ plugins with 3.x without any trouble..

    There was only one thing that one parser didn't like in that file and that was the space in "Elite Builder" but I don't think that is your problem. When you say everyone has a red name, what exactly does that mean? Are they all admins and you are the only one who isn't? Do you know if you are actually in the Co-Owner group? And what version of Permissions are you running? You may need to post your server.log and the rest of your files to be able to help.

    A couple things here. The first is that the global files aren't working quite as well as they should so they need to remain empty for now. Second is that the promote command isn't working in 3.1.4. Looking at the one file you posted, everything looks okay there.

    Your file works on my test server so I'm guessing the problem is in another file. Are your global files and your storageconfig.yml empty? Also, you might want to post your server.log.

    Promote/demote is broken in 3.1.4.

    Are you sure you aren't getting an error like:
    Caused by: while parsing a block mapping
     in "<reader>", line 82, column 13:
                    prefix: '&eModerator[WE]&f
    expected <block end>, but found Scalar
     in "<reader>", line 88, column 16:
                    - 'worldedit.*'
    because you have a problem in your groups.yml. If you aren't getting that error, then your files aren't in the right place. If you are getting that error, then the fix will be to add a closing quote to line 82. Your prefix is missing that.
            default: false
                prefix: '&eModerator[WE]&f
    I looked up one but I have no idea if it is the right one. Probably better if you did the search but you can find it here.

    As for the tables, you don't set those up and neither does the Perl script. When you set Permissions to use SQL, the first time you launch it the tables will be set up.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  7. Offline


    Quick question. Is there a cheat sheet on how to set up groups and permissions and everything using MySQL for this plugin? I am having some luck looking at the GitHub wiki, but nothing that makes as much sense as the YMAL guides. If not the big speedbump I am hitting how is how do you add a User to a group. I made a group but how do I add a user to that group in MySQL?

    If someone can help my through a few speed bumps like this so I can fully understand how the MySQL database is organized, I will do my best to write up tutorials and everything on the github wiki for any newcomers.
  8. Offline


    Hi Guys,
    I am trying to write a plugin and need to get the Group of the Player, but don't know which method to use. Can anyone tell me this? Thanks for helping :D
    Awesome Plugin btw ;)

    And how should this work? You got any sample code so I can learn by looking? ;) Thank you though^^
    My Problem is that these methods need more than one String, bu I don't know what these Strings are. It just says arg01, arg02, ... This is why I need help^^

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  9. Offline


    ph.getGroup() for 2.7 and 2.7 compatibility in 3.x or ph.getGroups() for full 3.x support.

    There isn't anything for this that I know of and I think it would be hard to write. Everyone using SQL is doing so for their own reasons and that makes it hard to tell someone how best to do it the way they want. As for the available commands, they are the same no matter which format you pick.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 10, 2018
  10. Offline


    i know the commands are all the same, but I am trying to setup the default group and I am having trouble like setting the prefix and such. I am able to add users to groups now and add permissions to that group, but how do I add a prefix or other data as such to the database.

    I am using a PHPMyAdmin interface for the database.


    Actually I think I am going to try to do it through the permissions command line commands. Just wondering where should the prefix and suffix come into play? Just so I know if they are working in game.
  11. Offline


    I tried removing the global files entirely and letting Permissions regenerate them, but it's still showing the same behavior. I found out though, that it seems like on all three worlds I can build, but only in some chunks. On the other chunks, the blocks just revert immediately, with no message to my chat, or to the server console. I suspected it might be a WorldGuard problem, but I've been removing the entire world folders and regenerating them a few times during this process, and that hasn't seemed to help either. The chunks I can edit in do seem to stay put... they don't move around between stop/start of the server, or login/logout. Any thoughts on what I might try next?

    The part that really bothers me is this:
    >pr dUc0N w:main parents listall
    00:41:11 [INFO] [Permissions] Parents: Group Admin in main, Group  Moderator in main, Group Elite in main, Group Member in main, Group  Visitor in main
    That's with a users.yml that looks like this:
    [mineserv@inquisitor Permissions]$ cat main/users.yml
            - Admin
    Is that the right behavior, that it should be inheriting every group below the one I'm in? In my groups.yml file, every group starting from the least-privileged one inherits from the rank right below it, except the superuser one, which inherits nothing and gets '*'. The only other funky thing I did is give the visitor group '-*' so I could be sure I was starting with a blank slate and adding permissions for security reasons... but I tried commenting out that line and it didn't help at all.

    Probably time for me to give it up for tonight so I can get some sleep... but if nothing else, then tomorrow I might try disabling plugins one at a time until the problem stops. Then I'll at least have some idea where the issue is at, for sure.
  12. Offline


    The building problems seem like they might come from having permissions in the global files. Same as with any strangeness around the commands. As for your listall, I would expect exactly that output. You are currently in Admin and it inherits from all of those groups so it is listing them all. And only being able to build in certain areas sure seems to be a problem with WorldGuard.

    You can take a look at the sample code here or look at any of the chat plugins which would use the getGroup() call for the prefix.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  13. Offline


    Yes, my global files and storageconfig.yml are empty. My server log doesn't contain any errors; just the plugins loading.
    148 recipes
    16 achievements
    12:24:33 [INFO] Starting minecraft server version Beta 1.6.6
    12:24:33 [INFO] Loading properties
    12:24:33 [INFO] Starting Minecraft server on *:30005
    12:24:33 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-767-
    g14a36a7-b819jnks (MC: 1.6.6)
    12:24:33 [INFO] Preparing level "world.biome"
    12:24:33 [INFO] Preparing start region for level 0
    12:24:33 [INFO] Preparing start region for level 1
    12:24:34 [INFO] [WormholeXTremeWorlds][v0.4][By alron]Load Beginning.
    12:24:34 [INFO] [WormholeXTremeWorlds]Config Loaded
    12:24:34 [INFO] [WormholeXTremeWorlds][v0.4]Load Completed.
    12:24:34 [INFO] [Permissions] (Yeti) was initialized.
    12:24:34 [INFO] MoveCraft 0.6.8 Final Beta plugin enabled
    12:24:34 [INFO] [WormholeXTremeWorlds][v0.4]Enable Beginning.
    12:24:34 [WARNING] [WormholeXTremeWorlds]Not a supported version of Permissions.
     Recommended is 2.7.x
    12:24:34 [INFO] [WormholeXTremeWorlds]Attached to Permissions version 3.1.4
    12:24:34 [INFO] [WormholeXTremeWorlds]Help plugin is not yet available; there wi
    ll be no Help integration until it is loaded.
    12:24:34 [INFO] [WormholeXTremeWorlds][v0.4]Enable Completed.
    12:24:34 [INFO] [AncientGates v1.0.2] Loading conf from disk
    12:24:34 [INFO] [AncientGates v1.0.2] Loading gates from disk
    12:24:34 [INFO] [AncientGates v1.0.2] Enabled
    12:24:34 [INFO] [FishPeople] version 1.6 is enabled!
    12:24:34 [INFO] [FishPeople] using permissions
    12:24:34 [INFO] [Superheat] Enabled.
    12:24:34 [INFO] [Permissions] version [3.1.4] (Yeti)  loaded
    12:24:34 [INFO] [Citizens]: version [1.0.8f] (Realist) loaded
    12:24:34 [INFO] [Citizens]: Permissions enabled.
    12:24:34 [INFO] Done (0.113s)! For help, type "help" or "?"
    12:24:34 [INFO] [Citizens]: Loaded 0 NPCs.
  14. Offline


    Make sure you aren't mirroring permissions for worlds (parent and child permissions) It will make the child so that some users can't build (users that don't have a rank)
  15. Offline


    Since you don't actually have any permissions to any of your other plugins, have you tried to remove them to see if it fixes things?
  16. Offline


    Hey there, plugin dev trying to deal with a bug report between my plugin and permissions. Is there a reason why a call to getGroups would give a NullPointerException? Also, is the source on GitHub up to date? It looks relatively untouched.
    12:31:34 [SEVERE] Could not pass event PLAYER_JOIN to rTriggers
            at java.util.ArrayDeque.addLast(Unknown Source)
            at java.util.ArrayDeque.add(Unknown Source)
            at com.nijiko.permissions.Entry.getAncestors(
            at com.nijiko.permissions.ModularControl.getGroups(
            at com.reil.bukkit.rTriggers.rTriggers.getMessages(
            at com.reil.bukkit.rTriggers.rTriggers.triggerMessages(
            at com.reil.bukkit.rTriggers.rTriggers.triggerMessages(
            at com.reil.bukkit.rTriggers.rTriggersPlayerListener.onPlayerJoin(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.ServerConfigurationManager.c(
            at net.minecraft.server.NetLoginHandler.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.Packet1Login.a(SourceFile:43)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
            at net.minecraft.server.MinecraftServer.h(
    The call in question goes like this:
    if (triggerer != null){
    	. . . .
    	if(PermissionsPlugin != null) groupArray.addAll(Arrays.asList(PermissionsPlugin.getGroups(triggerer.getWorld().getName(),triggerer.getName())));
  17. Offline


    The code is hiding under the experimental branch.

    As for the error, those usually show up when there is some problem with their permissions files. Most of the time when they set up their users.yml file with group tags and not the correct groups tag. Ask them for their full server.log and permissions files.
  18. Offline


    For some reason when I am using a MySQL database the default group on a world does not work. Is this a common problem or do I probably have something configured wrong?
    gamingvortex likes this.
  19. Offline


    There is alot of posts and i have gone thourgh all and just got confused. I have switched from 2.* to 3.1.4

    I have got the permissions to work with my MYSQL Database but although the original YML groups and users have my name in them i come up default, So i thought to look in the database. I cant find anything which allows me to assign me the group i want. Any help?
  20. Offline


    I have mine in the plugins\permissions folder and its called world.yml which is the name of my world so what could it be?
  21. Offline


    Permissions is rewriting my users.yml file while adding people who are on the server the first time auch as:

    The issue is that it is rewriting also all other users in the list, but wrong:
                - guest
    this above is rewritten to this here:
            - guest
    While permissions works fine with this wrong indentation, this is a different data that is screwing with other programs reading the permissions data. The way permissions writes this file, it lists "groups" and "-guest" as a sub-value of the user instead of the value "guest" as a sub-value of "groups".

    This is highly urgent and NEEDS to be fixed ASAP.
  22. Offline


    Every time i use this no one in the server can do anything and i put myself in the admin group and make build true but nothing happens any help?

    i need alot of help i cant even get mine to let me place blocks

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  23. Offline


    Such a great plugin !
    That's all i wanted to say :)
  24. Offline


    I dont get how to use globalusers/groups. Any time i copy exact content of the working file from any world
    (ex. world1/ users) in there (globalusers), it does not work!
  25. Offline


    Have you read thru the Threads @ Oberschlumpel ?
    The globalgroups & globalusers don't have any function at this time. And we don't know exactly how it will be implemented in Permissions at this time.


    Edit: So for now. Just use the normal folders like: plugins/permissions/yourworldfolder/groups.yml and users.yml
  26. Offline


    I did. I still can't place blocks!

    ... solved.

    So I went back and disabled all of my plugins for about the sixth time and went through the installation instructions. My mistake was that I hadn't copied the users.yml and groups.yml files from the root directory into my worlds directories.

    Thank you Jeyge for your help!
  27. Offline


    That did something this morning, at least... now it seems like I can build anywhere on the main world, but nowhere on sphere/nether. So at least it's failing in a way that makes more sense. I'll crawl back through the WorldGuard stuff tonight after work, and if I can't straighten it out that way, maybe try disabling plugins one at a time again, or even working from a fresh install.

    On a side note, was there a command to tell Permissions to write its current configs to the files? Can't seem to find it anywhere, but I could be thinking of another mod.
  28. Offline


    Does this work properly with McMyAdmin?
  29. Offline


    Does the Plugin function with anyone of you???
    In this Thread are just Postings where the people say that there ist an error or it doesn't work...
  30. Offline


    Thats the problem exactly.
    Inside your storageconfig.yml file don't use world mirroring, it doesn't work correctly.
            type: YAML
    Is what mine looks like (just default)
    If you want the same permissions for both worlds copy them from the world you had set as parent into the world you wanted to be child

    Not for me

    It works just some aspects of it don't. We are notifying and helping people with the problems they have. Sharing individual problems is part of the solution.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  31. Offline


    Can someone who knows of the Global files problem (McMyAdmin writes to Globals: world files get generated automaticaly, and then Globals don't work) please at least let us all know if this problem is still considered a bug or whether it's down to user config becuase atm it's almost impossible to use McMyAdmin and Permissions together.

    I've posted this twice now and can never get a straight answer from anyone who is at least in some way affiliated with the plugin. If it is a config problem then I can report it to PhonicUK; if it is a problem with the plugin (which Phonic says it is) then I would at least like to know that it's being looked at and not just forgotten.
Thread Status:
Not open for further replies.

Share This Page