Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Ok, with 2.7.4 everything works fine. We shall wait for the update and then upgrade to 3

    Thanks for the help.
  3. Offline


    Haha, dont worry. Ill probably make another more detailed tutorial later. I will make sure the scrolling is slower and the resolution is bigger on that one.
  4. Offline


    While this seems to work, users can now no longer check their stats in mcMMO, or use warps (I use xWarp plugin), things like that. Are these plugins simply not compatible with 3.1.1?
  5. Offline


    Thanks, Works great!
  6. Offline


    ok so i tried getting the same permisions, and deleting mywarp no luck any more ideas ?
    148 recipes
    16 achievements
    19:26:29 [INFO] Starting minecraft server version Beta 1.6.6
    19:26:29 [INFO] Loading properties
    19:26:29 [INFO] Starting Minecraft server on *:25565
    19:26:29 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-
    g3fc0460-b818jnks (MC: 1.6.6)
    19:26:29 [INFO] Preparing level "world"
    19:26:29 [INFO] Preparing start region for level 0
    19:26:30 [INFO] Preparing spawn area: 97%
    19:26:30 [INFO] Preparing start region for level 1
    19:26:31 [INFO] [Permissions] (Yeti) was initialized.
    19:26:31 [INFO] [ColorMe] v2.2 has been enabled.
    19:26:31 [INFO] [CommandSigns] 0.8.5 enabled.
    19:26:31 [INFO] CommandSigns: Integrated with Permissions
    19:26:31 [SEVERE] java.lang.NullPointerException
    19:26:31 [SEVERE]       at com.herocraftonline.dthielke.herochat.util.ConfigMana
    19:26:31 [SEVERE]       at com.herocraftonline.dthielke.herochat.util.ConfigMana
    19:26:31 [SEVERE]       at com.herocraftonline.dthielke.herochat.HeroChat.onEnab
    19:26:31 [SEVERE]       at
    19:26:31 [SEVERE]       at
    19:26:31 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.enablePlugin(Si
    19:26:31 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftSe
    19:26:31 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    19:26:31 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServe
    19:26:31 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    19:26:31 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftSe
    19:26:31 [SEVERE]       at
    19:26:31 [SEVERE]       at
    19:26:31 [WARNING] [HeroChat] Error encountered while loading data. Check your c
    onfig.yml and users.yml. Disabling HeroChat.
    19:26:31 [INFO] [HeroChat] HeroChat version 4.10.3 disabled.
    19:26:31 [INFO] [HeroicDeath] enabled.
    19:26:31 [INFO] 280
    19:26:31 [INFO] 50
    19:26:31 [INFO] [Jail] Loaded 1 jail zones.
    19:26:31 [INFO] [Jail] Loaded 2 prisoners.
    19:26:31 [INFO] [Jail] Loaded 0 cells.
    19:26:31 [INFO] [Permissions] version [3.1.2] (Yeti)  loaded
    19:26:31 [INFO] [HeroChat] Permissions 3.1.2 found.
    19:26:31 [INFO] [Permissions] SQL Interface enabled!
    19:26:31 [INFO] PlgEssentials version 4.6 is enabled!
    19:26:31 [INFO] PlgSetspawn version 4.1 is enabled!
    19:26:31 [INFO] [SimpleSign] Permissions system detected!
    19:26:31 [INFO] [SimpleSign] Version 1.3 has been enabled!
    19:26:31 [INFO] [WeatherControl] Loaded configuration for world 'world'
    19:26:31 [INFO] [WeatherControl] Loaded configuration for world 'world_nether'
    19:26:31 [INFO] [WeatherControl] version 0.8.2 is enabled!
    19:26:31 [INFO] WorldEdit 4.4 enabled.
    19:26:31 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
     for permissions.
    19:26:31 [INFO] Done (0.259s)! For help, type "help" or "?"
  7. Offline


    That would be a different error so what we did before did fix the error you had and you now have a new error. Looks like your HeroChat config files aren't set up correctly. I don't know anything about HeroChat so I can't help with the error you have but you might find someone in the HeroChat thread that will know what to do.
  8. Offline


    as soon as i got rid of herochat to see if that effected it this came up:
    148 recipes
    16 achievements
    19:38:09 [INFO] Starting minecraft server version Beta 1.6.6
    19:38:09 [INFO] Loading properties
    19:38:09 [INFO] Starting Minecraft server on *:25565
    19:38:09 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-
    g3fc0460-b818jnks (MC: 1.6.6)
    19:38:09 [INFO] Preparing level "world"
    19:38:09 [INFO] Preparing start region for level 0
    19:38:10 [INFO] Preparing spawn area: 89%
    19:38:11 [INFO] Preparing start region for level 1
    19:38:11 [INFO] Preparing spawn area: 97%
    19:38:12 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko
    .permissions.ModularControl$1RefreshTask from class com.nijiko.permissions.Modul
    19:38:12 [SEVERE]       at com.nijiko.permissions.ModularControl.<init>(ModularC
    19:38:12 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    19:38:12 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    19:38:12 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    19:38:12 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServe
    19:38:12 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    19:38:12 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftSe
    19:38:12 [SEVERE]       at
    19:38:12 [SEVERE]       at
    19:38:12 [SEVERE] [Permissions] Unable to load permission data.
    19:38:12 [INFO] [Permissions] Shutting down Permissions due to error(s).
    19:38:12 [INFO] [Permissions] (Yeti) was initialized.
    19:38:12 [INFO] Backup v1.6 was sucessfully loaded!
    19:38:12 [INFO] [ColorMe] v2.2 has been enabled.
    19:38:12 [INFO] [CommandSigns] 0.8.5 enabled.
    19:38:12 [INFO] CommandSigns: Integrated with Permissions
    19:38:12 [INFO] [HeroicDeath] enabled.
    19:38:12 [INFO] 280
    19:38:12 [INFO] 50
    19:38:12 [INFO] [Jail] Loaded 1 jail zones.
    19:38:12 [INFO] [Jail] Loaded 2 prisoners.
    19:38:12 [INFO] [Jail] Loaded 0 cells.
    19:38:12 [INFO] [MYWARP]: 39 warps loaded
    19:38:12 [INFO] [MYWARP] Permissions enabled using: Permissions v3.1.2
    19:38:12 [WARNING] [MYWARP] 'Help' isn't detected. No /help support.
    19:38:12 [INFO] MyWarp 1.10.7 enabled
    19:38:12 [INFO] [Permissions] version [3.1.2] (Yeti)  loaded
    19:38:12 [INFO] [Permissions] SQL Interface enabled!
    19:38:12 [INFO] PlgEssentials version 4.6 is enabled!
    19:38:12 [INFO] PlgSetspawn version 4.1 is enabled!
    19:38:12 [INFO] [SimpleSign] Permissions system detected!
    19:38:12 [INFO] [SimpleSign] Version 1.3 has been enabled!
    19:38:12 [INFO] [WeatherControl] Loaded configuration for world 'world'
    19:38:12 [INFO] [WeatherControl] Loaded configuration for world 'world_nether'
    19:38:12 [INFO] [WeatherControl] version 0.8.2 is enabled!
    19:38:12 [INFO] WorldEdit 4.4 enabled.
    19:38:12 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
     for permissions.
    19:38:12 [INFO] Done (0.273s)! For help, type "help" or "?"
  9. Offline


    Alright, thanks! For the record I'm also having problems with whatever mod controls /sethome, /home and similar goodies. Bad news bears!

    Back to 2.7.4 I gooooooooo..
  10. Offline


    That would be the error I was expecting before which means you need to remove MyWarp.
  11. Offline


    cool :D thats works now, does that mean i cannot use any warps?
  12. Offline


    Not for now. You can also switch back to 2.7.4 if you need them though and wait for a fix.
  13. Offline


    why is the promote command so long ? this is big shit <.<
  14. Offline

    Don Redhorse

    well yes... the search tool is... forgettable... you are lucky though that the thread is just 43 pages atm.. :)

    sorry by ranting so much, but if you READ the full thread you get the impression that almost nobody reads it, just posts his problem and demand a step by step solution to it.. and if that is not given in 4,53483423 minutes top it is demanded that the plugin needs rewritten, bugfixed and the world is saved ... in 2 minutes..

    because you should stick to 2.x and permissions plus.. as it looks like you don't need the new features of 3.x

    correct, remove it or stick to 2.x atm.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  15. Offline


    I sure give a lot of leeway in this thread as it is sometimes hard to know that the problem someone else had is the same as yours but when you look at the rest of the forums, you just see the same posts over and over again. They don't even read the previous post which will a lot of times answer the question they had. And the whole 818?????/Update now plox crap just gets really old. I honestly would be happy to update the FAQ now that I know I can but then I'll just be saying "Take a look at the FAQ" instead of "Remove MyHome/MyWarp". Doesn't look like it saves me many characters.
  16. Offline


    Hello everyone ;)
    I am using Bukkit 818 and Permissions 3.1.2. But whenever I try to use a command like "/permissions -reload" it says that I am not allowed to do that.
    Here ist my groups.yml (server/plugins/Permissions/spielewiese/groups.yml):

    and here my users.yml (server/plugins/Permissions/spielewiese/groups.yml):

            type: YAML
    My world and servername:
    server-name=GrillGuth's Spielewiese ;)

    I dont know what I have done wrong :)

    Thanks for helping,
  17. Offline


    very funny, permissionplus is shit too <.< i miss the simply /promote from hmod, why nobody can make this simply command, nobody needs so long commands
  18. Offline


    Getting this on startup with 3.1.2 on Bukkit 818

    Show Spoiler

    2011-06-03 13:18:50 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko.permissions.ModularControl$1RefreshTask from class com.nijiko.permissions.ModularControl
    2011-06-03 13:18:50 [SEVERE] at com.nijiko.permissions.ModularControl.<init>(
    2011-06-03 13:18:50 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-06-03 13:18:50 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-06-03 13:18:50 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-06-03 13:18:50 [SEVERE] at net.minecraft.server.MinecraftServer.e(
    2011-06-03 13:18:50 [SEVERE] at net.minecraft.server.MinecraftServer.a(
    2011-06-03 13:18:50 [SEVERE] at net.minecraft.server.MinecraftServer.init(
    2011-06-03 13:18:50 [SEVERE] at
    2011-06-03 13:18:50 [SEVERE] at
    2011-06-03 13:18:50 [SEVERE] [Permissions] Unable to load permission data.
    2011-06-03 13:18:50 [INFO] [Permissions] Shutting down Permissions due to error(s).
    2011-06-03 13:18:50 [INFO] [Permissions] (Yeti) was initialized.
  19. Offline


    You need to change group: to groups: in your users.yml file.
    The need for all those parameters is caused by everyone wanting multi-group support. The commands need to know what you want to do and what group you want it done to. Along with the whole multi-world part adding a world parameter.

    If you have MyHome and/or MyWarp, you will want to remove them. If not, try removing FalseBook/CraftBook and/or BigBrother. If none of those work, start removing plugins until you find the one it doesn't like. Or if you don't like any of the above, switch back to 2.7.4 until there are fixes for this.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
    GrillGuth likes this.
  20. Offline


    I understand this, but not all players need different groups for other worlds, i use now groupmanager again, this is old but in my opinion the best
  21. Offline

    Don Redhorse

    well... there is a learning effect... sometimes... if the FAQ really covers a lot (atm not really) and is helpfull you can point people to it... some people will skim the thread... some people will read the faq by themself... the others...

    well you need to be firm, point them to the faq.. thats it.. ignore them till they come back with something which is not in the faq.

    I started a thread about the problem we have here in the web suggestion forum. This is plugin RELEASES not HELP. It is a pita to find anything useful in threads which have more than 20 pages. I did forum support for 8 years for a big company with posting 400 messages every week on top of my normal work, but every product did have at least one subforum, so everybody could post a new thread, sometimes people could even see directly a problem they had in the title and the search did WORK.. something which isn't the case here.

    ATM the forums lag the capability to support a support forum, it would be fine for JUST releases but in this way with threads at more than 100 pages, people just posting without reading and a not working search I don't see a better future.

    which is sad, because the only alternative would be that developers would move the stuff OFF from here and just post release threads and force people to go to their own forum or use bug trackers.

    There needs to be a change, especially when fill arrives.. but there is no information from the higher powers, like always.

    Don't get me wrong, without the bukkit team and the developers Minecraft wouldn't be what it is now, but the lack of communication and community involvement is a poor view IMHO.

    Without people like you and some others and plugin developers who go the extra mile I would think a lot more people would drop bukkit and minecraft, and those admins who know their stuff and need only some specific help would be drowned in the flood of messages like I need a video to understand that.. post one .. tl:dr here is my UNIQUE problem, everything is configured right.

    I'm not without error but I invest a lot more time than 80% in the forums by reading through all the same stuff again and again and trying to find the information I need, I even have a TEST server where I test the plugins first before I roll them out on our play server.. something 95% of the "admins" here don't do.

    What's the song again from BlackEyedPears... we are the NOW generation.. :-(
    Jeyge likes this.
  22. Offline


    I get this error. I am using the full zip with no other plugins installed (Test server).

    148 recipes
    16 achievements
    20:43:58 [INFO] Starting minecraft server version Beta 1.6.6
    20:43:58 [INFO] Loading properties
    20:43:58 [INFO] Starting Minecraft server on *:25565
    20:43:58 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-
    g3fc0460-b818jnks (MC: 1.6.6)
    20:43:58 [INFO] Preparing level "world"
    20:43:58 [INFO] Preparing start region for level 0
    20:43:59 [INFO] Preparing start region for level 1
    20:43:59 [INFO] Preparing spawn area: 36%
    20:43:59 [SEVERE] [Permissions] storageconfig.yml is not a file.
    20:43:59 [INFO] [Permissions] Shutting down Permissions due to error(s).
    20:43:59 [SEVERE] [Permissions] storageconfig.yml cannot be read.
    20:43:59 [INFO] [Permissions] Shutting down Permissions due to error(s).
    20:43:59 [INFO] [Permissions] Creating storageconfig.yml.
    20:43:59 [INFO] [Permissions] (Yeti) was initialized.
    20:43:59 [INFO] [Permissions] version [3.1.2] (Yeti)  loaded
    20:43:59 [INFO] [Permissions] SQL Interface enabled!
    20:43:59 [INFO] Done (0.148s)! For help, type "help" or "?"
  23. Offline


    Hence the optional parameters but it is always best to run whatever plugin you want.
  24. Offline


    but the tracks are not optional and i think this is unnecessary
  25. Offline


    Run it a second time. There are a lot of plugins that create config files and require a restart to complete that step.

    You don't have to use promote to put someone in a group. It all depends on how complex your server is and how often you move people around. For me, I have no problem with the length of any of the commands he has right now but that might come from my typing speed and accuracy.

    Edit - I should add that accuracy doesn't mean I can spell.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 10, 2018
  26. Offline


    Thanks Jeyge, That did update the files and I added everything from my old YML files to the new ones. I made it so the global groups and users are the same as the "world" groups and users.

    148 recipes
    16 achievements
    20:51:30 [INFO] Starting minecraft server version Beta 1.6.6
    20:51:30 [INFO] Loading properties
    20:51:30 [INFO] Starting Minecraft server on *:25565
    20:51:30 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-
    g3fc0460-b818jnks (MC: 1.6.6)
    20:51:30 [INFO] Preparing level "world"
    20:51:30 [INFO] Preparing start region for level 0
    20:51:31 [INFO] Preparing start region for level 1
    20:51:31 [INFO] Preparing spawn area: 81%
    20:51:32 [SEVERE] unacceptable character #FFFD special characters are not allowe
    in "<reader>", position 0
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.reader.StreamReader.checkPrintable
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.reader.StreamReader.update(StreamR
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.reader.StreamReader.peek(StreamRea
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.reader.StreamReader.peek(StreamRea
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToke
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreToken
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(Sca
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDoc
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(Parser
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(Parse
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.getSingleNode(Co
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.constructor.BaseConstructor.getSin
    20:51:32 [SEVERE]       at org.yaml.snakeyaml.Yaml.load(
    20:51:32 [SEVERE]       at com.nijiko.configuration.NotNullConfiguration.load(No
    20:51:32 [SEVERE]       at
    20:51:32 [SEVERE]       at<init>(YamlUserStorag
    20:51:32 [SEVERE]       at
    20:51:32 [SEVERE]       at
    20:51:32 [SEVERE]       at com.nijiko.permissions.ModularControl.forceLoadWorld(
    20:51:32 [SEVERE]       at com.nijiko.permissions.ModularControl.loadWorld(Modul
    20:51:32 [SEVERE]       at com.nijiko.permissions.ModularControl.load(ModularCon
    20:51:32 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    20:51:32 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    20:51:32 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    20:51:32 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServe
    20:51:32 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    20:51:32 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftSe
    20:51:32 [SEVERE]       at
    20:51:32 [SEVERE]       at
    20:51:32 [SEVERE] [Permissions] Unable to load permission data.
    20:51:32 [INFO] [Permissions] Shutting down Permissions due to error(s).
    20:51:32 [INFO] [Permissions] (Yeti) was initialized.
    20:51:32 [INFO] [Permissions] version [3.1.2] (Yeti)  loaded
    20:51:32 [INFO] [Permissions] SQL Interface enabled!
    20:51:32 [INFO] Done (0.127s)! For help, type "help" or "?"
    20:51:42 [INFO] YavaY [/] logged in with entity id 6 at (1.125,
     71.0, 2.34375)
    20:51:49 [INFO] <YavaY> helllo
    20:51:52 [INFO] <YavaY> shit.
    I don't think it even loaded permissions? :S.

    EDIT: And now I can't even access the global YML files. It's saying I need to choose encoding language. (Im using Microsoft word).
  27. Offline


    I for one have caused a lot of the 2 Permissions threads growing so much. I could simply fix everything for everyone but I feel as though it is better if they learn what needs to change and why so they will be able to do it again the next time they need to. This sometimes takes 2-3 or even 15 posts and I'm bad about not removing extra information. I feel bad about doing that but sometimes it is just easier to hit reply and type something.

    As for these forums, I love the support that everyone gives here. I was quite shocked when I first came here a couple months ago and I'm just like you in that I do a lot of searching. I started probably the same way most did running Essentials and a few other plugins but for me, I hated the whole manuadd..... crap so I quickly switched to Permissions. Yml never scared me although I sometimes wonder about why they implemented some of the stuff they did but it allows me to just modify the files without any commands. Overall though, it took me a week before I even started my first server and if you can believe it, I read every post in multiple 100+ page threads before I even did that.

    Hell, speaking of the manuadd crap, give me 15 100+ character commands that all start with /pr and have some sort of promote/demote or parents add and I would be extremely happy. I don't even use the commands in Permissions but I know most of them already because they are logical. I always had to refer to the wiki for the GroupManager commands.

    Don't use Word to edit the files. Get Notepad++ (Windows) or TextWrangler (Mac). You have most likely converted your files to rtf or something worse.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 10, 2018
  28. Offline


    They are all still YML files. How do I use notepad++ because it keeps making tabs when I press space which can make errors in YML files?
  29. Offline


    I'm not aware of a convert space to tab option in notepad++ but it does have the option to convert tabs to spaces. Take a look in your Settings/Preferences for that option.

    The .yml doesn't define the encoding of a file. You could have a .exe that is just a text file. Your encoding is controlled by the program that writes to the file.
  30. Offline


    Everything should now be working properly, but it's not. I done everything right and no error is happening on console. But it simply isn't working in game. This could be because the storageconfig file is empty. If anyone can do a remote assist then I would greatly appreciate it :).
  31. Offline


    You'll want to post your files. Put them on or in code tags here.

    SQL isn't required. It is just yet another option.
    As I said in the above post, put them on or in code tags. In the toolbar above where you type is a code option that allows you to post things and preserve the spacing.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 28, 2018
Thread Status:
Not open for further replies.

Share This Page