Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Upgraded to P3.1.1 from 2.7.4. Took me 20 mins of configing and debugging of the 70 page long users.yml. Works flawlessly now. No errors and I have around 45 plugins running.

    Could you possibly add these basic commands:
    add user to group (not by promoting/demoting)
    remove user from all groups.
  3. Offline


    You can use "/pr <user> parents add <group>" if you are in the same world as them and "/pr <user> w:<world> parents add <group>" if you aren't.
  4. Offline


    I was wondering, is there a maximum number of permissions I can use per group ? I have probably 40+ permissions for my Players group and alot of them don't work :\
  5. Offline


    Okay, that works. I still need a command to strip a user of all his groups. Plus, I need permission nodes for those commands. I was using AssignPermissions before to do this, now I'm kinda screwed lol.
    By permission nodes I mean only allowing a person to remove all groups from himself. And only being able to set certain groups and only to self.
    If you're wondering why would I need this, I had a user-controlled class changing system for my rpg server with AssignPermissions, rTriggers and bCoolDown. Thought P3 would remove the need for assignpermissions.
  6. Offline


  7. Offline


    I'm sorry, I meant to answer about the removal of all but the damn tv drew my attention and I forgot about that part. :( There isn't currently a way to remove all groups but what you describe is exactly what tracks are set up for.

    They would give you the ability to have someone start at say the Grunt group and based on what track they want to follow (fighter, mage, thief, ...) they could move themselves to the next group. You can then give each group/person permissions to permissions.promote.<track>. Give me a few minutes and I'll set you up an example.

    Don't worry about the commands for now. I'm sure they will get better over time. Here is an example of your groups with tracks:
            permissions: null
            inheritance: null
            permissions: null
            inheritance: null
            permissions: null
            inheritance: null
            permissions: null
            inheritance: null
            permissions: null
            inheritance: null
            permissions: null
            inheritance: null
            permissions: null
            inheritance: null
        - Guest
        - Fighter1
        - Fighter2
        - Guest
        - Mage1
        - Mage2
        - Guest
        - Thief1
        - Thief2
    You could give everyone or just individuals these permissions:
        - permissions.promote.FighterTrack
        - permissions.promote.MageTrack
        - permissions.promote.ThiefTrack
        - permissions.demote.FighterTrack
        - permissions.demote.MageTrack
        - permissions.demote.ThiefTrack
    If someone picks the Fighter, they would type "/pr <user> promote Grunt FighterTrack". If they want to switch and are currently a Fighter1, they would type "/pr <user> demote Fighter1 FighterTrack" then they could switch to the Mage using "/pr <user> promote Grunt MageTrack". I'm not sure if this is kinda like what you did before, but it could probably be made to work.

    I don't believe there is a maximum.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  8. Offline


    Permissions says I don't have any parents, but in /plugins/Permissions/world/users.yml:
    group: Admins
    - ''
    group: Admins
    - ''
  9. Offline


    You'll want to change the group: Admins to:
            - Admins
  10. Offline

    Don Redhorse

    my honest opinion... wait, and use the old version till than... it has bugs atm and your post tells me that you don't have a lot of knowledge configuring bukkit servers..

    well it isn't in the front post.. but concerning other posts we have in this thread this isn't even read either..

    don't get me wrong but the solution Jeyge posted is in this thread already around 10 times, so I don't think that your FYI will really cut down the traffic in this post...

    mine neither I have to agree ;-(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  11. Offline


    Can anyone explain how to use the SQL?
    What does each Table do and whats a basic example of each?
  12. Offline

    Don Redhorse

    well I guess permissionsplus could just update for a simple case like this. but even that required manual config of the order of groups.. but I guess for most people it is not possible to wait till a new generation of a plugin is working correctly and supported.

    BTW: I know I'm ranting a lot and I must admit I envy your stamina in posting the same answers again and again. You are doing a great job in helping the community.

    well reading through this thread yuo would know that global users and groups aren't working yet. you will need to wait..

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  13. Offline


    Thanks. Seems like a ton of work in it's current stage though. I think I'll have the command "/class hunter" mapped to demoting off the track and setting a new one. Time to write 80 lines of rTriggers code for my 25 classes. :S
    Nvm, can't be done, since there is no way to check for what class the person has now and demote them accordingly. I thought I could add two commands but then I realized people would get multiple classes. I could make the command attempt to remove the person from all groups but that's trying to execute over 50 commands at once and would severely lag the server.
    Guess I have to wait for a group wipe command. *sigh*
  14. Offline


    The SQL schema is located here. It should be pretty self-explanitory.
  15. Offline


    Parent groups can come from different worlds.
  16. Offline


    For those of you that have problems, I have a video rendering right now. It should be up in around 7hrs. Ill post it when its done :) It shows how to set up permissions and it is with a voiceover, not text, so it should be easy to follow. Its 12min long, so Its really in-depth.
    Don Redhorse likes this.
  17. Offline


    Permissions 3.1.2 released. This fixes SQL data nodes returning as null, separates the SQL interface into PermissionsSql.jar (It's a normal plugin. Just put it in the plugins/ folder. You do not have to move permissions.db or storageconfig.yml.), makes the world parameter default to the main world, and adds user/group autocompleteing.

    An example of autocomplete and world defaulting in action:

    If a player named TDCgcc is online or in your config files, this command:
    /pr tdc perms list
    is equivalent to
    /pr TDCgcc w:world perms list
    , where "world" is the name of your default world.
  18. Offline


    How does inheritance/overriding from globalusers/globalgroups work? Do I have to configure it in storageconfig.yml? I can't seem to find a writeup for this anywhere in the wiki.

    EDIT: also, it's not generally real clear how inheritance is supposed to work. Like if I define world Subworld as inheriting from world Mainworld, then what specifically do I do in the Subworld groups.yml file to affect how it handles groups inherited from the Mainworld groups.yml file.
  19. Offline


    I don't think I'm the first to ask, but I can't find an answer anywhere.. we NEED setGroup() in the API! Please!!
  20. Offline


    There's no setGroup(), because users can be in multiple groups, though we have addGroup() and removeGroup().
    User adminToBe = Permissions.Security.getUserObject("world", "adminToBe");
    if(adminToBe == null) return;
    Group adminGroup = Permissions.Security.getGroupObject("world","Admins");
    if(adminGroup==null) return;
    Admittedly, the API is underdocumented.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
    Ant59 likes this.
  21. Offline


    Oooo thank you very much :) I'll see what I can do with this :) Have a "like" :p
  22. Offline


    I just updated from 3.0.6 to 3.1.2 and I'm getting this error:
    2011-06-03 19:41:39 [INFO] Starting minecraft server version Beta 1.6.6
    2011-06-03 19:41:39 [INFO] Loading properties
    2011-06-03 19:41:39 [INFO] Starting Minecraft server on *:25565
    2011-06-03 19:41:39 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-g3fc0460-b818jnks (MC: 1.6.6)
    2011-06-03 19:41:39 [INFO] Preparing level "world"
    2011-06-03 19:41:39 [INFO] Preparing start region for level 0
    2011-06-03 19:41:40 [INFO] Preparing start region for level 1
    2011-06-03 19:41:40 [SEVERE] not found
    2011-06-03 19:41:40 [INFO] DataSourcePool [TimeShift] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    2011-06-03 19:41:41 [INFO] SubClassFactory parent ClassLoader []
    2011-06-03 19:41:41 [INFO] Entities enhanced[0] subclassed[1]
    2011-06-03 19:41:41 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko.permissions.ModularControl$1RefreshTask from class com.nijiko.permissions.ModularControl
    2011-06-03 19:41:41 [SEVERE]     at com.nijiko.permissions.ModularControl.<init>(
    2011-06-03 19:41:41 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-06-03 19:41:41 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-06-03 19:41:41 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-06-03 19:41:41 [SEVERE]     at net.minecraft.server.MinecraftServer.e(
    2011-06-03 19:41:41 [SEVERE]     at net.minecraft.server.MinecraftServer.a(
    2011-06-03 19:41:41 [SEVERE]     at net.minecraft.server.MinecraftServer.init(
    2011-06-03 19:41:41 [SEVERE]     at
    2011-06-03 19:41:41 [SEVERE]     at
    2011-06-03 19:41:41 [SEVERE] [Permissions] Unable to load permission data.
    2011-06-03 19:41:41 [INFO] [Permissions] Shutting down Permissions due to error(s).
    2011-06-03 19:41:41 [INFO] [Permissions] (Yeti) was initialized.
    2011-06-03 19:41:41 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-06-03 19:41:41 [INFO] WorldGuard: Blacklist loaded.
    2011-06-03 19:41:41 [INFO] WorldGuard: Loaded configuration for world 'world"
    2011-06-03 19:41:41 [INFO] WorldGuard: Loaded configuration for world 'world_nether"
    2011-06-03 19:41:41 [INFO] WorldGuard 5.0-alpha10 enabled.
    2011-06-03 19:41:41 [INFO] CommandBook 1.5.1-customized enabled.
    2011-06-03 19:41:41 [INFO] CommandBook: 0 banned name(s) loaded.
    2011-06-03 19:41:41 [INFO] CommandBook: 2 kit(s) loaded.
    2011-06-03 19:41:41 [INFO] CommandBook: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-06-03 19:41:41 [INFO] [MagicCarpet] MagicCarpet version 1.5.5 is enabled!
    2011-06-03 19:41:41 [INFO] [MagicCarpet] Take yourself wonder by wonder, using /magiccarpet or /mc.
    2011-06-03 19:41:41 [INFO] [MagicCarpet] Restricted to: []
    2011-06-03 19:41:41 [INFO] SimpleCronClone 0.4 is enabled.
    2011-06-03 19:41:41 [INFO] SimpleCronClone: Scheduling: backup.scc
    2011-06-03 19:41:41 [INFO] [HeroicDeath] enabled.
    2011-06-03 19:41:41 [INFO] [MobileAdmin] Loading server stats.
    2011-06-03 19:41:41 [INFO] [MobileAdmin] Loading chat log.
    2011-06-03 19:41:41 [INFO] [MobileAdmin] Loading users.
    2011-06-03 19:41:41 [INFO] [MobileAdmin] Starting server...
    2011-06-03 19:41:41 [INFO] [MobileAdmin] Version 3.0 is enabled!
    2011-06-03 19:41:41 [INFO] WorldEdit 4.4 enabled.
    2011-06-03 19:41:41 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-06-03 19:41:41 [INFO] [MobileAdmin] Server listening on *:5839
    2011-06-03 19:41:41 [INFO] [Permissions] version [3.1.2] (Yeti)  loaded
    2011-06-03 19:41:41 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-06-03 19:41:41 [INFO] CommandBook: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-06-03 19:41:41 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-06-03 19:41:41 [INFO] [dynmap] Using environment as template: normal
    2011-06-03 19:41:41 [INFO] [dynmap] Configuration of world world
    2011-06-03 19:41:41 [INFO] [dynmap] center: org.dynmap.ConfigurationNode@74a638fc
    2011-06-03 19:41:41 [INFO] [dynmap] enabled: true
    2011-06-03 19:41:41 [INFO] [dynmap] title: world
    2011-06-03 19:41:41 [INFO] [dynmap] maps: [{class=org.dynmap.flat.FlatMap, name=flat, title=Flat, prefix=flat, colorscheme=detailed}, {class=org.dynmap.kzedmap.KzedMap, renderers=[{class=org.dynmap.kzedmap.DefaultTileRenderer, name=surface, title=Surface, prefix=t, maximumheight=127, colorscheme=detailed}]}]
    2011-06-03 19:41:41 [INFO] [dynmap] name: world
    2011-06-03 19:41:41 [INFO] [dynmap] Loading maps of world 'world'...
    2011-06-03 19:41:41 [INFO] [dynmap] Loading renderers for map 'class org.dynmap.kzedmap.KzedMap'...
    2011-06-03 19:41:41 [INFO] [dynmap] Loaded 1 renderers for map 'class org.dynmap.kzedmap.KzedMap'.
    2011-06-03 19:41:41 [INFO] [dynmap] Loaded 2 maps of world 'world'.
    2011-06-03 19:41:41 [INFO] [dynmap] Using environment as template: nether
    2011-06-03 19:41:41 [INFO] [dynmap] Configuration of world world_nether
    2011-06-03 19:41:41 [INFO] [dynmap] center: org.dynmap.ConfigurationNode@c77a748
    2011-06-03 19:41:41 [INFO] [dynmap] enabled: true
    2011-06-03 19:41:41 [INFO] [dynmap] title: world_nether
    2011-06-03 19:41:41 [INFO] [dynmap] maps: [{class=org.dynmap.flat.FlatMap, name=flat, title=Flat, prefix=flat, colorscheme=default}, {class=org.dynmap.kzedmap.KzedMap, renderers=[{class=org.dynmap.kzedmap.DefaultTileRenderer, name=nether, title=Surface, prefix=nt, maximumheight=127, colorscheme=default}]}]
    2011-06-03 19:41:41 [INFO] [dynmap] name: world_nether
    2011-06-03 19:41:41 [INFO] [dynmap] Loading maps of world 'world_nether'...
    2011-06-03 19:41:41 [INFO] [dynmap] Loading renderers for map 'class org.dynmap.kzedmap.KzedMap'...
    2011-06-03 19:41:41 [INFO] [dynmap] Loaded 1 renderers for map 'class org.dynmap.kzedmap.KzedMap'.
    2011-06-03 19:41:41 [INFO] [dynmap] Loaded 2 maps of world 'world_nether'.
    2011-06-03 19:41:41 [INFO] [dynmap] Loaded 5 components.
    2011-06-03 19:41:41 [INFO] [dynmap] Dynmap WebServer started on null:8123
    2011-06-03 19:41:41 [INFO] [dynmap] version 0.17 is enabled
    2011-06-03 19:41:41 [INFO] [TimeShift] hooked into Permissions.
    2011-06-03 19:41:42 [INFO] TimeShift version 2.0.1 is enabled!
    2011-06-03 19:41:42 [INFO] [MYWARP]: 0 warps loaded
    2011-06-03 19:41:42 [INFO] [MYWARP] Permissions enabled using: Permissions v3.1.2
    2011-06-03 19:41:42 [WARNING] [MYWARP] 'Help' isn't detected. No /help support.
    2011-06-03 19:41:42 [INFO] MyWarp 1.10.7 enabled
    2011-06-03 19:41:42 [INFO] Enabled DefaultPermissions v0.3
    2011-06-03 19:41:42 [INFO] Done (0.223s)! For help, type "help" or "?"
  23. Offline


    Uh, yeah, the docs linked in the post for 3.1.1 were for 2.7.4, so nothing worked when I tried to update BigBrother to 3.1.1.
  24. Offline


    Permissions has many errors after adding some nodes
    Defaults can't use Essentials

    I have got following plugins
    Permissions 3.1.2
    LWC 2.31
    Falsebook 0.85
    Worldedit 4.4
    Worldguard 5.0alpha10
    FloodGates 1.2
    Controllerblock 1.18
    Essentials 2.3

    and now even if im admin cant use any permissions command
  25. Offline


    3.1.2 SQL, no w:* inheritance and build.
  26. Offline


    Please add a command to remove the user from all groups, or to set one group, so if a user is in multiple groups he's removed from them and added to only one.
  27. Offline


  28. Offline


    Will look into it.
    I'll think about this.
    Can you PM me all the JARs in your entire plugins/ folder?
               - 'lwc.protect'
                - 'essentials.home'
                - 'essentials.sethome
                - 'essentials.list'
    needs to be
                - 'lwc.protect'
                - 'essentials.home'
                - 'essentials.sethome
                - 'essentials.list'
    Indent "- 'lwc.protect'" by one more space.
  29. Offline


    yeah :(

    problem is, i did try search for the error, but the search tool is to vague, coming up with every permissions post... looks like you need to make a FAQ Jeyge!
  30. Offline


    Same Problem!
  31. Offline


    Loads of problems..

    			- "*"
    			- Owner
            default: true
                prefix: ''
                suffix: ''
                build: false
               - 'lwc.protect'
                - 'essentials.home'
                - 'essentials.sethome
                - 'essentials.list'
            default: false
                prefix: '&7[&7BOUWER&7]&f'
                suffix: ''
                build: true
               - Default
                - ''
                - ''
                - 'essentials.item'
                - 'essentials.powertool'
                - 'essentials.give'
                - 'essentials.clearinventory'
                - ''
                - ''
                - 'essentials.remove.block'
                - 'mywarp.warp.basic.warp'
                - 'mywarp.warp.basic.list'
                - 'mywarp.warp.sign.warp'
                - 'essentials.kit.*'
            default: false
                prefix: '&2[&2MODERATOR&2]&f'
                suffix: ''
                build: true
               - Default
                - 'essentials.give'
                - 'essentials.kick'
                - 'essentials.mute'
                - 'essentials.item'
                - ''
                - 'essentials.time'
                - 'essentials.signs.heal.create'
                - 'essentials.signs.heal.use'
                - ''
                - 'essentials.tpo'
                - ''
                - 'essentials.suicide'
                - 'essentials.heal'
                - 'essentials.tree'
                - 'essentials.bigtree'
                - ''
                - 'mywarp.warp.basic.warp'
                - 'mywarp.warp.basic.createpublic'
                - 'mywarp.warp.basic.createprivate'
                - 'mywarp.warp.basic.list'
                - 'mywarp.warp.sign.create'
                - 'mywarp.warp.sign.warp'
                - 'com.crazydog.ibicf.IBICF'
                - 'mywarp.basic.warp.use'
                - 'mywarp.basic.warp.create'
                - 'essentials.sethome'
                - 'essentials.home'
                - 'essentials.clearinventory'
                - 'essentials.warp'
                - 'essentials.setwarp'
                - 'essentials.tptoggle'
                - 'essentials.kit.*'
            default: false
                prefix: '&5[&5ADMINISTRATOR&5]&f'
                suffix: ''
                build: true
               - '*'
            default: false
                prefix: '&4[&4EIGENAAR&4]&f'
                suffix: ''
                build: true
               - '*'
    Server Error:
    13:22:35 [WARNING] Unexpected exception while parsing console command
    org.bukkit.command.CommandException: Unhandled exception executing command 'pr' in plugin Permissions v3.1.2
    	at org.bukkit.command.PluginCommand.execute(
    	at org.bukkit.command.SimpleCommandMap.dispatch(
    	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    	at net.minecraft.server.MinecraftServer.b(
    	at net.minecraft.server.MinecraftServer.h(
    Caused by: while scanning for the next token
    found character 	'\t' that cannot start any token
     in "<reader>", line 2, column 1:
    	at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(
    	at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
    	at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingValue.produce(
    	at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
    	at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
    	at org.yaml.snakeyaml.composer.Composer.composeNode(
    	at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    	at org.yaml.snakeyaml.composer.Composer.composeNode(
    	at org.yaml.snakeyaml.composer.Composer.composeDocument(
    	at org.yaml.snakeyaml.composer.Composer.getSingleNode(
    	at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(
    	at org.yaml.snakeyaml.Yaml.load(
    	at com.nijiko.configuration.NotNullConfiguration.load(
    	at com.nijiko.permissions.ModularControl.storageReload(
    	at com.nijiko.permissions.ModularControl.reload(
    	at com.nijikokun.bukkit.Permissions.Permissions.reload(
    	at com.nijikokun.bukkit.Permissions.Permissions.onCommand(
    	at org.bukkit.command.PluginCommand.execute(
    	... 6 more
    Help please!

    My Plugins:
    -MyWarp (Which isn't working)
Thread Status:
Not open for further replies.

Share This Page