Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Hello can anyone help me?
    i become everytime the same error message
    2011-08-30 16:27:36 [SEVERE] java.lang.Exception: Freshly loaded world object does not exist!
    2011-08-30 16:27:36 [SEVERE]     at com.nijiko.permissions.ModularControl.safeGetGroup(
    2011-08-30 16:27:36 [SEVERE]     at com.nijiko.permissions.ModularControl.getGrp(
    2011-08-30 16:27:36 [SEVERE]     at com.nijiko.permissions.User.<init>(
    2011-08-30 16:27:36 [SEVERE]     at com.nijiko.permissions.PermissionWorld.reload(
    2011-08-30 16:27:36 [SEVERE]     at com.nijiko.permissions.ModularControl.forceLoadWorld(
    2011-08-30 16:27:36 [SEVERE]     at com.nijiko.permissions.ModularControl.loadWorld(
    2011-08-30 16:27:36 [SEVERE]     at com.nijiko.permissions.ModularControl.load(
    2011-08-30 16:27:36 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-08-30 16:27:36 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-08-30 16:27:36 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-08-30 16:27:36 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.<init>(
    2011-08-30 16:27:36 [SEVERE]     at net.minecraft.server.ServerConfigurationManager.<init>(
    2011-08-30 16:27:36 [SEVERE]     at net.minecraft.server.MinecraftServer.init(
    2011-08-30 16:27:36 [SEVERE]     at
    2011-08-30 16:27:36 [SEVERE]     at
    the permissions settings are work i test it with the yaml parser
  3. Offline

    Alex H

    what is a good replacement to perm? or hiow long will perm be inactive
  4. Offline


    Permissions 3 will be inactive forever, better to switch now, you can use any of 3 that ninjazidane helpfully listed below.

  5. Offline


    Is there a feature that you can change the group a player is in in-game? Like group-manager's /manuadd? If not, do you think you could implement it? :3
  6. Offline


  7. Offline


    or is there another simple permissions plugin to replace this plugin

    i think you forgot all the ''
    e.g - 'buttonwarp.getreward'
    not - buttonwarp.getreward
    its gonna take u a long time to get those apostrophes.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  8. Offline


    I've gone for a good while without them. Are they really neccessary?
  9. Offline


    Read three posts up from your own.
  10. Offline


    I have XcraftGate and after i got this, no one (including me) was able to use the gates. PLEASE HEEELP!!!
  11. Offline


    No one will help because you are using an old, inactive plugin. Once you switch to permissionsbukkit, PEX, or bPermissions im sure someone would be able to help you get it working.
  12. Offline


    I had a good look between PEX, bPermissions and PermissionsBukkit. Im just saying which is the simplest to use?
  13. Offline


    What is the Newest and Standard Permisson Addon ?
    Sorry my English is not so gut to Read this Thread Compleatly and Understand this.

    Please give my a Link to the new Plugin.

    Big Thanks :)
  14. Offline


    Could you please post what these errors are? its pretty hard to fix if we dont know what screwed up.

    09:28:10 [INFO] [Multiverse-Core] - Version 2.0-b228 Enabled - By Rigby and fern
    09:28:10 [INFO] [Multiverse-Core] - Attached to Permissions
    09:28:10 [INFO] [AllPay] - Version 1.0.3 - hooked into iConomy 5 for Multiverse-
    Core v2.0-b228
    09:28:10 [INFO] [Multiverse-Core] - Multiverse Config -- Loaded
    09:28:10 [INFO] [Multiverse-Core] - World Config -- Loaded
    09:28:10 [INFO] Preparing start region for level 2 (Seed: -2798821076832627949)
    09:28:11 [SEVERE] unacceptable character #0 special characters are not allowed
    in "<reader>", position 0
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.reader.StreamReader.checkPrintable
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.reader.StreamReader.update(StreamR
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.reader.StreamReader.peek(StreamRea
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.reader.StreamReader.peek(StreamRea
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToke
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreToken
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(Sca
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDoc
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(Parser
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(Parse
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.getSingleNode(Co
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.constructor.BaseConstructor.getSin
    09:28:11 [SEVERE]       at org.yaml.snakeyaml.Yaml.load(
    09:28:11 [SEVERE]       at org.bukkit.util.config.Configuration.load(Configurati
    09:28:11 [SEVERE]       at
    09:28:11 [SEVERE]       at<init>(YamlUserStorag
    09:28:11 [SEVERE]       at
    09:28:11 [SEVERE]       at
    09:28:11 [SEVERE]       at com.nijiko.permissions.ModularControl.forceLoadWorld(
    09:28:11 [SEVERE]       at com.nijiko.permissions.ModularControl.loadWorld(Modul
    09:28:11 [SEVERE]       at com.nijikokun.bukkit.Permissions.PrWorldListener.onWo
    09:28:11 [SEVERE]       at$54.execute(Ja
    09:28:11 [SEVERE]       at org.bukkit.plugin.RegisteredListener.callEvent(Regist
    09:28:11 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.callEvent(Simpl
    09:28:11 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.createWorld(CraftS
    09:28:11 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.createWorld(CraftS
    09:28:11 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.createWorld(CraftS
    09:28:11 [SEVERE]       at com.onarandombox.MultiverseCore.MultiverseCore.addWor
    09:28:11 [SEVERE]       at com.onarandombox.MultiverseCore.MultiverseCore.loadWo
    09:28:11 [SEVERE]       at com.onarandombox.MultiverseCore.MultiverseCore.onEnab
    09:28:11 [SEVERE]       at
    09:28:11 [SEVERE]       at
    09:28:11 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.enablePlugin(Si
    09:28:11 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftSe
    09:28:11 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.enablePlugins(Craf
    09:28:11 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServe
    09:28:11 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    09:28:11 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftSe
    09:28:11 [SEVERE]       at
    09:28:11 [SEVERE]       at
    ive already talked to the devs of multiverse about this and they had nothing to say, so since there are errors in it involving permissions, i decided to ask you.

    and lastly, pick this project back up PLEASE. it is the best permissions plugin in bukkit, and having it when it worked has helped me out so much, no other plugin has so many plugins that rely on it, so PLEASE pick this back up. for the children.[/quote]

    I dont suppose that you placed a # in your config files or something did you? that could be quite the error considering that its not a valid character and will completely screw up everything.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 28, 2018
  15. Offline


    If you are looking for simple bPermissions is the way to go. It has built in P3 support and is very easy to configure.
  16. Offline


    no, i didnt, i know thats what it says but i never did

    and also, a # in code, or atleast java, means a comment on that line. so it IS an acceptable character. but i never did, it just said this.
  17. Offline


    Actually, a # in java will screw you badly. try putting that in eclipse and text after that, it will hate you. the # adds a comment in .yml, which is what configs are used for. a # in java will make it screw up and hate you until you fix it. I'm no expert on java, but that should fix your problems... if it doesnt, let me know and i'll see what i can do.
  18. Offline


    Can we do specific in game commands like adding a user to a group?
    For example, I want to promote...say "Default" to "Builder" or something IN GAME. If so how would I do that?
  19. Offline


    You can use tracks to enable in game promoting, I use it on my server! You can set the track to go
    - Default
    - Builder
    - Mod
    - Admin

    So when you use the in-game command (or console) /pr <user> promote/demote <world>
    it will move them up/down the track that you have set, therefore promoting/demoting them like you want.

    Have a look at this website: to find out how to make a track and if you get stuck PM me and I'll try to help - I've got tracks set up on my server.

    Hope this was what you were looking for :)

    Does this plugin support SuperPerms? As the NPC plugin called Citizens will no longer support Permissions 3 in their new update (1.1) and I really want to be able to use the plugin. Any help is appreciated cheers :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  20. Offline


    Cant seem to get multiworld permissions working i have added the user accounts into the users section of permissions in the new world created however the group name states Deafult however in the other world it states Owner what what would be the issue?
  21. Offline


    Is there a way to turn off the build at spawn protection?
    It gets very annoying when me and my friends have to run a long distance just to build!

    Thanks in advance!:)
  22. No, it does not, and no it will not ever.

    *points to the title*

    The plugin is inactive. It will not be updated. Previous page states it best:

    There may be others by now, but looking for updates to this plugin is not an option.
  23. Offline


    GAH! Permissions cant pass ANYTHING to ANY plugin! D: Im really pissed... This plugin NEEDS to be updated to 1060!
  24. People, what part of "INACTIVE" is being missed?

    This plugin is D-E-A-D, full stop. It will not be updated. You will have to update to a permissions plugin that supports the Bukkit 'superpermissions' scheme if you want a permissions plugin that is up to date. That being said, it was working for for me under 1060, but I didn't have anything fancy set up.

    Personally, I looked at PermissionsBukkit and PermissionsEx and decided to implement PEX due to it's finer grain control over the anti-build (I was able to configure a guest user so they could open doors and use switches, but not build or open containers).

    If a wandering moderator happens to see this, can you lock the thread and change the title to reflect that this plugin is discontinued?
  25. Offline


    @Plague could you close this thread? people dont seem to understand this plugin is dead
  26. Offline


    Right okay. Thanks for the links.
  27. Offline


    i've used the global groups and the normal, what should i do now?
  28. Offline


    Switch to fricking SuperPerms people.
  29. Offline


    Why, when I start my server (with the latest "Permissions" installed), does it say "[INFO] [Permissions] (Yeti) disabled successfully" ??
  30. Offline


    I hope you know that Permissions is outdated and inactive. Meaning it will no longer be updated. "My server depends on it." I suggest you start looking for a new perms plugin asap. once 1.8 comes I'm sure this plugin will be non usable.
  31. Offline


    If only it were that easy. There is no good conversion process from Permissions 3.1.6 to SuperPerms. Redoing permissions by hand, for large servers, is a big task.
Thread Status:
Not open for further replies.

Share This Page