Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    That didn't help. You just took the unreadable from the other post and pasted it here with code blocks around it. But still, I took the time to try to read everything and it looks like you forgot to add a space after prefix: and suffix: and the actual text. It should be prefix: '' or suffix: ''.
    You'll want to include what is broken for you with 953 so the dev knows what needs to be fixed.
  3. Offline


    world inheritance isn't working for me, any ideas?

            type: YAML
                Ragnarok: Midgard
                Nether: Midgard
  4. Offline


    I don't understand how to do so I can be Admin, and do whatever I want, because now, I can't even place Pistons :/ Please, tell me!
  5. Offline


    So... it's not working at all for me.

    2011-07-04 09:48:07 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    2011-07-04 09:48:07 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko.permissions.ModularControl$RefreshTask from class com.nijiko.permissions.ModularControl
    2011-07-04 09:48:07 [SEVERE]     at com.nijiko.permissions.ModularControl.<init>(
    2011-07-04 09:48:07 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-07-04 09:48:07 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-07-04 09:48:07 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-07-04 09:48:07 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.<init>(
    2011-07-04 09:48:07 [SEVERE]     at net.minecraft.server.ServerConfigurationManager.<init>(
    2011-07-04 09:48:07 [SEVERE]     at net.minecraft.server.MinecraftServer.init(
    2011-07-04 09:48:07 [SEVERE]     at
    2011-07-04 09:48:07 [SEVERE]     at
    2011-07-04 09:48:07 [SEVERE] [Permissions] Unable to load permission data.
    2011-07-04 09:48:07 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
  6. Offline


    953 update?
  7. Offline


    When does the update comming?
    And can you add:
    That one player who are in the Admin group, that can do everything ('*'). But if i write { - -some.command } on that specific player he is not allowed to do that! (or can i do that now, how?)
    So you can change the players group in game. (if it not exist already, if it does how?)
    Maybe you understand that i am new on bukkit, but god what I love this, and permission mod!
    /Thanks, I hope some one can answer me :D
  8. Offline


    also my server has frozen 3 times since updating permissions (no other changes) and I wasn't able to soft-reset the server and had to force close it.

    also why is it making a users and groups file in the root /permissions/ directory when it's supposed to be using /world1/ /world2/ etc?
    and why does it add every single user to the users.yml files?
  9. Offline


    Hi, i have a problem with my permissions. They doesn`t work. Down i give you a link to a server warnings. Please help. I don`t know what can do this.
  10. Offline


    When i will promote my member, come -->

    an internal error occurred while attempting to perform this command

    What must i Do???
    I'm Fulladmin
  11. Offline


    I have a random question. With the inheritance, is there any way to tell it to inherit from another world? Or is there any way i can like keep some worlds so they have the same permissions/users and other world that have completely different ones?

    I have my main world, which has a number of different groups. I want my skylands and nether to have the exact same permissions and users (so if they're a miner on the main world, they're automatically a miner in the nether). right now they have their own config and anytime i want to change something (add a user or permissions node) i have to do it to all 3 files. I tried using the global but here's the larger problem- i have two other world, a survival and a creative, which each have a COMPLETELY different set of users and groups in the permissions.

    sorry if this is all confusing, if anyone need clarification on something, i can do that. thanks for your help.
  12. Offline


    but why it run with version 3.1.5 but not with 3.1.6?
  13. Offline


    The red lines indicated illegal characters, in this case, tabs
  14. Offline


  15. Offline


    What isn't working about it?
    Give yourself the "- '*'" permission and it will be like being an Admin.
    Take a look at the OP and/or the Wiki FAQ for how to fix this error.
    We won't know unless you post your information again. We can't see any formatting on those files because you just copied them into code tags without the correct spacing. You will need to copy them again from your drive if you want us to check more.
    You will need to tell us what is broken before the dev can fix it.
    If you mean the 3.2 update, we don't know yet.
    You can remove permissions using "- ''".
    You can use promote/demote or parents add/remove to change their group. Take a look at the wiki for the commands.
    I'm not sure why it would create a users.yml and groups.yml in your root directory. Are you sure they weren't copied there? Either way, I would think you could just remove them.
    It creates the users to make it easier to promote them to the group you want them to be in. If they weren't created, then you would have to run more commands just to give them permissions.
    That would depend on the errors you are getting. Post your server.log and permissions yml files.
    Take a look at world mirroring and world inheritance from the wiki here.
    That error just shows up randomly but it is easy to fix so it shouldn't be much of a problem.
  16. Offline


    well, look.

            type: YAML
                Ragnarok: Midgard
                Nether: Midgard
    I want the midgard permissions to be inherited to the other 2 worlds there, but they're not. it's not working. the other worlds don't have those permissions when I go ingame.
  17. Offline

    Chris Lewis

    Ok im sorry i didnt read all 140 pages of posts so if this question has already been answered im sorry. When a player joins my server do I have to define them in the users or globalusers.yml? I am using global permissions because i dont need/want world permissions. However it seems that my players that are not defined in the globalusers.yml are not automatically getting put in the default group... perhaps i did something wrong? CB 953 Permissions 3.1.6
    here is my globalusers.yml
            - Admins
                prefix: '&6'
                suffix: ''
            - textplayer.admin
            - Admins
                prefix: '&6'
                suffix: ''
            - Admins
                prefix: '&6'
                suffix: ''
            - Admins
                prefix: '&6'
                suffix: ''
    here is my globalgroups.yml
            default: true
                prefix: ''
                suffix: ''
                build: true
            inheritance: null
            - general.spawn
            - iConomy.payment
            - iConomy.rank
            - iConomy.list
            - uQuest.CanQuest
            - lwc.protect
            - jail.usercmd.jailstatus
            - herochat.create
            - war.player
            - war.warp
            - ecoCreature.Rewarding.*
            - ecoCreature.Creature.*
            - uQuest.CanDropQuest
            - herobounty.accept
            - herobounty.locate
            - commandbook.spawn
            - commandbook.who
            - commandbook.motd
            - commandbook.say
            - commandbook.msg
            - myhome.home.basic.*
            - myhome.home.soc.*
            - odd.item.aliases
            - odd.item.list
            - odd.item.reload
            - craftbook.mech.*
            - backtobody.btb
            - wolfpound.use
            - textplayer.textadmin
            - textplayer.text
            - textplayer.listusers
            - portalstick.teleport
            default: false
                prefix: ''
                suffix: ''
                build: true
            - Default
            - general.time
            - general.teleport
            - iConomy.admin.grant
            - iConomy.admin.set
            - iConomy.admin.stats
            - iConomy.admin.reset
            - lwc.mod
            - jail.command.jailcreate
            - jail.command.jaildelete
            - jail.command.jail
            - jail.command.unjail
            - jail.command.jailtransfer
            - jail.command.jailtransferall
            - jail.command.jailcheck
            - jail.command.jailtelein
            - jail.command.jailteleout
            - jail.command.jaillist
            - jail.command.unjailforce
            - jail.command.jailclear
            - jail.command.jailclearforce
            - jail.command.jailbackup
            - jail.modifyjail
            - vanish.vanish
            - vanish.vanishlist
            - vanish.dont.hide
            - BackupPlugin.backup
            - BackupPlugin.admin
            - herochat.admin
            - war.*
            - multiverse.portal.create
            - multiverse.portal.remove
            - multiverse.portal.destination
            - multiverse.portal.rename
            - multiverse.portal.exempt
            - portalstick.*
            default: false
                prefix: ''
                suffix: ''
                build: true
            inheritance: null
            - tpp.admin.*
            - herochat.admin
            - '*'
    Also when I use the /pr <username> w:<worldname> parents list command for any users not defined in the global users i get that they are not in a group, and for me (Broland) its says i am in group * instead of group admin?!
  18. Offline


    You need a space after type: and before YAML. It should look like "type: YAML".
    while scanning a simple key
     in "<reader>", line 3, column 1:
  19. Offline


    2011-07-04 17:26:06 [INFO] Starting minecraft server version Beta 1.7.2
    2011-07-04 17:26:06 [INFO] Loading properties
    2011-07-04 17:26:06 [INFO] Starting Minecraft server on *:25565
    2011-07-04 17:26:06 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    2011-07-04 17:26:06 [INFO] Starting Minequery server on *:25566
    2011-07-04 17:26:07 [SEVERE] not found
    2011-07-04 17:26:07 [INFO] DataSourcePool [HiddenDoor] autoCommit[false] transIsolation[SERIALIZABLE] min[2] max[20]
    2011-07-04 17:26:07 [INFO] SubClassFactory parent ClassLoader []
    2011-07-04 17:26:07 [INFO] Entities enhanced[0] subclassed[1]
    2011-07-04 17:26:08 [INFO] [Permissions] (Yeti) was initialized.
    2011-07-04 17:26:08 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    2011-07-04 17:26:08 [INFO] Preparing level "Mcwar World"
    2011-07-04 17:26:08 [INFO] Preparing start region for level 0 (Seed: -5701333806307121107)
    2011-07-04 17:26:09 [INFO] Preparing spawn area: 81%
    2011-07-04 17:26:09 [INFO] [ScheduledAnnouncer] Connected to Permissions.
    2011-07-04 17:26:09 [INFO] ScheduledAnnouncer v1.6.3 is enabled!
    2011-07-04 17:26:09 [INFO] plugins/Help/ExtraHelp/CraftBukkit.yml
    2011-07-04 17:26:09 [INFO] plugins/Help/ExtraHelp/WorldGuard.yml
    2011-07-04 17:26:09 [INFO] plugins/Help/ExtraHelp/Iconomy.yml
    2011-07-04 17:26:09 [INFO] plugins/Help/ExtraHelp/mcMMO.yml
    2011-07-04 17:26:09 [SEVERE] [HELP] Error!
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    2011-07-04 17:26:09 [INFO] plugins/Help/ExtraHelp/RCSkills.yml
    2011-07-04 17:26:09 [WARNING] [HELP] A Help entry node is missing a command name
    2011-07-04 17:26:09 [WARNING] [HELP] A Help entry node is missing a command name
    2011-07-04 17:26:09 [INFO] plugins/Help/ExtraHelp/CommandBook.yml
    2011-07-04 17:26:10 [INFO] [HELP] 84 extra help entries loaded
    2011-07-04 17:26:10 [INFO] [HELP] Permissions enabled using: Permissions v3.1.6
    2011-07-04 17:26:10 [INFO] [HELP] Help enabled
    2011-07-04 17:26:10 [INFO] [TeleConfirmLite] [v1.5] loaded
    2011-07-04 17:26:10 [INFO] [MYHOME]: 80 homes loaded
    2011-07-04 17:26:10 [INFO] [MYHOME] Permissions enabled using: Permissions v3.1.6
    2011-07-04 17:26:10 [INFO] [MYHOME] 'Help' support enabled.
    2011-07-04 17:26:10 [INFO] [MYHOME] MyHome 1.9.5 enabled
    2011-07-04 17:26:10 [INFO] [iChat] Found Permissions (v3.1.6)
    2011-07-04 17:26:10 [INFO] iChat (v2.3.1) enabled
    2011-07-04 17:26:10 [INFO] [Performance Tweaks] Version 0.08 enabled.
    2011-07-04 17:26:10 [INFO] [Performance Tweaks] Set auto save interval to 36000 in world "Mcwar World"
    2011-07-04 17:26:10 [INFO] [Performance Tweaks] Chunk Life Time: 300000ms
    2011-07-04 17:26:10 [INFO] [Performance Tweaks] Chunk Prune Time: 5000ms
    2011-07-04 17:26:10 [INFO] [Performance Tweaks] Monster Limit set to 0
    2011-07-04 17:26:10 [INFO] [Performance Tweaks] Monster Limiter:
    2011-07-04 17:26:10 [INFO] [Performance Tweaks]      "Mcwar World":
    2011-07-04 17:26:10 [INFO] [Performance Tweaks]          Max Monsters: 2500
    2011-07-04 17:26:10 [INFO] [Performance Tweaks]          Allow Monsters: true
    2011-07-04 17:26:10 [INFO] [Performance Tweaks]          Allow Animals: true
    2011-07-04 17:26:10 [INFO] [AutoPlant] version 1.6 is enabled!
    2011-07-04 17:26:10 [INFO] Vanilla version 0.1 is enabled!
    2011-07-04 17:26:10 [INFO] [Priest]: Using Permissions
    2011-07-04 17:26:10 [INFO] [Priest]: Plugin Started
    2011-07-04 17:26:10 [INFO] §2[Virtual Shop] §fVirtualShop loading.
    2011-07-04 17:26:10 [INFO] FalseBookExtra v0.86.2alpha by GeMo enabled
    2011-07-04 17:26:10 [INFO] [HeroSneak] enabled.
    2011-07-04 17:26:10 [INFO] [BBROTHER] ------------------------------------
    2011-07-04 17:26:10 [INFO] [BBROTHER] Hello, and thank you for using the TESTING version of BigBrother!
    2011-07-04 17:26:10 [INFO] [BBROTHER] Please note that, since this is far from complete, there will be many bugs.
    2011-07-04 17:26:10 [INFO] [BBROTHER] Please stay tuned in #bigbrother for updates and build notifications.
    2011-07-04 17:26:10 [INFO] [BBROTHER] ------------------------------------
    2011-07-04 17:26:23 [INFO] [BBROTHER] Building `bbdata` table...
    2011-07-04 17:26:23 [INFO] [BBROTHER] BBData H2 Driver r1 loaded!
    2011-07-04 17:26:23 [INFO] [BBROTHER] Building `bbworlds` table...
    2011-07-04 17:26:23 [INFO] [BBROTHER] Building `bbusers` table...
    2011-07-04 17:26:23 [INFO] [BBROTHER] Permissions enabled using: Permissions v3.1.6
    2011-07-04 17:26:23 [INFO] [BBROTHER] 'Help' support enabled
    2011-07-04 17:26:23 [INFO] [BBROTHER] BigBrother 1.9-SNAPSHOT (build #569) enabled!
    2011-07-04 17:26:25 [INFO] [iConomy] Logging is currently disabled.
    2011-07-04 17:26:25 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    2011-07-04 17:26:25 [INFO] [iConomy] Developed by: [Nijikokun]
    2011-07-04 17:26:25 [INFO] [iConomy] hooked into Permissions.
    2011-07-04 17:26:25 [INFO] HiddenDoor: Trying to enable version 0.2 ...
    2011-07-04 17:26:26 [INFO] HiddenDoor: Configuration file loaded.
    2011-07-04 17:26:26 [INFO] HiddenDoor: No hidden doors has been loaded.
    2011-07-04 17:26:26 [INFO] HiddenDoor: Version 0.2 enable.
    2011-07-04 17:26:26 [INFO] NoWeather version 1.5 is enabled!
    2011-07-04 17:26:26 [INFO] [FalseBook Block] 3100 Books loaded!
    2011-07-04 17:26:26 [INFO] FalseBookBlock v0.86.2alpha by GeMo enabled
    2011-07-04 17:26:26 [INFO] [FalseBook Block] 2 Cauldrons successfully loaded.
    2011-07-04 17:26:26 [INFO] [Jail] Loaded 1 jail zones.
    2011-07-04 17:26:26 [INFO] [Jail] Loaded 7 prisoners.
    2011-07-04 17:26:26 [INFO] [Jail] Loaded 0 cells.
    2011-07-04 17:26:26 [INFO] [FalseBook Core] FalseBookCore v0.86.2alpha by GeMo enabled!
    2011-07-04 17:26:26 [INFO] [bAntiCaps] Permission system found
    2011-07-04 17:26:26 [INFO] [bAntiCaps] version 1.2.0 is enabled!
    2011-07-04 17:26:26 [INFO] CommandBook 1.5.2-customized enabled.
    2011-07-04 17:26:26 [INFO] CommandBook: Maximum wrapper compatibility is enabled. Some features have been disabled to be compatible with poorly written server wrappers.
    2011-07-04 17:26:26 [INFO] CommandBook: 0 banned name(s) loaded.
    2011-07-04 17:26:26 [INFO] CommandBook: 7 kit(s) loaded.
    2011-07-04 17:26:26 [INFO] CommandBook: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-04 17:26:26 [INFO] WorldEdit 4.6 enabled.
    2011-07-04 17:26:26 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-04 17:26:26 [INFO] [Command iConomy] Loaded.
    2011-07-04 17:26:26 [INFO] FalseBookIC v0.86.2alpha by GeMo enabled
    2011-07-04 17:26:26 [INFO] [VanishNoPickup] 1.9.9 enabled.
    2011-07-04 17:26:26 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-07-04 17:26:26 [INFO] WorldGuard: Blacklist loaded.
    2011-07-04 17:26:26 [INFO] WorldGuard: (Mcwar World) Single session is enforced.
    2011-07-04 17:26:26 [INFO] WorldGuard: (Mcwar World) TNT ignition is blocked.
    2011-07-04 17:26:26 [INFO] WorldGuard: (Mcwar World) Lighters are PERMITTED.
    2011-07-04 17:26:26 [INFO] WorldGuard: (Mcwar World) Lava fire is blocked.
    2011-07-04 17:26:26 [INFO] WorldGuard: (Mcwar World) Fire spread is UNRESTRICTED.
    2011-07-04 17:26:26 [INFO] WorldGuard: Loaded configuration for world 'Mcwar World"
    2011-07-04 17:26:26 [INFO] WorldGuard: 13 regions loaded for 'Mcwar World'
    2011-07-04 17:26:26 [INFO] WorldGuard 5.0-alpha10 enabled.
    2011-07-04 17:26:26 [INFO] [HeroicDeath] enabled.
    2011-07-04 17:26:26 [INFO] Found Diamonds STARTED
    2011-07-04 17:26:26 [INFO] [MYWARP] [MYWARP]: 29 warps loaded
    2011-07-04 17:26:26 [INFO] [MYWARP] Permissions enabled using: Permissions v3.1.6
    2011-07-04 17:26:26 [INFO] [MYWARP] Help plugin support enabled.
    2011-07-04 17:26:26 [INFO] [MYWARP] MyWarp 2.0 enabled
    2011-07-04 17:26:26 [INFO] Commands Logging version 1.1 is enabled!
    2011-07-04 17:26:26 [INFO] MCBans: mcbans version 2.9.1 is enabled!
    2011-07-04 17:26:26 [INFO] MCBans: Checking for premium!
    2011-07-04 17:26:27 [INFO] MCBans: Server NOT premium!
    2011-07-04 17:26:27 [INFO] Loading Config File...
    2011-07-04 17:26:28 [INFO] [mcMMO] Permissions enabled.
    2011-07-04 17:26:28 [INFO] mcMMO version 1.0.26 is enabled!
    2011-07-04 17:26:28 [INFO] BorderGuard version 3.1 is enabled!
    2011-07-04 17:26:28 [INFO] AfkKick version 1.4 is enabled with permissions!
    2011-07-04 17:26:28 [INFO] [NoCheat] version [1.06b] couldn't find CrafTIRC plugin. Disabling logging to IRC.
    2011-07-04 17:26:28 [INFO] [NoCheat] version [1.06b] is enabled with the following checks: moving speedhack airbuild bogusitems flying fastswim
    2011-07-04 17:26:28 [INFO] Done (1.969s)! For help, type "help" or "?"
    2011-07-04 17:26:28 [INFO] [FalseBook Block] 0 Areas loaded.
    2011-07-04 17:26:28 [INFO] [FalseBook Block] 1 Bridges successfully loaded.
    2011-07-04 17:26:28 [INFO] [FalseBook Block] 1 Doors successfully loaded.
    2011-07-04 17:26:28 [INFO] [FalseBook Block] Gates successfully loaded.
    2011-07-04 17:26:28 [INFO] [FalseBook IC] No Transmitters loaded.
    2011-07-04 17:26:28 [INFO] [FalseBook IC] No Receivers loaded.
    2011-07-04 17:26:28 [INFO] [FalseBook IC] No Sensors loaded.
    2011-07-04 17:26:31 [INFO] alexm118118 [/] logged in with entity id 9 at ([Mcwar World] 400.30000001192093, 68.0, 440.0641499577746)
    2011-07-04 17:26:33 [INFO] [BBROTHER] Removed 21754 old records because of age in 0h00m03s.
    2011-07-04 17:26:33 [INFO] <*Console*>: Welcome back, alexm118118
    2011-07-04 17:26:33 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-07-04 17:26:38 [INFO] §a[CAD]§f alexm118118: ah im in
    2011-07-04 17:27:00 [INFO] <*Console*>: Saving world data. Expect lag for a short while.
    2011-07-04 17:27:00 [INFO] Forcing save..
    2011-07-04 17:27:00 [INFO] Save complete.
    2011-07-04 17:27:00 [INFO] <*Console*>: Save Complete
    2011-07-04 17:27:04 [INFO] krzemus [/] logged in with entity id 1538 at ([Mcwar World] 475.5, 72.62000000476837, 394.5)
    2011-07-04 17:27:04 [INFO] Creating user krzemus
    2011-07-04 17:27:04 [INFO] <*Console*>: krzemus has just joined for the first time.
    2011-07-04 17:27:04 [INFO] <*Console*>: 328 unique players have visited this server.
    2011-07-04 17:27:14 [INFO] krzemus used command "/list"
    2011-07-04 17:27:15 [INFO] §a[CAD]§f alexm118118: welcome Krzemus
    2011-07-04 17:27:16 [INFO] / lost connection
    2011-07-04 17:27:18 [INFO] §8[Guest]§f krzemus: hi
    2011-07-04 17:27:29 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-07-04 17:27:29 [WARNING] Unexpected exception while parsing console command
    org.bukkit.command.CommandException: Unhandled exception executing command 'pr' in plugin Permissions v3.1.6
        at org.bukkit.command.PluginCommand.execute(
        at org.bukkit.command.SimpleCommandMap.dispatch(
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
        at net.minecraft.server.MinecraftServer.b(
        at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
        at java.util.HashSet.<init>(
        at com.nijiko.permissions.PermissionWorld.getTracks(
        at com.nijiko.permissions.ModularControl.getTracks(
        at com.nijikokun.bukkit.Permissions.Permissions.onCommand(
        at org.bukkit.command.PluginCommand.execute(
        ... 6 more
    2011-07-04 17:27:34 [INFO] Connected players: alexm118118, krzemus
  20. Offline


    If what you are looking for it to avoid having a unique set of permissions per world, then using the global files isn't what you want to use. You should look at world mirroring on the wiki here. Using that, you will only enter one set of groups and users and all other worlds will use those. If you really want to use the global files, then you will have to live with promoting in both the world and global users files.
  21. Offline

    Chris Lewis

    Ok this didn't exactly answer my question, but it did point me in the right direction, and i have it resolved now, thank you muchly.
  22. Offline


    I get this error when I try to add permissions on faction plugin
    help please >.<
  23. Offline


    You are missing the - in front of your permissions. They should look like "- 'factions.participate'".
  24. Offline


    Im currently trying to convert from Permissions 2 to the current version. My problem is that im going to use MySQL now and now flatfile. Is there a converter for this, since I cant find a guide how the new system works stuff like Default permissions, inheritance.

    Best regards
  25. Offline


    I need help... When I join my server, it doesn't says test1 and test2 with my name... Prefix and suffix doesn't work, why? Also, how do I give myself 0wn3r, admin, etc? And other people? I have tried to add myself to users.yml at world, not global, but it isn't working... U can see here:

    If that is wrong, please tell me how I should to it :s

    - Thanks, Cawers

    EDIT: It works like god now! :D BIIIIIIIIG thanks to Sladewill! :)
  26. Offline


    2011-07-04 18:39:38 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko.permissions.ModularControl$RefreshTask from class com.nijiko.permissions.ModularControl
    2011-07-04 18:39:38 [SEVERE]     at com.nijiko.permissions.ModularControl.<init>(
    2011-07-04 18:39:38 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-07-04 18:39:38 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-07-04 18:39:38 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-07-04 18:39:38 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.<init>(
    2011-07-04 18:39:38 [SEVERE]     at net.minecraft.server.ServerConfigurationManager.<init>(
    2011-07-04 18:39:38 [SEVERE]     at net.minecraft.server.MinecraftServer.init(
    2011-07-04 18:39:38 [SEVERE]     at
    2011-07-04 18:39:38 [SEVERE]     at
    2011-07-04 18:39:38 [SEVERE] [Permissions] Unable to load permission data.
    2011-07-04 18:39:38 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    2011-07-04 18:39:38 [INFO] [Permissions] (Yeti) was initialized.
    2011-07-04 18:39:38 [INFO] [Permissions] (Yeti) disabled successfully.
    Permissions has stopped working today for no apparent reason. The server loads fine without this plugin but I have changed nothing other than update a few plugins. Its also not creating the missing folders/files.

    Edit: Forgot to mention server craftbukkit version 956
  27. Offline


    Does it works with Bukkit 953 ? At my 953 serwer it doesn't work. I don't know why. It can't be enabled (In plugman it is "Permissions" is red.)
  28. Offline


    Can I have 2 prefix when I have two groups?
    If yes, how?
    PS: I use IChat
  29. Offline


    Im prolly overlooking something mayor, but what do i do to make it use mysql?

    Heres what i did
    [1] I setup the database with the example sql on github, but it has capitals, wich i cant use (or well, theyre beeing reverted?)
    [2] I setup the storageconfig.yml to be like the mysql example (with other login and database ofc)
    [3] I tried localhost,, the external server ip and a (external) domainname for server, no difference

    The plugin seems to totally not care for the storageconfig, and reverts to using users & groups yml files.......?!
    Any help highly appreciated, im about to format the server, everything fell apart since i tried using permissions 3.x :(
  30. Offline


    It appears the new files storageconfig, globalusers, and globalgroups have no effect on permissions but for players to build they have to be there.
  31. Offline


    im having trouble with the default user group, i changed the name from 'Default' to 'bloxGuest' and the server gave me an error saying 'Missing a prefix or suffix for Default.' When i revert back to the original group name everything works perfectly. Is there anyway to get around this? I know on another server I have access to, the default name is mmcDefault and it works. Although changing the name to bloxDefault doesn't seem to work either for me. please help! :) ty
Thread Status:
Not open for further replies.

Share This Page