Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Works with new update? I'm hoping so.
  3. Offline


    Its only one release build off. Plus, 928 came out yesterday...
    Last edited by a moderator: Sep 9, 2018
  5. Offline


    Since I've updated to the new Bukkit build I cant use the ingame commands. the error is "unknown command" how can I fix this?
  6. try re-downloading everything
  7. Offline


    I'm migrating from permissions 2.
    I have 5 world. I put every groups and users.yml in the folder TheCraft (my main world) and I put storageconfig.yml in the folder Permissions/ (in plugins/) with:
            type: YAML
                Nether: TheCraft
    But when go to the world Nether, I have no permissions u_u
    Thanks for helping me
  8. Offline


    Hey guys i need oure help when i hat install permission and permission plus i will promote anyone but i cant promote
    1.unknown console command or
    the group not in the rank
    pls help me can anyone make me the files? plsss
  9. Offline


    I second this. What happened? :{ I might need to downgrade :O
  10. Offline


    My problem is still not fixed
  11. Offline


    Multiverse commands also broke so I'd say it part of the bukkit changes, give it some time and a fix will be released, for now though, be patient and rollback to 860, a new RB doesn't immediatly make the old ones useless
    Problems found, working on a fix, will edit post when done
    EDIT: See attached file, I make no claim or promise that these files will work as I don't work with Globals on my server, I just followed the Wiki

    Attached Files:

  12. Offline


    How can I edit the MySQL tables that this plugin makes?
  13. Offline


    I would use the built in commands to make a few example entries then use phpMyAdmin or any other MySQL interface of your choice if you wish to edit the database directly
  14. Offline


    omg please help me, my server is like lagging really bad becouse of this everytime if u do anything, like moving ur mouse breaking and other stuff like that, my consol goes just crazy and the server lags really bad
    This is what I get:
  15. Offline


    You have tabs in your YML, change all the tabs to 4 spaces
  16. Offline


    [FONT='Arial]Also if I put anything at all like[/FONT]
    - 'buttonwarp.use'
    it starts happening and lots of lag : (

    what do u mean?
    This is what I have:

    default: true
    prefix: ''
    suffix: ''
    build: true
    - ''
    - 'buttonwarp.use'

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  17. Offline


    The donators on my server can't use /heal please help
            default: true
                prefix: '&2'
                suffix: '&2'
                build: true
                - mcmmo.motd
                - mcmmo.regeneration
                - mcmmo.commands.ptp
                - mcmmo.commands.whois
                - mcmmo.skills.*
                - craftbook.mech.ammeter.use
                - craftbook.mech.bridge
                - craftbook.mech.bookshelf.use
                - craftbook.mech.cauldron
                - craftbook.mech.elevator
                - craftbook.mech.elevator.use
                - craftbook.mech.gate
                - craftbook.mech.light-switch
                - essentials.depth
                - essentials.getpos
                - essentials.compass
                - essentials.portal
                - essentials.msg
                - essentials.afk
                - essentials.rules
                - essentials.motd
                - essentials.list
                - essentials.seen
                - essentials.whois
                - essentials.clearinventory
                - DropPlugin.drop.*
                - factions.participate
                - factions.create
                - anyonesleep.cansleep
            default: false
                prefix: '&9'
                suffix: '&9'
                build: true
                - Member
                - scavenger.scavenge
                - mcmmo.ability.woodcutting
                - mcmmo.ability.mining
                - mcmmo.ability.axes
                - mcmmo.ability.excavation
                - mcmmo.ability.swords
                - mcmmo.ability.unarmed
                - mcmmo.ability.herbalism
                - lwc.protect
                - essentials.home
                - essentials.sethome
                - essentials.warp
                - essentials.warp.list
                - essentials.spawn
                - essentials.jump
                - essentials.back
                - essentials.back.ondeath
                - essentials.item
                - invtools.allowtools
                - invtools.allowarmor
                - essentials.heal
            default: false
                prefix: '&1'
                suffix: '&1'
                build: true
                - Member
                - essentials.tempban
                - essentials.banip
                - essentials.mute
                - essentials.kick
                - essentials.kickall
                - essentials.ban
                - essentials.unban
                - essentials.unbanip
                - OpenInv.openinv
                - essentials.tphere
                - essentials.tpohere
                - essentials.tpo
                - backup.canbackup
            default: false
                prefix: '&4'
                suffix: '&4'
                build: true
                - '*'
  18. Offline


    New to MC server admin.

    I've installed Craftbukkit's latest recommended snapshot (0.0.0-889).
    I've installed MySQL 5.5.13.

    I'm looking for clear and concise instruction on how to install the SQL version of Permissions (PermissionsSQL.jar).

    Actually, nevermind.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  19. Offline


    Open your files and search for tabs, on at least 1 line you have a tab, highlight that tab and change it to 4 spaces, tabs are rejected by YAML
  20. Offline


    by the looks of it (if you mean they can and you don't want them to be able to) you need to remove their last permission node ( - essentials.heal ). if that's all they can do then I'm not sure what's wrong.
  21. Offline


    hello, wanna report a little issue, on build 928 i can't reload a plugin on screen linux with command permissions -reload all anyone have my problem?
  22. Offline


    I mean they can't and I want them to. I noticed I put can lol.
  23. Offline


    hmm... I don't think it would matter, but surround each permission by single quotes maybe?
    for example:
    - essentials.heal
    - 'essentials.heal'
    I know it's a pain since you've already gotten your permissions squared away, but maybe that's why?

    can they do any of their permissions besides not being able to do /heal?
  24. Offline


    They can do them all except /heal. umm I'll just put ' around just that command :p
  25. Offline


    I've added myself in the users list, but i still can't build. I added myself to admin group.
  26. Offline


    I have tried to install PHPMyAdmin a few times, but to no avail. What are the other MySQL interfaces? And I only need to edit the tables manually because I need to assign prefixes and suffixes to certain groups. So, if someone could tell me how I can do this with the in-game commands, I would greatly appreciate it.
  27. Offline


  28. Offline


    How do I convert from GroupManager to Permissions?
  29. Offline


    Yes we all do.
    Permissions commands are broken from build 912 and up.
    Must wait for update.
  30. Offline


    How do I disallow a command? I want to not let an Admin do something that has '*' as a permissions. How do I not allow?
  31. Offline


    All of a sudden no one can access workbenches on my server. The only way around this is to add the '*' permission. I've got Backup, Permissions, WorldEdit, WorldGuard, NoCheat, and DefaultCommand installed. Am I missing a node or something?
Thread Status:
Not open for further replies.

Share This Page