Inactive [ADMIN] Crafty v0.7.6 - Server GUI [1240]

Discussion in 'Bukkit Tools' started by Timberjaw, Feb 3, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Update! Crafty v0.7.6 works with CB1240.

    Unfortunately, the way the MC server instance starts up has been changed a bit, and this means I have to call an internal initializer for one class. This means that Crafty will probably need a minor update for each new Minecraft version (at least until they stop obfuscating everything).
  2. Offline


    I'm running Ubuntu 11.04 with Bukkit 1240, and whenever I run the wrapper I get:
    Exception in thread "main" java.lang.NoClassDefFoundError: joptsimple/OptionException
    Caused by: java.lang.ClassNotFoundException: joptsimple.OptionException
        at Method)
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
    Could not find the main class: com.aranai.crafty.Crafty. Program will exit.
  3. Offline


    Hey Timberjaw, I had the same problem my computer is running in Windows 7 x64 well i first changed the name to craftbukkit.jar and i would get the "Could not find the main class: com.aranai.crafty.Crafty" so I renamed the file to craftbukkit without the .jar and it worked perfectly. Just wanted to share this since you are the developer I think that might help somehow =).

    Thanks for the GUI version

  4. Offline


  5. Offline


    Will this be updated for 1.0.1?
  6. Offline


    @glasimonix By default, Windows hides the file extension for known file types, so it's likely that when you see the filename "craftbukkit", it's actually "craftbukkit.jar". So if you had the visible name "craftbukkit.jar", it may have actually been "craftbukkit.jar.jar"

    @Rynn21 I'm using 0.7.6 with 1.0.1 currently. If you're having issues with Crafty and 1.0.1, let me know! :)
  7. Offline


    It hasn't worked for me since 1.7.3 for some odd reason. Whenever I click on it it instantly closes and makes an error sound, which is strange cause when I was using an even older server version it worked just fine. :(
  8. Offline


    Just downloaded this and ran it for the first time, I like it, its clean and straight forward, start and stop works awesome. the only thing is, how would I allocate more memory to it? is that in the .bat file because i havn't checked that yet, perhaps I should :p

    Edit - As I figured You alocate more memory in the .bat file :p sorry, But other than that I like it. Nice Job
  9. Offline


    I recommend for mac users this command:
    cd "$( dirname "$0" )"
    java -Xincgc -Xmx1024M -jar crafty.jar
  10. Offline


    Still using it, still loving it!
  11. Offline


    German:Könntest du das nochmal in eine html datei einfügen?

    English:Could you paste again into a html file?
  12. When i cilck the crafty.bat i get this error:

    Could not find the mail class: com.aranai.crafty.Crafty.Program will exit.

    Any suggestions on how to fix this?
  13. Offline


    Thanks Timberjaw!

    Is there plans to create a version for Mac?
  14. Offline


    Any plans to continue this project?

    If not, could someone link me to another similar and up to date project?
  15. Offline


    Still works, and I'm still using it...but I would like to see if Timberjaw will update or release the source at some point :)
  16. Offline


    The newest build breaks Crafty... (CB 1.2.5-R2)
  17. Offline


    When i run the bat, i get a alert box in the face which says "A Java Exception has occured.". I got a 100% new clean bukkit server, and i've also tried to redownload the thingy. Help please?
  18. Offline


    Timberjaw was last seen March 13th! O_O
  19. Offline


  20. Offline


    Not dead or gone, I've just been busy (and lately I've been putting my free time into the Dungeonator plugin). I'll try to sort out Crafty this weekend.
  21. Offline


    Updated! Fixed the load issue, built against CraftBukkit 1.2.5-R4 (#2222). Download

    No other fixes or improvements. Let me know if you run into trouble.
  22. Offline


    Got this error when I ran the bat(yea I'm on windows):
    Could not find the main class: com.aranai.crafty.Crafty. Program will exit.
    Bukkit build is R4.0 and Crafty 0.7.7
  23. Offline


    chrisman0091 Make sure your craftbukkit file is called craftbukkit.jar
  24. Offline


    Oh alright. Thanks! I'll comment again if it doesn't work :)
  25. Offline


    Would be EXTRA nice if this was for mac and linux too
  26. Offline


  27. Offline


    I tried opening the .bat file came up with "A java exception has occured" so i tried opening the jar file said "A java exception has occured"
  28. Offline


    I opened the crafty.bat file but it gave me this error even though I even changed the craftbukkit.jar file name.
    Exception in thread "main" java.lang.InstantiationError: net.minecraft.server.MinecraftServer
    at com.aranai.crafty.Crafty.startServer(
    at com.aranai.crafty.Crafty.<init>(
    at com.aranai.crafty.Crafty.main(
  29. Offline


    uhmm.. every time i start from the .bat or the .jar i get this error: A java exception has occurred
  30. Offline


    This tool is out of date. Please find a different GUI to use. Check the Tools Index for a list.
Thread Status:
Not open for further replies.

Share This Page