Solved 1.9 PvP stop working

Discussion in 'Bukkit Help' started by BRoKenmc, Feb 5, 2017.

Thread Status:
Not open for further replies.
  1. Offline

    BRoKenmc

    So i have a server for 3 months and everything was all right, but the last 2 days the 1.9 pvp stop working.
    My server is in 1.10 version, and i havent put any plugin that bring back 1.8 pvp.
    Also i saw that when i respawn the 1.9 pvp works for 5 seconds and then it stop working again.
    Does anyone know how can i fix this problem?


    And if you ask, my plugins are:

    Plugins (38): WorldEdit, HealthBar, Essentials, GroupManager, MythicLib, SmartBans, BuycraftX, Votifier, CPCameraStudioReborn, ProtocolLib, WorldGuard, Multiverse-Core, AntiWDL, LibsDisguises, AdvancedPortals, Morphy, Shopkeepers, EssentialsProtect, EssentialsChat, ExtremeCommandBlocker, mcMMO, OPSecurity, WGCustomFlags, GAListener, Vault, ZavAutoMessager, EssentialsSpawn, ChestShop, AreaShop, mcjobs, Rankup, CompatNoCheatPlus, HolographicDisplays, NoCheatPlus, SignColors, ColoredTags, MythicMobs, CratesPlus
     
  2. Offline

    timtower Moderator Moderator

    Moved to Bukkit help
    @BRoKenmc Did you change anything in those days?
     
  3. Offline

    BRoKenmc

    Yeah i changed many thing to figure out what was the problem but still the same problem happends
     
  4. Offline

    Zombie_Striker

    Essentials has not been updated since 1.8. They are no longer expected to work. Start looking for replacements for these plugins.

    That is a lot of anti-hack plugins. Are you sure you need them all? Are you sure non of them are conflicting with eachother?

    Main problem: What changes have you made to the server? Have you downloaded any new plugins? Have you modified any existing plugins?
     
  5. Offline

    BRoKenmc

    NoCheatPlus, CompatNoCheatplus and AntiWDL and i need them but OPSecurity is up to date so it doesnt work, but the problem is that all this plugins i had them before and the 1.9 pvp it was working.
    I dont what happend now and 1.9 pvp doesnt work
    And the changes, i just delete some plugins and on some others i check the config if the say anything about 1.8 pvp but again nothing
     
  6. Offline

    Zombie_Striker

    @BRoKenmc
    You will need to troubleshoot then. Remove all the plugins from your server. If you no longer have 1.8 pvp, then it is an issue with one of the plugins. If that is the case, slowly, re-add each plugin till you find the one that causes the change.

    If you still have 1.8 PVP, create an entire new server and see if that fixes the problem. If it does, it has something to do with the map you have/ game-rules you have set. If creating a new server fixes the problem, re-add all the plugins one at a time and check if the PVP changes. If the pvp changes again, you know it has something to do with the plugin. If there are no changes, then it has something to do with the map, meaning you may have to delete the map.
     
  7. Offline

    BRoKenmc

    Hello, so i delete all the plugin from the server and the same thing happend, i check the gamerules and i couldnt find anything, i did the thing with world and again the same thing happend.
    What can i do now?
     
  8. Offline

    Rayzr522

    Did you ever install a plugin to make the PVP be like 1.8? I know you said you don't currently have any plugins that do that, but did you have one at some point?
     
  9. Offline

    BRoKenmc

    Yeah.. Last week I download a plugin that make the PvP 1.8 but because I didn't like it I delete it. Now I don't remember if the next day 1.9 PvP was working again.
    Also sorry for don't saying it earlier, I forgot it.... And I know that in the start I say that the last 2 days 1.9 PvP wasnt working is because I saw the problem 2 days ago..
     
  10. Offline

    Zombie_Striker

    @BRoKenmc
    If all that did not work, re-create the entire server as a test. Nothing from your original server can be used in this test. Download the newest spigot jar and run it. Test if that fixes the error. If it somehow still uses 1.8 pvp, your plugin must have deeply affected your computer (which should not be the case). If not, again, slowly re-add everything till you find the thing that is causing the change.
     
  11. Offline

    Rayzr522

    @BRoKenmc which plugin did you install? I know the OldCombatMechanics (I helped write that one) has safeguards so if you remove the plugin it won't have you server still be screwed up, but I can't vouch for any of the others. One possible simple fix would be to run OCMFixer on all your worlds. It was intended to be used in a case where a user of OldCombatMechanics removed it and had your exact same problem, but it should work regardless of what plugin you installed that modified combat.

    Disclaimer, I have to put this in because yay rules: the Bukkit staff have not approved that plugin, and neither them nor I take any responsibility for any damage done to your server. Back your worlds up first.

    EDIT: Don't run OCMFixer on all worlds, just your main one, generally whichever one is specified in your server.properties. There's instructions on the OCMFixer page that I linked you to.
     
    Last edited: Feb 6, 2017
    Zombie_Striker likes this.
  12. Offline

    BRoKenmc

    OMG thanks that worked, you dont know how happy im right now :D
     
  13. Offline

    Rayzr522

    @BRoKenmc glad to help! If you ever need anything else, you know where to find me :)

    And if that's everything, please mark this thread as solved.
     
Thread Status:
Not open for further replies.

Share This Page