1.8 Bukkit Discussion

Discussion in 'Bukkit Discussion' started by agafaba, Sep 14, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hm, no idea, I'm not really near my server PC, so I'm not able to check it out myself. I'll give the new build a try when I can and see.

    Edit: Yep, looks like you're correct. Health is regenerating as it should in normal when full.
  2. Offline


    Maybe a plugin that fucks the server up? Try it without any plugins...

    The changes on these builds say, that they're still investigating the cause but created two workarounds to prevent the bug from killing your chests.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  3. Offline


    With 1.13 same error

    2011-09-21 08:08:22 [SEVERE] Error occurred while enabling PermissionsEx v1.13 (Is it up to date?): org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
    java.lang.NoSuchMethodError: org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
        at ru.tehkode.permissions.bukkit.BukkitPermissions.collectPermissions(BukkitPermissions.java:105)
        at ru.tehkode.permissions.bukkit.BukkitPermissions.<init>(BukkitPermissions.java:73)
        at ru.tehkode.permissions.bukkit.PermissionsEx.onEnable(PermissionsEx.java:103)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:906)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:173)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:156)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    but run great with the latest dev build of pex.

    plugins :
  4. Offline


    #1162 fixed this bug.
  5. Offline


    #1167 have finally fixed the phantom chest positioning that occurs when running 1.7 map on 1.8.
  6. Offline


    Also the rain is broken. I walked into my host within my online server and thought a sunami had hit. Place had rain inside it :(
  7. Offline


    Bug occured to me on vanilla, so no bukkit related error in there :)
  8. Offline


    Here is my code to do that. Change the seed, and keep the L at the end of the seed.

    Code (open)

    import java.util.Random;

    class Strongholds {

    public static void main(String[] args) {

    Random c = new Random();

    c.setSeed(<YOU SEED HERE>L);
    double d = c.nextDouble() * 3.1415926535897931D * 2D;
    for(int l = 0; l < 3; l++)
    double d1 = (1.25D + c.nextDouble()) * 32D;
    int j1 = (int)Math.round(Math.cos(d) * d1);
    int k1 = (int)Math.round(Math.sin(d) * d1);

    int j2 = (j1 << 4) + 8;
    int k2 = (k1 << 4) + 8;

    System.out.println(l + ": " + j2 + " " + k2);

    d += 6.2831853071795862D / 3D;
  9. Offline


    I dont use nor do i have a clue what vanilla is. But when i go onto my server it spawns me in ma house and its raining inside :*(
  10. Offline

    Rocket Widget

    Sorry, I should have specified, I'm not using any plugins whatsoever.

    So here's the problem, when I try to start Bukkit with my 1.8.1 map/server, I get the stuff below spit out at me, but if I let it start fresh and generate a new map, it works fine... No plugins or anything in either situation, and it's happened with any build of bukkit I try

    161 recipes
    17 achievements
    12:22:48 [INFO] Starting minecraft server version Beta 1.8.1
    12:22:48 [INFO] Loading properties
    12:22:48 [WARNING] server.properties does not exist
    12:22:48 [INFO] Generating new properties file
    12:22:48 [INFO] Starting Minecraft server on *:25565
    12:22:49 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1063-g6b85ecc-b1176jnks (MC: 1.8.1)
    12:22:49 [WARNING] Failed to load ban list: java.io.FileNotFoundException: banned-players.txt (The system cannot find the file specified)
    12:22:49 [WARNING] Failed to load ip ban list: java.io.FileNotFoundException: banned-ips.txt (The system cannot find the file specified)
    12:22:49 [WARNING] Failed to load ops: java.io.FileNotFoundException: ops.txt (The system cannot find the file specified)
    12:22:49 [WARNING] Failed to load white-list: java.io.FileNotFoundException: white-list.txt (The system cannot find the file specified)
    12:22:49 [INFO] Preparing level "world"
    12:22:49 [INFO] Default game type: 0
    12:22:49 [INFO] Unable to find spawn biome
    12:22:49 [SEVERE] java.lang.NullPointerException
    12:22:49 [SEVERE]       at net.minecraft.server.WorldServer.c(WorldServer.java:106)
    12:22:49 [SEVERE]       at net.minecraft.server.World.a(World.java:2224)
    12:22:49 [SEVERE]       at net.minecraft.server.Chunk.addEntities(Chunk.java:629)
    12:22:49 [SEVERE]       at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:81)
    12:22:49 [SEVERE]       at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(ChunkProviderServer.java:106)
    12:22:49 [SEVERE]       at net.minecraft.server.World.getChunkAt(World.java:300)
    12:22:49 [SEVERE]       at net.minecraft.server.World.getTypeId(World.java:247)
    12:22:49 [SEVERE]       at net.minecraft.server.World.isEmpty(World.java:251)
    12:22:49 [SEVERE]       at net.minecraft.server.World.a(World.java:218)
    12:22:49 [SEVERE]       at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
    12:22:49 [SEVERE]       at net.minecraft.server.World.canSpawn(World.java:104)
    12:22:49 [SEVERE]       at net.minecraft.server.World.c(World.java:202)
    12:22:49 [SEVERE]       at net.minecraft.server.World.<init>(World.java:150)
    12:22:49 [SEVERE]       at net.minecraft.server.WorldServer.<init>(WorldServer.java:27)
    12:22:49 [SEVERE]       at net.minecraft.server.SecondaryWorldServer.<init>(SecondaryWorldServer.java:8)
    12:22:49 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:221)
    12:22:49 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
    12:22:49 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    12:22:49 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    12:22:49 [SEVERE] Unexpected exception
            at net.minecraft.server.WorldServer.c(WorldServer.java:106)
            at net.minecraft.server.World.a(World.java:2224)
            at net.minecraft.server.Chunk.addEntities(Chunk.java:629)
            at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:81)
            at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(ChunkProviderServer.java:106)
            at net.minecraft.server.World.getChunkAt(World.java:300)
            at net.minecraft.server.World.getTypeId(World.java:247)
            at net.minecraft.server.World.isEmpty(World.java:251)
            at net.minecraft.server.World.a(World.java:218)
            at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
            at net.minecraft.server.World.canSpawn(World.java:104)
            at net.minecraft.server.World.c(World.java:202)
            at net.minecraft.server.World.<init>(World.java:150)
            at net.minecraft.server.WorldServer.<init>(WorldServer.java:27)
            at net.minecraft.server.SecondaryWorldServer.<init>(SecondaryWorldServer.java:8)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:221)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)[CODE]
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  11. Offline


    I just meant, that it's a bug in minecraft itself, that occurs on my server sometimes, that is currently running 1.8.1 without ANY plugins at all. Not even bukkit.
  12. Offline


    Unable to find spawn biome
    That's some kind of strange. Did you try to "reinstall" the server in a new folder with this two main files?
    CraftBukkit Starter.bat
  13. Offline

    Rocket Widget

    Yes, I just tried a fresh install, and it generated a map on its own and started up properly, which leads me to believe that somehow this is a problem related to my map, or something.
  14. Offline


    only OP can place wooden doors ~ is this only effecting me?
  15. Offline


    just u OR it was before the current latest update

    BTW permissionsEX just got the outdated message on the latest update :3
  16. Offline


    If only i knew what i was supposed to do with this lol. i think my friend will though :p
  17. Offline


    OOOOOOOOoooooooo Ma Bad Homie! Well i wanna be able to sit at my fireplace and smoke my crack pipe with being drowned.......... so any suggestions?
    M1sT3rM4n likes this.
  18. Offline


    Has anyone noticed big decrease in number of passive mobs being spawned? Also, the "spawn-animals" parameter seems to control nothing - small number of animals are present if the value of the parameter is equal to "true" or "false" (the server has been restarted between value changes).

    Craft Bukkit version used: #1183
  19. Offline


    Also happening on my server. Issue is still present on 1183. Only OP can place wooden doors.

    I also have no mobs. I had to put a pig spawner in an open field so my players don't starve. (I provided supper, they have to do the dishes. I think it's a fair trade.)
  20. Offline


    19:25:43 [SEVERE] java.lang.NoSuchFieldError: br
    19:25:43 [SEVERE] at com.bergerkiller.bukkit.tc.NativeMinecartMember.move(NativeMinecartMember.java:667)
    19:25:43 [SEVERE] at net.minecraft.server.EntityMinecart.s_(EntityMinecart.java:393)
    19:25:43 [SEVERE] at net.minecraft.server.World.entityJoinedWorld(World.java:1193)
    19:25:43 [SEVERE] at net.minecraft.server.WorldServer.entityJoinedWorld(WorldServer.java:48)
    19:25:43 [SEVERE] at net.minecraft.server.World.playerJoinedWorld(World.java:1175)
    19:25:43 [SEVERE] at net.minecraft.server.World.cleanUp(World.java:1090)
    19:25:43 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:460)
    19:25:43 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    19:25:43 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    19:25:43 [SEVERE] Unexpected exception
    java.lang.NoSuchFieldError: br
    at com.bergerkiller.bukkit.tc.NativeMinecartMember.move(NativeMinecartMember.java:667)
    at net.minecraft.server.EntityMinecart.s_(EntityMinecart.java:393)
    at net.minecraft.server.World.entityJoinedWorld(World.java:1193)
    at net.minecraft.server.WorldServer.entityJoinedWorld(WorldServer.java:48)
    at net.minecraft.server.World.playerJoinedWorld(World.java:1175)
    at net.minecraft.server.World.cleanUp(World.java:1090)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:460)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    sorry im not sure if this is fixed in the new update. Can someone tell me whats going on? Im running a cracked minecraft server. Help?!?
  21. Offline


    theres your problem. get a real one.
    Phaedrus likes this.
  22. Offline


    You aren't likely to get much help if you're running a cracked server. Cough up 20 bucks and buy a copy. Sheesh.
  23. Offline


    what i find funny is that people actually state the fact that they are using a cracked version lol
  24. Offline


    Probably just something that will get fixed when we get an RB + Plugins updated to RB - but, anyone have issues with the console repeating everything multiple times? only seen serverside, not by clients. I THINK I narrowed it down to Hawkeye, but, not sure. It doesnt seem to affect performance.

    - - its the first time in a long time I wish my server would empty out completely in the evening, so I can do some extensive tests.
  25. Offline


    Build #1185 have been recommended.
  26. Offline


    I got this also. Just updated to the recommended build today. The world is from before and some time ago we changed the spawn point with MCEdit, which may have caused this(?).
    Unable to find spawn biome
  27. Offline


    This isn't a result of MCEdit moving spawn. We moved spawn on our server in 1.7.3 and updated to recommended build today. I was able to connect for about 15 minutes, after which I was booted during a server restart and received this error as well.
  28. Offline


    1.7 was normal... but now it is all laggy >.> ... I can barely move on the server >.>
  29. Offline


    The real question is... what does he mean by cracked server. Last I saw running a server was free, you pay to play minecraft.
  30. Offline


    Get minecraft_server.jar. Run server for first time. Shut down.

    In server.property, set online=false. Then get Bukkit. Now install xAuth plugin.

    Torrent MC and play!
Thread Status:
Not open for further replies.

Share This Page